
R&S®SGS100A
SGMA RF Source
User Manual

 
1173910502
Version 13

(;×é52)



This document describes the R&S®SGS100A, stock no. 1416.0505.02 and its options.
● R&S®SGS-B1 (1416.2408.02)
● R&S®SGS-B26 (1416.1353.02)
● R&S®SGS-B106/106V (1416.2308.02/1416.2350.02)
● R&S®SGS-B112/112V (1416.1553.02/1416.1576.02)
● R&S®SGS-K22 (1416.2650.02)
● R&S®SGS-K90 (1416.2608.02)

This manual describes firmware version FW 5.00.232.xx and later of the R&S®SGS100A.

© 2022 Rohde & Schwarz GmbH & Co. KG
Muehldorfstr. 15, 81671 Muenchen, Germany
Phone: +49 89 41 29 - 0
Email: info@rohde-schwarz.com
Internet: www.rohde-schwarz.com
Subject to change – data without tolerance limits is not binding.
R&S® is a registered trademark of Rohde & Schwarz GmbH & Co. KG.
All other trademarks are the properties of their respective owners.

1173.9105.02 | Version 13 | R&S®SGS100A

Throughout this manual, products from Rohde & Schwarz are indicated without the ® symbol , e.g. R&S®SGS is indicated as
R&S SGS.

mailto:info@rohde-schwarz.com
http://www.rohde-schwarz.com


ContentsR&S®SGS100A

3User Manual 1173.9105.02 ─ 13

Contents
1 Safety and regulatory information......................................................11

1.1 Safety instructions...................................................................................................... 11

1.2 Labels on R&S SGS.................................................................................................... 13

1.3 Warning messages in the documentation................................................................ 13

1.4 Korea certification class B......................................................................................... 14

2 Welcome............................................................................................... 15
2.1 Key features.................................................................................................................15

2.2 What's new...................................................................................................................15

2.3 Documentation overview............................................................................................16

2.3.1 Getting started manual..................................................................................................16

2.3.2 User manual and help................................................................................................... 16

2.3.3 Service manual............................................................................................................. 16

2.3.4 Instrument security procedures.....................................................................................17

2.3.5 Basic safety instructions................................................................................................17

2.3.6 Data sheets and brochures........................................................................................... 17

2.3.7 Release notes and open source acknowledgment (OSA)............................................ 17

2.3.8 Application notes, application cards, white papers, etc.................................................17

2.4 Typographical conventions........................................................................................17

2.5 Notes on screenshots.................................................................................................18

3 Preparing for use................................................................................. 19
3.1 Lifting and carrying.....................................................................................................19

3.2 Unpacking and checking............................................................................................19

3.3 Choosing the operating site.......................................................................................19

3.4 Setting up the R&S SGS............................................................................................. 20

3.4.1 Placing the R&S SGS on a bench top...........................................................................20

3.4.2 Mounting the R&S SGS in a rack..................................................................................21

3.5 Considerations for test setup.................................................................................... 22

3.6 Connecting to power.................................................................................................. 22

3.7 Connecting to LAN......................................................................................................23

3.8 Connecting to RF 50Ω.................................................................................................23

3.9 Connecting to non-screwable connectors............................................................... 24



ContentsR&S®SGS100A

4User Manual 1173.9105.02 ─ 13

3.10 Switching on or off......................................................................................................25

3.11 Checking default settings.......................................................................................... 27

3.12 Working with Linux operating system...................................................................... 27

3.13 Connecting an external PC and devices...................................................................27

3.13.1 Installing the R&S SGMA-GUI software........................................................................28

3.13.2 Connecting a remote PC via LAN................................................................................. 30

3.13.3 Connecting a controller via PCI Express.......................................................................33

3.13.4 Connecting a controller via USB................................................................................... 33

4 Instrument tour.....................................................................................35
4.1 Front panel tour...........................................................................................................35

4.2 Rear panel tour............................................................................................................37

5 Trying out the Instrument....................................................................39
5.1 Configuring a CW Signal with the R&S SGMA-GUI..................................................39

5.2 Configuring a CW Signal with the R&S SGS100A Web-GUI....................................41

6 Instrument control............................................................................... 43
6.1 Manual operation via R&S SGMA-GUI...................................................................... 43

6.1.1 Introduction to the user interface...................................................................................43

6.1.2 How to use the help system.......................................................................................... 44

7 System overview..................................................................................46
7.1 Setups for instrument control....................................................................................46

7.1.1 Manual operation from the R&S SGMA-GUI.................................................................46

7.1.2 Remote control from a controller...................................................................................47

7.1.3 Control of an R&S SGS from an R&S signal generator................................................ 47

7.2 Connecting an R&S SGS and an R&S SGU.............................................................. 48

7.2.1 Using a direct LAN connection......................................................................................48

7.2.2 Connecting to a company network................................................................................49

7.2.3 Connecting via a PCIe switch....................................................................................... 52

7.2.4 Extending R&S SGS with the R&S SGU.......................................................................53

7.3 Introduction to the instrument functions..................................................................57

8 Understanding the R&S SGMA-GUI software....................................59
8.1 Operating menu and toolbar...................................................................................... 59

8.1.1 File menu...................................................................................................................... 60



ContentsR&S®SGS100A

5User Manual 1173.9105.02 ─ 13

8.1.2 Setup menu...................................................................................................................61

8.1.3 Help...............................................................................................................................69

8.2 Info dialog and messages in the info bar................................................................. 69

8.2.1 Info dialog......................................................................................................................70

8.2.2 Understanding the messages in the info bar.................................................................71

8.3 Main panel....................................................................................................................72

8.4 Working with R&S SGMA-GUI....................................................................................75

8.4.1 Saving and loading settings.......................................................................................... 75

8.4.2 Handling instruments in the R&S SGMA-GUI............................................................... 75

8.4.3 Finding out the default hostname of the instrument...................................................... 78

8.4.4 Bidirectional instrument identification............................................................................79

8.4.5 Managing messages in the info dialog..........................................................................82

8.5 Remote control of R&S SGMA-GUI........................................................................... 83

8.5.1 Programming examples................................................................................................ 83

8.5.2 R&S SGMA-GUI commands......................................................................................... 85

8.5.3 List of R&S SGMA-GUI commands.............................................................................. 90

9 Signal generator settings....................................................................91
9.1 Operation mode...........................................................................................................91

9.2 Frequency/Phase settings..........................................................................................92

9.3 Local oscillator (LO) coupling................................................................................... 93

9.3.1 Phase coherence.......................................................................................................... 94

9.3.2 Local oscillator (LO) coupling settings.......................................................................... 94

9.4 Reference oscillator....................................................................................................95

9.5 Level and power-on settings......................................................................................98

9.5.1 RF level......................................................................................................................... 99

9.5.2 Attenuator....................................................................................................................101

9.5.3 Power-On/EMF........................................................................................................... 103

9.5.4 ALC............................................................................................................................. 103

9.5.5 User correction settings.............................................................................................. 104

9.5.6 Filling the correction list automatically.........................................................................109

9.5.7 Fill with sensor............................................................................................................. 111

9.5.8 Using power sensors...................................................................................................112

9.6 Pulse modulation...................................................................................................... 124



ContentsR&S®SGS100A

6User Manual 1173.9105.02 ─ 13

9.6.1 Pulse modulation settings........................................................................................... 126

9.6.2 Pulse generator settings............................................................................................. 127

9.6.3 Pulse Connector/Trigger settings................................................................................ 128

9.7 Trigger connector settings.......................................................................................129

9.8 I/Q modulation and signal impairment....................................................................130

9.8.1 I/Q impairments...........................................................................................................131

9.8.2 General I/Q settings.................................................................................................... 133

9.8.3 Analog impairment settings.........................................................................................134

9.9 Preset......................................................................................................................... 135

9.10 Extension................................................................................................................... 136

10 General instrument settings and instrument setup........................140
10.1 Internal adjustments................................................................................................. 141

10.2 Hardware configuration............................................................................................144

10.3 Software / options..................................................................................................... 145

10.4 Install SW options..................................................................................................... 147

10.5 Protection.................................................................................................................. 147

10.6 Security...................................................................................................................... 148

10.7 Network settings....................................................................................................... 151

10.8 Remote channels...................................................................................................... 154

10.9 Factory preset........................................................................................................... 155

10.10 Eco mode................................................................................................................... 156

10.11 Standby and restart.................................................................................................. 157

10.12 Diagnostic and tests................................................................................................. 157

10.12.1 Selftest........................................................................................................................ 157

10.12.2 Keyboard tests............................................................................................................ 158

10.13 External adjustments................................................................................................158

11 Performing configuration tasks........................................................160
11.1 How to generate an I/Q modulated signal...............................................................160

11.2 How to generate I/Q signals..................................................................................... 162

11.3 How to enable a baseband bypass mode............................................................... 165

11.4 How to configure the reference oscillator source................................................. 165

11.5 How to configure the local oscillator coupling source......................................... 166

11.6 How to define the signal at the REF/LO OUT connector....................................... 167



ContentsR&S®SGS100A

7User Manual 1173.9105.02 ─ 13

11.7 How to prepare instruments for optimum phase coherence................................ 167

11.8 How to restore the LAN connection........................................................................ 168

11.9 How to switch between operating states................................................................169

11.10 How to use computer names................................................................................... 171

11.11 How to optimize performance..................................................................................171

11.12 How to install a new firmware version on the instrument.....................................172

11.13 How to activate options............................................................................................174

11.14 How to set a PCIe direct connection....................................................................... 174

12 Network operation and remote control............................................175
12.1 Remote control interfaces and protocols............................................................... 175

12.1.1 Remote control programs and libraries....................................................................... 176

12.1.2 LAN interface.............................................................................................................. 179

12.1.3 USB interface.............................................................................................................. 182

12.1.4 PCI Express interface................................................................................................. 182

12.1.5 GPIB interface (IEC/IEEE bus interface).....................................................................183

12.2 Starting a remote control session........................................................................... 184

12.2.1 How to find the VISA resource string.......................................................................... 184

12.2.2 Remote control over LAN using socket communication..............................................184

12.3 Advanced remote control using PCIe..................................................................... 186

12.3.1 Setting up a remote control connection via PCIe........................................................ 186

12.3.2 Downloading the drivers..............................................................................................187

12.3.3 Configuring the controller............................................................................................ 187

12.3.4 Connecting the controller and the instrument............................................................. 190

12.3.5 Enabling fast settings.................................................................................................. 190

12.4 Advanced remote control using fast socket.......................................................... 191

12.4.1 Setting up a remote control connection via fast socket...............................................191

12.4.2 Installing the protocol driver........................................................................................ 192

12.4.3 Enabling fast settings.................................................................................................. 192

12.5 Status reporting system........................................................................................... 193

12.5.1 Hierarchy of the status registers................................................................................. 193

12.5.2 Structure of a SCPI status register..............................................................................195

12.5.3 Status byte (STB) and service request enable register (SRE)....................................197

12.5.4 Event status register (ESR) and event status enable register (ESE)..........................198



ContentsR&S®SGS100A

8User Manual 1173.9105.02 ─ 13

12.5.5 Questionable status register (STATus:QUEStionable)................................................198

12.5.6 Operation status register (STATus:OPERation).......................................................... 199

12.5.7 Application of the status reporting system.................................................................. 199

12.5.8 Reset values of the status reporting system............................................................... 201

12.6 LXI configuration.......................................................................................................201

12.6.1 Default network settings..............................................................................................202

12.6.2 LXI browser settings....................................................................................................202

12.6.3 LAN configuration........................................................................................................203

12.6.4 How to record SCPI commands and messages via LXI............................................. 208

12.7 Monitoring remote control operation with R&S SGMA-GUI..................................209

13 Remote control commands...............................................................211
13.1 Programming examples........................................................................................... 212

13.1.1 Performing general tasks for instrument setup........................................................... 213

13.1.2 Generating an I/Q modulated signal........................................................................... 215

13.1.3 Adjusting network and remote channel settings..........................................................216

13.1.4 Advanced tasks to optimize performance................................................................... 218

13.1.5 Enabling and configuring an extension mode............................................................. 219

13.2 Common commands.................................................................................................220

13.3 General commands...................................................................................................225

13.4 Preset commands..................................................................................................... 226

13.5 CALibration subsystem............................................................................................227

13.6 CONNector subsystem............................................................................................. 229

13.7 DIAGnostic subsystem.............................................................................................230

13.8 EXTension subsystem.............................................................................................. 231

13.9 MMEMory subsystem............................................................................................... 234

13.9.1 File naming conventions............................................................................................. 235

13.9.2 Extensions for user files.............................................................................................. 235

13.9.3 Examples.................................................................................................................... 236

13.9.4 Remote control commands......................................................................................... 237

13.10 Fast speed commands............................................................................................. 243

13.11 OUTPut subsystem................................................................................................... 243

13.12 SENSe, READ, INITiate and SLISt subsystems......................................................245

13.13 SOURce subsystem.................................................................................................. 259



ContentsR&S®SGS100A

9User Manual 1173.9105.02 ─ 13

13.14 SOURce:CORRection subsystem............................................................................261

13.15 SOURce:IQ subsystem............................................................................................. 270

13.16 SOURce:PHASe subsystem.....................................................................................272

13.17 SOURce:POWer subsystem.....................................................................................273

13.18 SOURce:PULM Subsystem...................................................................................... 277

13.19 SOURce:ROSCillator subsystem.............................................................................282

13.20 STATus subsystem....................................................................................................284

13.21 SYSTem subsystem.................................................................................................. 288

13.22 TEST subsystem....................................................................................................... 301

13.23 UNIT subsystem........................................................................................................ 302

13.24 List of R&S SGS commands.................................................................................... 303

14 Error messages and troubleshooting.............................................. 309
14.1 Status information.................................................................................................... 309

14.2 Error messages......................................................................................................... 309

14.2.1 Volatile messages....................................................................................................... 309

14.2.2 Permanent messages................................................................................................. 310

14.3 SCPI-Error messages............................................................................................... 310

14.4 Device-Specific error messages..............................................................................310

14.5 Contacting customer support..................................................................................312

15 Transporting....................................................................................... 313

16 Maintenance, storage and disposal................................................. 314
16.1 Cleaning..................................................................................................................... 314

16.2 Storage.......................................................................................................................314

16.3 Disposal..................................................................................................................... 314

Annex.................................................................................................. 315

A Telnet program examples..................................................................315

Index....................................................................................................321



ContentsR&S®SGS100A

10User Manual 1173.9105.02 ─ 13



Safety and regulatory informationR&S®SGS100A

11User Manual 1173.9105.02 ─ 13

1  Safety and regulatory information
The product documentation helps you use the product safely and efficiently. Follow the
instructions provided here and in the following chapters.

Intended use

The product is intended for the development, production and verification of electronic
components and devices in industrial, administrative, and laboratory environments.
Use the product only for its designated purpose. Observe the operating conditions and
performance limits stated in the data sheet.

Where do I find safety information?

Safety information is part of the product documentation. It warns you of potential dan-
gers and gives instructions on how to prevent personal injury or damage caused by
dangerous situations. Safety information is provided as follows:
● In Chapter 1.1, "Safety instructions", on page 11. The same information is provi-

ded in many languages as printed "Safety Instructions". The printed "Safety
Instructions" are delivered with the product.

● Throughout the documentation, safety instructions are provided when you need to
take care during setup or operation.

1.1  Safety instructions

Products from the Rohde & Schwarz group of companies are manufactured according
to the highest technical standards. To use the products safely, follow the instructions
provided here and in the product documentation. Keep the product documentation
nearby and offer it to other users.

Use the product only for its intended use and within its performance limits. Intended
use and limits are described in the product documentation such as the data sheet,
manuals and the printed "Safety Instructions". If you are unsure about the appropriate
use, contact Rohde & Schwarz customer service.

Using the product requires specialists or specially trained personnel. These users also
need sound knowledge of at least one of the languages in which the user interfaces
and the product documentation are available.

Never open the casing of the product. Only service personnel authorized by
Rohde & Schwarz are allowed to repair the product. If any part of the product is dam-
aged or broken, stop using the product. Contact Rohde & Schwarz customer service at
http://www.customersupport.rohde-schwarz.com.

Lifting and carrying the product

The maximum weight of the product is provided in the data sheet. To move the product
safely, you can use lifting or transporting equipment such as lift trucks and forklifts. Fol-
low the instructions provided by the equipment manufacturer.

Safety instructions

http://www.customersupport.rohde-schwarz.com
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Choosing the operating site

Only use the product indoors. The product casing is not waterproof. Water that enters
can electrically connect the casing with live parts, which can lead to electric shock,
serious personal injury or death if you touch the casing. If Rohde & Schwarz provides
accessories designed for your product, e.g. a carrying bag, you can use the product
outdoors.

Unless otherwise specified, you can operate the product up to an altitude of 2000 m
above sea level. The product is suitable for pollution degree 2 environments where
nonconductive contamination can occur. For more information on environmental condi-
tions such as ambient temperature and humidity, see the data sheet.

Setting up the product

Always place the product on a stable, flat and level surface with the bottom of the prod-
uct facing down. If the product is designed for different positions, secure the product so
that it cannot fall over.

If the product has foldable feet, always fold the feet completely in or out to ensure sta-
bility. The feet can collapse if they are not folded out completely or if the product is
moved without lifting it. The foldable feet are designed to carry the weight of the prod-
uct, but not an extra load.

If stacking is possible, keep in mind that a stack of products can fall over and cause
injury.

If you mount products in a rack, ensure that the rack has sufficient load capacity and
stability. Observe the specifications of the rack manufacturer. Always install the prod-
ucts from the bottom shelf to the top shelf so that the rack stands securely. Secure the
product so that it cannot fall off the rack.

Connecting to power

The product is an overvoltage category II product. Connect the product to a fixed
installation used to supply energy-consuming equipment such as household applian-
ces and similar loads. Keep in mind that electrically powered products have risks, such
as electric shock, fire, personal injury or even death.

Take the following measures for your safety:
● Before switching on the product, ensure that the voltage and frequency indicated

on the product match the available power source. If the power adapter does not
adjust automatically, set the correct value and check the rating of the fuse.

● Only use the power cable delivered with the product. It complies with country-spe-
cific safety requirements. Only insert the plug into an outlet with protective conduc-
tor terminal.

● Only use intact cables and route them carefully so that they cannot be damaged.
Check the power cables regularly to ensure that they are undamaged. Also ensure
that nobody can trip over loose cables.

● If the product needs an external power supply, use the power supply that is deliv-
ered with the product or that is recommended in the product documentation or a
power supply that conforms to the country-specific regulations.

Safety instructions
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● Only connect the product to a power source with a fuse protection of maximum
20 A.

● Ensure that you can disconnect the product from the power source at any time.
Pull the power plug to disconnect the product. The power plug must be easily
accessible. If the product is integrated into a system that does not meet these
requirements, provide an easily accessible circuit breaker at the system level.

Cleaning the product

Use a dry, lint-free cloth to clean the product. When cleaning, keep in mind that the
casing is not waterproof. Do not use liquid cleaning agents.

Meaning of safety labels

Safety labels on the product warn against potential hazards.

Potential hazard

Read the product documentation to avoid personal injury or product damage.

Electrical hazard

Indicates live parts. Risk of electric shock, fire, personal injury or even death.

Hot surface

Do not touch. Risk of skin burns. Risk of fire.

Protective conductor terminal

Connect this terminal to a grounded external conductor or to protective ground. This connec-
tion protects you against electric shock if an electric problem occurs.

1.2  Labels on R&S SGS

Labels on the casing inform about:
● Personal safety, see "Connecting to power" on page 12.
● Product and environment safety, see Table 1-1.
● Identification of the product, see the serial number on the rear panel.
Table 1-1: Labels regarding R&S SGS and environment safety

Labeling in line with EN 50419 for disposal of electrical and electronic equipment after the prod-
uct has come to the end of its service life. For more information, see Chapter 16, "Maintenance,
storage and disposal", on page 314.

1.3  Warning messages in the documentation

A warning message points out a risk or danger that you need to be aware of. The sig-
nal word indicates the severity of the safety hazard and how likely it will occur if you do
not follow the safety precautions.

Warning messages in the documentation
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WARNING

Potentially hazardous situation. Could result in death or serious injury if not avoided.

CAUTION

Potentially hazardous situation. Could result in minor or moderate injury if not avoided.

NOTICE

Potential risks of damage. Could result in damage to the supported product or to other
property.

1.4  Korea certification class B

이 기기는 가정용(B급) 전자파 적합기기로서 주로 가정에서 사용하는 것을 목적으로 하
며, 모든 지역에서 사용할 수 있습니다.

Korea certification class B
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2  Welcome
The R&S SGS is a signal generator intended either for the generation of IQ-modulated
signals or as a pure local oscillator (LO) source.

Optimized for use in automated test equipment (ATE), the instrument offers fast settling
times in an exceptionally small form factor and low power consumption. The R&S SGS
can be equipped optionally with an active electronic step attenuator, a high stability ref-
erence oscillator and LO connectors for coupling multiple generators to a common LO
source.

2.1  Key features

The key features of the R&S SGS include the following:

● Compact size and low power consumption
● Remote connection via PCI Express, minimizing the setup time

Alternatively, LAN or USB connections available
● Coherent LO input and output connectors, also usable as MIMO input/output and

phase coherent I/Q demodulation
● Broadband analog input for vector modulation (I, Q)
● Linux operating system
● Graphical user interface R&S SGMA-GUI to set up and control one or more

R&S SGS instruments simultaneously from one remote computer, available for
Windows and Linux systems

2.2  What's new

This manual describes firmware version FW 5.00.232.xx and later of the
R&S®SGS100A.

Compared to the previous version, it provides the new features listed below:
● Upgrading to R&S SGS firmware versions 5.00.vvv.vv and later, see "Upgrading to

firmware versions 5.00.vvv.vv and later" on page 29.
● Extended "Configure Instruments" settings including scanning the subnet, setting

the IP address and the prefix length, see Chapter 8.1.2.1, "Configure instruments",
on page 61.

● Password management including user password and security password settings,
see Chapter 10.6, "Security", on page 148.

● Editorial changes, major changes are as follows:
– Safety and regulatory information updated, see Chapter 1, "Safety and regula-

tory information", on page 11.

What's new
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– Getting started updated, see Chapter 3, "Preparing for use", on page 19,
Chapter 4, "Instrument tour", on page 35, Chapter 5, "Trying out the Instru-
ment", on page 39 and Chapter 6, "Instrument control", on page 43.

– Transporting added, see Chapter 15, "Transporting", on page 313.
– Maintenance, storage and disposal added, see Chapter 16, "Maintenance,

storage and disposal", on page 314.

2.3  Documentation overview

This section provides an overview of the R&S SGS user documentation. Unless speci-
fied otherwise, you find the documents on the R&S SGS product page at:

www.rohde-schwarz.com/manual/sgs100a

2.3.1  Getting started manual

Introduces the R&S SGS and describes how to set up and start working with the prod-
uct. Includes basic operations, typical measurement examples, and general informa-
tion, e.g. safety instructions, etc. A printed version is delivered with the instrument.

2.3.2  User manual and help

Contains the description of all instrument modes and functions. It also provides an
introduction to remote control, a complete description of the remote control commands
with programming examples, and information on maintenance, instrument interfaces
and error messages. Includes the contents of the getting started manual.

The contents of the user manuals are available as help in the R&S SGS. The help
offers quick, context-sensitive access to the complete information.

All user manuals are also available for download or for immediate display on the Inter-
net.

2.3.3  Service manual

Describes the performance test for checking the rated specifications, module replace-
ment and repair, firmware update, troubleshooting and fault elimination, and contains
mechanical drawings and spare part lists.

The service manual is available for registered users on the global Rohde & Schwarz
information system (GLORIS, https://gloris.rohde-schwarz.com).

Documentation overview

http://www.rohde-schwarz.com/manual/sgs100a
https://gloris.rohde-schwarz.com
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2.3.4  Instrument security procedures

Deals with security issues when working with the R&S SGS in secure areas. It is avail-
able for download on the Internet.

2.3.5  Basic safety instructions

Contains safety instructions, operating conditions and further important information.
The printed document is delivered with the instrument.

2.3.6  Data sheets and brochures

The data sheet contains the technical specifications of the R&S SGS. It also lists the
options and their order numbers and optional accessories.

The brochure provides an overview of the instrument and deals with the specific char-
acteristics.

See www.rohde-schwarz.com/brochure-datasheet/sgs100a

2.3.7  Release notes and open source acknowledgment (OSA)

The release notes list new features, improvements and known issues of the current
firmware version, and describe the firmware installation.

The open source acknowledgment document provides verbatim license texts of the
used open source software.

See www.rohde-schwarz.com/firmware/sgs100a

2.3.8  Application notes, application cards, white papers, etc.

These documents deal with special applications or background information on particu-
lar topics.

See www.rohde-schwarz.com/application/sgs100a.

2.4  Typographical conventions

The following text markers are used throughout this documentation:

Convention Description

"Graphical user interface ele-
ments"

All names of graphical user interface elements on the screen, such as
dialog boxes, menus, options, buttons, and softkeys are enclosed by
quotation marks.

[Keys] Key and knob names are enclosed by square brackets.

Typographical conventions

http://www.rohde-schwarz.com/brochure-datasheet/sgs100a
http://www.rohde-schwarz.com/firmware/sgs100a
http://www.rohde-schwarz.com/application/sgs100a
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Convention Description

Filenames, commands,
program code

Filenames, commands, coding samples and screen output are distin-
guished by their font.

Input Input to be entered by the user is displayed in italics.

Links Links that you can click are displayed in blue font.

"References" References to other parts of the documentation are enclosed by quota-
tion marks.

2.5  Notes on screenshots

When describing the functions of the product, we use sample screenshots. These
screenshots are meant to illustrate as many as possible of the provided functions and
possible interdependencies between parameters. The shown values may not represent
realistic usage scenarios.

The screenshots usually show a fully equipped product, that is: with all options instal-
led. Thus, some functions shown in the screenshots may not be available in your par-
ticular product configuration.

Notes on screenshots
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3  Preparing for use
Here, you can find basic information about setting up the product for the first time.

3.1  Lifting and carrying

See also "Lifting and carrying the product" on page 11.

► Use the carrying handles at the side for lifting and carrying the R&S SGS.
The handles at the front are only for pushing and pulling the instrument when
mounting in a rack, see Chapter 3.4.2, "Mounting the R&S SGS in a rack",
on page 21.

3.2  Unpacking and checking

1. Unpack the R&S SGS carefully.

2. Retain the original packing material. Use it to protect the control elements and con-
nectors when transporting or shipping the R&S SGS later.
See also Chapter 15, "Transporting", on page 313.

3. Using the delivery notes, check the equipment for completeness.

4. Check the equipment for damage.

If the delivery is incomplete or equipment is damaged, contact Rohde & Schwarz.

3.3  Choosing the operating site

Specific operating conditions ensure proper operation and avoid damage to the prod-
uct and connected devices. For information on environmental conditions such as ambi-
ent temperature and humidity, see the data sheet.

See also "Choosing the operating site" on page 12.

Electromagnetic compatibility classes

The electromagnetic compatibility (EMC) class indicates where you can operate the
product. The EMC class of the product is given in the data sheet.
● Class B equipment is suitable for use in:

– Residential environments
– Environments that are directly connected to a low-voltage supply network that

supplies residential buildings

Choosing the operating site
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● Class A equipment is intended for use in industrial environments. It can cause
radio disturbances in residential environments due to possible conducted and radi-
ated disturbances. It is therefore not suitable for class B environments.
If class A equipment causes radio disturbances, take appropriate measures to
eliminate them.

3.4  Setting up the R&S SGS

See also:
● "Setting up the product" on page 12
● "Intended use" on page 11

3.4.1  Placing the R&S SGS on a bench top

To place the product on a bench top

1. Place the product on a stable, flat and level surface. Ensure that the surface can
support the weight of the product. For information on the weight, see the data
sheet.

2. WARNING! A stack of products can fall over and cause injury. Never stack more
than three products on top of each other. Instead, mount them in a rack.
Stack as follows:

● If the products have foldable feet, fold them in completely.
● It is best if all products have the same dimensions (width and length). If the

products have different dimensions, stack according to size and place the
smallest product on top.

● Do not exceed the permissible total load placed on the product at the bottom of
the stack:
– 50 kg when stacking products of identical dimensions (left figure).
– 25 kg when stacking smaller products on top (middle figure).

Setting up the R&S SGS
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Left = Stacked correctly, same dimensions
Middle = Stacked correctly, different dimensions
Right = Stacked incorrectly, too many products

3. NOTICE! Overheating can damage the product.
Prevent overheating as follows:

● Keep a minimum distance of 10 cm between the fan openings of the product
and any object in the vicinity.

● Do not place the product next to heat-generating equipment such as radiators
or other products.

3.4.2  Mounting the R&S SGS in a rack

To prepare the rack

1. Observe the requirements and instructions in "Setting up the product" on page 12.

2. NOTICE! Insufficient airflow can cause overheating and damage the product.
Design and implement an efficient ventilation concept for the rack.

To mount the R&S SGS in a rack

1. Use an adapter kit that fits the dimensions of the R&S SGS to prepare the instru-
ment for rack mounting.

a) Order the rack adapter kit designed for the R&S SGS. For the order number,
see data sheet.

b) Mount the adapter kit. Follow the assembly instructions provided with the
adapter kit.

2. Push the R&S SGS onto the shelf until the rack brackets fit closely to the rack.

3. Tighten all screws at the rack brackets with a tightening torque of 1.2 Nm to secure
the R&S SGS in the rack.

To unmount the R&S SGS from a rack

1. Loosen the screws at the rack brackets.

2. Remove the R&S SGS from the rack.

3. If placing the R&S SGS on a bench top again, unmount the adapter kit from the
R&S SGS. Follow the instructions provided with the adapter kit.

Setting up the R&S SGS
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3.5  Considerations for test setup

Cable selection and electromagnetic interference (EMI)

Electromagnetic interference (EMI) can affect the measurement results.

To suppress electromagnetic radiation during operation:
● Use high-quality shielded cables, especially for the following connector types:

– SMA/SMB
Double-shielded SMA/SMB cables.
How to: Chapter 3.8, "Connecting to RF 50Ω", on page 23

– USB
Double-shielded USB cables.
How to: Chapter 3.13.4, "Connecting a controller via USB", on page 33.

– LAN
At least CAT6 STP cables.
How to: Chapter 3.7, "Connecting to LAN", on page 23

● Always terminate open cable ends.
● Ensure that connected external devices comply with EMC regulations.

Signal input and output levels

Information on signal levels is provided in the data sheet. Keep the signal levels within
the specified ranges to avoid damage to the R&S SGS and connected devices.

Preventing electrostatic discharge (ESD)

Electrostatic discharge is most likely to occur when you connect or disconnect a DUT.

► NOTICE! Electrostatic discharge can damage the electronic components of the
product and the device under test (DUT).
Ground yourself to prevent electrostatic discharge damage:

a) Use a wrist strap and cord to connect yourself to ground.
b) Use a conductive floor mat and heel strap combination.

3.6  Connecting to power

For safety information, see "Connecting to power" on page 12.

1. Plug the AC power cable into the AC power connector on the rear panel of the
instrument. Only use the AC power cable delivered with the R&S SGS.

2. Plug the AC power cable into a power outlet with ground contact.

The required ratings are listed next to the AC power connector and in the data
sheet.

Connecting to power
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There is no need to set the voltage manually or change fuses.

3.7  Connecting to LAN

Network environment

Before connecting the product to a local area network (LAN), consider the following:
● Install the latest firmware to reduce security risks.
● For internet or remote access, use secured connections if applicable.
● Ensure that the network settings comply with the security policies of your company.

Contact your local system administrator or IT department before connecting your
product to your company LAN.

● When connected to the LAN, the product may potentially be accessed from the
internet, which may be a security risk. For example, attackers might misuse or
damage the product.

To connect to LAN

The connector is on the rear panel.

► Connect the LAN socket via an RJ-45 cable to the LAN.

By default, the R&S SGS is configured to use DHCP (dynamic host configuration pro-
tocol) and no static IP address is configured.

3.8  Connecting to RF 50Ω

The connector is on the rear panel.

To prepare for connecting to RF 50Ω

1. NOTICE! Damaged or not clean connections can lead to RF insertion loss and mis-
match, and even premature wear of the connectors.
Before connecting to the port, inspect the RF connector visually to check that it is
clean, undamaged and mechanically compatible.
See the application note 1MA99 for information on how to handle and maintain the
RF port, to minimize measurement deviations and ensure its longevity.

2. NOTICE! Risk of instrument damage. Excessive reverse power or DC voltage at
the RF 50Ω connector can damage the instrument.
Make sure that the values do not exceed the reverse power and DC limits as given
in the data sheet.

3. If switched-on, deactivate the RF output of the R&S SGS, before connecting an RF
cable to the RF 50Ω connector.

Connecting to RF 50Ω
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On the front panel, press the [RF ON] key.

To connect to screwable connectors

Additional to the RF 50Ω connector, the following procedure holds for all screwable
connectors of the R&S SGS. Screwable connectors include connector types as listed
in Table 3-1.

1. Use a high-quality cable that matches the connector type.
See "Cable selection and electromagnetic interference (EMI)" on page 22.

2. NOTICE! Risk of instrument damage and connector damage. Excessive tightening
can damage the cables and the connectors. However, if you do not tighten the con-
nectors enough, the measurement results can be inaccurate.
To connect the cable with the connector, proceed as follows:

a) Carefully align the connector of the cable and the connector along a common
axis.

b) Mate the connectors along the common axis until the male pin of the inner con-
nector engages with the female socket of the outer connector.

c) Turn the nut of the outer connector until the connectors are firmly coupled.
d) Torque the nut to the specified limit using a calibrated torque wrench. Hold the

opposite connector part stationary with a spanner.
For torque limits of the most relevant connector types, see Table 3-1. For more
information, see chapter "Handling" of the application note 1MA99.

3. Torque the nut to the specified limit using a calibrated torque wrench. Hold the
opposite connector part stationary with a spanner.

Table 3-1: Connector types and torque limits

Type Torque limit Nut opening

 lb-Inch Nm Inch mm

SMA, SMB 5 0.56 5/16 8

To prevent RF output switch-off

► NOTICE! If you set a too high output level without a load connected to the instru-
ment, the reverse power can exceed a limit forcing the R&S SGS to switch off the
RF output.
Connect a load with sufficient return loss.

3.9  Connecting to non-screwable connectors

Non-screwable connectors of the R&S SGS are BNC type connectors on the rear
panel.

► To connect the RF cable with the RF 50Ω connector, proceed as follows:

Connecting to non-screwable connectors
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a) Carefully align the connector of the cable and the RF 50Ω connector along a
common axis.

b) Mate the connectors along the common axis until the male pin of the connector
of the cable engages with the female socket of the RF 50Ω connector.

3.10  Switching on or off

The following table provides an overview of power states, LEDs and power switch posi-
tions.
Table 3-2: Overview of power states

State LED Position of power switch

Off  gray [0]

Standby  orange [I]

Ready  green [I]

To switch on the R&S SGS

The R&S SGS is off but connected to power. See Chapter 3.6, "Connecting to power",
on page 22.

1. Set the switch on the power supply to position [I].
The switch is on the rear panel.

The LED of the [POWER ON/STANDBY] key is orange.

2. If equipped with an oven-controlled oscillator (OCXO), option R&S SGS-B1, wait
until the OCXO warms up.
For the warm-up time, see data sheet.

3. Press the [POWER ON/STANDBY] key.
Key and LED are on the front panel.

The LED changes to green. The R&S SGS boots.

When starting for the first time, the R&S SGS starts with the default settings. When
restarting the instrument, the settings depend on the instrument configuration
before shut-down.
See Chapter 8.1.1, "File menu", on page 60.

To perform functional checks

When the instrument is switched on, it automatically monitors main functions. You can
query erroneous functions.

See Chapter 14, "Error messages and troubleshooting", on page 309.

In addition to the automatic monitoring, the R&S SGS offers the following capabilities
to ensure correct functioning:
● Internal adjustments

Switching on or off
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In the R&S SGMA-GUI, select the "Instrument > Setup > Internal Adjustments" dia-
log to access the dialog for performing and configuring the adjustments settings. A
maximum level accuracy can be obtained, for instance.

● Selftest
A selftest is provided for service purposes ("SGMA-GUI > Instrument > Diagnostic/
Test > Self Test").

To switch between standby and ready state

► Press the [POWER ON/STANDBY] key briefly to switch the instrument from the
standby to ready state or vice versa.

In ready state, the button is green. The instrument is ready for operation. All mod-
ules are power-supplied and the R&S SGS initiates its startup procedure.
In standby state, the button is orange. The standby power mode keeps the power
switch circuits and the remote control system active.

To start up and boot

The instrument boots the operating system and starts the instrument firmware. During
the booting process, the green [POWER ON/STANDBY] key blinks. If the previous ses-
sion was terminated regularly, the instrument uses the last setup with the relevant
instrument settings.

Once the startup procedure has been terminated, the instrument is ready for operation.

In the R&S SGMA-GUI, select "Instrument > Preset" function to return the instrument
to its defined reset/preset state, if the current setup is no longer relevant.

To customize the start settings, use the "SGMA-GUI > File > Save As/Open" function.

To shut down the product

The product is in the ready state.

► Press the [POWER ON/STANDBY] key.

The operating system shuts down. The LED changes to orange.

In standby state, the power switch circuits and the OCXO are active. To deactivate
them, disconnect the instrument from the power supply.

To disconnect from power

The R&S SGS is in the standby state.

1. NOTICE! Risk of data loss. If you disconnect the product from power when it is in
the ready state, you can lose settings and data. Shut it down first.
Set the toggle switch on the power supply to position [0].

The LED of the [POWER ON/STANDBY] key is switched off.

2. Disconnect the R&S SGS from the power source.

Switching on or off
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3.11  Checking default settings

When the instrument is switched on, it is not the preset state that is active, but rather
the instrument state that was set before the instrument was switched off. It is recom-
mended that you use the "SGMA-GUI > Instrument > Preset" function to return the
instrument to its defined preset state every time a new configuration is required or the
current setup is no longer relevant.

The R&S SGS offers a two-stage preset concept:
● Preset the instrument to a predefined state.

The "SGMA-GUI > Instrument Name > Preset" function calls up a defined instru-
ment setup. All parameters and switching states are preset. The default instrument
settings provide a reproducible initial basis for all other settings. However, functions
that concern the integration of the instrument into a measurement setup are not
changed.

● Preset the instrument to its factory settings.
The instrument can also be forced to load its default factory settings. To access the
corresponding dialog box, select the "SGMA-GUI > Instrument Name > Setup >
Factory Preset" function.
For more information and an overview of the settings affected by the factory preset
function, see Chapter 10.9, "Factory preset", on page 155.

User-defined instrument states can be stored and called up using the functions
"SGMA-GUI > File > Save As/Open".

3.12  Working with Linux operating system

The instrument uses an embedded Linux operating system, optimally adapted to the
instrument.

Accessing the operating system
No access to the operating system is required for normal operation.
All necessary system settings can be made in the "Setup" dialog.

3.13  Connecting an external PC and devices

For control and operation, the R&S SGS requires a connection to an external device.
The external device, e.g. an external PC, controls the R&S SGS via remote control or
manual operation via the R&S SGMA-GUI software installed on the external PC.

Both the remote control and the manual operation of the instrument require an external
controller. For the prerequisites and the instructions on how to configure an external
controller for remote control, refer to the user manual. A brief introduction to the remote

Connecting an external PC and devices
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control capabilities is provided in Chapter 12, "Network operation and remote control",
on page 175.

This section gives an introduction on how to configure the external PC for manual
operation. See Chapter 3.13.1, "Installing the R&S SGMA-GUI software", on page 28.

In addition to connecting an external controller, you can connect other external devi-
ces, e.g. a memory stick. The following interfaces are on the rear panel of the
R&S SGS:

● "LAN": Chapter 3.13.2, "Connecting a remote PC via LAN", on page 30
● "PCIe": Chapter 3.13.3, "Connecting a controller via PCI Express", on page 33
● "USB In": Chapter 3.13.4, "Connecting a controller via USB", on page 33

3.13.1  Installing the R&S SGMA-GUI software

The R&S SGMA-GUI software is a graphical user interface program for one or more
instruments. It runs on a remote PC.

The R&S SGMA-GUI software is provided as separate installation package for the dif-
ferent operating systems. The latest version of the software together with the release
notes is available for download at:

http://www.rohde-schwarz.com/product/SGS100A.html > "Downloads" > "Software"

This page always offers the latest information on your R&S SGMA-GUI.

The R&S SGMA-GUI installation package for Windows 64-bit operating system con-
sists of the file SGMA-GUI_<version_number>.exe. The version number within the
file name (<version_number>=v.vv.vvv.vv) varies with each update.

To install the R&S SGMA-GUI, check that you PC and drivers fulfill the following hard-
ware and software requirements.
Table 3-3: Hardware and software requirements

Requirement Remark

Operating system:

Windows 10, 1607 "Anniver-
sary Edition" and later

Install R&S SGMA-GUI on one of the supported operating systems. Also,
make sure that Microsoft offers support for the version of the operating sys-
tem.

Note: Any other Windows version or other operating systems are not sup-
ported. During installation, the operation system is checked. The installation
is terminated if this requirement is not fulfilled.

System type:
● 64-bit operating system
● x64-based or x86-based

processor

You can only run the latest software on a 64-bit operating system.

R&S VISA VISA drivers can be obtained on the Rohde & Schwarz website:

http://www.rohde-schwarz.com/rsvisa

CPU At least Pentium or compatible, as from 1 GHz (recommended).

VGA color display resolution At least 800*600 pixels

Connecting an external PC and devices
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Installing a new software version

1. Download the R&S SGMA-GUI software.

2. In Windows Explorer, navigate to the download folder of the installation file
SGMA-GUI_V.VV.VVV.VV.exe (<version_number>=v.vv.vvv.vv).

3. Open the installation file using administrator rights.

4. Follow the instructions in the installation wizard.

After the installation of the R&S SGMA-GUI software, two icons will be shown in your
Windows menu: one is the standard version and one for which the remote command of
the software through SCPIs is disabled. The SCPI disabled version allows you to install
and use the R&S SGMA-GUI on other instruments, without interfering with the remote
control of the host instrument.

Start the version that is required for your application.

Upgrading to firmware versions 5.00.vvv.vv and later

For upgrading the R&S SGS to firmware versions 5.00.vvv.vv and later, proceed as fol-
lows:

1. Download the *.rsu file for R&S SGS firmware version 4.30.046.300.

2. Install this firmware version before installing a firmware version 5.00.vvv.vv and
later.
Follow the step-by-step description in the release notes document, see Chap-
ter 2.3.7, "Release notes and open source acknowledgment (OSA)", on page 17.

3. Download and install a firmware version 5.00.vvv.vv and later.
Follow the step-by-step description in the release notes document, see Chap-
ter 2.3.7, "Release notes and open source acknowledgment (OSA)", on page 17.

Uninstalling an old software version

You can uninstall a previous version of the software before the installing a new soft-
ware version, but this step is not mandatory.

1. To uninstall this version, go to "Start > Settings > Control Panel > Add/Remove
Programs".

Connecting an external PC and devices
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2. Select the entry SGMA-GUI_V.VV.VVV.VV.

The script file identifies and removes all currently installed R&S SGMA-GUI soft-
ware items.

3.13.2  Connecting a remote PC via LAN

The R&S SGS is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The interface can be used, for example:

● To connect an external computer for manual control of the instrument by the R&S
SGMA-GUI software.

● To operate the device by a remote control program.
See Chapter 12, "Network operation and remote control", on page 175.

This section describes how to configure the LAN interface. It covers the following top-
ics:

● Connecting to the network...................................................................................... 30
● Assigning the IP address........................................................................................ 31
● Adding instruments to R&S SGMA-GUI..................................................................32

3.13.2.1  Connecting to the network

There are two methods to establish a LAN connection to the instrument:

● A non-dedicated network (Ethernet) connection from the instrument to an existing
network.

● A dedicated network connection (Point-to-point connection) between the instru-
ment and a single computer.

In both cases, an IP address has to be assigned to the instrument and the computer,
see Chapter 3.13.2.2, "Assigning the IP address", on page 31.

Setting up a non-dedicated network (LAN) connection

► See Chapter 3.7, "Connecting to LAN", on page 23.

Setting up a dedicated network connection

If your network does not support DHCP, set a dedicated network connection between a
stand-alone PC and a R&S SGS.

Prerequisite: The external PC and the R&S SGS are turned on and running.

1. Start the R&S SGMA-GUI.

2. NOTICE! Risk of network failure.
Consult your network administrator before performing the following tasks:
● Connecting the instrument to the network
● Configuring the network
● Changing IP addresses
Errors can affect the entire network.

Connecting an external PC and devices
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Connect the computer and the R&S SGS with a LAN network cable.

3. Wait for about one minute for the automatic assignment of IP addresses to com-
plete.

4. R&S SGMA-GUI main panel, select "Setup > Instruments".

5. In the "Configure Instruments" dialog, click "Scan".

The new instrument appears with a Zeroconf IP address 169.254.xx.yy.

6. To assign a static IP address to the instrument, see "Assigning a static IP address
to the R&S SGS" on page 31.

7. To assign a static IP address to the PC, see "Assigning a static IP address to your
Windows-PC network card" on page 32.

8. To edit the instrument settings, see Chapter 8.4.2.6, "How to edit instruments",
on page 78.

3.13.2.2  Assigning the IP address

Depending on the network capacities, the TCP/IP address information for the instru-
ment can be obtained in different ways.
● If the network supports dynamic TCP/IP configuration using the Dynamic Host

Configuration Protocol (DHCP), all address information can be assigned automati-
cally.

● If the network does not support DHCP, the instrument tries to obtain the IP address
via Zeroconf (APIPA) protocol. If this attempt does not succeed or if the instrument
is set to use, alternate TCP/IP configuration, the addresses must be set manually,
see "Setting up a dedicated network connection" on page 30.

The R&S SGS uses the Zeroconf IP addresses 169.254.xxx.yyy, where xxx takes val-
ues between 1...254 and yyy the values in the value range 1...255; the subnet mask is
always 255.255.0.0. The IP address of the host must be within the same address area
for Zeroconf.

Assigning a static IP address to the R&S SGS

Prerequisites: A connection is established between the R&S SGS and the controller
with installed SGMA-GUI.

For how to set up a LAN connection, see Chapter 3.13.2.1, "Connecting to the net-
work", on page 30.

For how to set up a USB connection, see "Setting up a USB connection from a PC to
the R&S SGS" on page 33.

1. Open "SGMA-GUI > Instrument > Setup > Network Settings" dialog.

2. Set the "Address Mode" to "Static".

3. Enter the "IP Address", for example 192.168.0.1..

Connecting an external PC and devices
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4. Enter the "Subnet mask", for example 255.255.255.0.

5. Enter the "Default Gateway", for example 192.168.0.1.

Assigning a static IP address to your Windows-PC network card

1. Obtain the IP address and subnet mask for the R&S SGS and the IP address for
the local default gateway from your network administrator. If necessary, also obtain
the name of your DNS domain and the IP addresses of the DNS and WINS servers
on your network. If you use more than one LAN connector, you need separate
address information for each connector.

2. Press the "Windows" key to access the operating system.

3. Open the "Control Panel" by selecting "Start > Settings > Control Panel".

4. Select "Network and Sharing Center".

5. In the left panel, click "Change adapter settings".

6. Select the network adapter that you want to change. Click "Change settings of this
connection".

7. On the "Networking" tab, click "Internet Protocol Version 4 (TCP/IPv4)". Select
"Properties".

8. Select "Use the following IP address".

9. Enter the address information as obtained from the network administrator.

10. If necessary, you can also select "Use the following DNS server addresses" and
enter your own DNS addresses.

For more information, refer to your Windows system help.

3.13.2.3  Adding instruments to R&S SGMA-GUI

For information on how to install the R&S SGMA-GUI software, refer to Chapter 3.13.1,
"Installing the R&S SGMA-GUI software", on page 28.

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Press the [POWER ON/STANDBY] key to switch on the instrument.
c) Wait until the [POWER ON/STANDBY] LED is green and not blinking.
d) Press the [ID] key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

3. Open the "Instruments" dialog.

4. Select "Scan".
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Note: This step is performed automatically on the first start and can also be omit-
ted for instruments with a direct LAN connection to the computer.

All instruments are added automatically to the main panel of the SIGMA-GUI.

3.13.3  Connecting a controller via PCI Express

Using the "PCIe" interface for remote control of the R&S SGS requires extended
knowledge. See Chapter 12.3, "Advanced remote control using PCIe", on page 186.

3.13.4  Connecting a controller via USB

The USB interface on the rear panel of the R&S SGS allows you to connect either a
USB device or use the R&S SGS as a device and connect it to a controller.

Connecting a controller (host PC or compatible signal generator)

If you connect a controller (host PC or compatible signal generator) to the R&S SGS,
the R&S SGS acts as a USB device.

To connect the controller to the USB interface of the R&S SGS, always connect the
USB type Micro-B connector to the R&S SGS. Refer to the documentation of the con-
troller to find out which USB connector type you can connect to the controller.

The Figure 3-1 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 3-1: USB type Micro-B connectors

An external PC with installed R&S SGMA-GUI is required for manual operation of the
R&S SGS.

Setting up a USB connection from a PC to the R&S SGS

If your network does not support DHCP, you can set a USB connection between a PC
and a R&S SGS.

Prerequisite: the computer and the R&S SGS are turned on and running.

1. Start the R&S SGMA-GUI.

2. Connect the computer and the R&S SGS with a USB cable.

In the "Setup > Instruments > Configure Instruments" table, the new instrument
appears automatically.
If it does not appear, open the "Setup > Instruments > Configure Instruments" dia-
log and select "Scan".
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3. If your network does not support DHCP, you can now set a static IP address to
your computer.

a) To assign a static IP address to the instrument, see "Assigning a static IP
address to the R&S SGS" on page 31.

b) To assign a static IP address to the PC, see "Assigning a static IP address to
your Windows-PC network card" on page 32.

c) To edit the instrument settings, see Chapter 8.4.2.6, "How to edit instruments",
on page 78.

Connecting a USB device

If you connect a USB device (memory stick, CD-ROM, an instrument) to the R&S SGS,
the R&S SGS acts as a host.

To connect a USB device to the interface of the R&S SGS, always connect the
USB type Micro-A connector to the R&S SGS. Refer to the documentation of the USB
device to find out which USB connector type you can connect to the USB device.

The Figure 3-2 illustrates schematically the required connector type to emphasize on
the different connector shape.

Figure 3-2: USB type Micro-A connectors

If you connect an R&S SGS to an R&S SGU via a USB cable, perform the steps as
described in Chapter 7.2, "Connecting an R&S SGS and an R&S SGU", on page 48.

Using a USB adapter
You can use a USB adapter to customize the connectors of a USB cable to the require-
ments of the instrument.
For example, use a Type-A / Micro-A adapter to customize a standard USB cable. The
customized cable connects type A and type Micro-B connectors for the connection of
an R&S SGS (acting as a host) to an R&S SGU (acting as a USB device).
Also, you can use a Type-A / Micro-B adapter to establish a connection to the instru-
ment. To check, whether the adapter you have is suitable or not you can connect a
USB stick with an LED through the adapter to the instrument. If the LED of the USB
stick lights up after a connection to the instrument then you can use this adapter for
further applications with the instrument.

Connecting an external PC and devices



Instrument tourR&S®SGS100A

35User Manual 1173.9105.02 ─ 13

4  Instrument tour
This chapter explains the control elements and the connectors of the R&S SGS. The
views of the front panel and the rear panel help you to get familiar with the instrument
and to perform first steps. For specifications of the interfaces, see the data sheet.

The meanings of the labels on the R&S SGS are described in Chapter 1.2, "Labels on
R&S SGS", on page 13.

4.1  Front panel tour

This section provides an overview of control elements on the front panel of the
R&S SGS. The front panel contains LEDs to inform you about the status of the instru-
ment, in particular for remote control of the R&S SGS.

The connectors of the R&S SGS are on the rear panel.

1 2 3 4 5 6

Figure 4-1: R&S SGS front panel controls

1 = [POWER ON/STANDBY]
2 = [RF ON]
3 = [REF EXT]
4 = [ERROR / WARNING]
5 = [LAN]
6 = [ID]

[POWER ON/STANDBY]
The [POWER ON/STANDBY] key switches the instrument from the standby to the
ready state or vice versa.
The LED above the [POWER ON/STANDBY] key indicates the instrument state, see
Table 3-2.
How to:
● Chapter 3.10, "Switching on or off", on page 25
● "To switch between standby and ready state" on page 26

[RF ON]
The [RF ON] key switches the RF signal on or off. If activated, the key is green.

Front panel tour
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Table 4-1: Overview of RF signal states

[RF ON] state LED Remark

On  green RF signal output at the RF 50Ω connector.

Off  gray No RF signal output.

How to: Chapter 3.8, "Connecting to RF 50Ω", on page 23

[REF EXT]
The [REF EXT] key activates synchronization to an external reference signal.
Use the "TRIG" on the rear panel for input of the external reference signal.
Table 4-2: Overview of external reference signal states

[REF EXT] state LED Remark

Synchronized  green R&S SGS synchronizes to the external clock signal.

Error  red R&S SGS cannot synchronize to the external clock signal.

Off  gray The internal reference signal is used.

[ERROR / WARNING]
The [ERROR / WARNING] LED indicates the status of the R&S SGS.
Table 4-3: Overview of [ERROR / WARNING] key states

[ERROR /
WARNING] state

LED Remark

Error  red Error occurred, e.g. temperature exceeded or power failure.

Running process  blinking orange Indicates a running process (e.g calibration, self-test).

No error  gray No errors or warnings occurred.

See also Chapter 14, "Error messages and troubleshooting", on page 309.

[LAN]
The [LAN] key indicates the LAN connection state.
Pressing the [LAN] key resets the network settings, e.g., "IP Adress Mode" is reset to
"DHCP".
Table 4-4: Overview of LAN connection states

[LAN] state LED Remark

Connected  green Connected to the network.

Running process  blinking orange Resets the network settings, applies the default settings.

Error  red Network error occurred.

Off  gray The internal reference signal is used.

How to:
● Chapter 3.7, "Connecting to LAN", on page 23

Front panel tour
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● Chapter 3.13.2, "Connecting a remote PC via LAN", on page 30

[ID]
The [ID] key allows you to identify your R&S SGS, e.g. in complex test setups with
more instruments.
The following applies if the R&S SGS is connected to a remote controller with
R&S SGMA-GUI installed:
● Press the [ID] key identify your R&S SGS on the remote controller. In the dialog

"SGMA-GUI > Setup > Instruments > Configure Instruments > Edit Instrument", the
R&S SGS is active.

● Set "Edit Instrument > Device Identify > On" to identify your R&S SGS from the
remote controller. The LED of the [ID] key is orange and blinking.

Table 4-5: Overview of [ID] key states

[ID] state LED Remark

Identification  blinking orange Identification of the R&S SGS.

Off/Inactive  gray No identification.

4.2  Rear panel tour

This section provides an overview of the connectors on the rear panel of the instru-
ment. For technical data of the connectors, refer to the data sheet.

1 2 3 4 5

8 7 6

Figure 4-2: R&S SGS rear panel controls and connectors

1 = AC power supply connector and power switch
2 = PCIe
3 = LAN
4 = USB In
5 = RF 50Ω
6 = LO IN, LO OUT, REF IN, REF OUT
7 = TRIG
8 = I/Q

AC power supply connector and power switch
Mains power switch for performing the following tasks:
● Connecting the internal power supply to the power source
● Disconnecting the internal power supply from the power source
How to: Chapter 3.6, "Connecting to power", on page 22

Rear panel tour
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LAN
RJ-45 connector to connect the R&S SGS to a LAN for remote control.
How to:
● Chapter 3.7, "Connecting to LAN", on page 23
● Chapter 3.13.2, "Connecting a remote PC via LAN", on page 30

PCIe
PCIe (Peripheral Component Interconnect Express) single lane interface for remote
control with optimized speed.
How to: Chapter 12.3.4, "Connecting the controller and the instrument", on page 190.

USB In
USB (universal serial bus) type Micro-B connector for remote control via various exter-
nal devices.
How to: Chapter 3.13.4, "Connecting a controller via USB", on page 33

RF 50Ω
SMA female connector for output of the RF signal.
How to: Chapter 3.8, "Connecting to RF 50Ω", on page 23

LO IN, LO OUT, REF IN, REF OUT
SMA female type connectors, for reference or local oscillator signals, and alternatively
also in MIMO setups.
Reference input and output:
● "REF IN": Input for external reference signal.
● "REF OUT": Output of internal reference signal.
Local oscillator input/output requires R&S SGS-K90.
Local oscillator input and output connectors:
● "LO IN": Input for external LO signals
● "LO OUT": Output of internal LO signals.
How to: "To connect to screwable connectors" on page 24

I/Q
Requires R&S SGS-B106V/-B112V.
SMA female connectors for input of external I/Q signals. The signals are fed directly
into the I/Q modulator.
How to: "To connect to screwable connectors" on page 24

TRIG
SMA female multipurpose connector for input and output signals, e.g., for the following
signals: "Trigger", "Marker 1/2", "Clock In/Out", "Sync In/Out".
Also, use the "TRIG" connector for input of an external pulse modulator signal.
How to: "To connect to screwable connectors" on page 24

Rear panel tour
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5  Trying out the Instrument
This section provides examples on how to configure the R&S SGS to generate a con-
tinuous wave (CW) signal via the R&S SGMA-GUI and the R&S SGS100A Web-GUI.

5.1  Configuring a CW Signal with the R&S SGMA-GUI

The R&S SGS in this example is a base unit equipped with the frequency option
R&S SGS-B106.

As a prerequisite for this example, the R&S SGS has to be connected to a remote PC.
The R&S SGMA-GUI software has to be installed on this remote PC and the instru-
ment is added to the list of "Available Instruments".

Figure 5-1: Example of the setup

For information on how to fulfill these requirements, refer to
● Chapter 3.13.2.1, "Connecting to the network", on page 30
● Chapter 3.13.1, "Installing the R&S SGMA-GUI software", on page 28
● Chapter 3.13.2.3, "Adding instruments to R&S SGMA-GUI", on page 32

1. Check the front panel of the R&S SGS.

The [POWER ON/STANDBY] and [LAN] key have to be green.

2. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application opens. The panel provides a quick access to the
main settings of the configured and activated instruments. The display shows one
row per instrument with the instrument-specific settings. The rows comprise the
instrument, the connection state, the used frequency and power level, the state of
the RF output and the modulator and the used reference frequency source.

Configuring a CW Signal with the R&S SGMA-GUI
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3. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.

4. In the R&S SGMA-GUI main panel, select the row corresponding to the instrument
to be configured and select "Instrument Name > Preset" to restore the predefined
instrument's settings.

5. In the R&S SGMA-GUI main panel, select the row corresponding to the instrument
to be configured and adjust the "Frequency" as required.

6. Select "SGMA-GUI > RF On" to enable the output of the CW signal.

The 5 GHz signal is output at the "RF 50Ω" connector at the rear panel of the
R&S SGS.

Configuring a CW Signal with the R&S SGMA-GUI
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Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". The green [LAN] LED on the front panel of the instrument blinks.
● Press the [ID] key on the instrument's front panel. The "Edit Instrument" dialog of

the respective instrument opens.

5.2  Configuring a CW Signal with the R&S SGS100A Web-
GUI

The R&S SGS100A Web-GUI is an alternative way to operate the R&S SGS. There is
no installation needed. It can be used with all devices and operating systems, including
tablets and smart phones, which have one of the following web browsers installed:

● Mozilla Firefox
● Google Chrome
● Microsoft Internet Explorer 9 or later

To connect to the R&S SGS from an external device, both of them must have access to
the same network, i.e. use a shared network.

The feature set of the R&S SGS100A Web-GUI is limited to the most common settings,
needed especially for modifying the output signal. For additional actions like firmware
updates or adjustments, please use the R&S SGMA-GUI.

You can operate the R&S SGS100A Web-GUI and the R&S SGMA-GUI simultane-
ously. Furthermore you can enable the "Update" function (upper right corner) to allow
an automatic update of the settings shown in the R&S SGS100A Web-GUI, if the set-
tings were changed via other software.

As a prerequisite for this example, the R&S SGS has to be connected to the same net-
work as the device used for controlling the instrument. Also one of the supported web
browsers has to be available.

1. Check the front panel of the R&S SGS.

The [POWER ON/STANDBY] and the [LAN] key have to be green.

2. Open a supported web browser.

3. Enter the instrument name or the IP address of the R&S SGS you want to connect
to.
Tip: The default hostname of the instrument is a non case-sensitive string built as
follows:
hostname = rssgs100a<serial number>, where
<serial number> is the individual serial number of the instrument.

Configuring a CW Signal with the R&S SGS100A Web-GUI
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The serial number is displayed at the rear side of the instrument. It is the third part
of the device ID printed on the bar code sticker, see Figure 5-2.

Figure 5-2: Serial number of the R&S SGS100A

The main panel of the R&S SGS100A Web-GUI opens.

In the R&S SGS100A Web-GUI main panel, the green indicator "System Status >
OK " confirms that there is a connection between the instrument and the remote
PC and that the instrument is recognized by the software.
If you want to get additional information about the instrument, click on the "Device
Name". For additional information on other settings, hold the mouse cursor over
the specific setting.
Error messages are also displayed in the R&S SGS100A Web-GUI. If you want to
hide an error message, click on it.

4. In the menu bar on the left side press " Preset" to restore the predefined instru-
ment's settings.

5. Select "Frequency" and adjust the setting as required.

6. Select "RF On" to enable the output of the CW signal.

A signal with the set frequency is output at the "RF 50Ω" connector at the rear
panel of the .

Configuring a CW Signal with the R&S SGS100A Web-GUI
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6  Instrument control
As a rule, the R&S SGS is operated exclusively via programmatic remote control from
a connected PC. For service and diagnostic tasks, and for manual configuration, a
graphical user interface (R&S SGMA-GUI) is provided which runs on the remote PC.

Also, some basic functionality is provided via the keys on the front panel of the instru-
ment (see Chapter 4.1, "Front panel tour", on page 35).

6.1  Manual operation via R&S SGMA-GUI

The R&S SGMA-GUI software application can be installed on a PC with Windows or
Linux operating system. This program allows you to control several devices of the
SGMA product family at the same time and to monitor the device status during remote
control. R&S SGMA-GUI requires one of the external interfaces described in Chap-
ter 3.13, "Connecting an external PC and devices", on page 27.

6.1.1  Introduction to the user interface

After the start of R&S SGMA-GUI, the main dialog of the application is displayed.

Figure 6-1: Example of R&S SGMA-GUI

The main dialog with an overview of the configured instruments is the operating and
control interface for the whole program. From here, all program functions are accessi-
ble.

The menus and dialogs are built using elements like selection lists, check boxes, and
entry fields. A blue frame indicates that the selected item is active. Entries can be
made in the highlighted element.

The main dialog comprises two main areas:
● On the top of the main panel, there are bars: the menu bar, the tool bar and the

info bar with the corresponding "Info" button.
The menu bar provides access to the functions related to the software application
itself, like saving current configurations, retrieving information about the installed
software version or configuring the connected instruments.
The messages displayed in the info line indicate information, warnings, and errors.
They are displayed in different colors depending on their importance and display

Manual operation via R&S SGMA-GUI
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duration. Use the "Info" button to open a dialog with information on the messages
in greater detail.

● The central part of the R&S SGMA-GUI main dialog is the main panel that shows
the list of all active instruments.
The main panel is the core element for the manual operation and provides quick
access to the main settings of the configured instruments. The display shows one
row per active instrument. Each row comprises the instrument's name and state,
the used frequency and level, the state of the RF output and the modulator and the
kind of used frequency reference.
The buttons with the instrument's symbolic name on it provides access to menus
and dialogs for further instrument configuration. Refer to the user manual for a
detailed description of all parameters and functions provided for configuration.

A detailed description of the R&S SGMA-GUI, in-depth information on how to work with
the application and on how to operate the R&S SGS is provided in the user manual.

6.1.2  How to use the help system

The R&S SGMA-GUI is equipped with a context-sensitive help function. A help page is
available for each parameter and can be called anytime during instrument operation.

Calling context-sensitive and general help

► To display the general help dialog box, select the "SGMA-GUI > Help > Contents"
or use the F1 key.

The help dialog is displayed. A topic containing information about the current menu
or the currently opened dialog box and its function is displayed.

Manual operation via R&S SGMA-GUI
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Contents of the help dialog box

The help dialog box contains two main areas:
● "Contents" - contains a table of help contents
● "Topic" - contains a specific help topic

The help system also provides an "Index", "Find" and "Zoom" functions that are
accessed with the corresponding buttons.

Navigating in the table of contents and in the help topics

1. To move through the displayed contents entries, use the mouse or the [Up/Down]
keys. Entries that contain further entries are marked with a plus sign.

2. To display a help topic, double click on the topic name or press the [ENTER] key.

3. To jump to the linked topic, press the link text.

4. Use the "Previous" or "Next" links to jump to the corresponding topic.

5. Use the "Scroll Right" or "Scroll Left" buttons to shift the indicated area of the navi-
gation window to the left or right.

Using the index

1. Select "SGMA-GUI > Help > Index" or use the "Go to Index" button in the "Help"
display.

2. Enter the first characters of the topic that you are interested in. The entries starting
with these characters are displayed.

3. Press the [ENTER] key to display the help topic.

The corresponding help topic is displayed.

Manual operation via R&S SGMA-GUI
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7  System overview
The R&S SGS RF Source is a signal generator. You can use it as a generator for IQ-
modulated signals or as a pure local oscillator (LO) source in the frequency range of
1 MHz to 12.75 GHz.

Optimized for use in automated test equipment (ATE), the instrument offers fast settling
times in an exceptionally small formfactor and low power consumption. The R&S SGS
can be equipped optionally with an active electronic step attenuator, a high stability ref-
erence oscillator and LO connectors for coupling multiple generators to a common LO
source.

7.1  Setups for instrument control

The R&S SGS is an instrument designed for the automated test equipment (ATE)
needs. To maintain the small size, the instrument is not equipped with a display and
hence additional equipment is required to control the instrument.

This section provides an overview of the possible configuration setups for controlling
the R&S SGS.

7.1.1  Manual operation from the R&S SGMA-GUI

The following example represents a basic configuration of the R&S SGS, operated
manually by the configuration software R&S SGMA-GUI. The configuration software is
installed on a remote PC and controls several instruments. The instruments are con-
nected to the remote PC over different remote control interfaces. Any combination of
the used interfaces is possible.

Figure 7-1: Configuration example: manual control from R&S SGMA-GUI

For information about the manual control, refer to:
● Chapter 8, "Understanding the R&S SGMA-GUI software", on page 59
● Chapter 9, "Signal generator settings", on page 91
● Chapter 10, "General instrument settings and instrument setup", on page 140

Setups for instrument control
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7.1.2  Remote control from a controller

The remote control provides access to the instrument's settings from a remote com-
puter (external controller) by remote commands. To automate often repeating settings
and sequences, these settings are grouped in the remote control programs, i.e. appli-
cation programs.

An instrument can be connected to the controller via any of the supported interfaces
LAN, USB or PCIe.

Figure 7-2: Configuration example: remote control from a controller

For information about remote control, refer to Chapter 12, "Network operation and
remote control", on page 175.

7.1.3  Control of an R&S SGS from an R&S signal generator

The R&S SGS can be used as an additional signal source to increase the number of
available RF outputs of anal Generator. In this setup, a controller does not need to
access the R&S SGS directly. Instead, the signal generator acts as a controller to the
R&S SGS and depending on the required output signal parameters performs all
required settings automatically.

The Figure 7-3 shows a configuration example of the R&S SGS, directly controlled by
an R&S SMW.

Figure 7-3: Configuration example: Control from an R&S SMW

Setups for instrument control
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7.2  Connecting an R&S SGS and an R&S SGU

If an R&S SGU is connected to an R&S SGS, the R&S SGU acts as an extension to
the R&S SGS extending its frequency range. In this setup, a controller does not need
to access the R&S SGU directly. Instead, the R&S SGS acts as a controller to the R&S
SGU. The generator performs all required settings automatically depending on the
required output signal parameters.

This chapter gives an overview of how to connect the instruments. It covers the follow-
ing topics.

● Using a direct LAN connection................................................................................48
● Connecting to a company network..........................................................................49
● Connecting via a PCIe switch................................................................................. 52
● Extending R&S SGS with the R&S SGU.................................................................53

7.2.1  Using a direct LAN connection

The R&S SGS and the R&S SGU can be connected through a direct connection as
shown in Figure 7-4.

Direct connection of an R&S SGS and an R&S SGU

Figure 7-4: Direct connection of an R&S SGS and an R&S SGU

1. Connect the R&S SGS and the R&S SGU directly using one of the following
options:

a) USB cable. Use a type Micro-A connector for R&S SGS and a type Micro-B
connector for R&S SGU. See also Chapter 3.13.4, "Connecting a controller via
USB", on page 33.

b) LAN cable.
c) PCIe cable. Refer to Chapter 12.3.4, "Connecting the controller and the instru-

ment", on page 190 for cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

The R&S SGS automatically identifies the connected R&S SGU as its extension
and starts the extension mode.

Connecting an R&S SGS and an R&S SGU
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For a direct PCIe connection, an automatic identification of the R&S SGU as an exten-
sion is only available for an R&S SGS with a " Controller > Revision" 5 or higher. For a
description on how to set the PCIe identification manually, see Chapter 11.14, "How to
set a PCIe direct connection", on page 174.
You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

If instrument is not automatically added as an extension
You can do that manually in the "SGMA-GUI > R&S SGS Name > Extension" dialog.
If the R&S SGU is not listed in the list of "Available Instruments", you can press "Scan
> Start" to find the instrument.

7.2.2  Connecting to a company network

This step-by-step instruction describes how to connect an R&S SGS and an R&S SGU
in a company network. As a prerequisite for this example the R&S SGMA-GUI software
has to be installed on a remote PC.

Connecting an R&S SGS and an R&S SGU



System overviewR&S®SGS100A

50User Manual 1173.9105.02 ─ 13

Figure 7-5: Connection of an R&S SGS and an R&S SGU in a company network

1. Connect the test equipment as shown in Figure 7-5:

a) Connect the R&S SGS, the R&S SGU and the controller to the company net-
work.

b) Connect the "RF 50Ω" of the R&S SGS to the "LO IN" of the R&S SGU.

2. Switch on the R&S SGS and the R&S SGU.

Wait until the [POWER ON/STANDBY] keys are green and not blinking.

3. Press the [ID] keys on the front panels of the R&S SGS and the R&S SGU.

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.

Note: If you connect the instruments to the company network for the first time, this
process can take several minutes.

Connecting an R&S SGS and an R&S SGU
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5. In the R&S SGMA-GUI main panel, the green indicator in front of the instrument's
name confirms that there is a connection between the instrument and the remote
PC. Also, it confirms that the software recognizes the instrument.

6. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

Tip: Instrument does not appear in the extension dialog. If the R&S SGU is not
automatically shown in this dialog press "Scan > Start" to find the instrument.

7. Select the R&S SGU from the list.

8. Set "Available Instruments > Select > On" to enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU. The R&S SGMA-GUI indi-
cates the extended frequency range of the R&S SGS and the activated extension
mode.

Connecting an R&S SGS and an R&S SGU
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9. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested signal connections. If the
test connections are correct (shown by an uninterrupted blue line), you can start
using the R&S SGS and the R&S SGU in extension mode.

Tip: If your connection is marked as faulty, check whether the cables are connec-
ted properly. Check also if the connection cables are functioning properly.

Figure 7-6: A faulty connection between an R&S SGU and an R&S SGS

7.2.3  Connecting via a PCIe switch

The R&S SGS and the R&S SGU can be connected through a PCIe switch as shown
in Figure 7-7. This setup is recommended for achieving the highest setting/ measuring
speeds.

Connecting an R&S SGS and an R&S SGU
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PCIe switch connection of an R&S SGS and an R&S SGU

Figure 7-7: Connection of an R&S SGS and an R&S SGU through a PCIe switch

1. Connect the PCIe switch to a switched off computer with a single lane PCIe cable.

2. Connect the R&S SGS and the R&S SGU to the PCIe switch.

3. Switch on the R&S SGS and the R&S SGU.

Wait until the [POWER ON/STANDBY] keys are green and not blinking.

4. Switch on the computer.

5. On the computer start one of the following:

a) The R&S SGMA-GUI
b) An application program for remote control of the instruments

6. Manually (or remotely) activate the R&S SGU as an extension to the R&S SGS.

The logical connection between an R&S SGS and an R&S SGU is established by the
driver layer of a program (e.g. the R&S SGMA-GUI) or the library PCIeController.dll
(Linux: libpciecontroller.so) of a remote control program on the PC. Make sure that
such a program runs on the PC so that an R&S SGS is able to communicate with an
R&S SGU.

7.2.4  Extending R&S SGS with the R&S SGU

If you connect the R&S SGU to a compatible Rohde & Schwarz signal generator, you
need a controller. This controller talks to the signal generator and configures the
R&S SGU.

In the following example, the instrument the R&S SGMA-GUI software controls an
R&S SGS and an R&S SGU. The R&S SGU is equipped with the frequency option
R&S SGU-B120.

Configuring the R&S SGU

This step-by-step instruction describes how to configure the R&S SGU to upconvert a
CW signal. An R&S SGS generates the CW signal. As a prerequisite for this example
the R&S SGMA-GUI software has to be installed on a remote PC.

Connecting an R&S SGS and an R&S SGU
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Figure 7-8: Example of a test setup for upconverting a CW signal generated by the R&S SGS

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

1. Connect the test equipment as shown on Figure 7-8:

a) Connect the R&S SGS, R&S SGU and the controller to a LAN switch.
b) Connect the "RF 50Ω" of the R&S SGS to the "LO IN" of the R&S SGU.
c) Connect the "TRIG" connectors of the R&S SGS and the R&S SGU.
d) Connect the "RF 50Ω" of the R&S SGU to the RF input connector of the signal

analyzer.

2. Switch on the R&S SGS and the R&S SGU.

Wait until the [POWER ON/STANDBY] keys are green and not blinking.

3. If connected in a company network, press the [ID] keys on the front panels of the
R&S SGS and the R&S SGU.

4. On the connected remote PC, start the R&S SGMA-GUI software application.

The main panel of the application and the configure instruments dialog open. Both
instruments are added automatically to the instruments list and to the main panel of
the R&S SGMA-GUI software.
The main panel provides a quick access to the main settings of the configured and
activated instruments. The display shows one row per instrument with the instru-
ment-specific settings. The rows comprise the instrument, the connection state, the
used frequency and power level and the state of the RF output and the modulator.

Connecting an R&S SGS and an R&S SGU
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In the R&S SGMA-GUI main panel, the green indicator indicates a connection
between the instrument and the remote PC. It also indicates that the software rec-
ognizes the instrument.

5. To restore the default configuration of this instrument, select "Instrument Name >
Preset".

6. Select "SGMA-GUI main panel > R&S SGS > Extension".

The "Extension" dialog opens.

Tip: Instrument does not appear in the extension dialog. If the R&S SGU is not
automatically shown in this dialog, press "Scan > Start" to find the instrument.

7. Select the R&S SGU from the list.

8. Set "Available Instruments > Select > On" to enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection between the R&S SGS ant the R&S SGU. The R&S SGMA-GUI indi-
cates the extended frequency range of the R&S SGS and the activated extension
mode.

Connecting an R&S SGS and an R&S SGU
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9. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

10. Select "SGMA-GUI > R&S SGS > Freq = 40 GHz", "Lev = -30 dBm".

11. Select "SGMA-GUI > R&S SGS > RF > State > On" to enable the output of the CW
signal.

Connecting an R&S SGS and an R&S SGU
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The extension adopts these values and states automatically. Also, it generates a
CW signal with RF = 40 GHz and Level = -20 dBm.

The signal is output at the "RF 50Ω" connector on the rear panel of the R&S SGU.

Identifying a specific instrument
If several instruments are active in the R&S SGMA-GUI, use one of the device identifi-
cation functions to identify a specific device:
● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Channels >

Device Identify". On the front panel, the LED of the [LAN] key is green and blinks.
● Press the [ID] key on the instrument's front panel. The "Edit Instrument" dialog of

the respective instrument opens.

7.3  Introduction to the instrument functions

This section is intended to give a brief introduction to the instrument's function. The
description of the related user interface parameters is provided in the corresponding
section in Chapter 9, "Signal generator settings", on page 91.

For detailed information on how to work with the instrument and to perform basic and
advanced operating and configuration tasks, refer to Chapter 11, "Performing configu-
ration tasks", on page 160.

The Figure 7-9 provides a simplified block diagram of the instrument.

For better understanding of the instrument functions and the signal flow, the block dia-
gram shows the main blocks of the instrument together with the corresponding GUI
parameters.

Introduction to the instrument functions
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Figure 7-9: Simplified block diagram

TCXO = Built-in reference oscillator
OCXO = Oven-controlled oscillator, requires hardware option

R&S  SGS-B1.
Synth. = Synthesizer
I/Q Mod = I/Q Modulator
REF/LO IN, REF/LO OUT, I, Q, RF OUT = Connector at the rear panel
"Ref. Osc. Source", "REF/LO Out", "LO Coupling
Source", "Mod On/Off", "RF On/Off", "Operation
Mode"

= R&S SGMA-GUI equivalent parameter

The instrument can generate a CW or an I/Q modulated signal ("Mod On/Off"). The fre-
quency and level settings are adjustable ("Level", "RF On/Off", "Frequency"). The
instrument can use its internal reference frequency or a fed-in external one ("REF
IN/LO IN", "Ref. Osc. Source"). The reference frequency can also be output for syn-
chronization purposes ("REF OUT/LO OUT", "REF/LO Out"). The local oscillator (LO)
signal can be distributed in such a way, that two or more instruments are connected to
generate phase coherent signals ("LO Coupling Source", "REF OUT/LO OUT").
Whereas both possibilities, the input of the reference frequency and the input of a LO
signal, exclude each other because they use the same connectors. The same applies
for the output of the reference frequency and the LO signal. The instrument can also
be configured to work in the special baseband bypass mode ("Operation Mode").

Refer to Chapter 11, "Performing configuration tasks", on page 160 for an overview of
the general operating tasks. The Chapter 11.1, "How to generate an I/Q modulated sig-
nal", on page 160 explains the basic operating concept by an example.

Introduction to the instrument functions



Understanding the R&S SGMA-GUI softwareR&S®SGS100A

59User Manual 1173.9105.02 ─ 13

8  Understanding the R&S SGMA-GUI soft-
ware
This section gives a detailed description of the R&S SGMA-GUI user interface and
information on how to work with it. The main panel with the overview of the configured
instruments is the operating and control interface for the whole program. From here, all
program functions are accessible. This panel is displayed after the start of R&S SGMA-
GUI. The software always loads the previously used settings, so you can continue your
work in the next session.

● Operating menu and toolbar................................................................................... 59
● Info dialog and messages in the info bar................................................................ 69
● Main panel...............................................................................................................72
● Working with R&S SGMA-GUI................................................................................75
● Remote control of R&S SGMA-GUI........................................................................ 83

8.1  Operating menu and toolbar

On the top of the main panel, there is the menu bar, the toolbar and the info bar with
the corresponding "Info" key. Some of the functions are accessible via the toolbar with
its icons below the menu selection line.

The dialogs are built using elements, e.g., selection lists, checkboxes, and entry fields.
A blue frame indicates that the selected item is active. In a highlighted element, entries
can be made.

Operating menu and toolbar
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Table 8-1: Content of the operating menu

File Setup Help

 New Instruments About

 Open Software Contents

Save Reset SGMA-GUI Index

 Save as Protection  

Exit Remote  

Shut down instruments and exit   

8.1.1  File menu

The R&S SGMA-GUI employs the standard Save/Recall file management function and
allows you to save and reload settings in/to a file with a user-defined name and loca-
tion (see also Chapter 8.4.1, "Saving and loading settings", on page 75).

In the following, the "File" menu of the R&S SGMA-GUI is described in detail. It incor-
porates standard functions.

New
Resets R&S SGMA-GUI and all connected instruments to their preset settings.

Open
Opens the standard file open browser for loading a saved R&S SGMA-GUI file
(*.savrcl). The file contains the user-specific settings of a session, such as instru-
ments configured in the software. The complete settings of a session can be saved
and loaded.
Only files of this type are selectable.
Note: Instrument-specific settings, e.g. frequency and level settings, are saved locally
on the particular instrument itself. These instruments settings are saved automatically
in a predefined directory and loaded by default when starting the instrument again.
The files with instrument settings are not accessible.

Save
Standard quick save of the settings of the current session if a filename previously has
been applied. If not, the "Save As" dialog is opened.

Save as
Opens the standard file save browser for saving the settings of the current session.
R&S SGMA-GUI files have the file extension .savrcl so the name typed in is equip-
ped with this extension. The complete settings of a session are saved.

Exit
Quits the R&S SGMA-GUI. The current settings of the instrument's session are saved
and loaded by default when starting the software again.
Note: The instruments configured in the R&S SGMA-GUI are not shut down.

Operating menu and toolbar
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Shut down instruments and exit
Quits the R&S SGMA-GUI and switches the connected instruments to the standby
state (see also Chapter 11.9, "How to switch between operating states", on page 169).

8.1.2  Setup menu

Access:

► Select "SGMA-GUI > Setup"

The setup menu provides access to dialogs for setting the general settings of the
software, like dialogs for managing the connected instruments or dialogs providing
information about the installed options.

Settings

● Configure instruments.............................................................................................61
● Add/Edit instruments...............................................................................................65
● Software..................................................................................................................67
● Reset SGMA-GUI....................................................................................................68
● Protection................................................................................................................68
● Remote....................................................................................................................69

8.1.2.1  Configure instruments

This dialog is the central point for managing the instrument that is configured and oper-
ated via the R&S SGMA-GUI. New instruments can be created and appended to the
list of available instruments. Connection settings can be edited, instruments can be
removed from the list or they can be deactivated, but kept in the list for further use.

Operating menu and toolbar
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Refer to Chapter 8.4.2, "Handling instruments in the R&S SGMA-GUI", on page 75 for
information on how to configure and manage instruments in R&S SGMA-GUI.

Available Instruments....................................................................................................62
Scan.............................................................................................................................. 63
New............................................................................................................................... 63
Delete............................................................................................................................63
Clear..............................................................................................................................63
Edit................................................................................................................................ 63
Export............................................................................................................................63
Scan LAN instruments with host name prefix............................................................... 64
Scan Subnet..................................................................................................................64
IP Address.....................................................................................................................64
Prefix Length................................................................................................................. 64

Available Instruments
This section comprises a list of configured instruments. Each instrument is represented
by a "Symbolic Name" which is also displayed in the main panel and an "Instrument
Type". It is also displayed whether the instrument is activated in the R&S SGMA-GUI
and hence displayed in the main panel or not.

Operating menu and toolbar
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Remote command: 
:INSTruments:COUNt? on page 86
:INSTruments:NAME on page 87
:INSTruments:TYPE on page 90
:INSTruments:ACTive[:STATe] on page 85

Scan
Triggers a scan function and searches for instruments connected to the remote com-
puter via all the available interfaces. During the scan process, a progress bar is dis-
played.
Tip: The first initialization of a newly connected instrument in a network and the instru-
ment's request to the DHCP server for an IP address may take some time. During this
time, the instrument does not respond to the query sent by the scan function. If the
instrument does not appear in the list of "Available Instruments", trigger the scan func-
tion again after some minutes.
Remote command: 
:INSTruments:SCAN on page 88

New
Calls the Add/Edit instruments dialog.

Delete
Removes the selected instrument from the list of Available Instruments.

Clear
Removes all instruments from the list of Available Instruments.

Edit
Calls the Add/Edit instruments dialog.

Export
Opens the standard file save browser for saving the list of the available instruments in
a mapping file. The mapping files have the file extension .map so the filename typed in
is automatically equipped with this extension.
A mapping file provides a cross-reference between the instruments' symbolic names
and their respective remote control parameters. The information in the mapping file is
grouped in rows, where one row corresponds to one configured instrument. The rows
have the following structure:
<InstrumentType> <SymbolicName> <IP_Address/Hostname>
<RemoteChannel> <SerialNumber>

Operating menu and toolbar
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Figure 8-1: Mapping file example

Tip: In a remote control application program, address the instruments by their symbolic
names and retrieve the remain required settings from the mapping file. This workflow is
especially useful for frequent exchange of instruments.
Remote command: 
:INSTruments:MAPPing:FILE on page 87

Scan LAN instruments with host name prefix
Sets the prefix the searched host names begin with. Use this function to limit the
amount of the searched instruments and to speed up the scan process.
For example, set this field to "RsSGS, RsSGU, RsSGT", if you want to search for all
available instruments.
If your instrument is not listed in the "Avalable Instruments" dialog, leave the field
empty and execute another scan.
Remote command: 
:INSTruments:SCAN:HNPRefix on page 88

Scan Subnet
Activates scanning of the subnet.
If you click "Scan" the scanning procedure includes instruments detected in the subnet.
Remote command: 
:INSTruments:SCAN:SNET[:STATe] on page 89

IP Address
Sets the IP address with the subnet.
Remote command: 
:INSTruments:SCAN:SNET:IPADdress on page 88

Prefix Length
Sets the prefix length in bits.
Remote command: 
:INSTruments:SCAN:SNET:PLENgth on page 89
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8.1.2.2  Add/Edit instruments

The dialog provides access to the main instrument's settings, such as "Symbolic
Name", "Instrument Type" and connection settings.

Refer to Chapter 8.4.2, "Handling instruments in the R&S SGMA-GUI", on page 75 for
information on how to configure and manage instruments in R&S SGMA-GUI.

Instrument Nr.
Automatically assigned number that indicates the instrument's index in the list of "Avail-
able Instruments".

Symbolic Name
Selects the alias name of the instrument.
Remote command: 
:INSTruments:NAME on page 87

Instrument Type
Selects the instrument's family.
Remote command: 
:INSTruments:TYPE on page 90

Active
Activates/deactivates the display of the instrument's settings in the main panel.
Note: Only instruments in an active state can be controlled from the R&S SGMA-GUI.

Operating menu and toolbar
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Remote command: 
:INSTruments:ACTive[:STATe] on page 85

Exclusive Access
Checks whether the instrument is locked by another user and if not locks the instru-
ment.
When an instrument is locked, it is reserved for manual and remote operation. Locking
means, that you can operate the instrument exclusively from the remote PC on which
the R&S SGMA-GUI is running or from which the SCPI command is sent.
For interfaces using VISA, i.e. for LAN and USB, enabling the "Exclusive Access" trig-
gers the standard viLock request. For remote control over PCIe or Socket, the lock
request is performed on a higher application level.
Tip: We recommend that you lock the instrument before further configuration. Locked
instruments are not found by the scan function. Unlock the instrument to allow opera-
tion from another remote PC.
Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.
Disable "Exclusive Access" if the instrument is monitored by an external PC.
Remote command: 
:INSTruments:EACCess[:STATe] on page 86
:LOCK? on page 225
:UNLock on page 225

Device Identity
Triggers the device identification function. The [LAN] LED on the front panel of the
selected instrument blinks.
See also Chapter 8.4.4, "Bidirectional instrument identification", on page 79.

Hardware Channel
Selects the hardware interface used by the remote channel.
Remote command: 
:INSTruments:REMote:CHANnel on page 87

Instrument Name / IP Address
Enters the IP address or the host name of the connected instrument.
See also Chapter 8.4.3, "Finding out the default hostname of the instrument",
on page 78.
Remote command: 
:INSTruments:REMote:NAME on page 88

GPIB Address
Enters the GPIB address of the connected instrument.
See also Chapter 12.1.5, "GPIB interface (IEC/IEEE bus interface)", on page 183.
Remote command: 
:INSTruments:GPIB:ADDRess on page 87

Operating menu and toolbar



Understanding the R&S SGMA-GUI softwareR&S®SGS100A

67User Manual 1173.9105.02 ─ 13

Board Number
Identifies the GPIB bus card of the controller to that the adapter is connected.
See also Chapter 12.1.5, "GPIB interface (IEC/IEEE bus interface)", on page 183.
Remote command: 
:INSTruments:GPIB:BOARd on page 87

Serial Number
Enters the serial number as instrument's identification while using the USB or PCIe
interfaces for remote control.
Remote command: 
:INSTruments:SERial on page 89

Ok
Confirms the settings and closes the dialog.

Apply
Confirms the settings.

Cancel
Discards settings and closes the dialog.

8.1.2.3  Software

Querying information about the installed options and software version

► Select "Setup > Software".

The "Versions / Options" info dialog opens, showing program information.

Software
Displays information on:
"Package" Installed software packages.
"Version" Release of the software package.

Operating menu and toolbar
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Show Open Source Acknowledgments
Accesses the list of the used open source software packages and the corresponding
verbatim license texts.

Versions
Shows the installed software platform and its version.

8.1.2.4  Reset SGMA-GUI

Resets R&S SGMA-GUI to its factory preset settings.

The connected instruments are not affected by this preset.
To preset one specific instrument to its factory preset settings, select "SGMA-GUI >
Instrument Name > Setup > Factory Preset". Refer to Chapter 10.9, "Factory preset",
on page 155 for an overview of the settings affected by this function.

8.1.2.5  Protection

The "Protection" dialog provides access to the unlocking of protected service functions
(authorized personnel of Rohde & Schwarz service departments only).

Unlocking of protected service functions

1. Select "SGMA-GUI > Setups > Protection".

After the instrument has been switched on, the protection levels 1 to 4 are auto-
matically activated.

2. To deactivate the protection, enter the correct password.
Enter "Protection Level 1 > Password > 123456".

Protection Level 1 is activated.

Operating menu and toolbar
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Protection Level / Password
"Protection Level 1" can be activated to expand the functionality of the internal adjust-
ment. The password is 123456.
The other protection levels 2 to 4 provide access to protected service functions. Only
the authorized personnel of Rohde & Schwarz service departments can access these
functions.

8.1.2.6  Remote

Access: "SGMA-GUI > Setup > Remote".

SCPI Port
Sets the port number of the LAN interface for remote control with TCP/IP socket proto-
col.
Set different port numbers to control different software from the same application, e.g.
R&S SGMA-GUI and R&S WinIQSIM2.
Remote command: 
:SYSTem:COMMunicate:SOCKet:PORT on page 296

8.1.3  Help

The R&S SGMA-GUI is equipped with a context-sensitive help function. A help page
can be called anytime during software operation.

The context-sensitive page which is opened with the [F1] key is part of a comprehen-
sive help system.

It is possible to move from this context-sensitive page to any page of the help system.
An overview of the contents of the online help can be reached via the menu "SGMA-
GUI > Help > Contents".

A search for keywords within the help function is available via menu item "SGMA-GUI
> Help > Index".

8.2  Info dialog and messages in the info bar

A few operating states and the current messages are displayed in the info line. For
information on messages in greater detail and their management, an "Info" dialog can
be opened.

Info dialog and messages in the info bar
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8.2.1  Info dialog

The "Info" dialog provides a list of currently active permanent messages and a detailed
description of each message. The messages are color-coded according to their level.

Accessing the info dialog

► In the "R&S SGMA-GUI main panel", select the "Info" key.

The "Info" dialog opens.

1

2

3

1 = Info line
2 = List of current messages with short description
3 = Detailed description of a selected message

The upper part of the "Info" dialog lists the currently active permanent messages. See
the following table for explanation of the displayed information.

Parameter Description

"LEV" Message level. Messages referring to a logical component of R&S SGMA-GUI, e.g.,
Unicode, are marked in red color, info messages are marked in black color.
The following level messages can occur:
● Err: Error message
● Info: Information message
● Sys: System message
● Crit: Critical message

For detailed information on the message types, see Chapter 8.2.2, "Understanding the
messages in the info bar", on page 71.

"SCPI" Indicates the SCPI error code.

Text A list of all currently permanent messages in the order of their occurrence, i.e., the most
recent message is displayed first.

The keys in the lower part of the "Info" dialog provide quick access to some functions
for managing these messages. For a detailed description on how to clear error mes-
sages or display a history of all messages, refer to Chapter 8.4.5, "Managing mes-
sages in the info dialog", on page 82.
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Function Description

"Delete" Clears the highlighted message. This key is available only if the history of the mes-
sages is displayed.

"Delete All" Clears all messages.

This key is available only if the history of the messages is displayed.

"Del. volatile" Clears all brief messages. This key is available only if the history of the messages
is displayed.

"Show History/Static" Calls the list of all messages that have occurred since instrument switch-on. The
most recent messages are displayed at the top of the list. When the key is pressed
again, the list of current messages is displayed.

Refer to Chapter 8.4.5, "Managing messages in the info dialog", on page 82 for infor-
mation on how to manage messages.

8.2.2  Understanding the messages in the info bar

Messages indicate information, warnings, and errors. They are displayed in the info
line in different colors depending on their importance and display duration. The follow-
ing messages are displayed:
● Error

There are two options:
– Critical errors are errors that prevent the instrument from working, e.g. an HW

failure. Critical errors are displayed in red color.
– System errors are errors that concern the operating system, e.g., wrong file

path. System errors are displayed in black color.
● Information

The information, e.g., file not found, is displayed in black color.
● Warning

A warning indicates a less significant error and is displayed in black color.
● Brief message

Brief messages report automatic settings in the program, e.g. switching on illegal
entries that are not accepted by the program, e.g., range violations. They are dis-
played in the info line on a yellow background. They are displayed on top of status
information or permanent messages.
Brief messages usually do not demand user actions and disappear automatically
after a short period of time. They are saved in the history, however.

● Permanent messages
Permanent messages are displayed if an error occurs that impairs further program
operation. The error signaled by a permanent message must be eliminated before
correct software operation can be ensured.
The message is displayed until the error is eliminated. It covers the status display
in the info line. After error elimination, the message automatically disappears and is
also recorded in the history.

Info dialog and messages in the info bar
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8.3  Main panel

The main panel of the R&S SGMA-GUI provides quick access to the main settings of
the configured instruments. The display shows one row per instrument and comprises
the instrument name and state. It also shows the used frequency and power level, the
states of the RF output and modulator and the used reference source.

Click one of the keys with an instrument name on it to access the menu tree with fur-
ther settings for the corresponding instrument. For a detailed description of the provi-
ded settings, see:
● Chapter 10, "General instrument settings and instrument setup", on page 140 for

general settings
● Chapter 9, "Signal generator settings", on page 91 for R&S SGS settings.

Settings

Instrument/Connection State.........................................................................................73
Maximum Frequency.....................................................................................................73
Pulse Modulation ..........................................................................................................73
Instrument Name/ IP Address....................................................................................... 73
Freq/Freq (Offs).............................................................................................................73
RF On/Off......................................................................................................................73
Mod State......................................................................................................................74
PEP............................................................................................................................... 74
Level/Level Offset..........................................................................................................74
Ref. Oscillator Source/Ext Ref On/Off...........................................................................74
LO Scr Ext.....................................................................................................................75
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Instrument/Connection State
The three colors of the state indicator in front of the instrument's name distinguish
between the following states:
● Gray: the instrument is configured and activated in the R&S SGMA-GUI but there is

no connection to the instrument.
● Green: the instrument is active, the connection is working and the instrument can

be manually and remotely operated.
● Red: the instrument is in one of the following states:

– Standby state
To operate the instrument manually, it has to be switched to ready state (see
"To return the instrument from standby to ready state" on page 170).

– Instrument locked
The red state indication together with the message "Instrument Locked" in the
"Info" line indicates that the instrument is locked for Exclusive Access from
another SGMA-GUI or controller.

– The instrument is performing a time consuming operation, e.g. a selftest.

Maximum Frequency
The numbers in the rectangular box  on the left of the instrument's name indicate the
maximum frequency of the instrument.
When the Eco mode is turned on, the rectangular is colored in green and the frequency
shown in the rectangular corresponds to the maximum frequency available in this
mode.

Pulse Modulation
A  sign on the left of the instrument's name indicates that the pulse modulation is
switched on.

Instrument Name/ IP Address
Displays the alias name of the instrument and the IP address, as set by the parameters
in "SGMA-GUI > Setup > Instruments > Add/Edit Instruments" dialog.
Click the key to access a menu tree for configuring the available instrument's settings,
e.g. "Level" settings.

Freq/Freq (Offs)
Sets the RF frequency, incl. enabled frequency offset.
The following apples:
"Freq" = Frequency + Offset
The value of the parameter "SGMA-GUI main panel > instrument name > Frequency/
Phase > Frequency" is the RF frequency at the RF output without the frequency offset.
The icon "Freq (Offs)" indicates that a frequency offset is applied.
Remote command: 
[:SOURce]:FREQuency[:CW|FIXed] on page 259

RF On/Off
Activates and deactivates the RF output signal.

Main panel
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The current state of the RF output (activated and deactivated) is indicated in the main
panel with the different block color (blue or gray) and the status "On/Off".
Remote command: 
:OUTPut[:STATe] on page 245

Mod State
Switches the I/Q modulation on and off.
Remote command: 
[:SOURce]:IQ:STATe on page 270

PEP
Displays the Peak Envelope Power (PEP) of the RF signal of the selected instrument.
The value is calculated as follows:
"PEP" = Level + Crest Factor
Remote command: 
[:SOURce]:POWer:PEP? on page 276

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.
If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".

Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 275
[:SOURce]:POWer:POWer on page 274

Ref. Oscillator Source/Ext Ref On/Off
Determines whether the internal built-in oscillator (TXCO or OXCO) is used as a refer-
ence source or if an external reference is used. The internal reference oscillator OCXO
requires the additional option R&S SGS-B1.
To feed in an external instrument reference, use the input connector "REF/LO IN". To
output the reference frequency at the output "REF/LO OUT", select "SGMA-GUI >
Instrument Name > Ref. Oscillator > REF/LO Output > REF".
See also Chapter 11.4, "How to configure the reference oscillator source",
on page 165.
"Int" The internal reference signal of 10 MHz is used.
"Ext" An external reference signal is used. The frequency of the external

reference signal must be selected with the parameter "SGMA-GUI >
Instrument Name > Ref. Oscillator > Ex. Ref. Input Frequency".
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Remote command: 
[:SOURce]:ROSCillator:SOURce on page 283

LO Scr Ext
This icon indicates that the internal local oscillator is switched off.
See "Source" on page 95.

8.4  Working with R&S SGMA-GUI

This section explains how to work with the R&S SGMA-GUI software and perform con-
figuration tasks for manual operation of the instruments.

8.4.1  Saving and loading settings

To proceed work with a particular configuration of the instruments in the R&S SGMA-
GUI, it is useful to save the used settings and load them again later.

How to save and load settings

1. Select "SGMA-GUI main panel > File > Save As".

2. Navigate to the desired directory.

3. Enter the filename.
The software adds the file extension *.savrcl automatically.

4. Select "Save".

The current settings of the software are saved to the selected file.

5. To load settings from a file, select "SGMA-GUI main panel > File > Open"

6. Navigate to the storage directory of the saved file.

7. Select this file.

Loads the saved settings to the R&S SGMA-GUI and the main panel displays the
saved configuration of the instrument.

8.4.2  Handling instruments in the R&S SGMA-GUI

This section provides information on how to configure and manage instruments in the
R&S SGMA-GUI.

For reference information about all provided settings in the user interface, refer to the
corresponding sections:
● Chapter 8.1.2.1, "Configure instruments", on page 61 and Chapter 8.1.2.2, "Add/

Edit instruments", on page 65
● Chapter 8.1.2.3, "Software", on page 67
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Chapter 8.1.2.4, "Reset SGMA-GUI", on page 68

8.4.2.1  How to add new instruments automatically

1. For each new instrument perform the following steps:

a) Connect the instrument to the network.
b) Switch on the instrument.
c) Press the [ID] key on the front panel of the instrument.

2. Start the SGMA-GUI on a computer connected to the same network.

All instruments are added automatically to the main panel of the SGMA-GUI.

8.4.2.2  How to add new instruments manually

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Select the "New" key.

The Add Instrument dialog opens to register a new instrument.

3. In the "Symbolic Name" field, enter an alias name of your choice, e.g.
SGS-100021.

4. In the "Instrument Type" field, select the device family to connect to.

5. To select the hardware interface, select "Remote Control > Hardware Channel".

6. For LAN or Socket interfaces, select "Remote Control > Instrument Name / IP
Address".

7. Enter the IP address or the hostname of the connected instrument, e.g.
rssgs100a100021.
See also Chapter 8.4.3, "Finding out the default hostname of the instrument",
on page 78.

8. For USB or PCIe interfaces, select "Remote Control > Serial Number".

9. Enter the serial number of the connected instrument, e.g., 100021.

10. Set "Active > On" to activate the instrument. Only active instruments are displayed
in the R&S SGMA-GUI main panel.

11. To apply the settings, you have two options:

● Click "OK".
The dialog also closes.

● Click "Apply".
● The dialog remains opened.
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12. Click the "Cancel" key to discard settings and to close the dialog.

8.4.2.3  How to scan for new instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens.

2. Click the "Scan" key to trigger the instrument to scan all remote channel interfaces
for connected instruments.

Tip: To limit the amount of the searched instruments and to speed up the scan
process, select "Configure Instruments > Scan LAN instruments with hostname
prefix" and enter the prefix the searched hostnames begin with.
The scan function searches only for instruments whose hostnames begin with the
selected prefix.

The" Available Instruments" list all instruments that are connected to one of the
available interfaces, switched on and not locked by a control instrument.
The R&S SGMA-GUI obtains all information for connecting to the instrument, so
further configuration is not necessary.

8.4.2.4  How to activate instruments for control

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The "Available Instruments" in the Configure Instruments dialog lists all instruments
configured in the software.

2. Select the new or deactivated instrument.

3. To activate the instrument, select "Active > On".

Tip: Only active instruments are displayed in the R&S SGMA-GUI main panel.

8.4.2.5  How to reserve the instrument for control

1. Open the "SGMA-GUI > Setup > Instruments > Configure Instruments" dialog.

2. Select the instrument in the list of "Available Instruments".

3. Select "Edit".

4. In the "Edit Instrument" dialog, enable "Exclusive Access".

5. Alternatively, send the SCPI command :INSTruments:EACCess[:STATe] from
the external PC that has an R&S SGMA-GUI software installation.

The instrument is reserved for control from this external PC and cannot be
accessed from any other controller. A scan function started from another controller
finds the instrument but the instrument is indicated as locked.
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The two functions "Exclusive Access" and monitoring are mutually exclusive.
The "Exclusive Access" must be disabled to remote control or monitor the instrument
form another external PC (see Chapter 12.7, "Monitoring remote control operation with
R&S SGMA-GUI", on page 209).

8.4.2.6  How to edit instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".

The Configure Instruments dialog opens and lists the "Available Instruments".

2. Select the instrument, that you want to edit.

3. Click the "Edit" key.

The Edit Instrument dialog opens.

4. Change the settings.

5. Confirm with "Ok".

The edited settings are applied.

8.4.2.7  How to delete an instrument

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Select the instrument, that you want to delete.

3. Click the "Delete" key.

The selected instrument is deleted from the list of "Available Instruments".

8.4.2.8  How to delete all instruments

1. In the R&S SGMA-GUI main panel, select "Setup > Instruments".
The Configure Instruments dialog opens.

2. Click the "Clear" key.

All instruments are deleted from the list of "Available Instruments".

8.4.3  Finding out the default hostname of the instrument

The default hostname of the instrument is a non-case-sensitive string built as follows:

● hostname = <instrument name><serial number>
● <serial number> is the individual serial number of the instrument.
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● <instrument name> is the complete name of the instrument, written without
spaces.

How to query the hostname of the instrument

1. Find the individual serial number on rear of the instrument, e.g. 100021.

2. Build the default hostname.

For the R&S SGS with serial number 100021, the default hostname is
rssgs100a100021.

For instructions on how to change the default hostname, refer to Chapter 11.10, "How
to use computer names", on page 171.

8.4.4  Bidirectional instrument identification

In practice, instruments are integrated into a large network or placed in racks together
with several other instruments of the same kind. It can be difficult to find out, which of
the instruments configured in the R&S SGMA-GUI corresponds to which physical
instrument. Also, localizing all instruments operated by the current controller.

The R&S SGMA-GUI and the instrument provide the "Device Identification" function for
this purpose.

How to find an instrument in the R&S SGMA-GUI

► If you activate several instruments in the R&S SGMA-GUI, press the [ID] key on
the instrument's front panel to trigger device identification.

The "Edit Instrument" dialog of this instrument opens.
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Field "Edit Instrument > Symbolic Name" displays the name of the instrument as
shown in the R&S SGMA-GUI main panel.
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Dialog "Edit Instrument" does not appear
If this dialog does not open, perform the following:
● Check whether the instrument is correctly connected to the external PC on which

you work with the R&S SGMA-GUI.
● Check if the instrument is configured in the R&S SGMA-GUI and perform, if neces-

sary, the steps described in Chapter 8.4.2, "Handling instruments in the R&S
SGMA-GUI", on page 75.

● Select "SGMA-GUI > Setup > Instruments", check the state of the instrument in the
"Configure Instruments > Available Instruments" table and activate it, if disabled.

How to identify an instrument in an instrument set

1. To identify the instrument in an instrument set, use one of the device identification
functions:

● Select "SGMA-GUI > Setup > Instruments > Available Instruments > Instrument
> Edit > Edit Instrument".

● Select "SGMA-GUI > Instrument Name > Setup > Remote > Remote Chan-
nels".

● Select "SGMA-GUI > Instrument Name > Setup > LXI Status".
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2. Select "Device Identify" to trigger identification.

The green [LAN] LED on the front panel of the instrument blinks.

8.4.5  Managing messages in the info dialog

How to get additional information on the message

► In the "Info" dialog, click a message to select it.

In the lower section of the dialog, additional information on the highlighted mes-
sage is displayed.

How to display all messages

► In the "Info" dialog, click the "History" key.

A history of all messages that have occurred since the R&S SGMA-GUI software
was started is listed in the upper dialog pane. The most recent message is dis-
played first.

How to delete an error message

1. In the "Info" dialog, select the highlighted message and

2. Click the "Delete" key.

Tip: This key is available only when the history of the messages is displayed.

The highlighted message is cleared.

How to delete all error messages

► In the "Info" dialog, click the "Delete All" key.

Tip: This key is available only when the history of the messages is displayed.

All messages are cleared.

How to delete all brief messages

► In the "Info" dialog, click the "Del. volatile" key.

Tip: This key is available only when the history of the messages is displayed.

All brief messages are cleared.

How to call the history

1. In the "Info" dialog, click the "History" key.
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A list of all messages that have occurred since the instrument switch-on is dis-
played. The most recent messages are displayed at the top of the list.

2. Click the "History" key once more.
The history lists current instrument messages.

8.5  Remote control of R&S SGMA-GUI

This section focuses on remote control of the R&S SGMA-GUI software. Also, all
remote-control commands are presented in detail with their parameters and the ranges
of numerical values.

Prerequisites for remote control of R&S SGMA-GUI

Remote control of R&S SGMA-GUI requires the following:
● A remote PC is connected to the SGMA instrument.
● The remote PC and the SGMA instrument are switched on.
● A connection between remote PC and the SGMA instrument is established
● The security setting "System Config > Setup > Security > SCPI over LAN" is

enabled.

For more information, see Chapter 3.13, "Connecting an external PC and devices",
on page 27.

For general information on remote control of Rohde & Schwarz products via SCPI,
refer to www.rohde-schwarz.com/rc-via-scpi.

8.5.1  Programming examples

The corresponding sections of the same title provide simple programming examples for
the R&S SGS. The purpose of the examples is to present all commands for a given
task. In real applications, one would rather reduce the examples to an appropriate sub-
set of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (for example comments) start with two characters //.

At the beginning of the most remote control programs, an instrument preset/reset is
recommended to set the R&S SGS to a definite state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

The programming examples address the following tasks:
● Example "Searching for SGMA instruments" on page 84
● Example "Scanning a subnet for SGMA instruments" on page 84
● Example "Evaluating scan results" on page 84

Remote control of R&S SGMA-GUI
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● Example "Configuring SGMA instruments" on page 85

Example: Searching for SGMA instruments
// Search for SGMA instruments using the scan function. It detects instruments
// that are connected to the remote computer via all of the available interfaces.
INSTruments:SCAN 1
*OPC?

// Query the number of available instruments.
INSTruments:COUNt?
// Response: 3
// Query instrument types.
INSTruments:TYPE?
// Response: SGU,SGS,SGT
// Query the symbolic names.
INSTruments:NAME?
// Response: SGU-100002,SGS-100006,SGT-100008
// Query the serial numbers. 
INSTruments:SERial?
// Response: 100002,100006,100008
// Query the remote channel used.
INSTruments:REMote:CHANnel?
// Response: LAN,USB,PCIe
// Query the hostname/IP address.
INSTruments:REMote:NAME?
// Response: rssgu100a100002, rssgs100a100006, rssgt100a100008

// You can also define a hostname prefix to filter detected SGMA instruments.
:INSTruments:SCAN:HNPRefix "rssg"
// The scan returns only instruments with hostname beginning with "rssg".
:INSTruments:SCAN 1

Example: Scanning a subnet for SGMA instruments
// Set the IP address of an instrument of the subnet.
INSTruments:SCAN:SNET:IPADdress 10.111.1.11
// Set the prefix length of the subnet.
INSTruments:SCAN:SNET:PLENgth 20
// Higher prefix lengths accelerate the scan but lower the ability to detect all
// instruments within the subnet.
INSTruments:SCAN 1

Example: Evaluating scan results
// Check the instrument state and activate instruments, if required.
INSTruments:ACTive:STATe?
// Response: 0,1,1
INSTruments:ACTive:STATe ON,OFF,OFF
// Activates the first instrument in the list, i.e. the instrument SGS-100006.

// Export the configuration into a mapping file.
INSTruments:MAPPing:FILE "d:\mapping_files\mapping.map"
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// Enable exclusive access for the selected instrument.
INSTruments:EACCess:STATe?
// Response: 0,0,0
INSTruments:EACCess:STATe ON,OFF,OFF
// Locks the first instrument.

Example: Configuring SGMA instruments
// Clear the device list and add new instruments manually.
INSTruments:CLEar
INSTruments:NAME "MYSGT100A","MYSGS100A","MYSGU100A"
// Define the instrument types.
INSTruments:TYPE "SGT","SGS"
// Specify the remote interface and name or address for the instruments in the
// device list.
INSTruments:REMote:CHANnel LAN,USB,GPIB
INSTruments:REMote:NAME "10.124.1.247","RSSGS100A1000025", 
INSTruments:USB:SERial 0,0,100025
INSTruments:GPIB:ADDRess 0,0,28
INSTruments:GPIB:BOARd 0,0,0

8.5.2  R&S SGMA-GUI commands

This section comprises the SCPI commands provided for remote control of the R&S
SGMA-GUI software.

:INSTruments:ACTive[:STATe]........................................................................................... 85
:INSTruments:CLEar........................................................................................................ 86
:INSTruments:COUNt?..................................................................................................... 86
:INSTruments:EACCess[:STATe]........................................................................................86
:INSTruments:GPIB:ADDRess...........................................................................................87
:INSTruments:GPIB:BOARd..............................................................................................87
:INSTruments:MAPPing:FILE............................................................................................ 87
:INSTruments:NAME........................................................................................................ 87
:INSTruments:REMote:CHANnel....................................................................................... 87
:INSTruments:REMote:NAME............................................................................................88
:INSTruments:SCAN........................................................................................................ 88
:INSTruments:SCAN:HNPRefix......................................................................................... 88
:INSTruments:SCAN:SNET:IPADdress............................................................................... 88
:INSTruments:SCAN:SNET:PLENgth................................................................................. 89
:INSTruments:SCAN:SNET[:STATe]................................................................................... 89
:INSTruments:SERial........................................................................................................89
:INSTruments:TYPE......................................................................................................... 90

:INSTruments:ACTive[:STATe] <State>

Enables/disables the instrument for the R&S SGMA-GUI. The main panel of this soft-
ware displays only activated instruments.

Remote control of R&S SGMA-GUI



Understanding the R&S SGMA-GUI softwareR&S®SGS100A

86User Manual 1173.9105.02 ─ 13

Parameters:
<State> List of BOOL-values

<StateInstr#1>,<StateInstr#2>,...
0, 1, ON, OFF

Example: See Example "Evaluating scan results" on page 84.

Manual operation: See "Available Instruments" on page 62
See "Active" on page 65

:INSTruments:CLEar

Clears all instruments in the device list.

Parameters:
<Count> float

Range: 0  to  12

Example: See Example "Configuring SGMA instruments" on page 85.

Usage: Event

:INSTruments:COUNt?

Queries the number of the currently available instruments.

Return values: 
<Count> float

Range: 0  to  12

Example: See Example "Searching for SGMA instruments" on page 84.

Usage: Query only

Manual operation: See "Available Instruments" on page 62

:INSTruments:EACCess[:STATe] <State>

"Locks" the instruments, meaning the instrument is reserved and can be operated
exclusively from the remote PC that sent this SCPI command.

Tip: It is recommended to lock the instrument prior to further configuration.

Parameters:
<State> List of BOOL-values

<LockInstr#1>,<LockInstr#2>,...
0,1,OFF,ON

Example: See Example "Evaluating scan results" on page 84.

Manual operation: See "Exclusive Access" on page 66
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:INSTruments:GPIB:ADDRess <Serial>

Sets the GPIB address of the connected instrument.

Parameters:
<Serial> List of Numbers

Example: See Example "Configuring SGMA instruments" on page 85.

Manual operation: See "GPIB Address" on page 66

:INSTruments:GPIB:BOARd <Board>

Identifies the GPIB bus card the controller uses.

Parameters:
<Board> List of Numbers

Example: See Example "Configuring SGMA instruments" on page 85.

Manual operation: See "Board Number" on page 67

:INSTruments:MAPPing:FILE <File>

Saves the list of the available instruments in a mapping file. Mapping files are stored
with the predefined file extension .map; the file extension may be omitted.

The file is saved in the default directory. Use the command MMEM:CDIRectory to
change the default directory or specify the complete path.

Parameters:
<File> string

Example: See Example "Evaluating scan results" on page 84.

Manual operation: See "Export" on page 63

:INSTruments:NAME <Name>

Selects the alias name of the instruments, i.e. sets the "Symbolic Name".

Parameters:
<Name> <SymbolicNameInstr#1>,<SymbolicNameInstr#2>,...

Example: See Example "Searching for SGMA instruments" on page 84.

Manual operation: See "Available Instruments" on page 62
See "Symbolic Name" on page 65

:INSTruments:REMote:CHANnel <Channel>

Sets the hardware interface used by the remote channel.
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Parameters:
<Channel> List of CHAR-Data

<Channellnstr#1>,<Channellnstr#2>,...
The available interfaces are: LAN, USB, SOCKET, PCIe, GPIB,
HiSLIP

Example: See Example "Searching for SGMA instruments" on page 84.

Manual operation: See "Hardware Channel" on page 66

:INSTruments:REMote:NAME <Name>

Enters the IP Address or the host name of the connected instrument.

Parameters:
<Name> <Hostname/IP-AddressInsr#1>,<Hostname/IP-Addres-

sInsr#2>,...

Example: See Example "Searching for SGMA instruments" on page 84.

Manual operation: See "Instrument Name / IP Address" on page 66

:INSTruments:SCAN <State>

Triggers a scan function and searches for instruments connected to the remote com-
puter via all of the available interfaces.

Parameters:
<State> number

1 = triggers the scan function, 0 = aborts the running scan proc-
ess
The query command returns 1 as long as scan is running; 0 indi-
cates completed scan process.

Example: See Example "Searching for SGMA instruments" on page 84.

Manual operation: See "Scan" on page 63

:INSTruments:SCAN:HNPRefix <Prefix>

Sets the prefix the searched host names begin with.

Parameters:
<Prefix> string

Example: See Example "Searching for SGMA instruments" on page 84.

Manual operation: See "Scan LAN instruments with host name prefix" on page 64

:INSTruments:SCAN:SNET:IPADdress <Address>

Sets the IP address of an instrument within a subnet.
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Use the IP address to optimize scanning for instruments within a subnet.

Parameters:
<Address> string

Example: See Example "Scanning a subnet for SGMA instruments"
on page 84.

Manual operation: See "IP Address" on page 64

:INSTruments:SCAN:SNET:PLENgth <Number>

Sets the prefix length of the subnet mask.

Use the prefix length to optimize scanning for instruments within a subnet. A higher
value accelerates the scanning procedure but lowers the ability to detect all instru-
ments within the subnet.

Parameters:
<Number> integer

Range: 18  to  30
*RST: 18
Default unit: bit

Example: See Example "Scanning a subnet for SGMA instruments"
on page 84.

Manual operation: See "Prefix Length" on page 64

:INSTruments:SCAN:SNET[:STATe] <State>

Activates scanning of a subnet with given IP address and prefix length of the subnet.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: n.a. (no preset. default: OFF)

Example: See Example "Scanning a subnet for SGMA instruments"
on page 84.

Manual operation: See "Scan Subnet" on page 64

:INSTruments:SERial <Serial>

Enters the serial number as instrument's identification while using the USB interface for
remote control.

Parameters:
<Serial> <SerialNumberInstr#1>, <SerialNumberInstr#2>,...

Example: SeeExample "Configuring SGMA instruments" on page 85.

Manual operation: See "Serial Number" on page 67
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:INSTruments:TYPE <Type>

Sets the instrument type.

Parameters:
<Type> List of CHAR-Data

<TypeInstr#1>,<TypeInstr#2>,...

Example: See Example "Configuring SGMA instruments" on page 85.

Manual operation: See "Available Instruments" on page 62
See "Instrument Type" on page 65

8.5.3  List of R&S SGMA-GUI commands
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9  Signal generator settings
This section summarizes the settings necessary to configure the instrument for signal
generation. The description in this section follows the menu tree structure of the graph-
ical user interface. Each of the discussed topics follows a common structure, providing
basic background information and reference to the user interface.

For step-by-step instructions for fulfilling typical tasks, refer to Chapter 11, "Performing
configuration tasks", on page 160.

● Operation mode...................................................................................................... 91
● Frequency/Phase settings.......................................................................................92
● Local oscillator (LO) coupling..................................................................................93
● Reference oscillator................................................................................................ 95
● Level and power-on settings................................................................................... 98
● Pulse modulation...................................................................................................124
● Trigger connector settings.....................................................................................129
● I/Q modulation and signal impairment...................................................................130
● Preset....................................................................................................................135
● Extension.............................................................................................................. 136

9.1  Operation mode

You can operate the R&S SGS in two modes, normal mode and baseband bypass
mode. In baseband bypass mode, an external IF signal at the "I/Q In" connectors is
directly routed to the "RF 50Ω" connector. The level of the signal can be adjusted.

Refer to Figure 7-9 for visualization of the signal flow.

Access:

► Select "SGMA-GUI > Instrument Name > Operation Mode".

Operation Mode
Sets the operation mode.
"Normal" The complete signal processing chain is used.
"Baseband Bypass"

The IF signal fed in at the "I/Q In" connectors is directly routed to the
"RF 50Ω" connector.

Note: The "Baseband Bypass" is a special operation mode. See also
Chapter 11.3, "How to enable a baseband bypass mode",
on page 165.

Operation mode
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Remote command: 
[:SOURce]:OPMode on page 259

9.2  Frequency/Phase settings

Depending on the installed options, the instrument provides an adjustable output fre-
quency in the frequency range of 1 MHz to 6 GHz or to 12.75 GHz.

Access:

► Select "SGMA-GUI > Instrument Name > Frequency/Phase".

The frequency and phase-related settings are provided in this dialog.

Configuring the RF frequency

1. To change the RF frequency of the selected instrument, perform one of the follow-
ing:

a) Select "SGMA-GUI > Instrument Name > Frequency/Phase > Frequency"
b) Select "SGMA-GUI main panel > Freq".

The value includes a possible frequency offset.

2. To enable a frequency offset, for example, to consider the frequency shift of a
downstream instrument, set the parameter "Frequency/Phase > Offset".

Changes of the RF frequency have an immediate effect on the output signal.

Frequency
Sets the RF frequency at the RF output connector of the selected instrument.
The displayed value does not consider an enabled frequency offset (Offset).
Remote command: 
See [:SOURce]:FREQuency[:CW|FIXed] on page 259

Offset
Sets a frequency offset.

Frequency/Phase settings
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The frequency offset value represents the frequency shift of a downstream instrument,
as, for example, an attenuator or an amplifier.
Enabled frequency offset does not change the frequency at the RF output (Frequency).
It influences the value of the parameter "SGMA-GUI main panel > Freq".
The following applies:
"Freq" = Frequency + "Offset"
In the "SGMA-GUI main panel", enabled frequency offset is also indicated with the key-
word "Freq (Offs)".
Remote command: 
[:SOURce]:FREQuency:OFFSet on page 260

Delta Phase
Sets the phase of the RF signal. The current phase of the signal is used as the refer-
ence. This function allows, for example, the phase of the output signal to be synchron-
ized with the phase of a signal from a second signal generator.
Remote command: 
[:SOURce]:PHASe on page 272

Reset Delta Phase Display
Resets delta phase value. The set phase is adopted as the new current phase, i.e. the
delta phase value is reset to 0.
Remote command: 
[:SOURce]:PHASe:REFerence on page 272

9.3  Local oscillator (LO) coupling

The LO coupling function allows you to distribute the local oscillator signal. Distribute
the LO signal in a way that multiple R&S SGS instruments or other R&S signal genera-
tors can be driven by the same LO signal. Use the same LO signal for phase coherent
applications, e.g., the generation of beamformed signals and for phase coherent
demodulation.

The LO coupling function requires option R&S SGS-K90 (Phase Coherence). This
option enables phase coherent RF outputs of two or more RF signals. The local oscilla-
tor signal is provided at the "REF/LO OUT" connector. An external signal can be input
at the "REF/LO IN" connector.
Refer to Figure 7-9 for visualization of the signal flow.

See also:
● Chapter 11.5, "How to configure the local oscillator coupling source", on page 166
● Chapter 11.6, "How to define the signal at the REF/LO OUT connector",

on page 167

Local oscillator (LO) coupling
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● Chapter 11.7, "How to prepare instruments for optimum phase coherence",
on page 167

9.3.1  Phase coherence

Phase coherence of RF signals designates a defined, constant delta phase between
two or more RF carrier signals with the same frequency or a multiple of the frequency.

If two signal generators are coupled via their 10 MHz reference, they are generating
the same frequency but only in the long-term perspective. The instantaneous differen-
tial phase (“delta phase”) of these two RF signals is unstable due to the following:
● Phase noise of the two synthesizers
● “weak” coupling at 10 MHz and a long synthesis chain up to the RF domain
● Temperature differences, which cause slightly different phase drift for the different

synthesizers

Most critical for a stable delta phase is the thermal RF phase fluctuation between multi-
ple RF synthesizers. These fluctuations can be minimized by using a common synthe-
sizer (common local oscillator (LO) signal) for all RF carriers.

See also Chapter 11.7, "How to prepare instruments for optimum phase coherence",
on page 167.

9.3.2  Local oscillator (LO) coupling settings

The LO coupling-related settings are provided in the "Frequency/Phase" dialog.

Access:

► Select "SGMA-GUI > Instrument Name > Frequency/Phase > Local Oscillator (LO)
Coupling".

Local oscillator (LO) coupling
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Source
Selects the source of the local oscillator signal.
"Int" The instrument uses the built-in local oscillator.
"Ext" The signal fed-in at the "REF/LO IN" input connector is used as signal

source.

An icon in the block diagram indicates that an external LO source is
used.

Note: The local oscillator input/output requires the additional software
option R&S SGS-K90.

Remote command: 
[:SOURce]:LOSCillator:SOURce on page 260

REF/LO Output
Determines the signal provided at the output connector [REF/LO OUT].
See also Chapter 11.6, "How to define the signal at the REF/LO OUT connector",
on page 167.
"OFF" No signal is provided.
"LO" The signal of the local oscillator (LO) is available at the [REF/LO

OUT] connector.
"REF" The signal of the reference oscillator is available at the [REF/LO

OUT] connector.
Remote command: 
:CONNector:REFLo:OUTPut on page 230

9.4  Reference oscillator

The R&S SGS is equipped with an internal TXCO reference oscillator. If equipped with
the additional HW option -B1, an OXCO can be used as an internal reference fre-

Reference oscillator
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quency source for the synthesizer. Moreover, an external reference signal source can
be connected to the REF/LO IN connector of the instrument.

Refer to Figure 7-9 for visualization of the signal flow.

Access:

► Select "SGMA-GUI > Instrument Name > Reference Oscillator".

Ref. Oscillator Source/Ext Ref On/Off
Determines whether the internal built-in oscillator (TXCO or OXCO) is used as a refer-
ence source or if an external reference is used. The internal reference oscillator OCXO
requires the additional option R&S SGS-B1.
To feed in an external instrument reference, use the input connector "REF/LO IN". To
output the reference frequency at the output "REF/LO OUT", select "SGMA-GUI >
Instrument Name > Ref. Oscillator > REF/LO Output > REF".
See also Chapter 11.4, "How to configure the reference oscillator source",
on page 165.
"Int" The internal reference signal of 10 MHz is used.
"Ext" An external reference signal is used. The frequency of the external

reference signal must be selected with the parameter "SGMA-GUI >
Instrument Name > Ref. Oscillator > Ex. Ref. Input Frequency".

Remote command: 
[:SOURce]:ROSCillator:SOURce on page 283

Ext. Ref. Input Frequency
Available only for "Source > Ext".
Selects the frequency of the external reference signal.
Remote command: 
[:SOURce]:ROSCillator:EXTernal:FREQuency on page 282

Reference oscillator
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Synchronization Bandwidth
Available only for "Source > Ext".
Selects the synchronization bandwidth for an external reference signal. The wideband
setting is provided for using good reference sources of high spectral purity.
"Wide" Synchronization bandwidth is app. 250 Hz.
"Narrow" Synchronization bandwidth is app. 40 Hz.
Remote command: 
[:SOURce]:ROSCillator:EXTernal:SBANdwidth on page 284

Output Frequency
Selects the output for the reference oscillator signal. The available values depend on
the input frequency and the reference oscillator source.
Table 9-1: Output frequency

"Reference Oscillator Source" Input frequency Output frequency

"Internal" 10 MHz 10 MHz

1 GHz

"External" 10 MHz

13 MHz

100 MHz

1 GHz

10 MHz, 1 GHz

13 MHz, 1 GHz

100 MHz, 1 GHz

1 GHz

Support of 13 MHz reference frequency requires that the instrument is equipped with
hardware module RF board with part number 1419.5308.02.
To find out the RF board installed in the instrument:
● Select "SGMA-GUI > instrument name > Setup > Hardware Config" > "RF Assem-

bly"
● Observe the part number of the assembly "RfBoard".
Remote command: 
[:SOURce]:ROSCillator:OUTPut:FREQuency on page 283

REF/LO Output
Determines the signal provided at the output connector [REF/LO OUT].
See also Chapter 11.6, "How to define the signal at the REF/LO OUT connector",
on page 167.
"OFF" No signal is provided.
"LO" The signal of the local oscillator (LO) is available at the [REF/LO

OUT] connector.
"REF" The signal of the reference oscillator is available at the [REF/LO

OUT] connector.
Remote command: 
:CONNector:REFLo:OUTPut on page 230

Reference oscillator
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Active Adjustment Data
Displays whether the factory or user defined (custom) calibration value is used for the
external calibration of the reference oscillator.
Adjusting the calibration value for the OCXO adjustments is a protected service proce-
dure that requires a Protection Level 2 password. The exact test procedure is descri-
bed in the service manual.
See also Chapter 10.13, "External adjustments", on page 158.

Adjustment Active
Available only for "Source > Int".
Selects adjustment mode.
"OFF" Uses the calibrated internal reference frequency. This value is deter-

mined at one of the R&S service centers during calibration.
"ON" A user-defined adjustment value is used. The value is entered under

DAC Value.
User-defined values allow you to set the impaired frequency freely, for
example, to simulate a frequency error.
The instrument is no longer in the calibrated state. However, the cali-
bration value is not changed and the instrument resumes the calibra-
ted state after switching the "Adjustment State" to Off.

Remote command: 
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe] on page 284

DAC Value
Enters a user-defined adjustment value for the internal reference frequency. This value
is not used unless "Adjustment Active > On" is selected.
"DAC Value = 0" indicates the calibrated state. The setting range depends on the refer-
ence oscillator type and its factory calibration value.
Remote command: 
[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue on page 283

9.5  Level and power-on settings

This section explains the level settings of the R&S SGS. The instrument can be equip-
ped optionally with an active electronic step attenuator (R&S SGS-B26).

Configuring RF level

► To change the RF level of the selected instrument, perform one of the following:

a) Select "SGMA-GUI main panel > Level".
b) Select "SGMA-GUI > Instrument Name > Level > RF Level > Level".

Changes of the RF level have an immediate effect on the output signal.

Level and power-on settings
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9.5.1  RF level

Access:

► Select "SGMA-GUI > Instrument Name > Level > RF Level".

This dialog comprises settings like the RF level and level limit.

Level/Level Offset
Sets the RF level at the RF output connector of the selected instrument.
If you set a level offset, it will be indicated in the R&S SGMA-GUI main panel by a
change in the name of this parameter from "Level" to "Level Offset".

Note: The SCPI command [:SOURce]:POWer[:LEVel][:IMMediate][:
AMPLitude] sets the level of the "Level" display, that means the level containing off-
set while [:SOURce]:POWer:POWer sets the level at the RF output connector.

Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] on page 275
[:SOURce]:POWer:POWer on page 274

Offset
Sets a level offset.
This value represents the level shift of a downstream instrument, as, for example, an
attenuator or an amplifier, and is indicated in the status bar of the display. It does not
change the level at the RF output.

Level and power-on settings
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Remote command: 
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet on page 276

Mode
Allows you to optimize the RF output signal for applications, where improved harmonic
distortion or improved wideband noise is required.
"Normal" In normal mode, the generator provides an RF output signal with high

signal to noise ratio and low distortion, according to the data sheet.
"Low Noise" This setting forces the generator to optimize the signal to noise ratio.
"Low Distortion"

In this mode, the generator reduces distortions of the RF signal to a
minimum.

Remote command: 
[:SOURce]:POWer:LMODe on page 274

Setting Characteristic
Selects the characteristic for the level setting. For some general applications, the
instrument operation can be optimized by selecting one of the predefined level setting
characteristics.
"Auto" The instrument provides the highest dynamic range and the fastest

setting times according to the data sheet.
The RF signal is shortly blanked when you switch on the step attenu-
ator.

"Uninterrupted Level setting"
Suppresses level blanking at frequency and level changes.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

"Strictly Monotone"
Provides level setting without discontinuities. All electronic switches in
the RF path are clamped. The operation mode is useful for applica-
tions using level searching algorithms.
This mode further reduces the dynamic range of the instrument. The
step attenuator is also fixed.

"Constant-VSWR"
Suppresses output impedance variations at the "RF 50Ω" connector
due to changed level setting.
This mode reduces the dynamic range of the instrument. The step
attenuator is fixed.

Remote command: 
[:SOURce]:POWer:SCHaracteristic on page 275

Level Range
Displays the level range within which the level setting is expected to work properly. The
range limits depend on several parameters like "Mode", "Setting Characteristic", the I/Q
signal's crest factor and other parameters.

Level and power-on settings
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Remote command: 
[:SOURce]:POWer:RANGe:LOWer? on page 277
[:SOURce]:POWer:RANGe:UPPer? on page 277

Limit
Sets the level limit.
The value specifies the upper limit of the level at the "RF 50Ω" connector. A message
appears if an attempt is made to set a level above this limit and the level at the RF out-
put is confined to the upper limit. However, the level indication is not influenced.
The value is not affected by an instrument preset. This parameter is influenced only by
the Factory preset and its factory value is equal to the upper limit.
Remote command: 
[:SOURce]:POWer:LIMit[:AMPLitude] on page 276

Readjust
Recalculates the instrument internal settings optimized for the current level. Not
required for automatic modes.
Remote command: 
[:SOURce]:POWer:ALC:SONCe on page 273

9.5.2  Attenuator

Access:

► Select "SGMA-GUI > Instrument Name > Level >Attenuator".

This dialog comprises the settings for the power-on behavior of the instrument.

Mode
Sets the attenuator mode at the RF output.

Level and power-on settings
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"Auto" Standard mode.
The electronically switching attenuator switches with a ~ 6 dB step
width at optimized switching points. The entire level range is availa-
ble.
The level setting is performed by continuous electronic level control
combined with switching the step attenuator.

"Fixed" The level settings are made without switching the attenuator.
When this operating mode is switched on, the attenuator is fixed in
the current position to provide level settings without interruption. The
resulting variation range is defined and displayed with the parameters
Level Range.
Note: The function is effective when automatic level control is activa-
ted ("ALC State = On").
If the normal variation range is overranged or underranged, level
errors increase considerably. The warning "Level under/overrange"
appears in the info line.
The spectral purity of the output signal decreases with high attenua-
tion.

"Auto Passive" The attenuator is switched automatically.
The level settings are made only for the passive reference circuits.
The high-level ranges are not available.

Remote command: 
:OUTPut:AMODe on page 244

SATT Switch-Over Offset
Sets the switch-over offset value of the attenuator.
Remote command: 
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] on page 274

Level Range
Displays the level range in which the level is set without interruption for the "Attenuator
Mode Fixed" setting.
Remote command: 
:OUTPut:AFIXed:RANGe:LOWer? on page 243
:OUTPut:AFIXed:RANGe:UPPer? on page 244

RF-Off-Mode
Determines the attenuator's state after the instrument is switched off.
In default setting, the electronic step attenuator switches to highest attenuation when
RF is off. By setting the RF-Off mode, the electronic step attenuator can be fixed to
keep the output impedance constant during RF off.
Remote command: 
[:SOURce]:POWer:ATTenuation:RFOFf:MODE on page 274

Level and power-on settings
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9.5.3  Power-On/EMF

Access:

► Select "SGMA-GUI > Instrument Name > Level > Power-On/EMF".

This dialog comprises the settings for the power-on behavior of the instrument.

Power-On State
Selects the state which the RF output takes after the instrument is switched on.
"RF Off" The output is deactivated when the instrument is switched on.
"Previous Setting"

When the instrument is switched on, the output takes the same state
as it had when the instrument was switched off.

Remote command: 
:OUTPut[:STATe]:PON on page 244

9.5.4  ALC

Access:

► Select "SGMA-GUI > Instrument Name > Level > ALC".

You can use automatic level control (ALC) with almost all applications, especially
I/Q modulation. Deactivate ALC for certain settings in the baseband and when I/Q
impairments are active ("Impairments > On").

Level and power-on settings
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By default, the instrument operates in "Table & On" mode to provide the highest
level accuracy and fastest setting time. Level control can be switched to "Off
(Table)" or "On" for particular applications. The "Off (Table)" state (level control Off)
is recommended if in CW mode the signal/intermodulation ratio is to be improved
for multi-transmitter measurements.

State
Sets the internal level control.
"Table & On" Default mode.

First sets the level to the target value using the internal level table.
Then activates the level control circuit to achieve maximum level
accuracy.

"On" Internal level control is permanently activated.
If "On" and "Attenuator Mode Fixed" is selected, the level is recalibra-
ted for every level and frequency setting.

"Off (Table)" Internal level control is performed according to the ALC table.
Remote command: 
[:SOURce]:POWer:ALC[:STATe] on page 273

Detector Sensitivity
Allows you to fix the internal level detector. We recommend that you to use "Auto"
mode (default).
"Auto" Automatic detector selection. Recommended mode of operation.
"Low" Low sensitivity detector selected.

This setting is intended for signals with high internal electronic levels.
"Med" Medium sensitivity detector selected.

This setting corresponds to normal mode. It is intended for signals
with medium internal electronic levels.

"High" High sensitivity detector selected.
Selects the detector path with high sensitivity, intended for signals
with low internal electronic levels.

"Fix" Fixes the last set sensitivity setting.
Remote command: 
[:SOURce]:POWer:ALC:DSENsitivity on page 273

9.5.5  User correction settings

Access:

► Select "SGMA-GUI > Instrument Name > Level > UCOR".

Level and power-on settings
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The "User Correction" function is used to create and activate lists in which level correc-
tion values predefined by the user are freely assigned to RF frequencies. Correction is
performed by the user-defined table values being added to the output level for the
respective RF frequency.

With frequencies which are not contained in the list, the level correction is determined
by interpolation of the closest correction values.

The lists are created in the "List Editor". Each list is stored in its own file with the prede-
fined file extension *. uco. The name of the "User Correction" file can be freely
selected. The files are loaded from the "Lists..." file manager. Externally created tables
with pairs of frequency and level values can be converted into "User Correction" files
using the import function. The external files must have the file extension *.txt or
*.csv. These file formats are provided, e.g., by the Microsoft Excel program. The sep-
arators for table columns and for decimal floating-point numerals can be set. In addi-
tion, internally created "User Correction" data can be exported into ASCII files using
the export function.

If user correction is activated, the "UCOR" display ("User Correction") is shown in the
header together with the "Level" display. The RF output level is the sum of both values.

"Level" + "UCOR" = Output level

If activated, user correction is effective in all operating modes.

State
Activates/deactivates user correction.
Remote command: 
[:SOURce<hw>]:CORRection[:STATe] on page 269

User Correction
Indicates the current value for level correction.
Remote command: 
[:SOURce<hw>]:CORRection:VALue? on page 269
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User Cor. Data
Calls the "File Select" menu for selecting and creating a list or the "File Manager".

Remote command: 
[:SOURce]:CORRection:CSET:DELete on page 264
[:SOURce<hw>]:CORRection:CSET[:SELect] on page 268

Edit User Cor. Data
Calls the editor for editing the selected user correction list.
A list consists of any number of frequency/level value pairs. The currently selected list
is displayed.
Each list is saved as a separate file with extension *.uco. The file name and the direc-
tory to which the file is saved are user-selectable. For example, Figure 9-1 displays
user correction data for the file ucor.uco.

Note: Save list only after filling both columns (frequency and level), otherwise the
entries are lost.

Figure 9-1: User correction data for file ucor.uco

"Frequency /Hz"
Enters the frequency to which the level correction value applies.
Note: The "Fill..." function allows you to automatically enter any num-
ber of frequencies with freely selectable range and increment.
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"Power/dB" Enters the level correction value to which the specified frequency
applies.

"Goto" Selects row for editing.

If "Goto Row" is selected, a window opens for entering the requested
row.

"Edit" Calls a selection of possible actions described below.

"Insert Range" Insert new rows before the marked row. The number of rows to be
inserted can be defined in an entry window.

"Insert Row" Insert a new row before the marked row.
"Fill...." Opens a sub menu for defining a set of list values to be automatically

entered in the ucor list, see Filling the correction list automatically).
"Fill with sensor..."

Opens a dialog to configure the settings for automatic filling of user
correction data with an R&S NRP power sensor, see Chapter 9.5.7,
"Fill with sensor", on page 111.

"Delete Row" Deletes the marked row.

Level and power-on settings
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"Delete Range..."
Allows you to delete any number of rows starting with the marked
row. The number of rows to be deleted can be defined in an entry
window.

"Save as" Open the file menu to save the list under a new name.
Note: Save list only after filling both columns (frequency and level),
otherwise the entries are lost.
Each list is saved to the R&S SGS hard disk as a separate file with
the file prefix *.uco. The file name and the directory to which the file
is saved are user-selectable.

"Save" The list is saved under its current name.
Remote command: 
[:SOURce<hw>]:CORRection:CSET[:SELect] on page 268
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency on page 262
[:SOURce<hw>]:CORRection:CSET:DATA:POWer on page 263

Import/Export >>>
Expands the menu with the area for import and export of user correction files.
Externally edited Excel tables with any number of frequency/level value pairs can be
imported as text or *.csv files and used for user correction.

Conversely, you can also export internally created user correction lists as text or
*.csv files.

Mode
Selects the mode to import or export user correction lists. The settings depend on the
selected mode.
Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:MODE on page 267

Extension
Selects the file extension of the ASCII file to be imported or exported. Selection "TXT"
(text file) or "CSV" (Excel file) is available.
Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension on page 265

Decimal Point
Selects the decimal separator used in the ASCII data between '.' (decimal point) and ','
(comma) with floating-point numerals.
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Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal
on page 266

Column Separator
Selects the separator between the frequency and level column of the ASCII table, that
the user correction list is exported to or imported from.
Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn
on page 266

Select ASCII Source/Destination
Calls the "File Manager" for selecting the ASCII file to be imported into a user correc-
tion list (source) or the ASCII file the user correction list is exported (destination) in.
Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect on page 265

Select Destination/Source
Calls the "File Manager" for selecting the user correction list to be exported (source)
into an ASCII file or the destination for the ASCII file to be imported (destination) in.
Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:SELect on page 268

Import/Export
Starts the export or import of the selected file.
When import is selected, the ASCII file is imported as user correction list.
When export is selected, the user correction list is exported into the selected ASCII file.
Remote command: 
[:SOURce<hw>]:CORRection:DEXChange:EXECute on page 267

9.5.6  Filling the correction list automatically

The "Fill Table" menu enables you to set the level correction values automatically.
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The start line and the number of rows to be filled are defined under "From" and
"Range".

The column to be filled is selected under "Select column to fill". Depending on the
selection here, the default for start, end, and increment value are set. As the settings
are interdependent, a change of one parameter can result in the automatic change of
one or more of the other parameters. The filling of the column with the selected value
settings is started with button "Fill".

The correction list entries are only computed when the "Fill" button is pressed.

From
Sets the start value of the index range.
Remote command: 
n.a.

Range
Sets the range for filling the table.
Remote command: 
n.a.

Select column to fill
Selects either the frequency or the level column to be filled with the value defined
below.
Remote command: 
n.a.

Start value
Sets the start value for the frequency or the level entries.
Remote command: 
n.a.
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End value
Displays the end value for the frequency or the level entries.
Remote command: 
n.a.

Increment value
Sets the increment for the frequency or the level entries.
Remote command: 
n.a.

Fill
Fills the selected column in the set range with values, starting with the start value and
using the set increment.
Remote command: 
n.a.

9.5.7  Fill with sensor

► To access this dialog, select "SGMA-GUI > Instrument Name > Level > UCOR >
Edit User Cor. Data> Fill With Sensor".

This dialog describes all parameters for filling a table automatically with sensor
readings.
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Since the settings are interdependent, the affected parameters change accordingly if
you set a value.
To fill the table, press the "Execute" button.
To select the sensor and determine its parameters, refer to Chapter 9.5.8.3, "NRP
power viewer", on page 117.

Fill User Correction Data with Sensor
● "Sensor"

Displays connected sensors for selection.
● "List To Fill"

Indicates the used list.
● "Include Zeroing"

Performs a zeroing procedure before acquiring the user correction data to improve
precision. Since during zeroing no signal can be applied to the sensor, RF is tem-
porarily switched off at the generator.
When unchecked, the zeroing procedure is skipped. However, the RF signal level
can be blanked shortly. This setting is recommended if blanking of RF is undesira-
ble or the absence of power at the sensor cannot be guaranteed.

● "Execute"
The "Execute" button is only enabled if a sensor is detected and the user correction list
contains at least one frequency value.
Remote command: 
[:SOURce<hw>]:CORRection:ZERoing:STATe on page 269
[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe
on page 264

Used Instrument Settings For Measurement
Displays the settings relevant for the measurement.
"Modulation" Indicates the modulation state
"Amplitude" Shows the currently set level.
"Use SParameter"

Indicates whether SParameter correction is used.
"Attenuator Mode"

Displays the selected mode of the attenuator.
"Fixed range (PEP) In"

Shows the level range.
Remote command: 
n.a.

9.5.8  Using power sensors

The R&S SGS works with most of the R&S NRP power sensors and thus supports var-
ious application tasks. Using power sensors, you can for example determine attenua-
tion characteristics of downstream equipment or cables. You can use the measured
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values to compensate the losses with internal control functions or with an external con-
trol circuit in real time.

R&S NRP power sensors are highly accurate standalone measuring devices, suitable
for a wide range of applications. The power sensors communicate directly with the sig-
nal generator, calculate the average or peak power internally, include S-parameter cor-
rection and return the measurement results to the generator.

The R&S SGS works with any sensor of the R&S NRP series and can perform up to
four power measurements simultaneously.

Check the firmware version of the R&S NRP sensors regularly. Update the firmware, if
necessary.
For updates, see the Rohde & Schwarz website http://www.rohde-schwarz.com in sec-
tion "Power Meters & Voltmeters".

9.5.8.1  Connecting R&S NRP power sensors to the R&S SGS

R&S NRP sensors are connected to the R&S SGS in the following ways:
● Connection to the USB In connector

Requires a USB Adapter Micro-A to A and the following cables, depending on the
used sensor type:
– R&S NRP-ZK6 and an R&S NRP-Z3 with external power supply for R&S

NRPxx power sensors
– R&S NRP-Z3 with external power supply for sensors of the R&S NRP-Zxx fam-

ily
● Connection via R&S NRP-Z5 sensor hub, see Using the R&S NRP-Z5 sensor hub.
● Connection via USB hub with external power supply unit, see Using USB hub.
● Connection via LAN for R&S NRPxxxSN power sensors

Using the Ethernet interface requires PoE (Power over Ethernet) to provide the
electrical power.
To establish the connection, you can use:
– A PoE Ethernet switch, e.g. R&S NRP-ZAP1 and an RJ-45 Ethernet cable.
– A PoE injector and an RJ-45 Ethernet cable.

Using the R&S NRP-Z5 sensor hub

The R&S NRP-Z5 USB sensor hub (high-speed USB 2.0) can host up to 4 R&S NRP
sensors. It provides simultaneous internal and external triggering of all connected sen-
sors.

Figure 9-2 illustrates the connection as principle. For details, see the description
R&S®NRP®Series Power Sensors getting started.
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Figure 9-2: Connecting power sensors to the R&S SGS via R&S NRP-Z5 sensor hub

I, II = Connection order
G = Signal source (R&S SGS)
1 = USB type Micro-A connector
2 = USB Adapter Micro-A to A
3 = Standard USB cable with USB type A and USB type B connectors
4 = USB type B connector
4a = External power supply unit, incl. power cable (supplied with the R&S NRP-Z5)
5 = Cable R&S NRP-ZK6 per sensor of the R&S NRPxx power sensor family; no further adapter cables for

sensors of the R&S NRP-Zxx family

Using USB hub

Figure 9-3 illustrates the connection as principle. For details, see the description
R&S®NRP®Series Power Sensors getting started.

Figure 9-3: Connecting power sensors to the R&S SGS via USB hub

I, II = Connection order
G = Signal source (R&S SGS)
1 = USB type Micro-A connector
2 = USB Adapter Micro-A to A
3 = Standard USB cable with USB type A and USB type B connectors
4 = USB type B connector
4a = External power supply unit and extra power cable
5 = Cable R&S NRP-ZKU per sensor of the R&S NRPxx power sensor family; R&S NRP-Z3 or R&S NRP-

Z4 USB adapter cables for sensors of the R&S NRP-Zxx family

Connection order

Always connect the equipment in the following order:

1. Connect the R&S NRP-Z5 sensor hub or the USB hub to the power supply and to
the R&S SGS

2. Switch on the R&S SGS
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3. Connect/disconnect the R&S NRP sensors

Detection and mapping

The R&S SGS automatically detects a connected R&S NRP power sensor and indi-
cates it in the "NRP Power Viewer" and "NRP Sensor Mapping" dialogs.

You can change the default mapping, see Chapter 9.5.8.2, "NRP sensor mapping",
on page 115.

On connection, the R&S SGS immediately starts the measurement of a detected
R&S NRP power sensor. If you perform an instrument preset, the R&S SGS stops the
measurements. The connection and the mapping of the power sensors remain, the
measurements must be restarted.

9.5.8.2  NRP sensor mapping

The "NRP Sensor Mapping" lists all R&S NRP sensors detected by the instrument.

Any R&S NRP sensor that supports the USB legacy protocol and is connected to one
of the USB interfaces, is detected automatically and added to the list. Vice versa, the
R&S SGS removes a sensor from the list, when it is disconnected.

R&S NRP sensors that are connected via LAN or use the USBTMC protocol are not
automatically detected. They are detected by the scan search function.

Access:

► Select "Instrument" > "NRP Sensor Mapping".
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The dialog lists all detected R&S NRP sensors for selection and mapping. You can
also browse the network for sensors.
The detected sensors are characterized by the used protocol and the correspond-
ing connector icon. In the "Mapping" column, you can assign the sensor to one of
the available sensor channels. The list can contain several entries but the
R&S SGS can only use up to four sensors simultaneously.

Settings

Sensor Mapping List....................................................................................................116
Scan............................................................................................................................ 116
Clear............................................................................................................................116
Add Sensor/Hide 'Add Sensor'.................................................................................... 116
Add Sensor settings.................................................................................................... 116

└ Add LAN Sensor settings.............................................................................. 117
└ Add USB Sensor settings..............................................................................117

Sensor Mapping List
Shows the sensors that are connected to the R&S SGS.
The table informs on the sensor type, specific features and the installed sensor firm-
ware. It also shows the interface the sensor is connected to, including the communica-
tion protocol and the assigned channel.
Remote command: 
:SLISt[:LIST]? on page 248
:SLISt:ELEMent<ch>:MAPPing on page 250
:SLISt:SENSor:MAP on page 250

Scan
Scans the network and the USB connections for sensors connected using the VISA
communication protocol, i.e. sensors that are addressed over LAN or USBTMC.
The instrument detects sensors communicating over the USB legacy protocol automat-
ically.
Remote command: 
:SLISt:SCAN[:STATe] on page 248

Clear
Removes the selected sensor from the sensor mapping list.
Remote command: 
:SLISt:CLEar:LAN on page 249
:SLISt:CLEar:USB on page 249
:SLISt:CLEar[:ALL] on page 250

Add Sensor/Hide 'Add Sensor'
Shows or hides the "Add Sensor" settings.

Add Sensor settings
Configures settings to add sensors connected to the R&S SGS via USB or LAN.
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Add LAN Sensor settings ← Add Sensor settings
Configures settings to add sensors connected to the R&S SGS via LAN.

"IP Address or Host Name"
Displays the host name or the IP address of a R&S NRP power sen-
sor.
If the R&S SGS does not detect a connected R&S NRP sensor, you
can assign the address information manually.

"Add LAN Sensor"
Adds a detected R&S NRP sensor connected in the LAN to the list of
sensors, including its device ID or name and its serial number.

Remote command: 
:SLISt:SCAN:LSENsor on page 248

Add USB Sensor settings ← Add Sensor settings
Configures settings to add sensors connected to the R&S SGS via USB.

"Device ID or Sensor Name"
Displays the device identifier or the name of the R&S NRP power
sensor.
If the R&S SGS does not detect a connected R&S NRP sensor, you
can assign the ID or name manually.

"Serial Number"
Displays the serial number of the R&S NRP power sensor.
If the R&S SGS does not detect a connected R&S NRPsensor, you
can assign the serial number manually.

"Add USBTMC Sensor"
Adds a detected R&S NRP sensor connected at the USB interface to
the list of sensors, including its device ID or name and its serial num-
ber.

Remote command: 
:SLISt:SCAN:USENsor on page 249

9.5.8.3  NRP power viewer

The R&S SGS features the power viewer function for measuring or monitoring signals
with R&S NRP power sensors.

About

The R&S SGS can perform up to four power measurements simultaneously.

The measured signals can be the RF output power or other selected signal sources.

Depending on the signal characteristic (CW, AM, pulsed, etc.) or the parameter to be
measured (average, peak, etc.) a suitable R&S power sensor must be used.
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About the measuring principle, averaging filter, filter length, and achieving stable
results

A sensor measures the average or peak RF power of the source continuously. The
measurement results are displayed in the "NRP Power Viewer" dialog.

The power viewer function uses averaging filters for getting a stable readout.

Measurement results could be interfered, for instance, by too much noise in your
setup, by a bad suppression of harmonics or non-harmonics or when you reach the
sensitivity level of your power sensor.

Measurements are continuously repeated in a predefined time window. The measure-
ment result is obtained by averaging the measured values for the last 2N time win-
dows. This approach is referred as a two-step averaging process.

The factor of 2 in the formula arises because the output signals from the microwave
detector are chopped at the same rate as the time windows to suppress low-frequency
noise. An independent measured value can only be obtained from two consecutive val-
ues.

The variable N in the formula indicates the filter length. The filter length then directly
influences the measurement time. The filter length can be selected automatically or it
can be manually set to a fixed value.

Depending on the R&S NRP power sensor type, the manual setting of the filter length
varies in resolution:
● Resolution = 1 for the R&S NRPxx power sensor family
● Resolution = 2n for R&S NRP-Zxx power sensors, with n = 1 to 16

Follow the following general recommendation to find out the optimum filter length:
● Always start a measurement in auto mode ("Filter > Auto").

Check if the measurement results are sufficient.
● If the power is not constant, select the filter length manually ("Filter > User").

Trigger the "Auto Once" function to search for the optimum filter length for the cur-
rent measurement conditions.
The estimated value is indicated as filter length.

● If the target measurement accuracy value is known, select "Filter > Fixed Noise".
The averaging factor is selected automatically and so that the sensor's intrinsic
noise (two standard deviations) does not exceed the specified noise content.

● Different sensor types achieve the same filtering result with different filter and time
window lengths.
The time window length depends on the sensor type:
– For most sensors, it is fixed to 20 ms.
– For the R&S NRP-Z81 sensor, it is 10 μs.

The R&S NRP-Z81 uses filter length that is 1000 times larger than the filter
length for other sensors.

About zeroing

Activates the auto zero function.
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Zeroing calibrates the external power sensor by adjusting its reading at zero signal
power. For this purpose, the RF power source must be switched off or disconnected
from the sensor. If a Rohde & Schwarz power sensor receives an input power during
the zeroing process, it aborts zeroing and generates an error message. Zeroing takes
a few seconds, depending on the sensor model. Refer to the documentation of your
power sensor for more information.

Tips for zeroing

When to perform zeroing:
● During warm up after switching on or connecting the instrument
● After a substantial change of the ambient temperature
● After fastening the power sensor module to an RF connector at high temperature
● After several hours of operation
● When low-power signals are to be measured, e.g. less than 10 dB above the lower

measurement limit.
● Switch off the RF power source for zeroing, but do not disconnect it from the power

sensor. This proceeding keeps the thermal equilibrium, and the zeroing process
also compensates the noise that superimposes the measured signal (e.g. from a
broadband amplifier).

Related settings and functions

● Measurements-related settings, like results, filter, filter length:
NRP power viewer settings

● Software version of the connected power sensor:
:SENSe<ch>[:POWer]:TYPE? on page 258

● Acquisition of level correction data:
Chapter 9.5.5, "User correction settings", on page 104.

Additional information

See Rohde & Schwarz website http://www.rohde-schwarz.com in section "Power
Meters & Voltmeters" for:
● R&S NRP power sensor manual.
● Information on the R&S NRP-Z5 sensor hub and the available accessories.
● Sensor software updates.

NRP power viewer settings

Access:

► Select "Instrument" > "NRP Power Viewer".
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The "Overview" tab shows the list of detected sensors, and provides a separate tab
per sensor.

A sensor tab contains all parameters for configuring the sensor settings, like aver-
age or peak display, reference source, filter and level offset.
The remote commands required to define these settings are described in Chap-
ter 13.12, "SENSe, READ, INITiate and SLISt subsystems", on page 245, including
the triggering of the measurement and the retrieval of measurement results.

Settings:

Sensor type and serial number................................................................................... 121
Level (Peak) / Level (Average)....................................................................................121
Sensor Mapping.......................................................................................................... 121
Sensor Settings...........................................................................................................121

└ State..............................................................................................................121
└ Zero...............................................................................................................121
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└ Source...........................................................................................................122
└ Frequency.....................................................................................................122
└ Level Offset State,Level Offset..................................................................... 122
└ Filter..............................................................................................................122
└ Filter Length..................................................................................................123
└ Auto Once.....................................................................................................123
└ Noise Content............................................................................................... 123
└ Timeout......................................................................................................... 123
└ Default Aperture Time...................................................................................123
└ Aperture Time............................................................................................... 124
└ S-Parameter..................................................................................................124
└ Enable Logging.............................................................................................124

Sensor type and serial number
Indicates the type and the serial number of the selected R&S NRP power sensor, and
the channel the sensor is assigned to.
The displayed Level (Peak) / Level (Average) values correspond to the particular sen-
sor.
Remote command: 
:SENSe<ch>[:POWer]:TYPE? on page 258
:SENSe<ch>[:POWer]:SNUMber? on page 257

Level (Peak) / Level (Average)
Indicates the measured peak or average level value.
You can also change the unit for the results display: Watt, dBm or dBμV.

Note: Peak level measurements are provided if the power sensor supports this feature.
Remote command: 
:READ<ch>[:POWer]? on page 251
:SENSe<ch>:UNIT[:POWer] on page 251

Sensor Mapping
Accesses the NRP sensor mapping dialog.

Sensor Settings
One tab per sensor provides the corresponding setting parameters.

State ← Sensor Settings
Activates level measurement.
Remote command: 
:INITiate<hw>[:POWer]:CONTinuous on page 250
To query the availability of a sensor at a given connector, use the command :
SENSe<ch>[:POWer]:STATus[:DEVice]? on page 258.

Zero ← Sensor Settings
Activates the auto zeroing.
For details, see "About zeroing" on page 118.
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Remote command: 
:SENSe<ch>[:POWer]:ZERO on page 259

Source ← Sensor Settings
Selects the source for measurement.
"RF" Assigns the signal to the RF path of the R&S SGS.

The R&S SGS transfers the RF frequency and level settings to the
R&S power sensor automatically. Thus you achieve power readings
of high accuracy, irrespective from the connected sensor type.

"User" Sets a user defined frequency.

Example: 
If you have a frequency converting device between the generator and
the DUT. If the frequency converter doubles the frequency, you can
set twice the frequency in the R&S SGS. The R&S power sensor con-
siders this RF frequency setting.

Set the parameter Frequency to the measurement's frequency.
Remote command: 
:SENSe<ch>[:POWer]:SOURce on page 257

Frequency ← Sensor Settings
Defines the frequency value if "Source > User" is used.
Remote command: 
:SENSe<ch>[:POWer]:FREQuency on page 256

Level Offset State,Level Offset ← Sensor Settings
Activates and defines a level offset which is considered in the power measurement
result. The level offset value is always expressed in dB, irrespective of the display of
the measurement result.
This function allows you to consider, for example, an attenuator in the signal path.
Remote command: 
:SENSe<ch>[:POWer]:OFFSet on page 257
:SENSe<ch>[:POWer]:OFFSet:STATe on page 257

Filter ← Sensor Settings
Selects the way the length of the used filter is defined.
See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 118.
"Auto" Selects the filter length automatically and adjusts it to the measured

value. The value is indicated with the parameter Filter Length.
When high output power is applied, the filter length and therefore the
measurement time can be short.
When low output power is applied, the filter length and therefore the
measurement time is increased which reduces the considered noise
content in your measurement.
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"User" The filter length is defined manually, with the parameter Filter Length.
As the filter length works as a multiplier for the time window, constant
filter length results in a constant measurement time.
Values 1 and 2N are allowed.

"Fixed Noise" The averaging factor is taken automatically in accordance to the
value Noise Content. Thus, the sensor's intrinsic noise (2 standard
deviations) does not exceed the specified noise content.
To avoid long measurement times when the power is too low, set a
Timeout.
Timeout is the maximum acceptable measurement time which limits
the averaging factor and therefore leads to a more unstable readout.

Remote command: 
:SENSe<ch>[:POWer]:FILTer:TYPE on page 255

Filter Length ← Sensor Settings
Sets or indicates the filter length, depending on the selected filter mode.
● "Filter > Auto" indicates the automatically adjusted filter length.
● "Filter > User" enables you to set the filter length manually.
● "Filter > Fixed Noise" hides the setting parameter.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO? on page 253
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] on page 254

Auto Once ← Sensor Settings
Searches the optimum filter length for the current measurement conditions. The result
is indicated with the parameter Filter Length.
See also "About the measuring principle, averaging filter, filter length, and achieving
stable results" on page 118.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:SONCe on page 255

Noise Content ← Sensor Settings
For Filter > Fixed Noise, sets the noise content.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio on page 254

Timeout ← Sensor Settings
For "Filter > Fixed Noise", sets a time limit for the averaging process.
Remote command: 
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe on page 254

Default Aperture Time ← Sensor Settings
The sensor default setting is sufficient. Disable this parameter to specify a user-defined
aperture time per sensor, if, for example, the readings vary.
To obtain stable readings, set the Aperture Time exactly to one modulation period.
Remote command: 
:SENSe<ch>[:POWer]:APERture:DEFault:STATe on page 252
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Aperture Time ← Sensor Settings
If "Use Default Aperture Time > Off", defines the acquisition time per sensor.
For example, to obtain a sufficient low average value, set the aperture time exactly to
one modulation period.
Remote command: 
:SENSe<ch>[:POWer]:APERture:TIMe on page 252

S-Parameter ← Sensor Settings
S-Parameter correction is used to mathematically shift the reference plane to the DUT
by considering the S-parameters for any components connected upstream of the sen-
sor.
The S-Parameter table can be changed with the S-Parameters tool, provided as part of
the free R&S NRP Toolkit software. For more information, refer to the manual of the
connected R&S NRP power sensor.
Remote command: 
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe on page 253
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST? on page 253
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect on page 252

Enable Logging ← Sensor Settings
Activates recording of R&S NRP power sensor readings in a log file.
There is 1 log file per sensor. The log files are created automatically and filled in con-
tinuously. They are text files with predefined filename SensLog<n>.txt, where <n>
indicates the connected sensor. Log files are stored on the internal memory, in the
directory /var/sgs/SensorLogging.

Each log file contains the measured value (2 readings when you work with peak sen-
sors), the sensor type, and the measurement time (timestamp). Logged data is not
overwritten. When a new measurement is started, the collected logging data is appen-
ded in the log file.
Check the used disc space regularly and remove log files to maintain storage capacity.
Note: The logging function is intended for measurements with long time intervals. It is
suitable source for data reconstructions if the connection to the sensor was interrupted.
Remote command: 
:SENSe<ch>[:POWer]:LOGGing:STATe on page 256

9.6  Pulse modulation

This section explains the pulse modulation settings of the R&S SGS. The equipment
layout for generating the pulse modulation signal includes the option Pulse Modulator
(R&S SGS-K22).

To configure and perform a pulse modulation, you need to select the modulation signal
source and provide the corresponding settings.
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Modulation signal sources

The R&S SGS provides the following signal sources for the signal modulation:
● Internal: A high-performance pulse generator that allows you to generate either

single or double pulse signals
● Externally supplied signal: the instrument expects the pulse modulation signals

at the "TRIG" connector.

Pulse modulation signal waveforms

The high-performance pulse generator enables you to generate single or double pulse
signals.

Figure 9-4: Pulse generator - single pulse mode

1 = Pulse period
2 = Pulse width
3 = Pulse delay

Figure 9-5: Pulse generator - double pulse mode
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1 = Pulse period
2 = Pulse width
3 = Double pulse width
4 = Double pulse delay

9.6.1  Pulse modulation settings

Access:

► Select "SGMA-GUI > Instrument Name > Pulse Modulation".

The "Pulse Modulation" dialog contains all parameters required to configure pulse
modulation and pulse signal generation.

State
Activates pulse modulation.
The R&S SGMA-GUI indicates an activated pulse modulation as follows:

Remote command: 
[:SOURce<hw>]:PULM:STATe on page 280

Source
Selects between the internal "Pulse Generator", or an "External" pulse signal for the
modulation. In the later case, the instrument expects the pulse modulation signals at
the "TRIG" connector.
Remote command: 
[:SOURce<hw>]:PULM:SOURce on page 280

Polarity
Sets the polarity of the active slope of the modulation signal for "Source > External".
Remote command: 
[:SOURce<hw>]:PULM:POLarity on page 280

External Impedance
Selects the input impedance for an external pulse modulation signal.
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Remote command: 
[:SOURce<hw>]:PULM:TRIGger:EXTernal:IMPedance on page 281

9.6.2  Pulse generator settings

Access:

► Select "SGMA-GUI > Instrument Name > Pulse Modulation > Pulse Genrator".

Comprises the settings necessary to configure the internal pulse modulation signal.

Pulse Mode
Sets the operating mode of the pulse generator.
"Single" Generates a single pulse in one pulse period, see Figure 9-4.
"Double" Generates two pulses in one pulse period, see Figure 9-5.
Remote command: 
[:SOURce<hw>]:PULM:MODE on page 279

Pulse Period
Sets the repetition rate of the generated pulse signal, see "Pulse modulation signal
waveforms" on page 125.
Remote command: 
[:SOURce<hw>]:PULM:PERiod on page 279

Pulse Width
Sets the pulse duration of the generated pulse signal, see "Pulse modulation signal
waveforms" on page 125.
Remote command: 
[:SOURce<hw>]:PULM:WIDTh on page 282

Double Pulse Width
Sets the width of the second pulse, see Figure 9-5.
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Remote command: 
[:SOURce<hw>]:PULM:DOUBle:WIDTh on page 279

Pulse Delay
Sets the pulse delay. The pulse delay determines the time that elapses after a trigger
event before pulse modulation starts, see Figure 9-4.
The pulse delay is not effective for double pulse generation.
Remote command: 
[:SOURce<hw>]:PULM:DELay on page 278

Double Pulse Delay
Sets the delay between the start of the first pulse and the start of the second pulse,
see Figure 9-5.
Remote command: 
[:SOURce<hw>]:PULM:DOUBle:DELay on page 279

9.6.3  Pulse Connector/Trigger settings

Access:

► Select "SGMA-GUI > Instrument Name > Pulse Modulation > Connector/Trigger".

Comprises the settings necessary to configure the signal at the multi-purpose
"TRIG" connector in the external trigger mode.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose [TRIG] connector.
"Signal Valid" Output of high signal to mark valid frequency and level settings.
"Not Signal Valid"

Output of high signal to mark the transition state when frequency and
level change.
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"Pulse Video Out"
Output of the internally generated pulse video (modulating) signal.
The video signal level corresponds to the RF envelope.

"Pulse Mod Ext Trigger"
Input for an external trigger signal, used to trigger the pulse genera-
tor.

"Pulse Mod Ext Source"
Input for an externally provided pulse modulation signal.
Used when an external pulse modulator source is provided at the
connector.

Remote command: 
:CONNector:TRIGger:OMODe on page 230

Trigger Mode
Selects between continuous pulse modulation or pulse modulation triggered by an
external signal.
"Auto" Generates the modulation signal continuously.
"Ext Single" Generates the signal each time an external trigger event occurs.
"Ext Gated" Generates the signal triggered by an external gate signal.
Remote command: 
[:SOURce<hw>]:PULM:TRIGger:MODE on page 281

Ext. Trigger Input Slope
Available only for "Trigger Mode > Ext Triggered "
Sets the polarity of the active slope of an applied external trigger signal.
Remote command: 
[:SOURce<hw>]:PULM:TRIGger:EXTernal:SLOPe on page 281

Gate Input Polarity
Available only for "Trigger Mode > Ext Gated "
Sets the polarity of the active slope of an applied gate signal.
Remote command: 
[:SOURce<hw>]:PULM:TRIGger:EXTernal:GATE:POLarity on page 281

9.7  Trigger connector settings

The dialog provides settings to determine the signal at the input/output of the multi-pur-
pose "TRIG" connector.

Trigger connector settings
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Access:

► Select "SGMA-GUI > Instrument Name > Connector".

Comprises the settings necessary to configure the signal at the input/output of the
multi-purpose "TRIG" connector.

Trigger Connector Mode
Determines the signal at the input/output of the multi purpose [TRIG] connector.
"Signal Valid" Output of high signal to mark valid frequency and level settings.
"Not Signal Valid"

Output of high signal to mark the transition state when frequency and
level change.

"Pulse Video Out"
Output of the internally generated pulse video (modulating) signal.
The video signal level corresponds to the RF envelope.

"Pulse Mod Ext Trigger"
Input for an external trigger signal, used to trigger the pulse genera-
tor.

"Pulse Mod Ext Source"
Input for an externally provided pulse modulation signal.
Used when an external pulse modulator source is provided at the
connector.

Remote command: 
:CONNector:TRIGger:OMODe on page 230

9.8  I/Q modulation and signal impairment

The R&S SGS offers I/Q modulation with external analog I/Q signals. I/Q modulation
with an external analog I/Q signal is possible for the instrument equipped with fre-
quency options R&S SGS-B106V/-B112V. The external signal is input via the I and Q
connectors and transferred to the I/Q modulator.

Before the signal is fed into the I/Q modulator, the signal can be impaired. Impairment
at this point along the signal flow is provided for error correction of the supplied signal
or for enabling dedicated impairments. Impairments caused by the I/Q modulator are
automatically corrected by the "Internal Adjustments" function.

I/Q modulation and signal impairment
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System error correction of the I/Q modulator permits precise and repeatable measure-
ments. Execute the correction routine if there are temperature fluctuations of several
degrees. To execute the routine, select "SGMA-GUI > Instrument Name > Setup >
Internal Adjustment" and execute the desired adjustment procedure.

9.8.1  I/Q impairments

Signal impairments are well-defined arithmetic modifications of the data. Every data
sample is modified in the same way. The purpose of adding impairments to the data
stream is to simulate frequent sources of distortions in a real signal-processing chain to
generate a test signal with dirty transmitter conditions.

9.8.1.1  Gain and gain imbalance

An I/Q gain is a multiplication of all I/Q amplitudes by a common factor. The effect is
equivalent to two identical I and Q gain factors. The effect of an increased gain factor
in the I/Q constellation diagram is shown below.

Figure 9-6: Effect of an increased amplitude in the I/Q constellation diagram

An I gain multiplies the I amplitudes by a factor, leaving the Q amplitudes unchanged.
A Q gain has the opposite effect. Different I and Q gain factors result in an I/Q imbal-
ance. The imbalance is usually due to different gains of the amplifiers in the I and Q
channels of the I/Q modulator. The effect of a positive and negative gain imbalance is
shown below.

I/Q modulation and signal impairment
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Figure 9-7: Negative gain imbalance (left) and positive (right) gain imbalance in the I/Q constellation
diagram

9.8.1.2  I and Q offset

An I offset adds a constant value to all I amplitudes, leaving the Q amplitudes
unchanged. A Q offset has the opposite effect. A combination of I and Q values results
in an I/Q offset, which is usually due to carrier feedthrough in the I/Q modulator. Possi-
ble reasons are interfering signals at the RF carrier frequency, e.g. an unsuppressed
RF carrier subchannel. The effect of a positive I and Q offset in the I/Q constellation
diagram is shown below.

Figure 9-8: I offset (left) and Q offset (right) in the I/Q constellation diagram

9.8.1.3  Quadrature offset

Changes the phase angle between the I and Q vectors from the ideal 90 degrees,
while the amplitudes are maintained. A positive quadrature offset results in a phase
angle greater than 90 degrees. The effect of a positive quadrature offset in the I/Q con-
stellation diagram is shown below.

I/Q modulation and signal impairment
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Figure 9-9: Positive quadrature offset in the I/Q constellation diagram

9.8.2  General I/Q settings

Access:

► Select "SGMA-GUI > Instrument Name > I/Q Settings > General".

Comprises the settings for setting the state and the analog wideband I/Q input.

Mod State
Switches the I/Q modulation on and off.
Remote command: 
[:SOURce]:IQ:STATe on page 270

I/Q Wideband
Setting mode for wideband modulation signals (higher I/Q modulation bandwidth).
The modulation frequency response of the R&S SGS in the useful bandwidth is
improved at the expense of poorer harmonic suppression. Improvement is achieved by
shifting the switching frequencies of the low pass filters in the output section.

I/Q modulation and signal impairment
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Remote command: 
[:SOURce]:IQ:WBSTate on page 272

Crest Factor
Sets the crest factor of the I/Q modulation signal.
The crest factor gives the difference in level between the peak envelope power (PEP)
and average power value (RMS) in dB. This value is necessary for the generation of
the correct output power at the RF output, i.e. the instrument uses the crest factor
value to compensate the average power.
In vector modulation mode, the output level setting is correlated to the nominal full-
scale voltage at the I/Q input. If the baseband signal exhibits no constant envelope, the
instrument internal level setting can be corrected by use of the crest factor value.
Remote command: 
[:SOURce]:IQ:CREStfactor on page 271

9.8.3  Analog impairment settings

Access:

► Select "SGMA-GUI > Instrument Name > I/Q Settings > Analog Impairments".

Comprises the settings like I/Q offset and quadrature offset.

State
Activates/deactivates I/Q impairments.
If activated, the settings for offset, gain imbalance and quadrature offset become effec-
tive.
It is indicated in the function block, if the I/Q impairment is activated.
Remote command: 
[:SOURce]:IQ:IMPairment[:STATe] on page 271

I/Q modulation and signal impairment
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Offset
Sets the carrier offset (in percent) of the amplitudes (scaled to the peak envelope
power (PEP) for the I and/or Q signal component. An ideal I/Q modulator suppresses
the carrier offset completely (offset = 0 percent).
For more information, see Chapter 9.8.1.2, "I and Q offset", on page 132.
Remote command: 
[:SOURce]:IQ:IMPairment:LEAKage:I on page 271
[:SOURce]:IQ:IMPairment:LEAKage:Q on page 271

Gain Imbalance
Sets the imbalance of the I and Q vector (see Chapter 9.8.1.1, "Gain and gain imbal-
ance", on page 131).
The entry is made in dB (default) or %, where 1 dB offset is roughly 12 % according to
the following:
Imbalance [dB] = 20log ( | GainQ | / | GainI |)

Positive values mean that the Q vector is amplified more than the I vector by the corre-
sponding percentage. Negative values have the opposite effect.
Remote command: 
[:SOURce]:IQ:IMPairment:IQRatio[:MAGNitude] on page 270

Quadrature Offset
Sets the quadrature offset (see Chapter 9.8.1.3, "Quadrature offset", on page 132).
Remote command: 
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] on page 271

9.9  Preset

Calls up a defined instrument setup. Presets all parameters and switching states
including inactive operating modes. The default instrument settings provide a reprodu-
cible initial basis for all other settings. However, functions that concern the integration
of the instrument into a measurement setup are not changed, e.g., reference oscillator
settings.

Overview of the most important preset states

The following list gives an overview of the presets for the most important generator set-
tings. The other presets can be found in the information accompanying the remote
commands.
● "RF frequency" = 1 GHz
● "Reference frequency" = "Internal"; adjustment off
● "RF output" switched off
● "Modulator State" = Off

Preset
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Settings that are not affected by the "SGMA-GUI > Instrument Name > Preset" func-
tion:
● Reference frequency settings ("Ref Oscillator" dialog)
● Power on settings ("Level" dialog)
● Network settings ("Setup" dialog)
● Password and settings protected by passwords ("Setup" dialog)
● "Eco Mode" state ("Setup > Eco Mode" dialog)

To preset the R&S SGMA-GUI itself and all configured instruments to their predefined
state, use the "SGMA-GUI > File > New" function.

SCPI command:

:SYSTem:PRESet on page 226

9.10  Extension

Depending on the installed option, your R&S SGS generates an RF signal with fre-
quency range up to 12.75 GHz. Some test cases, however, require even higher fre-
quencies. A general setup would thus include an upconverter connected to the signal
generator and you would have to control both the signal generator and the
upconverter.

The R&S SGS equipped with one of the options R&S SGS-B112/B112V provides the
build-in extension mode for controlling the R&S SGU upconverter. If you connect an
R&S SGU to the R&S SGS, this upconverter acts as an extension to your instrument
extending its frequency range to 20 GHz for instance. Refer to Chapter 7.2, "Connect-
ing an R&S SGS and an R&S SGU", on page 48 for a description of the possible set-
ups.

The extension mode provides the following advantages:
● Simplified calibration of the R&S SGU and single point of control

In this setup, a controller does not need to access the extension, i.e. the R&S
SGU, directly. Instead, the R&S SGS acts as a controller to it and depending on the
required output signal parameters performs all required settings automatically.
The signal generator settings of the extension are disabled for direct configuration
in the R&S SGMA-GUI. However, you can still remotely control the extension using
the corresponding SCPI commands.

● Extended value ranges and functionality
The main application field of the extension mode is the extended frequency range
but you can also benefit from the I/Q modulation and pulse modulation functions of
the extension. For frequencies greater than 12.75 GHz, the combination of R&S
SGS and R&S SGU can generate vector modulated signals even if the R&S SGS
is not equipped with the required options R&S SGS-B106V/B112V.

Prerequisites and required physical connections for operation in extension mode:
● The R&S SGS is equipped with one of the options R&S SGS-B112/B112V.

Extension
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● A remote PC is connected to the master instrument, the remote PC and the instru-
ment are switched on and a connection between them is established.
The instrument and the extension are connected via a direct remote connection or
over network/switch. All interfaces (LAN, PCIe, or USB) can be used for controlling
the SGU.

● The R&S SGMA-GUI or an application program is running on the remote PC.
● Signal connections between the R&S SGS and the R&S SGU are established, i.e.

the connections between:
– The "RF 50Ω" connector of the R&S SGS and the "LO IN" of the R&S SGU
– For vector modulated signals, the "I/Q Out" connectors of the R&S SGU and

the "I/Q In" of the R&S SGS
– The "TRIG" connectors of both instruments

This section describes the manual operation via the R&S SGMA-GUI software. The
remote commands required to define these settings are described in Chapter 13.8,
"EXTension subsystem", on page 231.

To access the extension mode settings and enable the extension mode

1. Select "SGMA-GUI > Instrument Name > Extension".

Tip: Steps 2 and 3 can be omitted if the R&S SGS and a single R&S SGU are con-
nected using PCIe or USB or by a direct LAN connection. In this case, R&S SGS
automatically activates the R&S SGU.

2. Trigger "Scan" to find all available instruments that can serve as an extension to
the particular instrument.

3. Select an instrument from the list

4. Set "Available Instruments > Select > On" to enable it as an extension.

A green status indicator "Connected" indicates the successfully established remote
connection to the extension.

Extension
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5. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

The R&S SGMA-GUI indicates the extended frequency range of the master instru-
ment and the activated extension mode.

You cannot access the signal generation settings of an instrument working in
extension mode. The extension is controlled via the master instrument.
To display the R&S SGU settings, click on the  button next to the instrument's
name.
Select for example "SGMA-GUI > Master Instrument Name > Freq = 20 GHz", "Lev
= -30 dBm" and enable "RF > State > On". The extension adopts these values and
states automatically. To confirm, disable the "Extension > Available Instruments >
Extension Name > Select > Off" and compare the values of the parameters
"SGMA-GUI > Extension Instrument Name > Freq/Lev".

Connected
The connection state indicator visualizes the state of selected extension:
● Grey - the connection to the extension is not activated ("Extension > Available

Instruments > Instrument# > Select > Off")
● Green - the extension is connected to the master instrument and can be manually

and remotely operated
● Red - the extension is in standby or locked state, or is performing a time consum-

ing operation

Available Instruments
Lists all available instruments that can serve as an extension to the R&S SGS.
Each instrument is represented by:
"Symbolic Name"

Alias name of the instrument as it is defined in the main panel of
R&S SGMA-GUI.

"Channel" Hardware channel, "Socket", "LAN", "USB" or "PCIe", used by the
extension as remote control channel

"Select" State of the remote connection to the extension.
The R&S SGMA-GUI indicates an activated extension mode as fol-
lows:

Remote command: 
:EXTension:BUSY[:STATe]? on page 233
:EXTension:INSTruments:NAME? on page 232
:EXTension:INSTruments:REMote:CHANnel? on page 232
:EXTension:INSTruments:REMote:LAN:NAME? on page 232
:EXTension:INSTruments:REMote:SERial? on page 233

Extension
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:EXTension:INSTruments:SCAN[:STATe] on page 232
:EXTension:REMote:STATe? on page 231

Scan
Triggers a scan function and searches for instruments connected to the instrument via
all the available interfaces.
Remote command: 
:EXTension:INSTruments:SCAN[:STATe] on page 232

Test Signal Connections
The "Test" function triggers a test of all signal connections between the instrument and
the extension. The schematic diagram displays the required physical signal connection
for the current test setup and the connection state.
A faulty connection is marked with a red line crossing the drawn blue connection line
as shown in Figure 9-10. If your connection is marked as faulty check whether the
cables are connected properly and if the connection cables are functioning properly.

Figure 9-10: A faulty connection between an R&S SGU and an R&S SGS

Note: If your connection is marked as faulty check whether the cables are connected
properly. Check also if the connection cables are functioning properly.
Remote command: 
:TEST:EXTension:CONNection? on page 234
:TEST:EXTension:CONNection:RF? on page 234

Extension
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10  General instrument settings and instrument
setup
This section describes the settings which do not directly affect signal generation.

Access:

1. Select "SGMA-GUI > Instrument Name > Setup".

2. Select the required dialog.

Settings

● Internal adjustments..............................................................................................141
● Hardware configuration.........................................................................................144
● Software / options................................................................................................. 145
● Install SW options................................................................................................. 147
● Protection..............................................................................................................147
● Security................................................................................................................. 148
● Network settings....................................................................................................151
● Remote channels.................................................................................................. 154
● Factory preset....................................................................................................... 155
● Eco mode..............................................................................................................156
● Standby and restart...............................................................................................157
● Diagnostic and tests..............................................................................................157
● External adjustments.............................................................................................158
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10.1  Internal adjustments

Access:

► Select "Setup > Internal Adjustments".

The dialog provides settings for internal adjustments of the R&S SGS.

All internal adjustments for which no external measuring equipment is needed can be
started in the "Internal Adjustments" dialog. The adjustments with external measuring
equipment are described in the service manual.

Deciding whether to run internal adjustments

1. Select "Setup > Internal Adjustments".

2. Observe the status and color indication in the section "Since Last Full Adjustment".

Green: Internal adjustments are not required.
Red: Internal adjustments are required. Observe also the indication in the "Informa-
tion" field.

3. We recommend you to run internal adjustments in the following cases:
● Before starting any application, that requires a maximum of level accuracy and

frequency accuracy
Also, after enabling/disabling of the "Eco Mode" (see Chapter 10.10, "Eco
mode", on page 156).

● When a long period of time has passed since the last adjustments
● If the ambient temperature of the instrument significantly differs from the one of

the last adjustments

4. Proceed as described in "Running internal adjustments" on page 142.

Internal adjustments
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Running internal adjustments

1. NOTICE! Adjustments can be invalid if performed when the instrument is not
warmed-up.
Wait until the instrument has reached its operating temperature before you start the
adjustment procedure.
The warm-up time is up to 30 minutes.

2. Select "Setup > Internal Adjustment > Adjust All".

The adjustment process starts.

3. Do not interrupt the adjustment process.
The extent of the adjustments depends on the installed options. It can last up to 2
hours.

A progress indicator shows the status of the adjustment process. If errors occur the
process aborts. An error message appears in the "Info" line.

Running internal adjustments in eco mode

► NOTICE! Risk of invalid adjustment after changing the Eco Mode. The switching off
and on of the doubler stage changes the thermal conditions in the instrument.
In order to achieve correct adjustment of the instrument, make sure that the instru-
ment is warm before performing adjustments. The warm-up time is 30 minutes.
See "Running internal adjustments" on page 142.

The R&S SGS performs the internal adjustment within the currently active fre-
quency range, i.e. up to 6 GHz for enabled mode "Eco Mode 1". The correct align-
ment of the parameters outside of the current active frequency range is not guaran-
teed. A subsequent readjustment for the total frequency range of the instrument is
recommended.

Settings

Adjust All..................................................................................................................... 142
Adjust I/Q Modulator at Current Frequency................................................................ 142
Synthesis.....................................................................................................................143
Level............................................................................................................................143
I/Q Modulator.............................................................................................................. 143
Delta Temperature.......................................................................................................143

Adjust All
Starts all internal adjustments for which no external measuring equipment is needed.
The adjustments with external measuring equipment are described in the service man-
ual.
Remote command: 
:CALibration:ALL[:MEASure]? on page 227

Adjust I/Q Modulator at Current Frequency
Starts the adjustment for the I/Q modulator for the currently set frequency. The I/Q
modulator is adjusted regarding carrier leakage, I/Q imbalance and quadrature.

Internal adjustments
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The adjustment is only possible when "RF > On" and "I/Q Mod > State > On".
Adjustment for only the set frequency is considerably faster than adjustment across the
entire frequency range. An adjustment of the entire range is possible with the I/Q Mod-
ulator button of this dialog.
Remote command: 
:CALibration:IQModulator:LOCal? on page 228

Synthesis
Performs all adjustments which affect the frequency.
Remote command: 
:CALibration:FREQuency[:MEASure]? on page 227

Level
Performs all adjustments which affect the level. The acquired correction values
improve the settling time and the signal quality.
Remote command: 
:CALibration:LEVel[:MEASure]? on page 228

I/Q Modulator
Starts the adjustment procedure for the I/Q modulator and/or the baseband for the
entire frequency range. The I/Q modulator is adjusted regarding carrier leakage, I/Q
imbalance and quadrature.
To accelerate the adjustment procedure, you can enable performing adjustments for
the I/Q modulator and the baseband separately.
Remote command: 
:CALibration:IQModulator:FULL? on page 228

Delta Temperature
Displays the difference between the current temperature and the temperature by the
last performed adjustment.
Note: Adjustment is recommended if the temperature range in which the instrument is
operated changes, before all applications which require maximum level and frequency
accuracy, or after enabling/disabling of the "Eco Mode" (see Chapter 10.10, "Eco
mode", on page 156).
Remote command: 
:CALibration:LEVel:TEMPerature? on page 228
:CALibration:FREQuency:TEMPerature? on page 228
:CALibration:IQModulator:TEMPerature? on page 228

Internal adjustments
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10.2  Hardware configuration

Querying information about the installed assemblies

► Select "SGMA-GUI > Instrument Name > Setup > Hardware Config".

In the "Hardware Config" dialog, the installed assemblies together with their var-
iants and revision states can be displayed for servicing purposes.

The dialog is a table that lists the installed assemblies. It is divided into the sec-
tions:
● "Common Assembly"
● "RF Assembly"

Settings

Assembly.....................................................................................................................144

Assembly
The tables list the installed assemblies.
"Assembly" Name of the assembly
"Part Number" Part number of the assembly
"Serial Number"

Serial number of the assembly
"Revision" Revision state of assembly

Hardware configuration
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Remote command: 
:SYSTem:HARDware:ASSembly<dir>:NAME? on page 298
:SYSTem:HARDware:ASSembly<dir>:PNUMber? on page 298
:SYSTem:HARDware:ASSembly<dir>:SNUMber? on page 299
:SYSTem:HARDware:ASSembly<dir>:REVision? on page 299

10.3  Software / options

Querying information about the installed options and software version

► Select "SGMA-GUI > Instrument Name > Setup > Software/Options".

The "Software/Options" dialog shows the firmware version of the instrument soft-
ware and all installed hardware and software options.

The dialog is divided into the following sections:
● "Firmware"
● "Hardware"

Software / options
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● "Software"
● "Loaded Modules"

Software options purchased at a later stage can be activated with a keycode. The acti-
vation code is supplied with the software option. An instruction on how to install options
is described in the service manual. You can install most hardware options at an author-
ized Rohde & Schwarz service center.

Settings

Software...................................................................................................................... 146
Hardware / Software/WinIQSIM.................................................................................. 146
Loaded Modules..........................................................................................................146
Show Open Source Acknowledgments.......................................................................146
LucasFonts RSCorpid EULA.......................................................................................147

Software
Shows the software/firmware version and the version of the software platform.
Note: Your instrument is delivered with the latest firmware version available. Firmware
updates and the release notes are provided on the Internet at the download site of the
instrument's home page. This home page always offers the latest information on your
instrument, e.g. also on changes of the firmware update procedure.

Hardware / Software/WinIQSIM
The tables in the sections "Hardware" and "Software" list the installed hardware and
software options.
"Option" Short name of the option
"Designation" Name of the option
"Licenses" Number of licenses
"Expiration Date"

For regular options, "Permanent" is indicated in this column. Some
options are available as trial versions. This column shows their expi-
ration date. After this date, the option is no longer available on the
instrument.

Remote command: 
:SYSTem:SOFTware:OPTion<dir>:NAME? on page 300
:SYSTem:SOFTware:OPTion<dir>:DESignation? on page 299
:SYSTem:SOFTware:OPTion<dir>:LICenses? on page 300
:SYSTem:SOFTware:OPTion<dir>:EXPiration? on page 300

Loaded Modules
Section "Loaded Modules" is provided for service purposes. It lists all loaded software
modules with their versions and offers a short description of each module.

Show Open Source Acknowledgments
Accesses the list of the used open-source software packages and the corresponding
verbatim license texts.

Software / options
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For R&S SGMA-GUI, the list shows the open-source acknowledgement for software
with Windows® operating system.
For R&S SGU/SGS/SGT, the list shows the open-source acknowledgement for soft-
ware with Linux® operating system.

LucasFonts RSCorpid EULA
Accesses copyright information on LucasFonts font type RSCorpid EULA.

10.4  Install SW options

Newly purchased software options are enabled in the "Install SW-Option" dialog. They
are ready to operate after they are enabled by a key code supplied with the option.

Only if the instrument is equipped with an older firmware version, a firmware update
before enabling the software option can be required. The information on the valid firm-
ware versions for the purchased software option is provided together with the option.

See:
● Chapter 11.12, "How to install a new firmware version on the instrument",

on page 172 for information on how to perform firmware update
● Chapter 11.13, "How to activate options", on page 174 for instruction on how to

install new options

The firmware update is also described in the service manual.

10.5  Protection

The "Protection" dialog provides access to the unlocking of protected service functions
(authorized personnel of R&S service departments only).

Unlocking protected service functions

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Protection".

The "Protection" dialog provides access to the unlocking of protected service func-
tions (authorized personnel of R&S service departments only).

2. To deactivate the protection, enter the correct password. After booting the instru-
ment, protection levels 1 to 4 are active.
Enter "Protection Level 1 > Password > 123456".

Protection Level 1 is activated.

Protection
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Settings

Protection Level / Password........................................................................................148

Protection Level / Password
"Protection Level 1" can be activated to expand the functionality of the internal adjust-
ment. The password is 123456.
The other protection levels 2 to 4 provide access to protected service functions. Only
the authorized personnel of R&S service departments can access these functions.

10.6  Security

The R&S SGS employs a security concept based on user and security password. The
security password is required for changing several critical settings, like performing firm-
ware updates. Access to the passwords and mass storage security settings is provided
in the "Security" dialog.

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Security".

The dialog is divided into the password sections and the security settings section. In
the password section, the passwords for securing a controlled access to the instrument
are defined and changed.

A change of passwords for the operating system and security password requires the
entry of the old and new password and the conformation of the new password. All set-
tings are only accepted after the "Change Password" button is pressed.

Security
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The settings of this dialog are not accessible over remote control (e.g. SCPI com-
mands).

Settings

User Password............................................................................................................150
└ User Name....................................................................................................150
└ Old Password................................................................................................150
└ New Password..............................................................................................150
└ Confirm Password.........................................................................................150
└ Change Password.........................................................................................150

Security Password...................................................................................................... 150
└ Old Password................................................................................................150
└ New Password..............................................................................................150
└ Confirm Password.........................................................................................150
└ Change Password.........................................................................................151

Security Settings......................................................................................................... 151
└ USB Storage.................................................................................................151

Security
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└ LAN Interface................................................................................................151
└ Security Password........................................................................................ 151
└ Accept...........................................................................................................151

User Password
The user name and password are required for remote access to the instrument via
VNC, FTP or SAMBA.
Note: It is highly recommended to change the default user password before connect-
ing the instrument to the network.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.5, "Contacting customer support", on page 312.

User Name ← User Password
Indicates the user name used for access to the Linux operating system and valid for
VNC, FTP and SAMBA access.

Old Password ← User Password
Enter the currently used user password. The default password is "instrument".

New Password ← User Password
Enter the new user password.

Confirm Password ← User Password
Enter the new password for conformation.
The new password is only valid after the "Change Password" button is pressed.

Change Password ← User Password
Changes the password accordingly.

Security Password
The security password is, for example, required when changing the status of the USB
and LAN interface or other security settings.
Note: It is highly recommended to change the default security password before con-
necting the instrument to the network.
Note: Note that you cannot reset the password to factory state.
If you encounter problems with the password, contact the Rohde & Schwarz customer
support, see Chapter 14.5, "Contacting customer support", on page 312.

Old Password ← Security Password
Enter the currently used security password. The default password is '123456'.

New Password ← Security Password
Enter the new security password. The security password can only contain decimal
characters.

Confirm Password ← Security Password
Enter the new password for conformation.

Security
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The new password is only valid after the "Change Password" button is pressed.

Change Password ← Security Password
Changes the password accordingly.

Security Settings
Comprises the settings for enabling and disabling the USB and LAN interfaces. The
setting requires the entry of the security password and is only accepted after the
"Accept" button is pressed.

USB Storage ← Security Settings
Enables/disables the access to external USB storage media.
The instrument does not recognize any device connected to the USB interface when
the interface is disabled.
To apply the change: enter the security password and confirm with "Accept". Otherwise
the change has no effect.
Note: Remove all USB memory devices before disabling the USB storage. If any USB
memory device remains connected, disabling is blocked, and the instrument returns a
warning message.

LAN Interface ← Security Settings
Enables/disables the LAN interface.
Note: It is not possible to access the instrument via LAN while the LAN connection is
disabled.
An enabled LAN connection is a prerequisite for the remote control of the instrument
via VNC, FTP or SAMBA.
To disable the LAN interface enter the security password and confirm with "Accept".
Otherwise the change has no effect.

Security Password ← Security Settings
Enters the password that is required to enable or to disable the settings protected by a
security password. The default is '123456'.
Note: It is highly recommended to change the default security password before con-
necting the instrument to the network. To change the security password, select
"SGMA-GUI > Instrument Name > Setup > Security > Change Security Password".
The settings are only accepted after the "Accept" button is pressed.

Accept ← Security Settings
Accept a new entry or selection and change the settings accordingly.

10.7  Network settings

The instrument is equipped with a network interface and can be connected to an Ether-
net LAN (local area network). The "Network Settings" dialog provides access to the
network settings.

Network settings
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Access:

► Select "SGMA-GUI > Instrument Name > Setup > Network Settings".

The dialog provides access to the network settings, like settings about the general net-
work environment and specific identification of the computer in the network. The dialog
also displays an indication whether the instrument is connected to the network or not.

Settings

Restart Network.......................................................................................................... 152
Hostname....................................................................................................................152
MAC Address.............................................................................................................. 153
Address Mode............................................................................................................. 153
IP Address...................................................................................................................153
Subnet Mask............................................................................................................... 153
Default Gateway..........................................................................................................154
Apply........................................................................................................................... 154

Restart Network
Shuts down the network connection of the instrument and then re-establishes the con-
nection.
This function can be used to resolve network problems.
Note: Only the connection of the instrument to the network restarts, the network itself
is not affected.

Hostname
Displays the individual computer name of the instrument.

Network settings
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A predefined name is indicated and can be used for network connections, see Chap-
ter 8.4.3, "Finding out the default hostname of the instrument", on page 78.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname on page 293

MAC Address
Indicates the MAC address of the network adapter.

Address Mode
Selects if the IP address is assigned automatically or manually.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Note: Lost LAN connection to an instrument.
If the connection to an instrument configured to use static IP addresses is lost, press
the [LAN LED] on the instrument front panel.
Pressing triggers a reset of the assignment mode ("Address Mode > Auto (DHCP)".
"Auto (DHCP)" The IP address is assigned automatically.

The network used must support automatic assignment of IP address
via DHCP or APIPA (Zeroconf) to use this function.

"Static" The IP address is assigned manually.
Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress:MODE on page 293

IP Address
Displays the IP address. To enter the IP address manually, select "Address Mode >
Static".
If there is manual input of the IP address, it is recommended that a connection of the
instrument to the network is coordinated with the network administrator. Connection
errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork:IPADdress on page 292

Subnet Mask
Displays the subnet mask. To enter the subnet mask manually, select "Address Mode >
Static".
This number is used together with the IP address to identify the network segment the
instrument is in.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK on page 294

Network settings
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Default Gateway
Displays the IP address of the default gateway. To enter the default gateway manually,
select "Address Mode > Static".
This address identifies the router on the same network as the instrument that is used to
forward traffic to destinations beyond the local network.
It is recommended that a connection of the instrument to the network is coordinated
with the network administrator. Connection errors can affect the entire network.
Remote command: 
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway on page 294

Apply
Applies the network settings to the instrument.

10.8  Remote channels

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Remote".

The "Remote" dialog provides access to the settings for remote control.

Settings

Visa Resource Strings.................................................................................................154
Device Identity.............................................................................................................155

Visa Resource Strings
Indicates the VISA resource strings used for remote control of the instrument. A sepa-
rate string is provided for remote control via the different interfaces.

Remote channels
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Note: For background information and description of the syntax of the VISA resource
strings, refer to the description of the corresponding interface in Chapter 12.1, "Remote
control interfaces and protocols", on page 175.
Remote command: 
:SYSTem:COMMunicate:HISLip:RESource? on page 295
:SYSTem:COMMunicate:NETWork:RESource? on page 294
:SYSTem:COMMunicate:SOCKet:RESource? on page 296
:SYSTem:COMMunicate:USB:RESource? on page 296
:SYSTem:COMMunicate:PCIexpress:RESource? on page 296

Device Identity
Triggers the device identification function. The [LAN] LED on the front panel of the
selected instrument blinks.
See also Chapter 8.4.4, "Bidirectional instrument identification", on page 79.

10.9  Factory preset

The "Factory Preset" dialog provides a function to reset the instrument's settings to
their factory states.

Access:

1. Select "SGMA-GUI > Instrument Name > Setup > Factory Preset".

2. Select "Execute Factory Preset".

The instrument's settings are reset to their factory states. Security settings and
user data are not affected.

Settings

Execute Factory Preset...............................................................................................155

Execute Factory Preset
Reset the instrument's settings to their factory state.
Note: Because "Factory Preset" resets the "Remote Channel Settings" and "Network
Settings" to the default values, executing factory preset via remote control can termi-
nate the connection to the instrument, if these settings had been configured to values
different to the default ones.

Factory preset
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The factory preset function resets nearly all instrument settings. In addition to the regu-
lar preset, a "Factory Preset" resets also the following values:
● Power on settings ("Level" dialog)
● Network settings including hostname ("Setup > Network Setting" dialog)
● Remote Channel settings ("Setup > Remote Channel" dialog)
● Eco mode state ("Setup > Eco Mode" dialog)
To maintain security, password settings and all settings protected by these passwords
like disabled USB and LAN connections are not changed.
Not affected by the "Factory Preset" are also user data, lists or instrument settings
files, created, for example, with the "File Save As" function.
Remote command: 
:SYSTem:FPReset on page 226

10.10  Eco mode

This energy-saving mode is available only for instruments equipped with
optionR&S SGS-B112/B112V.

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Eco Mode".

With enabled "Eco Mode 1", the doubler stage in a 12.75 GHz instrument is perma-
nently switched off to reduce power consumption and the maximum frequency is
limited to 6 GHZ. An enabled "Eco Mode" is indicated by a green coloring of the
frequency range in the R&S SGMA-GUI.

The state of this parameter is not affected by an instrument "Preset". This parame-
ter is influenced only by the Factory preset.

Running internal adjustments in eco mode

See "Running internal adjustments in eco mode" on page 142.

SCPI command:

:SYSTem:EMODe on page 289

Eco mode
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10.11  Standby and restart

See Chapter 11.9, "How to switch between operating states", on page 169.

10.12  Diagnostic and tests

This section describes the settings provided for diagnostic and test purposes.

Access:

► Select "SGMA-GUI > Instrument Name > Setup > Diagnostic / Test".

The selection provides the following settings.

Settings

● Selftest.................................................................................................................. 157
● Keyboard tests...................................................................................................... 158

10.12.1  Selftest

Access:

1. Select "SGMA-GUI > Instrument Name > Diagnostic Tests > Self-test".

2. To trigger a self-test, select "Self-test".

Performs a self test on all installed hardware options.

The result of the self-test, succeeded or failed, is displayed. The list of the numeric
results of the performed test cases is protected by protection level 2.

SCPI command:

:TEST:ALL:STARt on page 302

Diagnostic and tests
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:TEST:ALL:RESult? on page 302

10.12.2  Keyboard tests

Access:

► Select "SGMA-GUI > Instrument Name > Diagnostic Tests > Keyboard Test".

Use this function to check the proper operation of all front panel elements.

If "Keyboard Test" is enabled, all front panel LEDs except the [POWER ON] are
orange.

The exact test procedure is described in the service manual.

SCPI command:

:TEST:KEYBoard[:STATe] on page 302

10.13  External adjustments

The external adjustment is a protected service procedure, that requires "Protection
Level 2" password. For a detailed test procedure, see the R&S SGS service manual.

Access:

► Select "SGMA-GUI > Instrument Name > Service > External Adjustments".

Depending on the installed options, the R&S SGS is equipped with a TCXO or OCXO
reference oscillator. The reference oscillator is factory calibrated to a specific calibra-
tion value. In the external adjustment dialog, you can select a different (custom) cali-
bration value.

External adjustments
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Settings:

Active Adjustment Data...............................................................................................159
Calibration Value......................................................................................................... 159

Active Adjustment Data
Selects whether the factory provided or a user-defined calibration value is used to
adjust the reference oscillator.
Remote command: 
:CALibration:ROSCillator:DATA:MODE on page 229

Calibration Value
Sets a user-definable calibration value.
The permanent storage of this value in the instrument's memory is a password-protec-
ted function. The parameter is restored to its permanently stored value by "Preset" and
instrument restart.
Remote command: 
:CALibration:ROSCillator[:DATA] on page 229

External adjustments
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11  Performing configuration tasks
This section provides a general explanation on how to operate the instrument manually
via the R&S SGMA-GUI software.

We assume, that the R&S SGS is connected to a remote PC. The R&S SGMA-GUI
software is installed on this remote PC and the instrument has to be added to the list of
"Available Instruments".

For information on how to fulfill these requirements, refer to:
● Chapter 3.13.2.1, "Connecting to the network", on page 30
● Chapter 3.13.1, "Installing the R&S SGMA-GUI software", on page 28
● Chapter 3.13.2.3, "Adding instruments to R&S SGMA-GUI", on page 32

General workflow

The general workflow for generating a signal with the R&S SGS comprises the follow-
ing main steps:

1. Decide whether you want to generate a CW or an I/Q modulated signal.
See Chapter 11.1, "How to generate an I/Q modulated signal", on page 160.

2. Select the operating mode.
See Chapter 11.3, "How to enable a baseband bypass mode", on page 165.

3. Configure the reference and local oscillator settings.
See Chapter 11.4, "How to configure the reference oscillator source", on page 165
and Chapter 11.5, "How to configure the local oscillator coupling source",
on page 166.

4. Adjust the frequency, level and I/Q settings, for example, to optimize performance
or to add impairments to the generated signal (see Chapter 11.11, "How to optimize
performance", on page 171).

11.1  How to generate an I/Q modulated signal

The instrument is manually operated via the R&S SGMA-GUI software.

The I/Q modulator requires the hardware option R&S SGS-B106V and for operation up
to 12.75 GHz also the hardware option R&S SGS-B112V.

An example of how to configure the instrument to generate a continuous wave (CW)
signal is provided in Chapter 5, "Trying out the Instrument", on page 39.

How to generate an I/Q modulated signal
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To generate an I/Q modulated signal

1. Connect the test equipment. Provide the external analog modulation signal at the I
and Q connectors of the instrument.
The Figure 11-1 shows an example of the test setup. A signal generator, e.g., the
R&S AFQ100B, is the source of the external analog signal. The signal generator
provides its internal reference signal to the R&S SGS and the connected signal
analyzer, e.g. the R&S FSW.

Figure 11-1: Example of the setup

Tip: Refer to the user manual of the R&S signal generator and the R&S signal ana-
lyzer for information on how to configure the corresponding instrument.

2. To adjust the settings, select "SGMA-GUI main panel > Instrument Name > Refer-
ence Oscillator > Ext".

3. Select "SGMA-GUI main panel > Instrument Name > Frequency/Phase > LO Cou-
pling Source > Int".

Tip:
For detailed description on how to select the reference frequency source and the
LO coupling source, refer to:
● Chapter 11.4, "How to configure the reference oscillator source", on page 165

and
● Chapter 11.5, "How to configure the local oscillator coupling source",

on page 166.

4. In the "Frequency/Phase" dialog, configure the frequency settings.

5. To set the "RF Level", select the "SGMA-GUI > Instrument Name > Level > RF
Level > Level".
In the same dialog, configure the further "Level" and "Power-On" settings.

6. Optionally, impair the I/Q samples in the I/Q modulator:

How to generate an I/Q modulated signal
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a) Select the "SGMA-GUI main panel > Instrument Name > I/Q settings > Analog
Impairments"

b) Enable I/Q impairments.
c) Enable the I/Q modulator: In the "I/Q settings > General" dialog, set "State >

On".

7. To activate the RF output, you have two options:

● Select "SGMA-GUI main panel > RF > On"
● On the front panel of the instrument, press the [RF ON] key.

The [RF ON] key is green.

The I/Q modulated signal is output at the RF connector of the instrument.

To generate an I/Q modulated signal with higher RF

If the R&S SGS is equipped with one of the options R&S SGS-B112/B112V, you can
connect an R&S SGU as an extension. This extension also extends the frequency
range of the generated I/Q signal to up to 40 GHz.

See Chapter 11.2, "How to generate I/Q signals", on page 162.

11.2  How to generate I/Q signals

Options R&S SGS-B112V and R&S SGU-B120V/-B140V are required for the I/Q mod-
ulation.

To generate an I/Q modulated signal with higher frequency

In this example, the R&S SGU acts as an extension to the R&S SGS extending its fre-
quency range to 40 GHz.

The Figure 11-2 shows an example of the test setup.

How to generate I/Q signals
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Figure 11-2: Example of the test setup

For higher setting/ measuring speeds, use a PCIe switch and PCIe connections.

If a common reference frequency is required, use the internal reference signal of the
signal generator and provide it to the R&S SGS and the connected signal analyzer,
e.g. the R&S FSW.

1. Connect the test equipment as shown on Figure 11-2:

a) Connect the R&S SGS, the R&S SGU and the controller to a LAN switch.
b) Connect the "I/Q OUT" of the base band signal source to the " I/Q IN" of the

R&S SGU.
c) Connect the "I/Q OUT" of the R&S SGS to the I and Q connectors of the R&S

SGS.
d) Connect the "RF 50Ω" of the R&S SGS to the "LO IN" of the R&S SGU.
e) Connect the "TRIG" connectors of the R&S SGS and the R&S SGU.
f) Connect the "RF 50Ω" of the R&S SGU to the RF input connector of the signal

analyzer.

2. Select "SGMA-GUI main panel > R&S SGS > Extension".

Tip: Steps 3 to 5 can be omitted if the R&S SGS and a single R&S SGU are con-
nected using PCIe or USB or by a direct LAN connection. In this case, the R&S
SGS automatically activates the R&S SGU.

3. Press the ID key on the front panel of the R&S SGU (only required if you connect
the components via a company network).

4. In the "Extension" dialog, trigger "Scan".

How to generate I/Q signals
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The scan function finds out the connected R&S SGU.

5. To enable the R&S SGU as an extension, proceed as follows:

a) Select the R&S SGU from the list
b) Set "Available Instruments > Select > On".

A green status indicator "Connected" indicates the successfully established remote
connection to the extension.

6. Select "Test Signal Connections > Test" to trigger a check of all required signal
connections.

The diagram displays the connection state of the tested connections.

7. Configure RF output signal settings:

a) Select "SGMA-GUI > R&S SGS > Freq = 20 GHz".
b) Select "Lev = -30 dBm".
c) Activate the RF output: Select "RF > State > On".

The extension adopts these values and states automatically. Generated is an I/Q
signal with "RF = 20 GHz" and "Level = -30 dBm".

How to generate I/Q signals
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11.3  How to enable a baseband bypass mode

1. Provide an external analog signal at the I or Q connector or on both at the rear of
the instrument.
Refer to Figure 7-9 for visualization of the signal flow.

2. Select "SGMA-GUI > Instrument Name > Operation Mode > Baseband Bypass".

Some instrument's functions like "Frequency" and I/Q settings are disabled.

3. To adjust the level of the output signal, select "SGMA-GUI > Instrument Name >
Level > RF Level".

4. Set "SGMA-GUI > RF > On" or press the [RF ON] key on the front panel of the
instrument to enable the output of the generated signal at the RF connector.

The [RF ON] key is green.

The fed signal is amplified with the selected value and output at the RF connector
of the instrument.

11.4  How to configure the reference oscillator source

To use the internal reference frequency source

1. To enable the instrument to use its internal reference frequency source, perform
one of the following:

a) Select "SGMA-GUI main panel > Ext Ref Off ".
b) Select "SGMA-GUI > Instrument Name > Reference Oscillator > Source > Int".

2. In the "Reference Oscillator" dialog, set the "REF/LO Out > REF".

The "Output Frequency" can be configured to either 10 MHz or 1 GHz.

The instrument uses the internal reference signal. The [REF EXT] LED at the front
panel of the instrument is off.

To output the reference frequency (internal or external) at the REF/LO OUT connector
of the instrument, select "Reference Oscillator > REF/LO Output > REF".

To use an external reference frequency source

To improve measurement accuracy, provide one external reference frequency signal to
all the instruments in the test setup. Alternatively, distribute the internal reference sig-
nal of the R&S SGS to the remaining instruments.

1. Provide the signal of an external reference frequency source to the REF/LO IN
connector of the instrument.

How to configure the reference oscillator source
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2. To enable the instrument to use the external reference frequency source, perform
one of the following:

a) Select "SGMA-GUI main panel > REF > Ext Ref On ".
b) Select "SGMA-GUI > Instrument Name > Reference Oscillator > Source > Ext".

3. In the "Reference Oscillator" dialog, set the parameter "Ext. Ref. Input Frequency"
to the value of the fed external reference frequency.

Now, the instrument uses an external reference signal. The green [REF EXT] LED
at the front panel of the instrument indicates that the instrument is synchronized to
the external reference signal.

If the instrument is configured to use an external reference signal but no signal is fed in
at the "REF IN" connector, the [REF EXT] LED on the front panel of the instrument is
red and an error message is displayed in the "Info" line.

11.5  How to configure the local oscillator coupling source

For local oscillator (LO) coupling, the R&S SGS can use two frequency sources: An
internal and an external frequency source. The first possibility is to use the output sig-
nal of the internal synthesizer. If an external LO signal is provided at the "REF/LO IN"
connector, this signal can alternatively be directly routed to the LO input of the I/Q
modulator.

To use an external LO source

1. Provide the signal of an external LO source to the "REF IN" connector of the instru-
ment.

Note: The local oscillator input/output requires the additional software option
R&S SGS-K90.

2. Select "SGMA-GUI > Instrument Name > Frequency/Phase > LO Coupling Source
> Ext".

Tip: When you select "Source > Ext", the icon LO Scr Ext appears in the
R&S SGMA-GUI.

The signal provided by the external frequency source is directly routed to the input
of the I/Q modulator and used as carrier frequency.

To use the internal LO source

► Select "SGMA-GUI > Instrument Name > Frequency/Phase > LO Coupling Source
> Int".

The output signal of the internal synthesizer is used.

How to configure the local oscillator coupling source
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11.6  How to define the signal at the REF/LO OUT connec-
tor

The reference oscillator and the LO use the same "REF IN" connector. Hence, it is not
possible to use both an external reference source and an external LO source signal at
the same time.

The signal at the "REF OUT" connector also depends on the selected reference oscil-
lator and LO sources. The following table gives an overview of this dependency.
Table 11-1: Selection available at the REF/LO OUT connector depending on the LO and reference

oscillator sources

 LO coupling source  

Ref. oscillator source Int "Ext"

"Int" "OFF/REF/LO" "OFF/LO"

"Ext" "OFF/REF/LO" Combination not possible

To define the signal at the REF/LO OUT connector

1. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select the "LO
Source" as required.

2. In the "Reference Oscillator" dialog, select the "Ref. Oscillator Source" as required.

3. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, set the
"REF/LO Output".
For dependencies, see Table 11-1.

11.7  How to prepare instruments for optimum phase
coherence

Using the LO input/output connectors, two or more instruments can be coupled to ach-
ieve optimum phase coherence between their RF output signals. The first instrument in
the chain delivers the LO signal at the "REF OUT" connector to the "REF IN" connector
of second instrument. If necessary, more instruments can be connected in the same
way. The first instrument is set such that the internal synthesizer generates the system
LO frequency.

In all following instruments, the internal synthesizer is switched off and the LO signal
from the "REF IN" connector drives the I/Q modulator or the CW path.

To connect the instruments

1. Connect the instruments as a daisy chain (see Figure 11-3), i.e. connect the "REF
IN" connector of each further instrument to the "REF OUT" connector of the previ-
ous one.

2. Optionally, provide an external reference signal for the first instrument.

How to prepare instruments for optimum phase coherence
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3. Avoid unnecessary cable lengths and branching points.

Refer to Figure 11-3 for an example of how to connect two instruments for achieving
phase coherence. The configuration can be extended by further instruments.

Figure 11-3: Example of a setup: LO coupling

To configure the first instrument in the chain

1. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "LO
Source > Internal".

2. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "REF/LO
Output > LO".

3. If you use an external reference frequency, select "SGMA-GUI > Instrument Name
> Reference Oscillator > Source > External".

To configure next instruments

1. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "LO
Source > External".

2. In the "Frequency / Phase > Local Oscillator (LO) Coupling" dialog, select "REF/LO
Output > LO".

11.8  How to restore the LAN connection

If you lose the LAN connection of the instrument, for example, after assigning a static
IP address, proceed as follows:

► On the front panel of the instrument, press the [LAN] LED for more than 3 seconds.

Pressing trigger a reset of the LAN settings. In particular, the "Address Mode"
on page 153 switches to "DHCP".

If your network supports automatic assignment of IP address, the new IP address
is assigned to the instrument automatically.

How to restore the LAN connection
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11.9  How to switch between operating states

The Figure 11-4 gives an overview of the operating states of the instruments and how
to trigger the switch-over between them.

Figure 11-4: Operating states

:RESTart, :STANdby = SCPI commands
"Setup" > "Standby", "Setup" > "Restart", "Shut Down Instru-
ments and Exit"

= R&S SGMA-GUI controls

[POWER ON/STANDBY], power switch [ I/0] = Hardkey controls on the front/rear panel of
the instrument

The Table 11-2 provides a short description of the operating states and their indication.
Table 11-2: Indication of the operating states

Operating
state

Description Indication

Off The instrument is shut down. All LEDs on the front panel of the instrument
are off.

Booting The instrument boots the operating system
and starts the instrument firmware.

If the previous session was terminated reg-
ularly, the instrument uses the last setup
with the relevant instrument settings.

The green [POWER ON/STANDBY] key blinks.

How to switch between operating states
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Operating
state

Description Indication

Standby The standby power mode keeps the power
switch circuits and the remote control sys-
tem active.

In this state, it is safe to switch off the AC
power and disconnect the instrument from
the power supply.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is red.

The orange [POWER ON/STANDBY] key is
on.

Ready

(normal
operation)

The instrument is ready for operation. All
modules are power-supplied.

In the R&S SGMA-GUI, the status indicator in
front of the instrument name is green.

The green [POWER ON/STANDBY] key is on.

To switch the instrument to standby state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Standby".
b) Press the [POWER ON/STANDBY] key on the front panel of the instrument.
c) Send the SCPI command:

:SYSTem:REBoot
The current instruments settings are automatically saved. The instrument switches
to a power-saving mode.
In the R&S SGMA-GUI, the standby state is indicated by the red state symbol in
front of the corresponding instrument's name, on the front panel, by the orange
[POWER ON/STANDBY] button.
You can still remotely control the instrument.

To return the instrument from standby to ready state

► Use one of the following:

a) On the remote PC, select "SGMA-GUI > Instrument Name > Setup > Restart".
b) Press the orange [POWER ON/STANDBY] key on the front panel of the instru-

ment.
c) Send the SCPI command:

:SYSTem:RESTart
The instrument loads the last setup with all instrument settings, switches to ready
state and is ready for normal operation.
In the R&S SGMA-GUI, the ready state is indicated by the green state symbol in
front of the instrument's name.
On the front panel, the ready state is indicated by the green [POWER ON/
STANDBY] button.

To switch all connected instruments to standby state and close the R&S SGMA-
GUI

► In the R&S SGMA-GUI main panel, select "File > Shut down instruments and exit".

The R&S SGMA-GUI quits and switches the connected instruments to standby
state.

How to switch between operating states
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For description on how to terminate work and shut down the instrument regularly, see
Chapter 3.10, "Switching on or off", on page 25.

11.10  How to use computer names

If there is a name server in the network, alternatively to the IP address each PC or
instrument connected in a LAN can be accessed via an unambiguous computer name.
Each instrument is delivered with an assigned computer name, but this name can be
changed.

For instruction on how to find out the default computer name, refer to Chapter 8.4.3,
"Finding out the default hostname of the instrument", on page 78.

To query and change a computer name

To avoid violations and to use easy identification provided by the computer name, we
recommend that you to keep the default hostname unchanged.

1. Open "SGMA-GUI > Instrument Name > Setup > Network Settings" dialog.

The computer name is displayed under "Hostname".

2. Select "SGMA-GUI > Instrument Name > Setup > Protection"

3. Enable the "Protection Level 1".

The parameter "Hostname" in the "Network Settings" dialog is now enabled for
configuration.

4. Change the "Hostname".

5. Press the [POWER ON/STANDBY] key to restart the instrument.

Note: The "Factory Preset" function restores the factory value of the parameter
"Hostname".

11.11  How to optimize performance

In its (factory) preset state, the instrument uses predefined frequency and level setting
designed for best performance. The predefined settings, e.g. the" Level modes" "Auto"
and "Normal", ensure that the instrument automatically selects the optimal settings
according to the configured RF frequency and level.

However, in some special application cases it can be necessary to choose different
settings or to optimize the signal for the particular application. This section describes
instructions on how to achieve that.

How to optimize performance
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Restoring the default settings
Use the "R&S SGMA-GUI main panel > Instrument name > Preset" or the "R&S
SGMA-GUI main panel > Instrument name > Setup > Factory Preset" function to return
the instrument to its predefined state.

For information on how to adjust the quality characteristics of the RF output signal, i.e.
to optimize the quality characteristics of RF output signal, refer to Chapter 9.5, "Level
and power-on settings", on page 98.

For information on how to adjust the reference oscillator, e.g. to allow the frequency of
the internal reference oscillator to be impaired, refer to Chapter 9.4, "Reference oscilla-
tor", on page 95.

11.12  How to install a new firmware version on the instru-
ment

You can update the firmware of the R&S SGS.

Firmware installation via R&S SGMA-GUI

Install or update the firmware of the R&S SGS before installing or updating the soft-
ware R&S SGMA-GUI.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintenance > Oper-
ation > Install firmware package".

2. Press "Select Package" and navigate to the directory of the new firmware.

3. If several instruments require a firmware update, enable "Update All" to accelerate
the update procedure.

All instruments that are in active state and are connected to this controller are
updated simultaneously.

4. Enter the "Security Password".

5. Confirm the update with "Accept".

The software transfers the firmware file and automatically starts the update proce-
dure. During the update, the message "Updating Firmware" is displayed in the
"Info" line. The update process is indicated by an LED running light.

Note: The update procedure requires a restart of the instrument. The restart is per-
formed automatically. The instrument is not accessible during that time.

6. Wait until the message "Updating Firmware" disappears. After the message disap-
pears, the update is complete.

The [POWER ON/STANDBY] LED is green.

How to install a new firmware version on the instrument
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Tip: Calibration error. If the "Info" line shows the message "Calibration Error",
select "SGMA-GUI main panel > Instrument Name > Setup > Internal Adjustments
> Adjust All" to trigger internal adjustment.

7. If necessary, install the new R&S SGMA-GUI.
For detailed description, refer to Chapter 3.13.1, "Installing the R&S SGMA-GUI
software", on page 28

8. If you connect the instrument and the controller/PC over the PCIe interface and the
external PC does not support hot-plugging, restart the external PC.

Firmware update through a session control protocol (SCP)

Install or update the firmware of the R&S SGS before installing or updating the soft-
ware R&S SGMA-GUI.

1. Connect the R&S SGS and a Windows PC to the same network.

2. On the PC, open a windows explorer window.

3. To connect to the R&S SGS, enter the name of the instrument or its IP address in
the windows taskbar.

4. Enter the user name and password to connect to the R&S SGS. The default user
name is instrument and the password is instrument.

A folder opens, containing the share and the update folder.

5. Open the update folder.

6. Copy the new firmware update file into the folder.

The update starts automatically.

Unsuccessful or erroneous firmware update
An erroneous or unsuccessful installation of firmware update package is indicated by a
combination of one orange and red LEDs on the front panel.
Refer to the service manual for a description of the displayed error code or contact the
customer support center, see Chapter 14.5, "Contacting customer support",
on page 312.

How to install a new firmware version on the instrument
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11.13  How to activate options

A firmware update before the activation of the SW option can be required.
Refer to the description of the SW option for the required firmware version.
See also Chapter 11.12, "How to install a new firmware version on the instrument",
on page 172 for instruction on how to update the firmware version.

1. Select "SGMA-GUI main panel > Instrument Name > Setup > Install SW-Options".

2. Select "Option Key".

3. Enter the key code delivered with the new option.

The new option is now enabled and ready for operation.

11.14  How to set a PCIe direct connection

To build a direct PCIe connection between an R&S SGU and an R&S SGS, which has
a "Controller > Revision" < 5, first you have to set the correct PCIe interface mode
manually. If your R&S SGS has a "Controller > Revision" 5 or higher, these settings are
done automatically.

You can check the "Controller > Revision" of your instrument in the "SGMA-GUI >
Instrument Name > Hardware Config" dialog.

To set a PCIe direct connection between an R&S SGS and an R&S SGU manually

1. Connect the R&S SGS and the R&S SGU directly using a PCIe cable. Refer to
Chapter 12.3.4, "Connecting the controller and the instrument", on page 190 for
cable requirements and setup information.

2. Switch on the R&S SGS and the R&S SGU.

3. Select "SGMA-GUI main panel > Instrument Name > Setup > Maintainance".

4. Select "Operation > PCIe Interface Mode".

5. Select "PCIe Interface Mode > Root Complex".

6. Restart your instrument for the changes to take place.

The PCIe connection between the R&S SGS and the R&S SGU is established and
the instruments can be used.

How to set a PCIe direct connection
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12  Network operation and remote control
As an alternative to operating the R&S SGS interactively via the R&S SGMA-GUI, you
can operate the R&S SGS also from a remote location.

Information on network operation and remote control
The following descriptions provide information required for operating the R&S SGS
remotely. The information applies to all applications and operating modes supported by
the instrument. Definitions specified in the SCPI standard are not provided.
For basic knowledge on remote control operation and additional information, see the
following documents, available on the Rohde & Schwarz website:
● Remote control via SCPI
● 1GP72: Connectivity of Rohde&Schwarz Signal Generators
● 1MA208: Fast Remote Instrument Control with HiSLIP

● Remote control interfaces and protocols...............................................................175
● Starting a remote control session..........................................................................184
● Advanced remote control using PCIe....................................................................186
● Advanced remote control using fast socket.......................................................... 191
● Status reporting system........................................................................................ 193
● LXI configuration................................................................................................... 201
● Monitoring remote control operation with R&S SGMA-GUI.................................. 209

12.1  Remote control interfaces and protocols

The instrument supports several interfaces for remote control. The following table gives
an overview.
Table 12-1: Remote control interfaces and protocols

Interface Protocols, VISA*) address string and Library Remarks

Local Area
Network
(LAN)

● HiSLIP High-Speed LAN Instrument Protocol
(IVI-6.1)
TCPIP::host address::hislip0[::
INSTR]

● VXI-11
TCPIP::host address::inst0[::INSTR]
Library: VISA

● socket communication (Raw Ethernet, simple
Telnet)
TCPIP::host address[::
LAN device name]::<port>::SOCKET
Library: VISA or socket controller

A LAN connector is located on the
rear panel of the instrument.

The interface is based on TCP/IP and
supports various protocols.

For details, see Chapter 12.1.2, "LAN
interface", on page 179

USB USBTMC
USB::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: VISA

A USB connector is located on the
rear panel of the instrument.

For details, see Chapter 12.1.3, "USB
interface", on page 182

Remote control interfaces and protocols
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Interface Protocols, VISA*) address string and Library Remarks

PCIe Proprietary
PCIe::<vendor ID>::<product ID>::
<serial number>[::INSTR]
Library: PCIe controller

A PCIe connector is located on the
rear panel of the instrument.

For details, see Chapter 12.1.4, "PCI
Express interface", on page 182

GPIB (IEC/
IEEE Bus
Interface)

–
● GPIB::<address>[::INSTR] (no secondary

address)
VISA

The instrument is not equipped with
GPIB bus interfaces. Use a GPIB-to-
LAN or GPIB-to-USB adapter instead.

For details, see Chapter 12.1.5,
"GPIB interface (IEC/IEEE bus inter-
face)", on page 183

*) VISA is a standardized software interface library that provides input and output func-
tions to communicate with instruments. A VISA installation on the controller is a prereq-
uisite for remote control over LAN (when using VXI-11 or HiSLIP protocol) or USB.
However, no VISA installation is necessary for remote control while using socket com-
munication. For more information about VISA, refer to the user documentation.

Rohde & Schwarz provides the standardized I/O software library R&S VISA for com-
munication via TCP/IP (LAN: HiSLIP, VXI-11 and raw socket) or USB (USBTMC) inter-
faces.
R&S VISA is available for download at the Rohde & Schwarz website http://
www.rohde-schwarz.com/rsvisa.

SCPI (Standard Commands for Programmable Instruments)

SCPI commands are used for remote control. Commands that are not taken from the
SCPI standard follow the SCPI syntax rules. The instrument supports the SCPI version
1999. The SCPI standard is based on standard IEEE 488.2 and aims at the standardi-
zation of device-specific commands, error handling and the status registers. The tuto-
rial "Automatic Measurement Control - A tutorial on SCPI and IEEE 488.2" from John
M. Pieper (R&S order number 0002.3536.00) offers detailed information on concepts
and definitions of SCPI.

12.1.1  Remote control programs and libraries

The Figure 12-1 provides a schematic illustration of the remote control capabilities of
the instrument.

Remote control interfaces and protocols
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Figure 12-1: Remote control interfaces, protocols and libraries

The following examples give an overview of the dependencies between the available
libraries, the possible interfaces and protocols, and whether an instrument driver is pro-
vided. The involved parts are highlighted.
● Remote control program using VISA

Figure 12-2: Remote control program using VISA

Protocol Remote control program

Socket viOpen (..., "TCPIP:rssgs100a100010::5025::SOCKET", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

VXI-11 viOpen (..., "TCPIP:rssgs100a100010::inst0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

HiSLIP viOpen (..., "TCPIP:rssgs100a100010::hislip0::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

USBTMC viOpen (..., "USB::0x0aad::0x0088::1000010::INSTR", ...)
viPrintf (..., "SOUR:FREQ 2GHz\n")

● Remote control program using instrument driver (VISA available)

Remote control interfaces and protocols
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Figure 12-3: Remote control program using instrument driver (VISA available)

Protocol Remote control program

Socket rssgs_init ("TCPIP:rssgs100a100010::5025::SOCKET", ...)
rssgs_SetFrequency (..., 2e9)

VXI-11 rssgs_init ("TCPIP:rssgs100a100010::inst0::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

HiSLIP rssgs_init ("TCPIP:rssgs100a100010::hislip0::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

USBTMC rssgs_init ("USB::0x0aad::0x0088::1000010::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

PCIe rssgs_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

● Remote control program using instrument driver (VISA not available)

Figure 12-4: Remote control program using instrument driver (VISA not available)

Remote control interfaces and protocols
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Protocol Remote control program

Socket rssgs_init ("TCPIP:rssgs100a100010::5025::SOCKET", ...)
rssgs_SetFrequency (..., 2e9)

PCIe rssgs_init ("PCIe::0x162f::0x132e::1000010::INSTR", ...)
rssgs_SetFrequency (..., 2e9)

12.1.2  LAN interface

To be integrated in a LAN, the instrument is equipped with a LAN interface, consisting
of a connector, a network interface card and protocols.

For remote control via a network, the PC and the instrument must be connected via the
LAN interface to a common network with TCP/IP network protocol. They are connected
using an RJ45 cable (shielded or unshielded twisted-pair category 5). The TCP/IP net-
work protocol and the associated network services are preconfigured on the instru-
ment. Software for instrument control and (for specified protocols only) the VISA pro-
gram library must be installed on the controller.

Identifying instruments in a network
If several instruments are connected to the network, each instrument has its own IP
address and associated resource string. The controller identifies these instruments by
the resource string.

12.1.2.1  VISA resource strings

The VISA resource string is required to establish a communication session between
the controller and the instrument in a LAN. The resource string is a unique identifier,
composed of the specific IP address of the instrument and some network and VISA-
specific keywords.

TCPIP::host address[::LAN device name][::INSTR]
● TCPIP designates the network protocol used
● Host address is the IP address or host name of the device

See also Chapter 8.4.3, "Finding out the default hostname of the instrument",
on page 78.

● [::LAN device name] defines the protocol and the instance number of a subinstru-
ment:

● [::INSTR] indicates the instrument resource class (optional)

The IP address (host address/computer name) is used by the programs to identify and
control the instrument. It is automatically assigned by the DHCP server the first time
that the device is registered on the network. Alternatively, you can also assign its LAN
device name.

You can find the IP address in the "SGMA-GUI > Instrument Name > Setup > Remote"
dialog, and also adjust it manually, if necessary.

Remote control interfaces and protocols
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See below the characteristics of the VISA resource strings for the corresponding inter-
face protocols. The highlighted characters are crucial.

HiSLIP

TCPIP::host address::hislip0[::INSTR]
● hislip0 HiSLIP device name, designates that the interface protocol HiSLIP is used

(mandatory).

hislip0 is composed of [::HiSLIP device name[,HiSLIP port]] and must be assigned.

For details of the HiSLIP protocol, refer to Chapter 12.1.2.2, "HiSLIP protocol",
on page 180.

VXI-11

TCPIP::host address[::inst0][::INSTR]
● [::inst0] LAN device name, indicates that the VXI-11 protocol is used (optional).

inst0 currently selects the VXI-11 protocol by default and can be omitted.

For details of the VXI-11 protocol, refer to Chapter 12.1.2.3, "VXI-11 protocol",
on page 181.

Socket communication

TCPIP::host address::port::SOCKET
● Port determines the used port number
● SOCKET indicates the raw network socket resource class

Socket communication requires the specification of the port (commonly referred to as
port number) and of "SOCKET" to complete the VISA resource string with the associ-
ated protocol used.

The registered port for socket communication is port 5025.

See also Chapter 12.1.2.4, "Socket communication", on page 181.

Example: 
● Instrument has the IP address 10.113.11.91; the valid resource string using VXI-11

protocol is:
TCPIP::10.113.11.91::INSTR

● The DNS host name is rssgs100a100021; the valid resource string is:
TCPIP::rssgs100a100021::hislip0 (HiSLIP)
TCPIP::rssgs100a100021::inst0 (VXI-11)

● A raw socket connection can be established using:
TCPIP::10.113.11.91::5025::SOCKET

12.1.2.2  HiSLIP protocol

The High Speed LAN Instrument Protocol (HiSLIP) is the successor protocol for VXI-11
for TCP-based instruments specified by the IVI foundation. The protocol uses two TCP

Remote control interfaces and protocols
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sockets for a single connection - one for fast data transfer, the other for non-sequential
control commands (e.g. Device Clear or SRQ).

HiSLIP has the following characteristics:

● High performance as with raw socket network connections
● Compatible IEEE 488.2 support for Message Exchange Protocol, Device Clear,

Serial Poll, Remote/Local, Trigger, and Service Request
● Uses a single IANA registered port (4880), which simplifies the configuration of fire-

walls
● Supports simultaneous access of multiple users by providing versatile locking

mechanisms
● Usable for IPv6 or IPv4 networks

Using VXI-11, each operation is blocked until a VXI-11 instrument handshake returns.
However, using HiSLIP, data is sent to the instrument using the "fire and forget"
method with immediate return. Thus, a successful return of a VISA operation such as
viWrite() guarantees only that the command is delivered to the instrument's TCP/IP
buffers. There is no confirmation, that the instrument has started or finished the
requested command.

For more information see also the application note:

1MA208: Fast Remote Instrument Control with HiSLIP

12.1.2.3  VXI-11 protocol

The VXI-11 standard is based on the ONC RPC (Open Network Computing Remote
Procedure Call) protocol which in turn relies on TCP/IP as the network/transport layer.
The TCP/IP network protocol and the associated network services are preconfigured.
TCP/IP ensures connection-oriented communication, where the order of the
exchanged messages is adhered to and interrupted links are identified. With this proto-
col, messages cannot be lost.

12.1.2.4  Socket communication

An alternative way for remote control of the software is to establish a simple network
communication using sockets. The socket communication, also referred to as “Raw
Ethernet communication”, does not require a VISA installation on the remote controller
side.

The simplest way to establish socket communication is to use the built-in telnet pro-
gram. The telnet program is part of every operating system and supports communica-
tion with the software on a command-by-command basis.

Socket connections are established on a specially defined port. The socket address is
a combination of the IP address or the host name of the instrument and the number of
the port configured for remote-control. All instruments use port number 5025 for this

Remote control interfaces and protocols
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purpose. The port is configured for communication on a command-to-command basis
and for remote control from a program running on a connected PC.

12.1.3  USB interface

For remote control via USB connection, the PC and the instrument must be connected
via the USB interface. A USB connection requires the VISA library to be installed. VISA
detects and configures the R&S instrument automatically when the USB connection is
established. You do not have to install a separate driver.

USB resource string

The syntax of the used USB resource string is:
USB::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● USB denotes the used interface
● <vendor ID> is the manufacturer ID for Rohde&Schwarz
● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the USB resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
USB::0x0AAD::0x0088::100021::INSTR
0x0AAD is the vendor ID for Rohde & Schwarz.
0x0088 is the product ID for the R&S SGS.
100021 is the serial number of the particular instrument.

12.1.4  PCI Express interface

A PCI Express (PCIe) connector is provided on the rear panel of the instrument.

Refer to Chapter 12.3, "Advanced remote control using PCIe", on page 186 for a
description of how to set up a remote control connection via PCIe and the permitted
cables.

Via PCI Express some commands can be sent to the instrument with optimized speed
(memory-mapped remote control), e.g. frequency or level settings. Speed optimization
allows minimum setup time.

PCIe resource string

The syntax of the used PCIe resource string is:
PCIe::<vendor ID>::<product ID>::<serial number>[::INSTR], where:
● PCIe denotes the used interface
● <vendor ID> is the manufacturer ID for Rohde & Schwarz

Remote control interfaces and protocols
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● <product ID> is the product identification of the R&S instrument
● <serial number> is the individual serial number on the rear of the instrument
● [::INSTR] indicates the instrument resource class (optional)

You can retrieve the PCIe resource string from the "SGMA-GUI > Instrument Name >
Setup > Remote" dialog.

Example: 
PCIe::0x162f::0x132e::100021::INSTR
0x162f is the vendor ID for Rohde & Schwarz.
0x132e is the product ID for the R&S SGS.
100021 is the serial number of the particular instrument.

12.1.5  GPIB interface (IEC/IEEE bus interface)

The R&S SGS is not equipped with an IEC/IEEE bus interface.

To be able to control the instrument via the GPIB bus:

1. Connect a GPIB-to-LAN or a GPIB-to-USB adapter to the instrument.

2. Use a GPIB bus cable to connect the instrument and the controller.

3. Provide the GPIB bus card, the card drivers and the program libraries for the pro-
gramming language in the controller.

4. In the "SGMA-GUI > Setup > Instruments > instrument name > Remote Control",
set the "GPIB Address".
See "GPIB Address" on page 66.

5. If the controller has several GPIB bus cards, define the used "Board Number".

GPIB address

The controller must address the instrument with the GPIB bus channel. GPIB provides
channel addresses from 0 to 30.

The GPIB resource string is GPIB::<address>[::INSTR], where:
● GPIB denotes the used interface.
● <address> indicates the used channel.
● [::INSTR] indicates the instrument resource class (optional).

Note: If the VISA implementation supports the GPIB interface, you can optionally
define the VISA instrument control resource (INSTR). It is used to define the basic
operations and attributes for a device, such as reading, writing, or triggering.

Any connected IEC bus cable must be terminated by an instrument or controller.

Remote control interfaces and protocols
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12.2  Starting a remote control session

To start a remote control session, connect the instrument and the controller with a suit-
able cable and switch on both of them.

A remote control program must open a connection to the instrument, before it can send
commands to and receive device responses from the instrument.

Instrument address
To operate the instrument via remote control, it must be addressed using the defined
interface address.
See Chapter 12.1.2, "LAN interface", on page 179, Chapter 12.1.3, "USB interface",
on page 182 or Chapter 12.1.4, "PCI Express interface", on page 182 for details.

The VISA resource strings are indicated in the "SGMA-GUI main panel > Instrument
name > Setup > Remote Channels" dialog.

12.2.1  How to find the VISA resource string

To find the VISA resource strings of your instrument:

► Select "SGMA-GUI main panel > Instrument name > Setup > Remote Channels".

The "Remote Channel Settings" dialog shows all specified resource strings of the
supported remote control interfaces.

12.2.2  Remote control over LAN using socket communication

This section provides an example of how to establish a remote control connection over
telnet protocol and a simple sockets-based program example that can be further devel-
oped (see also Chapter A, "Telnet program examples", on page 315).

Starting a remote control session
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Basic knowledge of programming and operation of the controller are assumed. A
description of the interface commands can be obtained from the relevant manuals.

Refer to the getting started manual for an example of how to set up remote control con-
nection over LAN using VXI-11 protocol.

To set up a Telnet connection

To control the software, only a telnet program is required. The telnet program is part of
every operating system.

1. To establish a Telnet connection with the R&S SGS, start the telnet program.

2. Enter the socket address.
The socket address is a combination of the IP address or the host name of the
R&S SGS and the number of the port configured for remote-control via telnet.
Tip: The R&S SGS uses the port number 5025 for remote connection via Telnet.

The connection to the instrument is set up and remote-control commands can be
sent.

3. Even if the cursor is not visible on the screen, enter blind a remote-control com-
mand.

4. Confirm with "Enter".

Starting a remote control session
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12.3  Advanced remote control using PCIe

The PCIe bus is a high-speed serial bus, composed of point-to-point serial links. A pair
of serial links, one transmitting and one receiving link, make up a lane.

Fast settings

The PCIe interface can be utilized not only to transfer text messages, e.g., SCPI com-
mands but also to carry register based remote control messages. The latter mode is
called fast settings mode. The specially for this purpose provided instrument's driver is
mandatory for the instrument control with fast settings. This instrument driver contains
special functions for fast setup.

To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● Using the PCIe interface is mandatory (see also Chapter 12.3.1, "Setting up a

remote control connection via PCIe", on page 186)
● The fast settings must be enabled with the function rssgs_useFastSettings

(see also Chapter 12.3.5, "Enabling fast settings", on page 190).

The instrument driver automatically uses the fast settings method whenever possible -
currently only for the parameters frequency, level, RF state, modulator state - and
sends SCPI messages in all other cases.

Remote control programs written for PCIe will, without modifications, also run if one of
the other control channels, LAN or USB is used.

12.3.1  Setting up a remote control connection via PCIe

To set up a remote control connection vie PCIe, perform the following steps:

1. Download the drivers: See 12.3.2.

2. Configure the controller: See 12.3.3
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3. Connect the controller and the instrument: See 12.3.4

4. Enable fast settings: See 12.3.5.

12.3.2  Downloading the drivers

All required driver files are available for download on the product page at:

http://www.rohde-schwarz.com/product/SGS100A.html  > "Downloads" > "Drivers"

Provided are the following files:
● LabWindows/CVI, Linux/OSX driver rssgs (InstrumentDriver)

C source code files which provide a functional application programming interface
(API) to R&S SGS instruments. Required if you want to control an instrument via
PCIe.

● Low-Level SGS drivers
Archive file that contains the following:
– KernelDriver

C source code files from which you can build a Linux kernel mode driver for the
R&S SGS PCIe remote control interface.

– SgsDriverDemo
C source code module for a demo program using the instrument driver API.

– SharedLibraries-Dlls
Shared libraries (*.dll files) for remote control channels Socket and PCIe. To
be used with the instrument driver.

● VXIplug&play x64/x86 driver rssgs
Download the required archive and extract the files on a remote PC.

12.3.3  Configuring the controller

This section lists the steps necessary to configure a controller with Linux or Windows
operating system.

12.3.3.1  Building and installing the hardware driver

The hardware driver defines the way to communicate with the instrument via PCIe
interface.

For Windows operating systems, the hardware driver is installed automatically together
with the installation of the R&S SGMA-GUI software.
See also section "Installation of R&S SGMA-GUI Software" in the getting started man-
ual.

For Linux operating system, the source code of the driver is included in the
Low-Level SGS drivers file.
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To build and install this driver, root authority is required.

1. Copy folder KernelDriver to your hdd

2. Go to directory host.

3. On the command line, enter make.

The driver sgshost.ko is automatically built.

4. Enter make install.

Device nodes sgsX are created under the folder /dev (X from 0 to 31).
The module sgshost is loaded.

5. Enter lsmod to verify the module.

12.3.3.2  Making shared libraries accessible

Two library files per operating system are included in SharedLibraries-Dlls file:
● For Linux operating system

libsocketcontroller.so and libpciecontroller.so
● For Windows operating system

SocketController.dll and PCIeController.dll
These libraries act as the dynamic link libraries for programs using the socket or PCIe
interface.

Linux operating system

► To make the libraries accessible, perform one of the following:

a) Append the environment variable LD_LIBRARY_PATH with the path of these
two files, e.g., by changing the /etc/environment file.

b) Move these two files to /usr/lib or /lib directory.

Windows operating system

► To make the libraries accessible, perform one of the following:

a) Copy these two files to the folder of your executable.
b) Copy these two files to the WINDOWS\system32 folder.

12.3.3.3  Building a program

The help file rssgs_vxi.chm shows all functions of the instrument which you can use
in your own remote control program.

An example file is provided ( SgsDriverDemo.c), too.

Building the example program (Linux)

1. Copy folders InstrumentDriver and SgsDriverDemo to your hard disk.
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2. Go to folder Build

3. On the command line, enter cmake ..

4. Enter make
Folder Build contains the executable SgsDriverDemo.

Building the example program (Windows)

1. Copy folders InstrumentDriver and SgsDriverDemo to your hard disk.

2. Open SgsDriverDemo.vcproj with Visual Studio.

3. Build the program.

Running the example program

► On the command line, enter ./SgsDriverDemo RESOURCESTRING [cmd].

Where
● RESOURCESTRING is the (VISA) resource string of your instrument, e.g.

TCPIP::ipaddress::5025::SOCKET or PCIE::0x162f::
0x132e::serialno::INSTR.
Where ipaddress is the IP address or hostname of your instrument and
serialno is its serial number.

● cmd is an optional command (see table).

The following table list the available commands.

Command Description

? Usage

q Quit

f value Set frequency

f? Query frequency

l value Set level

l? Query level

r value Set RF state (value = 0 | 1 | ON | OFF)

r? Query RF state

If you enter an additional optional command, SgsDriverDemo executes it and
enters a loop waiting for further commands.

Example: 
TCPIP::10.111.11.44::5025::SOCKET ?
Lists the available commands.
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12.3.4  Connecting the controller and the instrument

The "PCIe" connector is located on the rear panel.

Permitted PCIe cables
PCIe extension cables must fulfill the following requirements:
● Single lane connectors
● Maximum cable length of 5 m.

For example: OSS-PCIe-CBL-x1 cable from One Stop Systems or 74576-000x cable
from Molex.

Connecting an external PC that does not support hot-plugging

1. Switch off the external PC and the instrument.
See also Chapter 3.10, "Switching on or off", on page 25.

2. NOTICE! Risk of device failure. The R&S SGS is equipped with a single lane PCIe
interface that supports hot plugging.
Do not connect an external PC to the PCIe connector of the instrument during
operation if this external PC does not support hot-plugging!
Connect the instrument and the controller with a permitted PCIe cable as specified
in "Permitted PCIe cables" on page 190.

3. Switch on the instrument.

4. Wait until the instrument has completed the booting (the "POWER" LED on the
instrument's front panel is constantly on).

5. Switch on the external PC.

12.3.5  Enabling fast settings

► To enable the special PCI express feature fast settings, enable the function
rssgs_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.

To disable the fast settings, call the function rssgs_UseFastSettings with argu-
ment fastEnabled=false.

Advanced remote control using PCIe



Network operation and remote controlR&S®SGS100A

191User Manual 1173.9105.02 ─ 13

12.4  Advanced remote control using fast socket

Fast settings

The socket interface can be utilized not only to transfer text messages, e.g., SCPI
commands but also to carry register based remote control messages. The latter mode
is called fast settings mode. The fast socket communication is based on the Ethernet
protocol which does not support routing. Therefore a controller PC can only control
devices within its own network segment using the fast socket method.

To use the advantage of the fast settings, the following prerequisites must be fulfilled:
● On Windows operating systems, the fast socket driver must be installed.
● The application program must be run with root/administrator rights.
● The fast settings must be enabled with the function rssgs_useFastSettings

(see also Chapter 12.3.5, "Enabling fast settings", on page 190).

The instrument driver uses the fast settings method whenever possible, currently for
the parameters frequency, level, RF state, I/Q modulator state, IQ wideband state. In
all other cases, SCPI messages are sent.

12.4.1  Setting up a remote control connection via fast socket

Download the required archive and extract the files on a remote PC, as described in
Chapter 12.3.2, "Downloading the drivers", on page 187.

Windows operating systems

To set up a remote control connection via fast socket for Windows operating systems,
perform the following steps:

1. Connect the controller and the instrument: See Chapter 3.13.2, "Connecting a
remote PC via LAN", on page 30.

2. Install the protocol driver to the controller: See Chapter 12.4.2, "Installing the proto-
col driver", on page 192.

3. On the controller, start the driver by using one of the following:

a) Start the Windows console user interface as an administrator.
Excute the command net start SGMANDISPROT.

b) Use a program for opening the driver.
See, for example, the example file SgsDriverDemo.c.

4. Start the application with administrator rights.

5. Enable fast settings: See Chapter 12.4.3, "Enabling fast settings", on page 192.
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Linux operating systems

To set up a remote control connection via fast socket for Linux operating systems, per-
form the following steps:

1. Connect the controller and the instrument: See Chapter 3.13.2, "Connecting a
remote PC via LAN", on page 30.

2. Start the application as root.

3. Enable fast settings: See Chapter 12.4.3, "Enabling fast settings", on page 192.

12.4.2  Installing the protocol driver

The protocol driver defines the way to communicate with the instrument via the LAN
fast socket interface.

For Linux operating system, no special driver is needed.

For Windows operating systems, the SGMANDISPROT driver is required. The protocol
driver is installed automatically together with the installation of the R&S SGMA-GUI
software. It is also provided in the Low-Level SGS drivers file.

To install the driver manually on a Windows operating system:

1. Open "Control Panel > Network and Sharing Center".

2. Select the network adapter on which you want to install the driver.

The "Local Area Connection Status" dialog opens.

3. Click "Properties" to open the "Local Area Connection Properties" dialog.

4. Click "Install" to open the "Select Network Feature Type" dialog.

5. Select "Protocol".

6. Select "Add".

7. In the "Select Network Protocol" dialog, select "Have Disk".

8. To select the driver, navigate to its storage directory.

9. Click "OK" to install the driver.

12.4.3  Enabling fast settings

► To enable the fast settings for the fast socket, call function
rssgs_UseFastSettings (ViSession instrumentHandle, ViBoolean
fastEnabled, ViBoolean asynchronousEnabled) included in the instru-
ment driver.

Settings for some parameters like level and frequency accelerate.
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To disable the fast settings, call the function rssgs_UseFastSettings with argu-
ment fastEnabled=false.

12.5  Status reporting system

The status reporting system stores all information on the current operating state of the
instrument, and on errors which have occurred. This information is stored in the status
registers and in the error queue.

You can query both with the commands of the STATus subsystem.

12.5.1  Hierarchy of the status registers

The Figure 12-5 shows the hierarchical structure of information in the status registers
(ascending from left to right).
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Figure 12-5: Graphical overview of the status registers hierarchy

OPER = Operation Status Summary Bit
RQS/MSS = Service Request Generation
ESB = Standard Event Status Summary Bit
MAV = Message Available in Output Queue
QUES = Questionable Status Summary Bit
2 = Error- /Event-Queue
1, 0 = not used

Note: This legend explains the abbreviations to the Status Byte Register.

The R&S SGS uses the following status registers:
● Status Byte (STB) and Service Request Enable (SRE), see Chapter 12.5.3, "Sta-

tus byte (STB) and service request enable register (SRE)", on page 197.
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● Standard Event Status, i.e. the Event status Register (ESR) and the Event Status
Enable (ESE), see Chapter 12.5.4, "Event status register (ESR) and event status
enable register (ESE)", on page 198.

● Questionable Status and Operation Status, the (SCPI status registers, see
Chapter 12.5.2, "Structure of a SCPI status register", on page 195, Chapter 12.5.5,
"Questionable status register (STATus:QUEStionable)", on page 198 and Chap-
ter 12.5.6, "Operation status register (STATus:OPERation)", on page 199.

● Output-Queue
The output queue contains the messages the instrument returns to the controller. It
is not part of the status reporting system but determines the value of the MAV bit in
the STB and thus is represented in the overview.

● Error- /Event-Queue
The error-/event-queue contains all errors and events that have occurred in the
past. When reading the queue, the instrument starts with the first occurred error/
event.

All status registers have the same internal structure.

SRE, ESE
The service request enable register SRE can be used as ENABle part of the STB if the
STB is structured according to SCPI. By analogy, the ESE can be used as the ENABle
part of the ESR.

12.5.2  Structure of a SCPI status register

Each SCPI status register consists of five parts. Each part has a width of 16 bits and
has different functions. The individual bits are independent of each other, i.e. each
hardware status is assigned a bit number, which is valid for all five parts. Bit 15 (the
most significant bit) is set to zero for all parts. Thus, the contents of the register parts
can be processed by the controller as positive integers.

Figure 12-6: The status-register model
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Description of the five status register parts

The five parts of a SCPI status register have different properties and functions:

● CONDition
The CONDition part is written directly by the hardware or it mirrors the sum bit of
the next lower register. Its contents reflect the current instrument status. This regis-
ter part can only be read, but not written into or cleared. Its contents are not affec-
ted by reading.

● PTRansition / NTRansition
The two transition register parts define which state transition of the CONDition
part (none, 0 to 1, 1 to 0 or both) is stored in the EVENt part.
The Positive-TRansition part acts as a transition filter. When a bit of the
CONDition part is changed from 0 to 1, the associated PTR bit decides whether
the EVENt bit is set to 1.
– PTR bit =1: the EVENt bit is set.
– PTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.
The Negative-TRansition part also acts as a transition filter. When a bit of the
CONDition part is changed from 1 to 0, the associated NTR bit decides whether
the EVENt bit is set to 1.
– NTR bit =1: the EVENt bit is set.
– NTR bit =0: the EVENt bit is not set.

This part can be written into and read as required. Its contents are not affected by
reading.

● EVENt
The EVENt part indicates whether an event has occurred since the last reading, it
is the "memory" of the condition part. It only indicates events passed on by the
transition filters. It is permanently updated by the instrument. This part can only be
read by the user. Reading the register clears it. This part is often equated with the
entire register.

● ENABle
The ENABle part determines whether the associated EVENt bit contributes to the
sum bit (see below). Each bit of the EVENt part is "ANDed" with the associated
ENABle bit (symbol '&'). The results of all logical operations of this part are passed
on to the sum bit via an "OR" function (symbol '+').
ENABle bit = 0: the associated EVENt bit does not contribute to the sum bit
ENABle bit = 1: if the associated EVENt bit is "1", the sum bit is set to "1" as well.
This part can be written into and read by the user as required. Its contents are not
affected by reading.

Sum bit

The sum bit is obtained from the EVENt and ENABle part for each register. The result
is then entered into a bit of the CONDition part of the higher-order register.
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The instrument automatically generates the sum bit for each register. Thus an event
can lead to a service request throughout all levels of the hierarchy.

12.5.3  Status byte (STB) and service request enable register (SRE)

The STatus Byte (STB) is already defined in IEEE 488.2. It provides a rough over-
view of the instrument status by collecting the pieces of information of the lower regis-
ters. A special feature is that bit 6 acts as the sum bit of the remaining bits of the status
byte.

The STB is read using the command *STB? or a serial poll.

The STatus Byte (STB) is linked to the Service Request Enable (SRE) register.
Each bit of the STB is assigned a bit in the SRE. Bit 6 of the SRE is ignored. If a bit is
set in the SRE and the associated bit in the STB changes from 0 to 1, a service
request (SRQ) is generated. The SRE can be set using the command *SRE and read
using the command *SRE?.

Table 12-2: Meaning of the bits used in the status byte

Bit No. Meaning

0...1 Not used

2 Error Queue not empty

The bit is set when an entry is made in the error queue. If this bit is enabled by the SRE, each
entry of the error queue generates a service request. Thus an error can be recognized and
specified in greater detail by polling the error queue. The poll provides an informative error mes-
sage. This procedure is to be recommended since it considerably reduces the problems
involved with remote control.

3 QUEStionable status register summary bit

The bit is set if an EVENt bit is set in the QUEStionable status register and the associated
ENABle bit is set to 1. A set bit indicates a questionable instrument status, which can be speci-
fied in greater detail by querying the STATus:QUEStionable status register.

4 MAV bit (message available)

The bit is set if a message is available in the output queue which can be read. This bit can be
used to enable data to be automatically read from the instrument to the controller.

5 ESB bit

Sum bit of the event status register. It is set if one of the bits in the event status register is set
and enabled in the event status enable register. Setting of this bit indicates a serious error which
can be specified in greater detail by polling the event status register.

6 MSS bit (main status summary bit)

The bit is set if the instrument triggers a service request. This is the case if one of the other bits
of this registers is set together with its mask bit in the service request enable register SRE.

7 STATus:OPERation status register summary bit

The bit is set if an EVENt bit is set in the OPERation status register and the associated
ENABle bit is set to 1. A set bit indicates that the instrument is just performing an action. The
type of action can be determined by querying the STATus:OPERation status register.
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12.5.4  Event status register (ESR) and event status enable register (ESE)

The ESR is defined in IEEE 488.2. It can be compared with the EVENt part of a SCPI
register. The event status register can be read out using command *ESR?.

The ESE corresponds to the ENABle part of a SCPI register. If a bit is set in the ESE
and the associated bit in the ESR changes from 0 to 1, the ESB bit in the STB is set.
The ESE register can be set using the command *ESE and read using the command
*ESE?.

Table 12-3: Meaning of the bits used in the event status register

Bit No. Meaning

0 Operation Complete

This bit is set on receipt of the command *OPC exactly when all previous commands have been
executed.

1 Not used

2 Query Error

This bit is set if either the controller wants to read data from the instrument without having sent a
query, or if it does not fetch requested data and sends new instructions to the instrument
instead. The cause is often a query which is faulty and hence cannot be executed.

3 Device-dependent Error

This bit is set if a device-dependent error occurs. An error message with a number between
-300 and -399 or a positive error number, which denotes the error in greater detail, is entered
into the error queue.

4 Execution Error

This bit is set if a received command is syntactically correct but cannot be performed for other
reasons. An error message with a number between -200 and -300, which denotes the error in
greater detail, is entered into the error queue.

5 Command Error

This bit is set if a command is received, which is undefined or syntactically incorrect. An error
message with a number between -100 and -200, which denotes the error in greater detail, is
entered into the error queue.

6 User Request

This bit is set when the instrument is switched over to manual control.

7 Power On (supply voltage on)

This bit is set on switching on the instrument.

12.5.5  Questionable status register (STATus:QUEStionable)

This register contains information on questionable instrument states. Such states may
occur when the instrument is not operated in compliance with its specifications.

To read the register, use the query commands STAT:QUEST:COND? or
STAT:QUEST[:EVEN]?.
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Table 12-4: Meaning of the bits used in the questionable status register

Bit No. Meaning

0–15 Not used

12.5.6  Operation status register (STATus:OPERation)

This condition part contains information on the actions currently being performed by
the instrument, while the event part contains information on the actions performed by
the instrument since the last readout of the register.

To read the register, use the query commands STAT:OPER:COND? or
STAT:OPER[:EVEN]?.

Table 12-5: Meaning of the bits used in the operation status register

Bit No. Meaning

0 Calibrating

The bit is set during the calibration phase.

1–2 Not used

3  

4–15 Not used

12.5.7  Application of the status reporting system

The purpose of the status reporting system is to monitor the status of one or several
devices in a measuring system. To do this and react appropriately, the controller must
receive and evaluate the information of all devices. The following standard methods
are used:

● Service request (SRQ) initiated by the instrument
● Serial poll of all devices in the bus system, initiated by the controller to find out

who sent an SRQ and why
● Query of a specific instrument status by commands
● Query of the error queue

12.5.7.1  Service request

Under certain circumstances, the instrument can send a service request (SRQ) to the
controller. Usually this service request initiates an interrupt at the controller, to which
the control program can react appropriately. An SRQ is always initiated if one or sev-
eral of bits 2, 4 or 5 of the status byte are set and enabled in the SRE. Each of these
bits combines the information of the error queue or the output buffer. To use the possi-
bilities of the service request effectively, all bits should be set to "1" in the enable regis-
ters SRE and ESE.
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Example: 
Use command *OPC to generate an SRQ .
*ESE 1 - set bit 0 of ESE (Operation Complete)
*SRE 32 - set bit 5 of SRE (ESB).
After its settings have been completed, the instrument generates an SRQ.

The SRQ is the only possibility for the instrument to become active on its own. Each
controller program should set the instrument such that a service request is initiated in
the case of malfunction. The program should react appropriately to the service request.

12.5.7.2  Serial poll

In a serial poll, just as with command *STB, the status byte of an instrument is queried.
However, the query is realized via interface messages and is thus clearly faster.

The serial poll method is defined in IEEE 488.1 and used to be the only standard pos-
sibility for different instruments to poll the status byte. The method also works for
instruments which do not adhere to SCPI or IEEE 488.2.

The serial poll is mainly used to obtain a fast overview of the state of several instru-
ments connected to the controller.

12.5.7.3  Query of an instrument status

Each part of any status register can be read using queries. There are two types of
commands:

● The common commands *ESR?, *IDN?, *IST?, *STB? query the higher-level
registers.

● The commands of the STATus system query the SCPI registers
(STATus:QUEStionable...)

The returned value is always a decimal number that represents the bit pattern of the
queried register. This number is evaluated by the controller program.

Queries are usually used after an SRQ in order to obtain more detailed information on
the cause of the SRQ.

12.5.7.4  Error queue

Each error state in the instrument leads to an entry in the error queue. The entries of
the error queue are detailed plain text error messages that can be looked up in the
Error Log or queried via remote control using SYSTem:ERRor[:NEXT]?. Each call of
SYSTem:ERRor[:NEXT]? provides one entry from the error queue. If no error mes-
sages are stored there any more, the instrument responds with 0, "No error".

The error queue should be queried after every SRQ in the controller program as the
entries describe the cause of an error more precisely than the status registers. Espe-
cially in the test phase of a controller program the error queue should be queried regu-
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larly since faulty commands from the controller to the instrument are recorded there as
well.

12.5.8  Reset values of the status reporting system

The following table contains the different commands and events causing the status
reporting system to be reset. None of the commands, except of *RST and
SYSTem:PRESet affect the functional instrument settings. In particular, DCL does not
change the instrument settings.
Table 12-6: Resetting the status reporting system

Event Switching on supply
voltage
Power-On-Status-
Clear

DCL,
SDC
(Device
Clear,
Selected
Device
Clear)

*RST or
SYSTem:
PRESet

STATus:
PRESet

*CLS

Effect 0 1

Clear STB, ESR - Yes - - - Yes

Clear SRE, ESE - Yes - - - -

Clear PPE - Yes - - - -

Clear error queue Yes Yes - - - Yes

Clear output buffer Yes Yes Yes 1) 1) 1)

Clear command processing
and input buffer

Yes Yes Yes - - -

1) The first command in a command line that immediately follows a <PROGRAM MESSAGE TERMINA-
TOR> clears the output buffer.

12.6  LXI configuration

"LAN eXtensions for Instrumentation" (LXI) is an instrumentation platform for measur-
ing instruments and test systems that is based on standard Ethernet technology. LXI is
intended to be the LAN-based successor to GPIB, combining the advantages of Ether-
net with the simplicity and familiarity of GPIB.

On the R&S SGS, the LXI functionality is already installed and enabled. Thus, the
instrument can be accessed via any web browser (like the Microsoft Internet Explorer)
to perform the following tasks:
● Modifying network configurations
● Remote control of the instrument
● Performing SCPI remote diagnostics
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12.6.1  Default network settings

According to the LXI standard, an LCI must set the following parameters to a default
state.

Parameter Value

TCP/IP mode DHCP + Auto IP Address

Dynamic DNS Enabled

ICMP ping Enabled

Password for LAN configuration LxiWebIfc

The LAN reset also resets the following parameters for the R&S SGS:

Parameter Value

Hostname <Instrument-specific host name>

Description Signal generator

Negotiation Auto detect

VXI-11 discovery Enabled

The LAN settings are configured using the instrument's LXI browser settings.

12.6.2  LXI browser settings

You can access LXI borowser settings via a web browser.

Access:

► Type in the instrument's host name or IP address in the address field of the
browser on your PC, for example "http://10.111.0.125".
Note: Do not add the missing zeros in the IP address, while opening the instru-
ment home page.
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The instrument home page (welcome page) opens.

The navigation pane of the browser interface contains the following elements:
● "LXI"

– "Home" opens the instrument home page.
The home page displays the device information required by the LXI stan-
dard, including the VISA resource string in read-only format.

– "Device Indicator" activates or deactivates the LXI status indication.
When activated, the LXI LEDs flash in the browser dialog. A green LXI sta-
tus symbol indicates that a LAN connection has been established; a red
symbol indicates that no LAN cable is connected.

– "Lan Configuration" allows you to configure LAN parameters and to initiate
a ping, see Chapter 12.6.3, "LAN configuration", on page 203.

– "Status" displays information about the LXI status of the instrument.
– "Utilities" provides access to the LXI event log functionality required by the

LXI standard.
● "Instrument Control"

– "Web Control" opens the R&S SGS Web-GUI for remote access to the
instrument, see Chapter 5.2, "Configuring a CW Signal with the R&S
SGS100A Web-GUI", on page 41.

● "Diagnostics"
– "SCPI Remote Trace" records messages exchanged via the remote control

interface, see Chapter 12.6.3.4, "SCPI remote trace", on page 206.
● "Help"

– "Glossary" explains terms related to the LXI standard.
– www.rohde-schwarz.com opens the Rohde & Schwarz home page.

12.6.3  LAN configuration

The "LAN Configuration" web page displays all mandatory LAN parameters and allows
their modification.

LXI configuration
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It comprises the following navigation entries.

● IP configuration..................................................................................................... 204
● Advanced Config...................................................................................................204
● Ping client..............................................................................................................205
● SCPI remote trace.................................................................................................206

12.6.3.1  IP configuration

The "IP configuration" web page displays all mandatory LAN parameters and allows
their modification.

The "IP Address Mode" selects a configuration mode for the IP address of the instru-
ment. With static configuration, the entered IP address, subnet mask, and default gate-
way are used. With dynamic configuration via DHCP or dynamic link local addressing
(automatic IP), the instrument IP address is assigned automatically.

Password protection
Changing the LAN configuration is password protected and requires the security pass-
word. The default password is "instrument".

12.6.3.2  Advanced Config

The "Advanced Config" web page provides LAN settings that are not declared manda-
tory by the LXI standard.

LXI configuration
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The following advanced parameters are available:
● "mDNS and DNS-SD": The additional protocols "multicast DNS" and "DNS service

discovery" are used for device communication in zero configuration networks,
working without DNS and DHCP.

● "ICMP Ping": Must be enabled to use the ping utility.
If you disable this setting, the instrument does not answer ping requests. The set-
ting does not affect the LXI ping client. You can ping other hosts from the instru-
ment, even if the setting is disabled.

● "VXI-11 Discovery": Must be enabled to detect the instrument in the LAN.
If you disable this setting, the instrument cannot be detected by the VXI-11 discov-
ery protocol mechanism. The setting does not affect other detection mechanisms.
Setting up a VXI-11 connection via the IP address or the host name is independent
of this setting.

Password protection
Changing the LAN configuration is password protected and requires the security pass-
word. The default password is "instrument".

12.6.3.3  Ping client

The "Ping Client" page provides the ping utility to verify the connection between the
LXI-compliant instrument and another device.

The ping is initiated from the instrument. Using the ICMP echo request and echo reply
packets, the function checks whether the communication with a device via LAN is
working. Ping is useful for the diagnosis of IP network or router failures.

LXI configuration
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To initiate a ping at the instrument:

1. On the "Ping Client" page, enter the IP address of the host in the "Destination
Address" field (for example 10.111.0.125).

2. Select "Submit".

12.6.3.4  SCPI remote trace

The remote trace functionality allows you to trace input and output strings at the
remote control interface of the R&S SGS, see Chapter 12.6.4, "How to record SCPI
commands and messages via LXI", on page 208.

A recorded trace (message log) can be evaluated directly in the dialog. Use the high-
lighting and navigation functions provided by the lower toolbar to locate error mes-
sages and messages containing arbitrary search strings. You can also export the mes-
sage log to a *.csv file and evaluate the file using a suitable program.

To trace and display messages, switch on "logging" and "live mode" in the toolbar.

LXI configuration
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Toolbars

The toolbar at the top of the dialog provides basic settings and functions.

● "Live mode" / "logging": If logging is switched on, messages are traced. They are
stored in an internal database and can be displayed upon request, using the
refresh button (live mode off) or they can be displayed automatically (live mode
on).

● "Filter": applies a filter to columns and/or rows when working (live mode off)
● "Refresh": reads the message log from the internal database and displays it
● "Download": stores the SCPI trace log to a *.csv file
● "Clear": deletes all message log entries in the database and at the screen
● "Details": displays details of the selected message, for example a SCPI command

in hex format (also possible by double\-clicking a message)

Columns

The following columns are available if no column filter is applied:

● "Rec": record number of the message within the message log
● "MT": indicates the type of the message. Possible values and related message

contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, highlighted by red color
– T = execution time, i.e. time required by the instrument to process the com-

mand internally

LXI configuration
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● I: number of the subinstrument
● "message": indicates the type of the message. Possible values and related mes-

sage contents are:
– > = incoming command
– < = outgoing response to a query
– E = error message, denoted in red
– T = execution time, i.e. time required by the instrument to process the com-

mand internally

12.6.4  How to record SCPI commands and messages via LXI

The remote trace functionality allows you to trace commands and messages
exchanged via a remote control interface of the R&S SGS.

To activate the SCPI remote trace:

1. Start a web browser that supports html5 (W3C compliant).

2. Enter the IP address of the R&S SGS in the browser's address bar.

The R&S SGS's welcome page is displayed.

3. In the navigation pane, select "Diagnostics > SCPI Remote Trace".

4. In the toolbar bar of the "SCPI Remote Trace" page, select "live mode > on" and
"logging > on".

"live mode > on" displays all commands and responses, and "logging > on" also
traces messages.

If you now control the R&S SGS with SCPI commands, using an appropriate tool,
the LXI function records the information sent and received.

LXI configuration
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The function records all sent commands, received responses and messages, and
stores them in an internal database. If "live mode" is disabled, you can display the
recent traces upon request, using the "refresh" button. You can also store the log in
a file.

12.7  Monitoring remote control operation with R&S SGMA-
GUI

The R&S SGMA-GUI can be used to monitor the behavior of one or more instruments
while they are remote controlled.

A typical configuration consists of one monitor, controllers and instruments. The moni-
tor is the remote PC on which the R&S SGMA-GUI is installed and the controller is the
remote PC on which the application program runs.

Simultaneous control of an instrument from a controller and a monitor can lead to colli-
sions whenever both the controller and the monitor utilize the same remote channel.
These collisions are indicated by an error message in the "Info" line, e.g. "Query inter-
rupted" or "Resource locked". Simultaneous monitoring and control over the same
remote channel is only possible, if the used protocols support
viLock()/viUnlock() and the remote program use these functions.

The Table 12-7 shows whether a collision-free communication over a particular combi-
nation of remote channels is possible or not and if there are any restrictions.
Table 12-7: Cross reference between used remote channels and collision-free communication

Monitor/
Controller

LAN
(VXI-11)

LAN (HiSLIP) USB LAN (Socket) PCIe

LAN (VXI-11) OK* OK OK OK OK

LAN (HiSLIP) OK OK OK OK OK

USB OK OK viLock/viUnlock OK OK

LAN (Socket) OK OK OK X OK

PCIe OK OK OK OK X

Where:
● OK: communication possible, no collisions

*) the R&S SGMA-GUI always uses the LAN device name instr1, see also Chap-
ter 12.1.2.3, "VXI-11 protocol", on page 181.

● X: communication is not possible without collisions
● viLock/viUnlock: communication is only possible, if the remote control com-

mands are enclosed in a viLock () - viUnlock() pair.

The R&S SGMA-GUI uses the viLock()/viUnlock() functions.

Monitoring remote control operation with R&S SGMA-GUI
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The figure below shows an example of configuration where the monitor and the con-
troller are two different computers, connected to the same instrument over two different
hardware interfaces.

Figure 12-7: Example of a setup for remote control monitoring

Connecting and configuring the monitoring PCs

In the "Setup > Security > Security Settings" dialog, check the state of the LAN and
USB interfaces and enable them if necessary.

1. Connect the monitoring PC to the instrument.

Note: Choose the hardware interface considering the limitations described in
Table 12-7.

2. Configure the instrument in the R&S SGMA-GUI: See Chapter 8.4.2, "Handling
instruments in the R&S SGMA-GUI", on page 75.

3. In the "SGMA-GUI > Setup > Instruments > Edit Instruments" dialog, disable
"Exclusive Access".

Note: The two functions "Exclusive Access" and monitoring are mutually exclusive.

4. Send remote control commands from the controller to the instrument.

5. Open the corresponding dialogs in the R&S SGMA-GUI. Observe the status of the
parameters.

Monitoring remote control operation with R&S SGMA-GUI
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13  Remote control commands
In the following, all remote-control commands are presented in detail with their param-
eters and the ranges of numerical values.

For an introduction to remote control and the status registers, refer to the following sec-
tions:
● "Information on network operation and remote control" on page 175
● Chapter 12.5, "Status reporting system", on page 193

Conventions used in SCPI Command Descriptions

The following conventions are used in the remote command descriptions:
● Command usage

If not specified otherwise, commands can be used both for setting and for querying
parameters.
If a command can be used for setting or querying only, or if it initiates an event, the
usage is stated explicitly.

● Parameter usage
If not specified otherwise, a parameter can be used to set a value and it is the
result of a query.
Parameters required only for setting are indicated as Setting parameters.
Parameters required only to refine a query are indicated as Query parameters.
Parameters that are only returned as the result of a query are indicated as Return
values.

● Conformity
Commands that are taken from the SCPI standard are indicated as SCPI con-
firmed. All commands used by the R&S SGS follow the SCPI syntax rules.

● Asynchronous commands
A command which does not automatically finish executing before the next com-
mand starts executing (overlapping command) is indicated as an Asynchronous
command.

● Reset values (*RST)
Default parameter values that are used directly after resetting the instrument (*RST
command) are indicated as *RST values, if available.

● Factory preset values
Default parameter values that are reset only by factory preset.

● Default unit
The default unit is used for numeric values if no other unit is provided with the
parameter.

● Manual operation
If the result of a remote command can also be achieved in manual operation, a link
to the description is inserted.

● Programming examples........................................................................................ 212
● Common commands.............................................................................................220
● General commands...............................................................................................225
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● CALibration subsystem......................................................................................... 227
● CONNector subsystem......................................................................................... 229
● DIAGnostic subsystem..........................................................................................230
● EXTension subsystem...........................................................................................231
● MMEMory subsystem............................................................................................234
● Fast speed commands..........................................................................................243
● OUTPut subsystem...............................................................................................243
● SENSe, READ, INITiate and SLISt subsystems................................................... 245
● SOURce subsystem..............................................................................................259
● SOURce:CORRection subsystem.........................................................................261
● SOURce:IQ subsystem.........................................................................................270
● SOURce:PHASe subsystem.................................................................................272
● SOURce:POWer subsystem.................................................................................273
● SOURce:PULM Subsystem.................................................................................. 277
● SOURce:ROSCillator subsystem..........................................................................282
● STATus subsystem................................................................................................284
● SYSTem subsystem..............................................................................................288
● TEST subsystem...................................................................................................301
● UNIT subsystem....................................................................................................302
● List of R&S SGS commands.................................................................................303

13.1  Programming examples

This chapter provides simple programming examples for the R&S SGS. The purpose
of the examples is to present all commands for a given task. In real applications, one
would rather reduce the examples to an appropriate subset of commands.

The programming examples have been tested with a software tool which provides an
environment for the development and execution of remote tests. To keep the examples
as simple as possible, only the "clean" SCPI syntax elements are reported. Non-exe-
cutable command lines (e.g. comments) start with two // characters.

At the beginning of most remote control program, an instrument preset/reset is recom-
mended to set the R&S SGS to a defined state. The commands *RST and
SYSTem:PRESet are equivalent for this purpose. *CLS also resets the status registers
and clears the output buffer.

It is also recommended that you lock the instrument for remote control from the
selected controller before further configuration. Use the LOCK command for this pur-
pose.

We assume that the R&S SGS is fully equipped with all available options.

● Performing general tasks for instrument setup..................................................... 213
● Generating an I/Q modulated signal..................................................................... 215
● Adjusting network and remote channel settings....................................................216
● Advanced tasks to optimize performance............................................................. 218
● Enabling and configuring an extension mode....................................................... 219
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13.1.1  Performing general tasks for instrument setup

In the following example we assume that a remote PC is connected to the instrument.
The remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS
// SYSTem:PRESet
// RESTart
// SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

LOCK? 72349234
// Lock instrument to avoid interference by other controllers.
// Use an arbitrary number.
// Response: 1
// Request granted, i.e. the instrument is locked.
// Abort program if request is refused.

// ******************************************************************
// Launch selftest, diagnostic and internal adjustments and retrieve results
// ******************************************************************

TEST:ALL:STARt?
TEST:ALL:RESult?
// Response: RUN
// Call :TEST:ALL:RESult? repeatedly until finished (0 or 1 is returned)

DIAGnostic:POINt:CATalog?
// Response: D_TEMP_RFB,D_TEMP_CPU,D_TEMP_DBL,...
DIAGNostic:MEASure:POINt? 'D_TEMP_RFB'

// Calibration functions may take several minutes
// Set timeout values of controller accordingly

CALibration:ALL:MEASure?
// starts the adjustment of all functions for the entire instrument
// Response: 0 / 1
// i.e. adjustment has been performed successfully / adjustment failed
CALibration:FREQuency:MEASure?
// starts the adjustment of frequency and level
CALibration:LEVel:MEASure?
// starts adjustments for maximum level accuracy

Programming examples
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// Options R&S SGS-B106V or R&S SGS-B112V required for modulator functions
CALibration:IQModulator:FULL?
CALibration:IQModulator:LOCal

// ******************************************************************
// Query the entries in the error queue
// ******************************************************************

SYSTem:SERRor?
// Query static errors
// SYSTem:ERRor:CODE:COUNT?
// SYSTem:ERRor:CODE:NEXT?
// SYSTem:ERRor:NEXT?
// STATus:QUEue:NEXT?
// SYSTem:ERRor:CODE:ALL?
SYSTem:ERRor:ALL?
// Query error queue

// ******************************************************************
// Query system information
// ******************************************************************

SYSTem:VERSion?

// ******************************************************************
// Activate eco mode
// ******************************************************************
SYSTem:EMODe EM1

// ******************************************************************
// Query the installed common assemblies and HW options 
// ******************************************************************

SYSTem:SOFTware:OPTion1:NAME?
SYSTem:SOFTware:OPTion1:DESignation?
SYSTem:SOFTware:OPTion1:LICenses?
SYSTem:SOFTware:OPTion1:EXPiration?

SYSTem:HARDware:ASSembly1:NAME?
SYSTem:HARDware:ASSembly1:PNUMber?
SYSTem:HARDware:ASSembly1:SNUMber?
SYSTem:HARDware:ASSembly1:REVision?

// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 72349234
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13.1.2  Generating an I/Q modulated signal

In the following example we assume that a remote PC is connected to the instrument.
The remote PC and the instrument are switched on and a connection between them is
established. An external analog signal is provided at the I and Q connectors of the
instrument.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Select normal operation mode
// ******************************************************************

SOURce:OPMode NORMal

// ******************************************************************
// Set RF frequency and level 
// ******************************************************************

SOURce:FREQuency:CW 2 GHz
// SOURce:PHASe 0
// SOURce:PHASe:REFerence
SOURce:POWer -10dBm
SOURce:POWer:PEP?

// ******************************************************************
// Enable internal reference frequency source 
// ******************************************************************

SOURce:ROSCillator:SOURce INTernal

// ******************************************************************
// Enable internal LO source 
// ******************************************************************

SOURce:LOSCillator:SOURce INT
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// ******************************************************************
// Define and enable impairments
// Enable modulation
// ******************************************************************

SOURce:IQ:IMPairment:LEAKage:I -1
SOURce:IQ:IMPairment:LEAKage:Q 1
SOURce:IQ:IMPairment:IQRatio:MAGNitude 1
// Sets the gain imbalance to 1 %
SOURce:IQ:IMPairment:IQRatio:MAGNitude?
// Response: 0.087 dB
SOURce:IQ:IMPairment:QUADrature:ANGLe 2
SOURce:IQ:WBSTate ON
SOURce:IQ:CREStfactor 0.05

SOURce:IQ:IMPairment:STATe ON
SOURce:IQ:STATe ON

// ******************************************************************
// Enable output of the generated signal at the RF connector
// ******************************************************************

OUTPut:STATe ON

// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 72349234

13.1.3  Adjusting network and remote channel settings

In the following example we assume that a remote PC is connected to the instrument.
The remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

:LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
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// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused

// ******************************************************************
// Query the VISA resource strings
// ******************************************************************

SYSTem:COMMunicate:NETWork:RESource?
// Response: TCPIP::10.113.11.91::INSTR
SYSTem:COMMunicate:SOCKet:RESource?
// Response: TCPIP:rssgs100a100021::5025::SOCKET
SYSTem:COMMunicate:USB:RESource?
// Response: USB::0x0AAD::0x0088::100021::INSTR
SYSTem:COMMunicate:PCIexpress:RESource?
// Response: PCIe::0x0AAD::4909::100021::INSTR

// ******************************************************************
// Query network settings
// ******************************************************************

SYSTem:COMMunicate:NETWork:COMMon:HOSTname?
// Response: rssgs100a100021
SYSTem:COMMunicate:NETWork:IPADdress:MODE?
// Response: AUTO
SYSTem:COMMunicate:NETWork:IPADdress?
// Response: 10.113.11.91
SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:MASK?
//Response: 255.255.0.0
SYSTem:COMMunicate:NETWork:IPADdress:GATeway?
//Response: 10.113.0.1

// ******************************************************************
// Changing network settings
// ******************************************************************

SYSTem:PROTect1:STATe OFF,123456
// SYSTem:COMMunicate:NETWork:COMMon:HOSTname "mySGS"
// SYSTem:COMMunicate:NETWork:IPADdress:MODE STATic
// SYSTem:COMMunicate:NETWork:IPADdress 9.8.7.6
SYSTem:COMMunicate:NETWork:RESTart

// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 72349234
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13.1.4  Advanced tasks to optimize performance

In the following example we assume that a remote PC is connected to the instrument.
The remote PC and the instrument are switched on and a connection between them is
established.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS
// SYSTem:PRESet
// :RESTart
// SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller.
// ******************************************************************

LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused.

// ******************************************************************
// Query and adjust the reference oscillator settings
// ******************************************************************

SOURce:ROSCillator:SOURce?
// Response: EXT
SOURce:ROSCillator:EXTernal:FREQuency?
// Response: 100MHZ
SOURce:ROSCillator:EXTernal:SBANdwidth?
//Response: WIDE
SOURce:ROSCillator:SOURce INTernal
SOURce:ROSCillator:OUTput:FREQuency 100MHZ
SOURce:ROSCillator:INTernal:ADJust:STATe OFF
// uses the calibrated adjustment value of the internal ref. frequency
SOURce:ROSCillator:INTernal:ADJust:VALue?
CONNector:REFLo:OUTPut?
// Response: REF

// ******************************************************************
// Optimizing the quality characteristics of the RF signal
// ******************************************************************

SOURce:POWer:LMODe LNO
// optimize the signal to noise ratio
SOURce:POWer:SCHaracteristic AUTO
// ensure highest dynamic range and fastest setting time
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SOURce:POWer:LEVel:IMMediate:AMPLitude -30dBm
SOURce:POWer:LIMit:AMPLitude 30dBm
SOURce:POWer:ALC:SONCe
:OUTPut:STATe:PON UNCHanged

// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 72349234

13.1.5  Enabling and configuring an extension mode

In the following example we assume that a remote PC is connected to the instrument.
The remote PC and the instrument are switched on and a connection between them is
established; the required application program is running on the remote PC. We
assume that at least one R&S SGU is connected to the instrument, directly or over net-
work/switch. There is a remote control connection between the instrument and the
extension. We further assume, that the required signal connections between the instru-
ment and the extension are established, too.

// ******************************************************************
// Reset instrument first
// ******************************************************************

*RST; *CLS
// SYSTem:PRESet
// :RESTart
// SYSTem:FPReset

// ******************************************************************
// Lock the instrument to the controller
// ******************************************************************

LOCK? 72349234
// Lock instrument to avoid interference by other controllers
// Use an arbitrary number
// Response: 1
// Request granted, i.e. the instrument is locked
// Abort program if request is refused.

// ******************************************************************
// Confirm that there is no extension currently enabled for the instrument 
// Scan the network for available extension instruments and
// query information on the available instruments:
// hostname/IP adress, serial number, used remote channel
// select and enable an extension
// ******************************************************************
EXTension:SELect?
// 0
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// no extension is currently enabled

EXTension:INSTruments:SCAN:STATe 1
EXTension:INSTruments:SCAN:STATe?
// 1
// scan process is running
EXTension:INSTruments:SCAN:STATe?
// 0
// scan finished

EXTension:INSTruments:REMote:LAN:NAME?
// rssgu100a100002,rssgu100a101010
EXTension:INSTruments:REMote:CHANnel?
// LAN,LAN
EXTension:INSTruments:REMote:SERial?
// 100002,101010
// there are two available extensions

// select and enalbe the first extension (rssgu100a100002)
EXTension:SELect 1
// determines the extension
// all further remote control commands are related to this extension
EXTension:REMote:STATe?
// 1
EXTension:BUSY:STATe?
// 0
// extension is connected and ready for operation

// ******************************************************************
// Send remote commands to the extension to control it
// e.g. activate the RF optput of the extension and subsequently confirm this
// ******************************************************************
EXTension:SEND ":OUTP:STAT ON"
EXTension:SEND? ":OUTP:STAT?"
// 1
// the RF ouptput of the extension is active

// ******************************************************************
// Unlock the instrument
// ******************************************************************

UNL 72349234

13.2  Common commands

Common commands are described in the IEEE 488.2 (IEC 625-2) standard. These
commands have the same effect and are employed in the same way on different devi-
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ces. The headers of these commands consist of "*" followed by three letters. Many
common commands are related to the Status Reporting System.

Available common commands:

*CLS.............................................................................................................................221
*ESE.............................................................................................................................221
*ESR?...........................................................................................................................221
*IDN?............................................................................................................................222
*IST?............................................................................................................................ 222
*OPC............................................................................................................................222
*OPT?...........................................................................................................................222
*PRE............................................................................................................................ 223
*PSC............................................................................................................................ 223
*RCL.............................................................................................................................223
*RST.............................................................................................................................223
*SAV.............................................................................................................................223
*SRE............................................................................................................................ 224
*STB?...........................................................................................................................224
*TRG............................................................................................................................ 224
*TST?........................................................................................................................... 224
*WAI.............................................................................................................................225

*CLS

Clear status

Sets the status byte (STB), the standard event register (ESR) and the EVENt part of
the QUEStionable and the OPERation registers to zero. The command does not
alter the mask and transition parts of the registers. It clears the output buffer.

Usage: Setting only

*ESE <Value>

Event status enable

Sets the event status enable register to the specified value. The query returns the con-
tents of the event status enable register in decimal form.

Parameters:
<Value> Range: 0 to 255

*ESR?

Event status read

Returns the contents of the event status register in decimal form and then sets the reg-
ister to zero.

Return values: 
<Contents> Range: 0  to  255
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Usage: Query only

*IDN?

Identification

Returns the instrument identification.

Return values: 
<ID> "Rohde&Schwarz,<device type>,<part number>/<serial num-

ber>,<firmware version>"

Example: Rohde&Schwarz,SGS100A,
1412.0000K02/000000,3.1.17.1-03.01.158

Usage: Query only

*IST?

Individual status query

Returns the contents of the IST flag in decimal form. The IST flag is the status bit
which is sent during a parallel poll.

Return values: 
<ISTflag> 0 | 1

Usage: Query only

*OPC

Operation complete

Sets bit 0 in the event status register when all preceding commands have been execu-
ted. This bit can be used to initiate a service request. The query writes a "1" into the
output buffer when all preceding commands have been executed, which is useful for
command synchronization.

*OPT?

Option identification query

Queries the options included in the instrument. For a list of all available options and
their description, refer to the data sheet.

Return values: 
<Options> The query returns a list of options. The options are returned at

fixed positions in a comma-separated string. A zero is returned
for options that are not installed.

Usage: Query only
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*PRE <Value>

Parallel poll register enable

Sets parallel poll enable register to the indicated value. The query returns the contents
of the parallel poll enable register in decimal form.

Parameters:
<Value> Range: 0  to  255

*PSC <Action>

Power on status clear

Determines whether the contents of the ENABle registers are preserved or reset when
the instrument is switched on. Thus a service request can be triggered when the instru-
ment is switched on, if the status registers ESE and SRE are suitably configured. The
query reads out the contents of the "power-on-status-clear" flag.

Parameters:
<Action> 0 | 1

0
The contents of the status registers are preserved.
1
Resets the status registers.

*RCL <Number>

Recall

Loads the instrument settings from an intermediate memory identified by the specified
number. The instrument settings can be stored to this memory using the command
*SAV with the associated number.

It also activates the instrument settings which are stored in a file and loaded using the
MMEMory:LOAD <number>, <file_name.extension> command.

*RST

Reset

Sets the instrument to a defined default status. The default settings are indicated in the
description of commands.

The command is equivalent to SYSTem:PRESet.

Usage: Setting only

*SAV <Number>

Save
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Stores the current instrument settings under the specified number in an intermediate
memory. The settings can be recalled using the command *RCL with the associated
number.

To transfer the stored instrument settings in a file, use the command :MMEMory:
STORe:STATe.

*SRE <Contents>

Service request enable

Sets the service request enable register to the indicated value. This command deter-
mines under which conditions a service request is triggered.

Parameters:
<Contents> Contents of the service request enable register in decimal form.

Bit 6 (MSS mask bit) is always 0.
Range: 0  to  255

*STB?

Status byte query

Reads the contents of the status byte in decimal form.

Usage: Query only

*TRG

Trigger

Triggers all actions waiting for a trigger event. In particular, *TRG generates a manual
trigger signal. This common command complements the commands of the TRIGger
subsystem.

Usage: Event

*TST?

Self-test query

Initiates self-tests of the instrument and returns an error code.

Return values: 
<ErrorCode> integer > 0 (in decimal format)

An error occurred.
(For details, see the Service Manual supplied with the instru-
ment).
0
No errors occurred.

Usage: Query only
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*WAI

Wait to continue

Prevents servicing of the subsequent commands until all preceding commands have
been executed and all signals have settled (see also command synchronization and
*OPC).

Usage: Event

13.3  General commands

:LOCK?.........................................................................................................................225
:UNLock........................................................................................................................225

:LOCK? <LockRequestId>

Sends a lock request ID which uniquely identifies the controller to the instrument.

Parameters:
<LockRequestId> Number

0
test query to prove whether the instrument is locked
Controller ID
request lock from the controller with the specified Controller ID

Return values: 
<Value> Number

0
request refused; the instrument is already locked to other <Lock
Request Id>, i.e. to another controller
1
request granted

Example: :LOCK? 12345
Response: 1
:UNL 12345

Usage: Query only

Manual operation: See "Exclusive Access" on page 66

:UNLock <UnlockId>

Unlocks an instrument locked to a controller with Controller ID = <Unlock Id>.
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Setting parameters: 
<UnlockId> Number

Unlock ID which uniquely identifies the controller to the instru-
ment. The value must match the Controller ID <Lock Request
Id> set with the command :LOCK?.
0
Clear lock regardless of locking state

Usage: Setting only

Manual operation: See "Exclusive Access" on page 66

13.4  Preset commands

The preset commands are not bundled into one subsystem. Therefore, they are listed
separately in this section. In addition, a specific preset command is provided for each
digital standard and for the fader. These specific commands are described in the asso-
ciated subsystems.

The following presetting actions are available:
● Activating the default state of all internal instrument functions (*RST on page 223).

Functions that concern the integration of the instrument into a measurement setup
are not changed, e.g. TCP/IP address or reference oscillator source settings.

● Activating the original state of delivery (factory reset, :SYSTem:FPReset
on page 226). Only functions that are protected by a password remain unchanged
and the passwords themselves.

:SOURce<hw>:PRESet
:SYSTem:PRESet
Triggers an instrument reset. It has the same effect as:
● The *RST command
● The "SGMA-GUI > Instrument Name > Preset" function.

However, the command does not close open GUI dialogs like the function does.

For an overview of the settings affected by the preset function, see Chapter 9.9, "Pre-
set", on page 135.

Example: SYST:PRES
All instrument settings (also the settings that are not currently
active) are reset to their default values.

Usage: Setting only

:SYSTem:FPReset

Triggers an instrument reset to the original state of delivery.
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Example: SYST:FPR
all instrument settings (also those that are not currently active)
are reset to the factory values.

Usage: Event

Manual operation: See "Execute Factory Preset" on page 155

13.5  CALibration subsystem

:CALibration:ALL[:MEASure]?......................................................................................... 227
:CALibration:FREQuency[:MEASure]?..............................................................................227
:CALibration:IQModulator:FULL?..................................................................................... 228
:CALibration:IQModulator:LOCal?....................................................................................228
:CALibration:LEVel[:MEASure]?.......................................................................................228
:CALibration:LEVel:TEMPerature?................................................................................... 228
:CALibration:FREQuency:TEMPerature?..........................................................................228
:CALibration:IQModulator:TEMPerature?..........................................................................228
:CALibration:OEXTension................................................................................................229
:CALibration:ROSCillator:DATA:MODE.............................................................................229
:CALibration:ROSCillator[:DATA]......................................................................................229

:CALibration:ALL[:MEASure]?

Starts all internal adjustments for which no external measuring equipment is needed.

Return values: 
<All> 1 | ON | 0 | OFF

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See "Adjust All" on page 142

:CALibration:FREQuency[:MEASure]?

Performs all adjustments which affect the frequency.

Return values: 
<Synthesis> 1 | ON | 0 | OFF

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See " Synthesis" on page 143
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:CALibration:IQModulator:FULL?

Starts the adjustment of the I/Q modulator for the entire frequency range. The I/Q mod-
ulator is adjusted with respect to carrier leakage, I/Q imbalance and quadrature.

Return values: 
<Modulator> 0 | 1

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See " I/Q Modulator" on page 143

:CALibration:IQModulator:LOCal?

Starts the adjustment of the I/Q modulator for the current frequency. The I/Q modulator
is adjusted with respect to carrier leakage, I/Q imbalance and quadrature.

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See "Adjust I/Q Modulator at Current Frequency" on page 142

:CALibration:LEVel[:MEASure]?

Starts all adjustments which affect the level.

Return values: 
<Level> 1 | ON | 0 | OFF

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See " Level" on page 143

:CALibration:LEVel:TEMPerature?
:CALibration:FREQuency:TEMPerature?
:CALibration:IQModulator:TEMPerature?
Queries the delta temperature since the last performed adjustment.

Return values: 
<Temperature> string

Usage: Query only

Manual operation: See "Delta Temperature" on page 143
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:CALibration:OEXTension <OExtension>

This SCPI command is used when the instrument is in extension mode.

Enables you to run an internal adjustment only on the extension instrument.

Parameters:
<OExtension> 1 | ON | 0 | OFF

*RST: 0

Example: :CAL:OEXT ON
activates the mode for calibrating only the extension instrument
:CAL:LEV:MEAS?
calibrates only the extension instrument
:CAL:OEXT OFF
deactivates the mode for calibrating only the extension instru-
ment

:CALibration:ROSCillator:DATA:MODE <Mode>

Defines whether the factory provided or a custom defined calibration value is used to
adjust the reference oscillator.

Parameters:
<Mode> FACTory | CUSTomer

*RST: FACTory

Example: :CALibration1:ROSCillator:DATA:MODE CUSTomer
:CALibration1:ROSCillator:DATA 35600

Manual operation: See "Active Adjustment Data" on page 159

:CALibration:ROSCillator[:DATA] <Data>

Sets the calibration value for the custom defined external adjustment.

Parameters:
<Data> integer

Range: 0  to  INT_MAX
*RST: 0

Example: See :CALibration:ROSCillator:DATA:MODE on page 229

Manual operation: See "Calibration Value" on page 159

13.6  CONNector subsystem

:CONNector:REFLo:OUTPut........................................................................................... 230
:CONNector:TRIGger:OMODe.........................................................................................230
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:CONNector:REFLo:OUTPut <Output>

Determines the signal provided at the output connector [REF/LO OUT] (rear of the
instrument).

Parameters:
<Output> REF | LO | OFF

*RST: REF

Manual operation: See "REF/LO Output" on page 95

:CONNector:TRIGger:OMODe <Mode>

Sets the operating mode of the trigger connector.

The parameters PVOut|PETRigger|PEMSource are available only with option
R&S SGS-K22.

Parameters:
<Mode> SVALid | SNValid | PVOut | PETRigger | PEMSource

SVALid|SNValid
signal valid /not valid
PVOut
pulse generator video out
PETRigger
pulse generator external trigger
PEMSource
external pulse modulator source

Manual operation: See "Trigger Connector Mode" on page 128

13.7  DIAGnostic subsystem

:DIAGnostic:POINt:CATalog?...........................................................................................230
:DIAGnostic[:MEASure]:POINt?.......................................................................................231

:DIAGnostic:POINt:CATalog?

Queries the test points available in the instrument.

For description of the test points, see the service manual.

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only
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:DIAGnostic[:MEASure]:POINt? <Name>

Triggers voltage or temperature measurement at the specified test point and returns
the measured value.

Use the command :DIAGnostic:POINt:CATalog? to retrieve a list of the available
test points.

For description of the test points, see the service manual.

Query parameters: 
<Name> string

Return values: 
<Value> number

Default unit: V or °C

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

13.8  EXTension subsystem

:EXTension:REMote:STATe?........................................................................................... 231
:EXTension:INSTruments:NAME?....................................................................................232
:EXTension:INSTruments:SCAN[:STATe].......................................................................... 232
:EXTension:INSTruments:REMote:CHANnel?................................................................... 232
:EXTension:INSTruments:REMote:LAN:NAME?................................................................ 232
:EXTension:INSTruments:REMote:SERial?.......................................................................233
:EXTension:BUSY[:STATe]?............................................................................................ 233
:EXTension:SELect.........................................................................................................233
:TEST:EXTension:CONNection?...................................................................................... 234
:TEST:EXTension:CONNection:RF?.................................................................................234

:EXTension:REMote:STATe?

Queries the state of the remote control connection to the extension.

Return values: 
<State> 0 | 1 | OFF | ON

1|ON
Connected
0|OFF
Not connected

Example: See Chapter 13.1.5, "Enabling and configuring an extension
mode", on page 219.

Usage: Query only

Manual operation: See "Available Instruments" on page 138
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:EXTension:INSTruments:NAME?

Queries the list of the symbolic names of the available extension devices.

Usage: Query only

Manual operation: See "Available Instruments" on page 138

:EXTension:INSTruments:SCAN[:STATe] <State>

Starts a scan for the available extension instruments.

Parameters:
<State> 0 | 1 | OFF | ON

1
Starts scan.
0
Aborts scan.
*RST: OFF

Example: See Chapter 13.1.5, "Enabling and configuring an extension
mode", on page 219.

Manual operation: See "Available Instruments" on page 138
See "Scan" on page 139

:EXTension:INSTruments:REMote:CHANnel?

Queries the remote channels of the available extension instruments. Possible interfa-
ces are: LAN, USB, SOCKet, PCIe.

Parameters:
<Channel> <Channellnstr#1>[,<Channellnstr#2>,...]

Returns a list of the used remote channels of the available
extensions, one interface per instrument. If an extension uses
more than one remote channels, the fastest one is returned.

Example: See Chapter 13.1.5, "Enabling and configuring an extension
mode", on page 219.

Usage: Query only

Manual operation: See "Available Instruments" on page 138

:EXTension:INSTruments:REMote:LAN:NAME?

Queries the IP addresses/instrument names of the available extension instruments.

Return values: 
<IPAddress> <IPAdr_Inst#1>[,<IPAdr_Inst#2>,...]

Example: See Chapter 13.1.5, "Enabling and configuring an extension
mode", on page 219.
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Usage: Query only

Manual operation: See "Available Instruments" on page 138

:EXTension:INSTruments:REMote:SERial?

Queiries the serial numbers of the available extension instruments.

Parameters:
<Serial> <SerialNumberInstr#1>[, <SerialNumberInstr#2>,...]

Example: See Chapter 13.1.5, "Enabling and configuring an extension
mode", on page 219.

Usage: Query only

Manual operation: See "Available Instruments" on page 138

:EXTension:BUSY[:STATe]?

Queries the state of the extension instrument.

Return values: 
<State> 0 | 1 | OFF | ON

0
The extension is connected to the master instrument and can be
remotely operated.
1
The extension is busy, i.e. in standby or locked state, or is per-
forming a time consuming operation.

Example: See Chapter 13.1.5, "Enabling and configuring an extension
mode", on page 219.

Usage: Query only

Manual operation: See "Available Instruments" on page 138

:EXTension:SELect <SelNr>

Selects an extension by its index number. The subsequent SCPI commands are rela-
ted to this extension.

Parameters:
<SelNr> float

0
no selection

Example: See Chapter 13.1.5, "Enabling and configuring an extension
mode", on page 219.
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:TEST:EXTension:CONNection?

Returns the results of a test to all signal connections between the instrument and the
extension.

Return values: 
<State> 0 | 1 | OFF | ON

0: no error detected
1: error detected

Usage: Query only

Manual operation: See "Test Signal Connections" on page 139

:TEST:EXTension:CONNection:RF?

Returns the results of a test of the RF signal connection to the extension. This query
does not report errors to the SCPI error queue.

You can use this SCPI to detect which extension is physically connected to a device.

Return values: 
<State> 0 | 1 | OFF | ON

0: no error detected
1: error detected

Usage: Query only

Manual operation: See "Test Signal Connections" on page 139

13.9  MMEMory subsystem

The MMEMory subsystem (Mass Memory) contains the commands for managing files
and directories as well as for loading and storing complete instrument settings in files.

The files are stored on the internal flash memory of the instrument or on external USB
memory devices.

The default directory is determined using the command MMEMory:CDIR.

Use the command :SYSTem:MMEMory:PATH:USER? to query the path of the direc-
tory for user-defined data.

The /opt directory is a protected and therefore a not accessible system directory. The
files on this directory contain data that must not be changed. Therefore, this directory
should not be accessed, since reconstruction of the system partition will lead to data
loss.
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13.9.1  File naming conventions

To enable files in different file systems to be used, the following file naming conven-
tions should be observed.

The file name can be of any length and is case-sensitive, meaning it is distinguished
between uppercase and lowercase letters.

The file and the optional file extension are separated by a dot. All letters and numbers
are permitted (numbers are, however, not permitted at the beginning of the file name).
If possible, special characters should not be used. The use of the slashes "\" and "/"
should be avoided since they are used in file paths. A number of names are reserved
for the operating system, e.g. CLOCK$, CON, AUX, COM1...COM4, LPT1...LPT3, NUL
and PRN.

In the R&S SGS all files in which lists and settings are stored are given a characteristic
extension. The extension is separated from the actual file name by a dot (see Chap-
ter 13.9.2, "Extensions for user files", on page 235 for an overview of the file types).

The two characters "*" and "?" function as "wildcards", meaning they are used for
selecting several files. The "?" character represents exactly one character, while the "*"
character represents all characters up to the end of the file name. "*.*" therefore stands
for all files in a directory.

When used in conjunction with the commands, the parameter <file_name> is speci-
fied as a string parameter with quotation marks. It can contain either the complete path
including the drive, only the path and the file name, or only the file name. The file name
must include the file extension. The same applies for the parameters
<directory_name> and <path>.

Depending on how much information is provided, either the values specified in the
parameter or the values specified with the command MMEM:CDIR (default directory)
are used for the path and the drive settings in the commands.

Before the instrument settings can be stored in a file, they have to be stored in an inter-
mediate memory using common command *SAV <number>. The specified number is
subsequently used in the :MMEMory:STORe:STATe on page 242 command. Also,
subsequently to loading a file with instrument settings with command :MMEMory:
LOAD:STATe on page 241, these settings have to be activated with the common com-
mand *RCL <number>.

13.9.2  Extensions for user files

The following table lists all available file extensions for user files.
Table 13-1: Automatically assigned file extensions in the instrument

Function Contents File suffix

R&S SGMA-GUI Save As/Open Software settings *.savrcl
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13.9.3  Examples

In these examples, the current instrument setting is stored in the file
test.savrcltxt in the directory /var/sgs/..

Storing and Loading Current Settings

1. Store the current setting in an intermediate memory with the number 4. This setting
can be called using command *RCL and the associated number of the memory, for
example *RCL 4.
*SAV 4

2. To store the settings in a file in a specific directory, specify the complete path.
MMEM:STOR:STAT 4,"/var/sgs/test.savrcltxt"

3. To store the settings in a file in the default drive, set the default drive and specify
only the file name.
MMEM:CDIR '/var/sgs/'*SAV 4
MMEM:STOR:STAT 4,"test.savrcltxt"

4. Load the file test.savrcltxt in the user directory.
MMEM:LOAD:STAT 4,'/var/sgs/test.savrcltxt'

5. Activate the instrument setting of the file test.savrcltxt.
*RCL 4

Working with Files and Directories

1. Read out all files in the specified directory.
MMEM:CAT? 'usbuser'
Response: 127145265,175325184,"test,DIR,0","temp,DIR,0",
"readme.txt,ASC,1324","state.savrcltxt,STAT,5327",
"waveform.wv,BIN,2342"
the directory usbuser contains the subdirectories test and temp as well as the
files readme.txt, state.savrcltxt and waveform.wv which have different
file types.

Tip: To query only the subdirectories of the current or specified directory, perform:
MMEM:DCAT? 'usbuser'
Response: 'test', 'temp'
To query only the number of subdirectories in the current or specified directory, per-
form:
MMEM:DCAT:LENG? 'usbuser'
Response: 2

2. To query the number of files in the current or specified directory, perform:
MMEM:CAT:LENG? 'usbuser'
Response: 3

3. Create a new subdirectory for mass memory storage in the specified directory.
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MMEM:MDIR 'usbnew'

4. Copy the file state to a new file.
MMEM:COPY '/var/sgs/state.savrcltxt','usbnew'

5. Rename the file state.
MMEM:MOVE 'state.savrcltxt','state_new.savrcltxt'

6. Remove the test directory.
MMEM:RDIR 'usbtest'

13.9.4  Remote control commands

:MMEMory:CATalog?......................................................................................................237
:MMEMory:CATalog:LENGth?......................................................................................... 238
:MMEMory:CDIRectory...................................................................................................238
:MMEMory:COPY...........................................................................................................238
:MMEMory:DATA............................................................................................................239
:MMEMory:DCATalog?....................................................................................................240
:MMEMory:DCATalog:LENGth?....................................................................................... 240
:MMEMory:DELete.........................................................................................................240
:MEMory:HFRee?.......................................................................................................... 240
:MMEMory:LOAD:STATe.................................................................................................241
:MMEMory:MDIRectory...................................................................................................241
:MMEMory:MOVE.......................................................................................................... 241
:MMEMory:MSIS............................................................................................................242
:MMEMory:RDIRectory...................................................................................................242
:MMEMory:STORe:STATe...............................................................................................242

:MMEMory:CATalog? <path>

Returns the content of a particular directory.

Query parameters: 
<path> string

String parameter to specify the directory.
If you leave out the path, the command returns the contents of
the directory selected with :MMEMory:CDIRectory.
The path may be relative or absolute.

Return values: 
<UsedDiskSpace> Byte size of all files in the directory.

<FreeDiskSpace> Remaining disk space in bytes.

<FileInfo> <NameFileN>,<SuffixFileN>,<SizeFileN>
List of files, separated by commas
<NameFileN>
Name of the file.
<SuffixFileN>
Type of the file. Possible suffixes are: ASCii, BINary, DIRectory
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<SizeFileN>
Size of the file in bytes.

Example: See "Working with Files and Directories" on page 236.

Usage: Query only

:MMEMory:CATalog:LENGth? <Path>

Returns the number of files in the current or in the specified directory.

Query parameters: 
<Path> string

String parameter to specify the directory. If the directory is omit-
ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<FileCount> integer

Number of files.

Example: See "Working with Files and Directories" on page 236.

Usage: Query only

:MMEMory:CDIRectory <Directory>

Changes the default directory for mass memory storage. The directory is used for all
subsequent MMEM commands if no path is specified with them.

Parameters:
<Directory> <directory_name>

String containing the path to another directory. The path can be
relative or absolute.
To change to a higher directory, use two dots '..' .

Example: See "Working with Files and Directories" on page 236.

Usage: SCPI confirmed

:MMEMory:COPY <SourceFile>[,<DestinationFile>]

Copies an existing file to a new file. Instead of just a file, this command can also be
used to copy a complete directory together with all its files.

Setting parameters: 
<SourceFile> string

String containing the path and file name of the source file
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<DestinationFile> string
String containing the path and name of the target file. The path
can be relative or absolute.
If <DestinationFile> is not specified, the <SourceFile> is
copied to the current directory, queried with the :MMEMory:
CDIRectory command.
Note: Existing files with the same name in the destination direc-
tory are overwritten without an error message.

Example: See "Working with Files and Directories" on page 236.

Usage: Setting only
SCPI confirmed

:MMEMory:DATA <Filename>, <BinaryBlock>
:MMEMory:DATA? <Filename>

The setting command writes the block data <BinaryBlock> to the file identified by
<Filename>.

Tip: Use this command to read/transfer stored instrument settings or waveforms
directly from/to the instrument.

Parameters:
<BinaryBlock> #<number><length_entry><data>

#: Hash sign; always comes first in the binary block
<number>: the first digit indicates how many digits the subse-
quent length entry has
<length_entry>: indicates the number of subsequent bytes
<data>: binary block data for the specified length.
For files with a size with more than nine digits (gigabytes), the
instrument allows the syntax #(<Length>), where <Length>
is the file size in decimal format.

Parameters for setting and query: 
<Filename> string

String parameter to specify the name of the file.

Example: MMEMory:DATA '/var/sgs/test.txt',#15hallo
Writes the block data to the file test.txt.
The digit 1 indicates a length entry of one digit; the digit 5 indi-
cate a length of the binary data (hallo) in bytes.
MMEMory:DATA? '/var/sgs/test.txt'
Sends the data of the file test.txt from the instrument to the
controller in the form of a binary block.
Response: #15hallo

Usage: SCPI confirmed
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:MMEMory:DCATalog? <path>

Returns the subdirectories of a particular directory.

Query parameters: 
<path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the content of the current directory,
queried with :MMEMory:CDIRectory command.

Return values: 
<Catalog> <file_entry>

Names of the subdirectories separated by colons. The first two
strings are related to the parent directory.

Example: See "Working with Files and Directories" on page 236.

Usage: Query only

:MMEMory:DCATalog:LENGth? [<Path>]

Returns the number of subdirectories in the current or specified directory.

Query parameters: 
<Path> String parameter to specify the directory. If the directory is omit-

ted, the command queries the contents of the current directory,
to be queried with :MMEMory:CDIRectory command.

Return values: 
<DirectoryCount> integer

Number of parent and subdirectories.

Example: See "Working with Files and Directories" on page 236.

Usage: Query only

:MMEMory:DELete <Filename>

Removes a file from the specified directory.

Setting parameters: 
<Filename> string

String parameter to specify the name and directory of the file to
be removed.

Example: See "Working with Files and Directories" on page 236.

Usage: Event
SCPI confirmed

:MEMory:HFRee?

Returns the used and available memory in Kb.
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Return values: 
<TotalPhysMemKb> integer

Total physical memory.

<ApplicMemKb> integer
Application memory.

<HeapUsedKb> integer
Used heap memory.

<HeapAvailableKb> integer
Available heap memory.

Usage: Query only

:MMEMory:LOAD:STATe <SavRclStateNumb>, <file_name>

Loads the specified file stored under the specified name in an internal memory.

After the file has been loaded, the instrument setting must be activated using an *RCL
command.

Setting parameters: 
<SavRclStateNumb> Determines to the specific <number> to be used with the *RCL

command, e.g. *RCL 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 236.

Usage: Setting only

:MMEMory:MDIRectory <Directory>

Creates a subdirectory for mass memory storage in the specified directory. If no direc-
tory is specified, a subdirectory is created in the default directory. This command can
also be used to create a directory tree.

Setting parameters: 
<Directory> string

String parameter to specify the new directory.

Example: See "Working with Files and Directories" on page 236.

Usage: Event

:MMEMory:MOVE <SourceFile>, <DestinationFile>

Moves an existing file to a new location or, if no path is specified, renames an existing
file.
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Setting parameters: 
<SourceFile> string

String parameter to specify the name of the file to be moved.

<DestinationFile> string
String parameters to specify the name of the new file.

Example: See "Working with Files and Directories" on page 236.

Usage: Event
SCPI confirmed

:MMEMory:MSIS <Msis>

Defines the drive or network resource (in the case of networks) for instruments with
windows operating system, using msis (MSIS = Mass Storage Identification String).

Note: Instruments with Linux operating system ignore this command, since Linux does
not use drive letter assignment.

Usage: SCPI confirmed

:MMEMory:RDIRectory <Directory>

Removes an existing directory from the mass memory storage system. If no directory
is specified, the subdirectory with the specified name is deleted in the default directory.

Setting parameters: 
<Directory> string

String parameter to specify the directory to be deleted.

Example: See "Working with Files and Directories" on page 236.

Usage: Event

:MMEMory:STORe:STATe <savrcl_state_nr>, <file_name>

Stores the current instrument setting in the specified file.

The instrument setting must first be stored in an internal memory with the same num-
ber using the common command *SAV.

Setting parameters: 
<savrcl_state_nr> Corresponds to the specific <number> defined with the *SAV

command, e.g. *SAV 4.

<file_name> String parameter to specify the file name with extension
*.savrcltxt.

Example: See "Storing and Loading Current Settings" on page 236.

Usage: Event
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13.10  Fast speed commands

This section describes special commands that allow a fast frequency and level setting.

:FFASt.......................................................................................................................... 243
:PFASt.......................................................................................................................... 243

:FFASt <Freq>

Special command to set the RF output frequency with minimum latency. No unit (e.g.
Hz) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Freq> float

Example: FFASt 12750000000

:PFASt <Pow>

Special command to set the RF output level with minimum latency at the RF output
connector. This value does not consider a specified offset. No unit (e.g. dBm) allowed.

Bypasses the status system so command *OPC? cannot be appended.

Parameters:
<Pow> float

Example: :PFASt -20

13.11  OUTPut subsystem

:OUTPut:AFIXed:RANGe:LOWer?...................................................................................243
:OUTPut:AFIXed:RANGe:UPPer?....................................................................................244
:OUTPut:AMODe........................................................................................................... 244
:OUTPut[:STATe]:PON....................................................................................................244
:OUTPut[:STATe]............................................................................................................245

:OUTPut:AFIXed:RANGe:LOWer?

Queries the minimum level which can be set without the attenuator being adjusted
(Attenuator FIXed).

Return values: 
<Lower> float

Default unit: dBm

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Usage: Query only
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Manual operation: See "Level Range" on page 102

:OUTPut:AFIXed:RANGe:UPPer?

Queries the maximum level which can be set without the attenuator being adjusted
(Attenuator FIXed).

Return values: 
<Upper> float

Default unit: dBm

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Usage: Query only

Manual operation: See "Level Range" on page 102

:OUTPut:AMODe <AMode>

Switches the mode of the attenuator at the RF output.

Parameters:
<AMode> AUTO | FIXed | APASsive

AUTO
The attenuator is switched automatically. The level settings are
made in the full range.
APASsive
The attenuator is switched automatically. The level settings are
made only for the passive reference circuits. The high-level
ranges are not available.
FIXed
The level settings are made without switching the attenuator.
When this operating mode is switched on, the attenuator is fixed
to its current position and the resulting variation range is defined.
*RST: AUTO

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Mode" on page 101

:OUTPut[:STATe]:PON <Pon>

Selects the state which the RF output assumes when the instrument is switched on.

Parameters:
<Pon> OFF | UNCHanged

*RST: UNCHanged
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Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "Power-On State" on page 103

:OUTPut[:STATe] <State>

Activates/ deactivates the RF output.

Parameters:
<State> 1 | ON | 0 | OFF

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "RF On/Off" on page 73

13.12  SENSe, READ, INITiate and SLISt subsystems

These subsystems contain the commands for configuring the power measurements
with R&S NRP power sensor connected to the R&S SGS.

The local state is set with the INIT command. Switching off the local state enhances
the measurement performance. Measurements results can be retrieved in local state
on or off.
Sensor parameters are set with the SENSe commands.
To start the measurement and retrieve the result, use the :READ<ch>[:POWer]?
command.

Suffix Value range Description

SENSe<ch> [1] to 4 Indicates the sensor

Use the :SLISt commands to change the sensor mapping

READ<ch> [1] to 4 Sensor assignment

INIate<hw> [1] to 4 Sensor assignment

ELEMent<ch> [1] to 25 Sensor-mapping list
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Programming examples

Example: Detecting and assigning a power sensor
SLISt:LIST?
// Response: "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy"
// Lists all automatically detected sensors.

SLISt:SCAN:STATe 1
// Searches for sensors connected in the LAN or via the USBTMC protocol.

SLISt:SCAN:LSENsor 'NRQ6',101624 // sensor name, serial number
SLISt:SCAN:LSENsor 11.123.1.123, 101624 // IP address, serial number
// Adds sensors to the list, that are connected to LAN.

SLISt:SCAN:USENsor 'NRQ6',101624 //sensor name, serial number
SLISt:SCAN:USENsor #H15b,101624  //device ID (hexadecimal), serial number
SLISt:SCAN:USENsor 347,101624    //device ID (decimal), serial number
// Adds a sensor to the list, that is connected to the USB interface.

SLISt:LIST?
// Response: "NRP33SN-V-900007-USB Legacy","NRP-Z211-900001-USB Legacy",
// "NRP33SN-V-900005-USBTMC","NRP33SN-V-900011-LAN"
// Lists all automatically detected sensors.

SLISt:ELEMent3:MAPPing SENS1
// Maps the third sensor from the list to the first sensor channel.

SLISt:SENSor:MAP "NRPS18S-100654-USB Legacy", SENS3
// Maps the sensor to channel 3.

SLISt:CLEar[ALL]
// Remove all sensors from the list.
SLISt:CLEar:LAN 
// Remove all sensors from the list, that are connected over LAN.
SLISt:CLEar:USB 
// Remove all sensors from the list, that are connected over USB.

Example: Performing a simple power measurement
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
INITiate1:CONTinuous ON
// Switches the continous power measurement on.

READ1?
// Triggers the measurement and displays the results.
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Example: Performing a power measurement with a fixed filter
Prerequisite: The sensor is connected to the instrument and mapped to the first sensor
channel.
SENSe1:SOURce RF 
// Sensor measures the power of the RF signal.

SENSe1:FILTer:TYPE NSRatio
// Selects fixed noise filter mode.

SENSe1:FILTer:NSRatio 0.02 DB
// Sets the maximum noise component in the result to 0.02 DB.

SENSe1:FILTer:NSRatio:MTIMe 10
//Limits the settling time to 10 seconds.

SENSe1:APERture:DEFault:STATe 0
// Deactivates the default aperture time of the sensor.

SENSe1:APERture:TIMe 10e-6
// Sets the aperture time to 10 us.

SENSe1:UNIT DBM
// Selects unit dBm for the measured value.

INITiate:CONTinuous ON
// Switches the continous power measurement on.

READ?
// Triggers the measurement and displays the results.

:SLISt[:LIST]?................................................................................................................ 248
:SLISt:SCAN[:STATe]......................................................................................................248
:SLISt:SCAN:LSENsor....................................................................................................248
:SLISt:SCAN:USENsor................................................................................................... 249
:SLISt:CLEar:LAN.......................................................................................................... 249
:SLISt:CLEar:USB..........................................................................................................249
:SLISt:CLEar[:ALL].........................................................................................................250
:SLISt:ELEMent<ch>:MAPPing........................................................................................250
:SLISt:SENSor:MAP.......................................................................................................250
:INITiate<hw>[:POWer]:CONTinuous............................................................................... 250
:READ<ch>[:POWer]?.................................................................................................... 251
:SENSe<ch>:UNIT[:POWer]............................................................................................251
:SENSe<ch>[:POWer]:APERture:DEFault:STATe.............................................................. 252
:SENSe<ch>[:POWer]:APERture:TIMe.............................................................................252
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect.......................................................252
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe........................................................253
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?.........................................................253
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?.................................................................. 253
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER].................................................................. 254
:SENSe<ch>[:POWer]:FILTer:NSRatio............................................................................. 254
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:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe.................................................................. 254
:SENSe<ch>[:POWer]:FILTer:SONCe.............................................................................. 255
:SENSe<ch>[:POWer]:FILTer:TYPE................................................................................. 255
:SENSe<ch>[:POWer]:FREQuency..................................................................................256
:SENSe<ch>[:POWer]:LOGGing:STATe............................................................................256
:SENSe<ch>[:POWer]:OFFSet........................................................................................ 257
:SENSe<ch>[:POWer]:OFFSet:STATe..............................................................................257
:SENSe<ch>[:POWer]:SNUMber?................................................................................... 257
:SENSe<ch>[:POWer]:SOURce.......................................................................................257
:SENSe<ch>[:POWer]:STATus[:DEVice]?......................................................................... 258
:SENSe<ch>[:POWer]:SVERsion?...................................................................................258
:SENSe<ch>[:POWer]:TYPE?......................................................................................... 258
:SENSe<ch>[:POWer]:ZERO.......................................................................................... 259

:SLISt[:LIST]?

Returns a list of all detected sensors in a comma-separated string.

Return values: 
<SensorList> String of comma-separated entries

Each entry contains information on the sensor type, serial num-
ber and interface.
The order of the entries does not correspond to the order the
sensors are displayed in the "NRP Sensor Mapping" dialog.

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Usage: Query only

Manual operation: See "Sensor Mapping List" on page 116

:SLISt:SCAN[:STATe] <State>

Starts the search for R&S NRP power sensors, connected in the LAN or via the
USBTMC protocol.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Manual operation: See "Scan" on page 116

:SLISt:SCAN:LSENsor <IP>

Scans for R&S NRP power sensors connected in the LAN.
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Setting parameters: 
<IP> string

*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Usage: Setting only

Manual operation: See "Add LAN Sensor settings" on page 117

:SLISt:SCAN:USENsor <DeviceID>, <Serial>

Scans for R&S NRP power sensors connected over a USB interface.

Parameters:
<Serial> integer

Range: 0  to  999999

Setting parameters: 
<DeviceID> String or Integer

Range: 0  to  999999
*RST: 0

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Usage: Setting only

Manual operation: See "Add USB Sensor settings" on page 117

:SLISt:CLEar:LAN

Removes all R&S NRP power sensors connected in the LAN from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Usage: Event

Manual operation: See "Clear" on page 116

:SLISt:CLEar:USB

Removes all R&S NRP power sensors connected over USB from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Usage: Event

Manual operation: See "Clear" on page 116
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:SLISt:CLEar[:ALL]

Removes all R&S NRP power sensors from the list.

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Usage: Event

Manual operation: See "Clear" on page 116

:SLISt:ELEMent<ch>:MAPPing <Mapping>

Assigns an entry from the :SLISt[:LIST]? to one of the four sensor channels.

Parameters:
<Mapping> SENS1 | SENSor1 | SENS2 | SENSor2 | SENS3 | SENSor3 |

SENS4 | SENSor4 | UNMapped
Sensor channel.
*RST: UNMapped

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Manual operation: See "Sensor Mapping List" on page 116

:SLISt:SENSor:MAP <SensorId>, <Mapping>

Assigns a sensor directly to one of the sensor channels, using the sensor name and
serial number.

To find out the the sensor name and ID, you can get it from the label of the R&S NRP,
or using the command :SLISt:SCAN[:STATe]. This command detects all R&S NRP
power sensors connected in the LAN or via 'USBTMC protocol.

Setting parameters: 
<SensorId> string

<Mapping> enum

Example: See Example "Detecting and assigning a power sensor"
on page 246.

Usage: Setting only

Manual operation: See "Sensor Mapping List" on page 116

:INITiate<hw>[:POWer]:CONTinuous <Continuous>

Switches the local state of the continuous power measurement by R&S NRP power
sensors on and off. Switching off local state enhances the measurement performance
during remote control.
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The remote measurement is triggered with :READ<ch>[:POWer]?). This command
also returns the measurement results. The local state is not affected, measurement
results can be retrieved with local state on or off.

Parameters:
<Continuous> 0 | 1 | OFF | ON

*RST: 0

Example: :INIT1:CONT ON
Switches local state of continuous power measurement on.

Manual operation: See "State" on page 121

:READ<ch>[:POWer]?

Triggers power measurement and displays the results.

Note: This command does not affect the local state, i.e. you can get results with local
state on or off. For long measurement times, we recommend that you use an SRQ for
command synchronization (MAV bit).

Suffix: 
<ch>

.
1 to 3

Return values: 
<Power> float or float,float

The sensor returns the result in the unit set with command :
SENSe<ch>:UNIT[:POWer]
Certain power sensors, such as the R&S NRP-Z81, return two
values, first the value of the average level and - separated by a
comma - the peak value.

Example: :SENS1:UNIT DBM
Selects unit dBm for presentation of measurement result.
:READ1?
Queries the measurement result of the sensor.
-45.6246576745440230
-45.6 dBm were measured at the given frequency.

Example: R&S NRP-Z81
:READ1?
-55.62403263352178,-22.419472478812476
-55.6 dBm is the measured average level, -22. 4 dBm is the
measured peak level at the given frequency.

Usage: Query only

Manual operation: See "Level (Peak) / Level (Average)" on page 121

:SENSe<ch>:UNIT[:POWer] <Power>

Selects the unit (Watt, dBm or dBμV) of measurement result display, queried with :
READ<ch>[:POWer]?.
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Parameters:
<Power> DBM | DBUV | WATT

*RST: DBM

Example: :SENS2:UNIT DBM
Selects dBm as unit for the measured value returned by com-
mand READ.
:READ2?
Response: 7.34
7.34 dBm are measured by sensor 2.

Manual operation: See "Level (Peak) / Level (Average)" on page 121

:SENSe<ch>[:POWer]:APERture:DEFault:STATe <UseDefAp>

Deactivates the default aperture time of the respective sensor.

To specify a user-defined value, use the command :SENSe<ch>[:POWer]:
APERture:TIMe on page 252.

Parameters:
<UseDefAp> 0 | 1 | OFF | ON

*RST: 1

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 247.

Manual operation: See " Default Aperture Time" on page 123

:SENSe<ch>[:POWer]:APERture:TIMe <ApTime>

Defines the aperture time (size of the acquisition interval) for the corresponding sensor.

Parameters:
<ApTime> float

Range: depends on connected power sensor
Increment: 1E-9
*RST: depends on connected power sensor

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 247.

Manual operation: See "Aperture Time" on page 124

:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect <Select>

Several S-parameter tables can be stored in a sensor. The command selects a loaded
data set for S-parameter correction for the corresponding sensor.

Parameters:
<Select> float

*RST: 0
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Manual operation: See "S-Parameter" on page 124

:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe <State>

Activates the use of the S-parameter correction data.

Note: If you use power sensors with attenuator, the instrument automatically activates
the use of S-parameter data.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: :SENSe1:POWer:CORRection:SPDevice:STATe 1
Activates the use of the S-parameters correction data.

Manual operation: See "S-Parameter" on page 124

:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?

Queries the list of the S-parameter data sets that have been loaded to the power sen-
sor.

Return values: 
<List> string list

*RST: 0

Usage: Query only

Manual operation: See "S-Parameter" on page 124

:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?

Queries the current filter length in filter mode AUTO (:SENSe<ch>[:POWer]:
FILTer:TYPE)

Return values: 
<Auto> float

Range: 1  to  65536

Example: :SENS1:FILT:TYPE AUTO
Selects auto filter.
:SENS1:FILT:LENG:AUTO?
Queries the automatically set filter length.
Response: 1024

Usage: Query only

Manual operation: See "Filter Length" on page 123
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:SENSe<ch>[:POWer]:FILTer:LENGth[:USER] <User>

Selects the filter length for SENS:POW:FILT:TYPE USER. As the filter length works as
a multiplier for the time window, a constant filter length results in a constant measure-
ment time (see also "About the measuring principle, averaging filter, filter length, and
achieving stable results" on page 118).

The R&S NRP power sensors provide different resolutions for setting the filter length,
depending on the used sensor type:
● Resolution = 1 for R&S NRPxx power sensors
● Resolution = 2n for sensors of the R&S NRP-Zxx family, with n = 1 to 16

Parameters:
<User> float

Range: 1  to  65536
*RST: 1

Example: :SENS1:FILT:TYPE USER
Selects user filter mode.
:SENS1:FILT:LENG 16
Sets a filter length of 16. E.g. using a sensor with 20 ms time
window, the resulting measurement time is 640 ms (2x16x20
ms)

Manual operation: See "Filter Length" on page 123

:SENSe<ch>[:POWer]:FILTer:NSRatio <NSRatio>

Sets an upper limit for the relative noise content in fixed noise filter mode (:
SENSe<ch>[:POWer]:FILTer:TYPE). This value determines the proportion of intrin-
sic noise in the measurement results.

Parameters:
<NSRatio> float

Range: 0.001  to  1
Increment: 0.001
*RST: 0.01

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 247.

Manual operation: See "Noise Content" on page 123

:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe <MTime>

Sets an upper limit for the settling time of the auto-averaging filter in the NSRatio
mode and thus limits the length of the filter. The filter type is set with command :
SENSe<ch>[:POWer]:FILTer:TYPE.
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Parameters:
<MTime> float

Range: 1  to  999.99
Increment: 0.01
*RST: 4

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 247.

Manual operation: See "Timeout" on page 123

:SENSe<ch>[:POWer]:FILTer:SONCe

Starts searching the optimum filter length for the current measurement conditions. You
can check the result with command :SENS1:POW:FILT:LENG:USER? in filter mode
USER (:SENSe<ch>[:POWer]:FILTer:TYPE).

Example: SENS1:FILT:TYPE USER
Selects user filter mode.
:SENS1:FILT:SONC
Activates the search for the optimum filter length.
:SENS1:FILT:LENG?
Returns the found optimum filter length.
Response: 128

Usage: Event

Manual operation: See "Auto Once" on page 123

:SENSe<ch>[:POWer]:FILTer:TYPE <Type>

Selects the filter mode. The filter length is the multiplier for the time window and thus
directly affects the measurement time.

Parameters:
<Type> AUTO | USER | NSRatio

AUTO
Automatically selects the filter length, depending on the mea-
sured value. The higher the power, the shorter the filter length,
and vice versa.
USER
Allows you to set the filter length manually. As the filter-length
takes effect as a multiplier of the measurement time, you can
achieve constant measurement times.
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NSRatio
Selects the filter length (averaging factor) according to the crite-
rion that the intrinsic noise of the sensor (2 standard deviations)
does not exceed the specified noise content. You can define the
noise content with command :SENSe<ch>[:POWer]:FILTer:
NSRatio.
Note: To avoid long settling times when the power is low, you
can limit the averaging factor limited with the "timeout" parame-
ter (:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe).
*RST: AUTO

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 247.

Manual operation: See "Filter" on page 122

:SENSe<ch>[:POWer]:FREQuency <Frequency>

Sets the RF frequency of the signal, if signal source "USER" is selected (:
SENSe<ch>[:POWer]:SOURce).

Parameters:
<Frequency> float

*RST: 1 GHz

Example: :SENS1:SOUR USER
Selects user-defined source.
:SENS1:FREQ 2.44GHz
Sets the RF frequency of the source which is 2.44 GHz.

Manual operation: See "Frequency" on page 122

:SENSe<ch>[:POWer]:LOGGing:STATe <State>

Activates the recording of the power values, measured by a connected R&S NRP
power sensor.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: :SENS:LOGG:STAT ON
Activates recording of the power measurement of the first sen-
sor.

Manual operation: See "Enable Logging" on page 124
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:SENSe<ch>[:POWer]:OFFSet <Offset>

Sets a level offset which is added to the measured level value after activation with
command :SENSe<ch>[:POWer]:OFFSet:STATe. The level offset allows, e.g. to
consider an attenuator in the signal path.

Parameters:
<Offset> float

Range: -100.0  to  100.0
*RST: 0
Default unit: dB

Example: :SENS1:POW:OFFS 10.0
Sets a level offset of 10 dB

Manual operation: See "Level Offset State,Level Offset" on page 122

:SENSe<ch>[:POWer]:OFFSet:STATe <State>

Activates the addition of the level offset to the measured value. The level offset value is
set with command :SENSe<ch>[:POWer]:OFFSet.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: :SENS1:POW:OFFS 0.4dB
Sets a level offset of 0.4 dB
:SENS1:POW:OFFS:STAT ON
A level offset of 0.4 dB is added to the measured value.

Manual operation: See "Level Offset State,Level Offset" on page 122

:SENSe<ch>[:POWer]:SNUMber?

Queries the serial number of the sensor.

Return values: 
<SNumber> string

Example: :SENS1:SNUM?
Queries the serial number.

Usage: Query only

Manual operation: See "Sensor type and serial number" on page 121

:SENSe<ch>[:POWer]:SOURce <Source>

Determines the signal to be measured.

SENSe, READ, INITiate and SLISt subsystems
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Note: When measuring the RF signal, the sensor considers the corresponding correc-
tion factor at that frequency, and uses the level setting of the instrument as reference
level.

Parameters:
<Source> A | USER | RF

*RST: A

Example: See Example "Performing a power measurement with a fixed fil-
ter" on page 247.

Manual operation: See "Source" on page 122

:SENSe<ch>[:POWer]:STATus[:DEVice]?

Queries if a sensor is connected to the instrument.

Return values: 
<Status> 0 | 1 | OFF | ON

*RST: 0

Example: :SENS1:STAT?
Response: 1
A sensor is connected.

Usage: Query only

Manual operation: See "State" on page 121

:SENSe<ch>[:POWer]:SVERsion?

Queries the software version of the connected R&S NRP power sensor.

Return values: 
<SVersion> string

Example: :SENS1:POW:SVER?
Queries the software version of the power sensor.

Usage: Query only

:SENSe<ch>[:POWer]:TYPE?

Queries the sensor type. The type is automatically detected.

Return values: 
<Type> string

Example: :SENS1:TYPE?
Queries the type of sensor.
Response: NRP-Z21
The R&S NRP-Z21 sensor is used.

Usage: Query only
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Manual operation: See "Sensor type and serial number" on page 121

:SENSe<ch>[:POWer]:ZERO

Performs zeroing of the sensor.

Zeroing is required after warm-up, i.e. after connecting the sensor.

Note: Switch off or disconnect the RF power source from the sensor before zeroing.

We recommend that you zero in regular intervals (at least once a day), if:
● The temperature has varied more than about 5 °C.
● The sensor has been replaced.
● You want to measure very low power.

Example: :SENS1:ZERO
Executes zeroing.

Usage: Event

Manual operation: See "Zero" on page 121

13.13  SOURce subsystem

[:SOURce]:OPMode....................................................................................................... 259
[:SOURce]:FREQuency[:CW|FIXed].................................................................................259
[:SOURce]:FREQuency:OFFSet......................................................................................260
[:SOURce]:LOSCillator:SOURce......................................................................................260
[:SOURce]:PATH:COUNt?...............................................................................................261

[:SOURce]:OPMode <OpMode>

Sets the operation mode.

Parameters:
<OpMode> NORMal | BBBYpass

NORMal
normal operation
BBBYpass
Baseband bypass mode
*RST: NORMal

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Operation Mode" on page 91

[:SOURce]:FREQuency[:CW|FIXed] <Cw>

Sets the RF frequency at the RF output connector of the selected instrument.
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Note: Enabled frequency offset affects the result of this query. The query returns the
frequency, including frequency offset.

See [:SOURce]:FREQuency:OFFSet on page 260.

Parameters:
<Cw> float

*RST: 1 GHz

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Freq/Freq (Offs)" on page 73
See "Frequency" on page 92

[:SOURce]:FREQuency:OFFSet <Offset>

Sets a frequency offset, for example include the frequency shift of downstream instru-
ment.

Note: Enabled frequency offset affects the result of the query :SOURce:FRE 
Quency:CW?
The query returns the frequency, including frequency offset.

Parameters:
<Offset> float

Range: -3e9  to  3e9
Increment: 0.001
*RST: 0

Example: SOURce:FREQuency:OFFSet 0
SOURce:FREQuency:CW 6000000000
SOURce:FREQuency:OFFSet 20000000
SOURce:FREQuency:CW?
// 6020000000

Manual operation: See "Offset" on page 92

[:SOURce]:LOSCillator:SOURce <Source>

Selects the source of the local oscillator signal.

Parameters:
<Source> INTernal | EXTernal

INT: use built in oscillator; EXT: use signal at [REF/LO IN] con-
nector
*RST: INTernal

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Source" on page 95
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[:SOURce]:PATH:COUNt?

Queries the number of installed RF paths.

Return values: 
<Count> integer

Range: 1  to  INT_MAX
*RST: 1

Example: PATH:COUN?
Queries the number of RF paths.
Response: 1
The instrument is equipped with one RF path.

Usage: Query only

13.14  SOURce:CORRection subsystem

The output level is corrected in the CORRection subsystem. Correction is performed
by user-defined table values being added to the output level for the respective RF fre-
quency. In the R&S SGS, this subsystem is used to select, transfer and activate user
correction tables.

Each list is stored as a file. The name of the user correction file can be freely selected.
The file extension *.uco is assigned automatically and cannot be changed.

The files can be stored in a freely selectable directory and opened from there. The
default directory is set using command :MMEMory:CDIRectory on page 238. In the
case of files which are stored in the default directory, only the file name has to be
specified in commands. Otherwise, the complete absolute path has to be specified with
every command. The extension can be omitted in any case.

In the following command examples, the files are stored in the default directory.

[:SOURce]:CORRection:CSET:CATalog?..........................................................................262
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency..................................................... 262
[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency:POINts?........................................262
[:SOURce<hw>]:CORRection:CSET:DATA:POWer............................................................ 263
[:SOURce<hw>]:CORRection:CSET:DATA:POWer:POINts?...............................................263
[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe.........................264
[:SOURce]:CORRection:CSET:DELete.............................................................................264
[:SOURce<hw>]:CORRection:DEXChange:AFILe:CATalog?...............................................264
[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension.............................................265
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect..................................................265
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn................................266
[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal................................266
[:SOURce<hw>]:CORRection:DEXChange:EXECute.........................................................267
[:SOURce<hw>]:CORRection:DEXChange:MODE............................................................ 267
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[:SOURce<hw>]:CORRection:DEXChange:SELect............................................................268
[:SOURce<hw>]:CORRection:CSET[:SELect]................................................................... 268
[:SOURce<hw>]:CORRection[:STATe]..............................................................................269
[:SOURce<hw>]:CORRection:VALue?..............................................................................269
[:SOURce<hw>]:CORRection:ZERoing:STATe.................................................................. 269

[:SOURce]:CORRection:CSET:CATalog?

Requests a list of user correction tables. The individual lists are separated by commas.

The lists are stored with the fixed file extensions *.uco in a directory of the user's
choice. The directory applicable to the commands is defined with the command
MMEMory:CDIR.

Return values: 
<Catalog> string

Example: MMEM:CDIR '/var/sgs/ucor'
selects the directory for the user correction files.
CORR:CSET:CAT?
queries which correction tables are available.
Response:UCOR1,UCOR2,UCOR3
the correction tables UCOR1, UCOR2 and UCOR3 are availa-
ble.

Usage: Query only

[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency <Frequency>

Transfers the frequency data to the table selected with :CORRection:CSET:SELect.

The numerical suffix at SOURce must not be used for this command.

Parameters:
<Frequency> Frequency#1[, Frequency#2, ...]

Range: 300 kHz  to  RFmax (depending on model)

Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR:CSET:DATA:FREQ 100MHz,102MHz,103MHz,...
enters the frequency value in the table ucor1.

Manual operation: See "Edit User Cor. Data" on page 106

[:SOURce<hw>]:CORRection:CSET:DATA:FREQuency:POINts?

Queries the number of frequency values in the selected table.

The numerical suffix at SOURce must not be used for this command.
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Return values: 
<Points> integer

Range: 0  to  10000
*RST: 0

Example: CORR:CSET '/var/sgs/'
selects the table ucor1.
CORR:CSET:DATA:FREQ:POIN?
queries the number of frequency values in the table ucor1.
Response: 440
the table ucor1 contains 440 frequency values.

Usage: Query only

[:SOURce<hw>]:CORRection:CSET:DATA:POWer <Power>

Transfers the level data to the table selected with [:SOURce<hw>]:CORRection:
CSET[:SELect].

*RST does not affect data lists. The numerical suffix at SOURce must not be used for
this command.

Parameters:
<Power> Power#1[, Power#2, ...]

Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR:CSET:DATA:POW 1dB, 0.8dB, 0.75dB,...
enters the level values in the table ucor1.

Manual operation: See "Edit User Cor. Data" on page 106

[:SOURce<hw>]:CORRection:CSET:DATA:POWer:POINts?

Queries the number of level values in the selected table.

The numerical suffix at SOURce must not be used for this command.

Return values: 
<Points> integer

Range: 0  to  10000
*RST: 0

Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR:CSET:DATA:POW:POIN?
queries the number of level values in the table ucor1.
Response: 440
the table ucor1 contains 440 level values.

Usage: Query only
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[:SOURce<hw>]:CORRection:CSET:DATA[:SENSor<ch>][:POWer]:SONCe

The command fills the selected user correction list with the level values measured by
the power sensor for the given frequencies.

To select the used power sensor set the suffix in key word SENSe.

Example: CORR:CSET:DATA:SENS:POW:SONC
fills the user correction list with level values acquired by the
power sensor connector to the [SENSOR] connector.

Usage: Event

Manual operation: See "Fill User Correction Data with Sensor" on page 112

[:SOURce]:CORRection:CSET:DELete <Filename>

Deletes the specified table.

The lists are stored with the fixed file extensions *.uco in a directory of the user's
choice. The directory applicable to the commands is defined with the command
MMEMory:CDIR. A path can also be specified in command SOUR:CORR:CSET:CAT?,
in which case the file in the specified directory is deleted.

Setting parameters: 
<Filename> <table name>

Example: MMEM:CDIR '/var/sgs/ucor'
selects the directory for the user correction files.
CORR:CSET:DEL 'UCOR1'
deletes the table ucor1.

Usage: Setting only

Manual operation: See "User Cor. Data" on page 106

[:SOURce<hw>]:CORRection:DEXChange:AFILe:CATalog?

Requests a list of available ASCII files for export/import of user correction data. The
individual files are separated by commas.

The ASCII files are stored with the fixed file extensions *.txt or *.csv in a directory
of the user's choice. The directory applicable to the commands is defined with the com-
mand MMEMory:CDIR.

Return values: 
<Catalog> string
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Example: MMEM:CDIR '/var/sgs/import'
selects the directory for the ASCII files with frequency and level
value pairs.
CORR:DEXC:AFIL:EXT TXT
selects that ASCII files with extension *.txt are listed.
CORR:DEXC:AFIL:CAT?
queries the available files with extension *.txt.
Response: 'ucor1,ucor2'
the ASCII files ucor1.txt and ucor2.txt are available.

Usage: Query only

[:SOURce<hw>]:CORRection:DEXChange:AFILe:EXTension <Extension>

Selects the file extension of the ASCII file to be imported or exported. Selection TXT
(text file) or CSV (Excel file) is available.

Parameters:
<Extension> TXT | CSV

*RST: TXT

Example: MMEM:CDIR '/var/sgs/import'
selects the directory for the ASCII files with frequency and level
value pairs.
CORR:DEXC:AFIL:EXT TXT
selects that ASCII files with extension *.txt are listed.
CORR:DEXC:AFIL:CAT?
queries the available files with extension *.txt.
Response: 'list1,list2'
the ASCII files ucor1.txt and ucor2.txt are available.

Manual operation: See "Extension" on page 108

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SELect <Filename>

Selects the ASCII file to be imported or exported.

The ASCII files are stored with the fixed file extensions *.txt or *.csv in a directory
of the user's choice. The directory applicable to the commands is defined with the com-
mand MMEMory:CDIR. A path can also be specified in command
SOUR:CORR:DEXC:AFIL:SEL, in which case the files are stored or loaded in the
specified directory.

Parameters:
<Filename> <ascii file name>
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Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.

Manual operation: See "Select ASCII Source/Destination" on page 109

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:COLumn <Column>

Selects the separator between the frequency and level column of the ASCII table.

Parameters:
<Column> TABulator | SEMicolon | COMMa | SPACe

*RST: COMMa

Example: CORR:DEXC:MODE EXP
selects that the user correction list is exported into an ASCII file.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects ASCII file ucor.csv as destination for the user correction
list data.
CORR:DEXC:AFIL:SEP:COL TAB
the pairs of frequency and level values are separated by a tabu-
lator.
CORR:DEXC:AFIL:SEP:DEC DOT
selects the decimal separator dot.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the user correction list ucor_imp is imported into
ASCII file ucor.csv.

Manual operation: See "Column Separator" on page 109

[:SOURce<hw>]:CORRection:DEXChange:AFILe:SEParator:DECimal <Decimal>

Selects the decimal separator used in the ASCII data between '.' (decimal point) and ','
(comma) with floating-point numerals.

Parameters:
<Decimal> DOT | COMMa

*RST: DOT
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Example: CORR:DEXC:MODE EXP
selects that the user correction list is exported into an ASCII file.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects ASCII file ucor.csv as destination for the user correction
list data.
CORR:DEXC:AFIL:SEP:COL TAB
the pairs of frequency and level values are separated by a tabu-
lator.
CORR:DEXC:AFIL:SEP:DEC DOT
selects the decimal separator dot.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the user correction list ucor_imp is imported into
ASCII file ucor.csv.

Manual operation: See "Decimal Point" on page 108

[:SOURce<hw>]:CORRection:DEXChange:EXECute

Starts the export or import of the selected file. When import is selected, the ASCII file is
imported as user correction list. When export is selected, the user correction list is
exported into the selected ASCII file.

Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.
CORR:DEXC:EXEC
starts the import of the ASCII file data into the user correction
file.

Usage: Event

Manual operation: See "Import/Export" on page 109

[:SOURce<hw>]:CORRection:DEXChange:MODE <Mode>

Selects if user correction lists should be imported or exported. Depending on the selec-
tion her, the file select command define either the source or the destination for user
correction lists and ASCII files.

Parameters:
<Mode> IMPort | EXPort

*RST: IMPort
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Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.

Manual operation: See "Mode" on page 108

[:SOURce<hw>]:CORRection:DEXChange:SELect <Filename>

Selects the user correction list to be imported or exported.

The user correction files are stored with the fixed file extensions *.uco in a directory
of the user's choice. The directory applicable to the commands is defined with the com-
mand MMEMory:CDIR. A path can also be specified in command
SOUR:CORR:DEXC:SEL, in which case the files are stored or loaded in the specified
directory.

Parameters:
<Filename> string

Example: CORR:DEXC:MODE IMP
selects that ASCII files with frequency and level value pairs are
imported and transferred into user correction lists.
CORR:DEXC:AFIL:SEL '/var/sgs/import_ucor.csv'
selects that ASCII file ucor.csv is imported.
CORR:DEXC:SEL '/var/sgs/import_ucor_imp'
selects that the ASCII file ucor.csv is imported into user cor-
rection list ucor_imp.

Manual operation: See "Select Destination/Source" on page 109

[:SOURce<hw>]:CORRection:CSET[:SELect] <Filename>

Selects or creates a file for the user correction data.

If the file does not exist, the instrument automatically creates a new file with the name
you assigned. Note the predefined file extensions under Chapter 13.9.2, "Extensions
for user files", on page 235.

To determine the file location (directory/path) you can either enter it with the command
directly, or use the command MMEMory:CDIR.

To activate level correction use the command [:SOURce<hw>]:CORRection[:
STATe].

Parameters:
<Filename> <table name>
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Example: CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
CORR ON
activates level correction. Correction is performed using the
table ucor1.

Manual operation: See "User Cor. Data" on page 106
See "Edit User Cor. Data" on page 106

[:SOURce<hw>]:CORRection[:STATe] <State>

Activates/deactivates level correction. Level correction is performed using the table
which has been selected with the command [:SOURce<hw>]:CORRection:CSET[:
SELect].

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: SOUR:CORR:CSET '/var/sgs/ucor1'
selects the table ucor1.
SOUR:CORR ON
activates user correction.

Manual operation: See "State" on page 105

[:SOURce<hw>]:CORRection:VALue?

Queries the current value for user correction.

Return values: 
<Value> float

Range: -100  to  100
Increment: 0.01
*RST: 0

Example: CORR:VAL?
queries the value currently used for level correction.
Response: -3
the correction value is - 3 dB.

Usage: Query only

Manual operation: See "User Correction" on page 105

[:SOURce<hw>]:CORRection:ZERoing:STATe <State>

Activates the zeroing procedure before filling the user correction data acquired by a
sensor.
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Parameters:
<State> 0 | 1 | OFF | ON

*RST: 1

Manual operation: See "Fill User Correction Data with Sensor" on page 112

13.15  SOURce:IQ subsystem

[:SOURce]:IQ:STATe...................................................................................................... 270
[:SOURce]:IQ:IMPairment:IQRatio[:MAGNitude]................................................................270
[:SOURce]:IQ:IMPairment:LEAKage:I...............................................................................271
[:SOURce]:IQ:IMPairment:LEAKage:Q.............................................................................271
[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe]...............................................................271
[:SOURce]:IQ:IMPairment[:STATe]................................................................................... 271
[:SOURce]:IQ:CREStfactor..............................................................................................271
[:SOURce]:IQ:WBSTate.................................................................................................. 272

[:SOURce]:IQ:STATe <State>

Switches the I/Q modulation on and off.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Mod State" on page 74

[:SOURce]:IQ:IMPairment:IQRatio[:MAGNitude] <IqRatio>

Sets the ratio of I modulation to Q modulation (amplification “imbalance”). The input
may be either in dB or %. The resolution is 0.001 dB, an input in percent is rounded to
the closest valid value in dB. A query returns the value in dB.

Parameters:
<IqRatio> float

Range: -1  to  1
Increment: 1E-3
*RST: 0

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Gain Imbalance" on page 135
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[:SOURce]:IQ:IMPairment:LEAKage:I <I>
[:SOURce]:IQ:IMPairment:LEAKage:Q <Q>
Sets the carrier leakage amplitude for the I-signal/ Q-signal component.

Parameters:
<Q> float

Range: -5  to  5
Increment: 0.01
*RST: 0
Default unit: PCT

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Offset" on page 135

[:SOURce]:IQ:IMPairment:QUADrature[:ANGLe] <Angle>

Sets the quadrature offset for the digital I/Q signal.

Parameters:
<Angle> float

Range: -8  to  8
Increment: 0.01
*RST: 0
Default unit: DEG

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Quadrature Offset" on page 135

[:SOURce]:IQ:IMPairment[:STATe] <State>

Activates/ deactivates the three impairment or correction values LEAKage, QUADra-
ture and IQRatio for the baseband signal prior to input into the I/Q modulator.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "State" on page 134

[:SOURce]:IQ:CREStfactor <CrestFactor>

Sets the crest factor of the IQ modulation signal.
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Parameters:
<CrestFactor> float

Range: 0  to  80
Increment: 0.01
*RST: 0

Example: see Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215

Manual operation: See "Crest Factor" on page 134

[:SOURce]:IQ:WBSTate <State>

Selects optimized settings for wideband modulation signals.

Parameters:
<State> 1 | ON | 0 | OFF

*RST: 0

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "I/Q Wideband" on page 133

13.16  SOURce:PHASe subsystem

[:SOURce]:PHASe......................................................................................................... 272
[:SOURce]:PHASe:REFerence........................................................................................272

[:SOURce]:PHASe <Phase>

Specifies the phase variation relative to the current phase.

Parameters:
<Phase> float

Range: -360  to  360
Increment: 0.1
*RST: 0
Default unit: DEG

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Delta Phase" on page 93

[:SOURce]:PHASe:REFerence

Adopts the phase set with command [:SOURce]:PHASe as the current phase.

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.
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Usage: Event

Manual operation: See "Reset Delta Phase Display" on page 93

13.17  SOURce:POWer subsystem

[:SOURce]:POWer:ALC:DSENsitivity............................................................................... 273
[:SOURce]:POWer:ALC[:STATe]...................................................................................... 273
[:SOURce]:POWer:ALC:SONCe...................................................................................... 273
[:SOURce]:POWer:ATTenuation:RFOFf:MODE................................................................. 274
[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet]..............................................................274
[:SOURce]:POWer:LMODe............................................................................................. 274
[:SOURce]:POWer:POWer..............................................................................................274
[:SOURce]:POWer:SCHaracteristic..................................................................................275
[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude]..........................................................275
[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet................................................................ 276
[:SOURce]:POWer:LIMit[:AMPLitude]...............................................................................276
[:SOURce]:POWer:PEP?................................................................................................ 276
[:SOURce]:POWer:RANGe:LOWer?................................................................................ 277
[:SOURce]:POWer:RANGe:UPPer?................................................................................. 277

[:SOURce]:POWer:ALC:DSENsitivity <Sensitivity>

Sets the power detector sensitivity. Used for compatibility reasons only.

Parameters:
<Sensitivity> OFF | LOW | MED | HIGH

*RST: OFF

Manual operation: See "Detector Sensitivity" on page 104

[:SOURce]:POWer:ALC[:STATe] <State>

Activates/deactivates automatic level control.

Parameters:
<State> 1 | OFFTable | OFF | ONTable | AUTO | ON

*RST: ONTable

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "State" on page 104

[:SOURce]:POWer:ALC:SONCe

Briefly activates level control for correction purposes.

Usage: Event

Manual operation: See "Readjust" on page 101
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[:SOURce]:POWer:ATTenuation:RFOFf:MODE <Mode>

Determines the attenuator's state after the instrument is switched on.

Parameters:
<Mode> MAX | FATTenuated | FIXed | UNCHanged

MAX = FATTenuated
Sets attenuation to maximum when the RF signal is switched off.
This setting is recommended for applications that require a high
level of noise suppression.
FIXed = UNCHanged
Retains the current setting and keeps the output impedance
constant during RF off.
*RST: n.a. (factory preset: MAX)

Manual operation: See "RF-Off-Mode" on page 102

[:SOURce]:POWer:ATTenuation:SOVer[:OFFSet] <Offset>

Sets the switch-over offset value of the attenuator.

Parameters:
<Offset> float

Range: -10  to  10
Increment: 0.1
*RST: 0

Manual operation: See "SATT Switch-Over Offset" on page 102

[:SOURce]:POWer:LMODe <LevMode>

Selects the level mode.

Parameters:
<LevMode> NORMal | LNOise | LDIStortion

NORM
automatic selection of the best settings
LNOISe
settings for lowest noise
LDIStortion
settings for lowest distortions

Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "Mode" on page 100

[:SOURce]:POWer:POWer <Amplitude>

Sets the level at the RF output connector.
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This value does not consider a specified offset. The command [:SOURce]:POWer[:
LEVel][:IMMediate][:AMPLitude] sets the level of the "Level" display, that
means the level containing offset.

Parameters:
<Amplitude> float

Range: -20  to  25
Increment: 0.01
*RST: -10

Example: POW:POW 15
sets the RF level at output to 15 dBm.

Manual operation: See "Level/Level Offset" on page 74

[:SOURce]:POWer:SCHaracteristic <Characteristic>

Selects the characteristic for the level setting.

Parameters:
<Characteristic> AUTO | UNINterrupted | CVSWr | USER | MONotone

UNINterrupted
uninterrupted level setting
CVSWr
constant-VSWR
MONotone
strictly monotone
*RST: AUTO

Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "Setting Characteristic" on page 100

[:SOURce]:POWer[:LEVel][:IMMediate][:AMPLitude] <Amplitude>

Sets the RF level at the RF output connector of the instrument.

Parameters:
<Amplitude> float

Range: -20  to  25
Increment: 0.01
*RST: -10

Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "Level/Level Offset" on page 74
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[:SOURce]:POWer[:LEVel][:IMMediate]:OFFSet <Offset>

Note: The level offset is also effective for level sweeps!

The command specifies the constant level offset of a downstream attenuator/amplifier.
If a level offset is entered, the level entered with [:SOURce]:POWer:POWer no longer
corresponds to the RF output level.

The following correlation applies:

:POWer = RF output level + POWer:OFFSet.

Entering a level offset does not change the RF output level, but rather the query value
of :POWer.

Parameters:
<Offset> float

Range: -100  to  100
Increment: 0.1
*RST: 0

Manual operation: See "Offset" on page 99

[:SOURce]:POWer:LIMit[:AMPLitude] <Amplitude>

Sets the upper limit of the RF signal power.

The value is not affected by an instrument preset and *RST function. This parameter is
influenced only by the factory preset (SYST:FPR) and its factory value is equal to the
upper limit.

Parameters:
<Amplitude> float

Range: -120  to  25
Increment: 0.01
*RST: 25
Default unit: dBm

Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "Limit" on page 101

[:SOURce]:POWer:PEP?

Queries the RF signal's peak envelope power.

Return values: 
<PEP> float

Example: see Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215

Usage: Query only
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Manual operation: See "PEP" on page 74

[:SOURce]:POWer:RANGe:LOWer?
[:SOURce]:POWer:RANGe:UPPer?
Queries the minimum/maximum level range in the current level mode

Return values: 
<Upper> float

Usage: Query only

Manual operation: See "Level Range" on page 100

13.18  SOURce:PULM Subsystem

This subsystem contains the commands for setting the pulse modulation.

Programming Examples

Example: Performing pulse modulation
This example shows a command sequence to perform pulse modulation.

// ******************************************************************
// Reset the instrument to start from an initial state
// ******************************************************************
*RST; *CLS

// ******************************************************************
// Set the RF signal frequency and level
// ******************************************************************
SOURce:FREQuency:CW 4000000000
SOURce:POWer:LEVel:IMMediate:AMPLitude -25

// ******************************************************************
// Configure the pulse modulation settings
// ******************************************************************
// Select the internal modulation generator
SOURce:PULM:SOURce INT
// Set trigger mode
SOURce:PULM:TRIGger:MODE AUTO
// Select pulse mode
SOURce:PULM:MODE DOUB 

// ******************************************************************
// Alternatively configure the pulse modulation settings for 
// external modulation source
// ******************************************************************
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// Select the external modulation source
SOURce:PULM:SOURce EXT
// Set the polarity of the externally applied modulation signal.
SOURce:PULM:POLarity NORMal
// Select the impedance for the external pulse modulation trigger input 
SOURce:PULM:TRIGger:EXTernal:IMPedance G10K

// ******************************************************************
// Configure the pulse generator settings
// ******************************************************************
// Set pulse period
SOURce:PULM:PERiod 10 us
// Set pulse width
SOURce:PULM:WIDth 8 us
// Set double pulse width
SOURce:PULM:DOUBle:WIDTh 0.0000012
// Set double pulse delay
SOURce:PULM:DOUBle:DELay 0.0000045

// ******************************************************************
// Activate the signal output
// ******************************************************************
SOURce:PGENerator:OUTPut:STATe 1
SOURce:PULM:STATe 1
OUTPut1:STATe 1

[:SOURce<hw>]:PULM:DELay........................................................................................ 278
[:SOURce<hw>]:PULM:DOUBle:DELay............................................................................279
[:SOURce<hw>]:PULM:DOUBle:WIDTh........................................................................... 279
[:SOURce<hw>]:PULM:MODE........................................................................................ 279
[:SOURce<hw>]:PULM:PERiod....................................................................................... 279
[:SOURce<hw>]:PULM:POLarity..................................................................................... 280
[:SOURce<hw>]:PULM:SOURce..................................................................................... 280
[:SOURce<hw>]:PULM:STATe.........................................................................................280
[:SOURce<hw>]:PULM:TRIGger:EXTernal:GATE:POLarity.................................................281
[:SOURce<hw>]:PULM:TRIGger:EXTernal:IMPedance...................................................... 281
[:SOURce<hw>]:PULM:TRIGger:EXTernal:SLOPe............................................................ 281
[:SOURce<hw>]:PULM:TRIGger:MODE........................................................................... 281
[:SOURce<hw>]:PULM:WIDTh........................................................................................282

[:SOURce<hw>]:PULM:DELay <Delay>

Sets the pulse delay.

Parameters:
<Delay> float

Range: 0  to  100 s
Increment: 10 ns
*RST: 10 ns
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Example: PULM:DEL 13 us
13 us elapse after a trigger before the first pulse is generated.

Manual operation: See "Pulse Delay" on page 128

[:SOURce<hw>]:PULM:DOUBle:DELay <Delay>

Sets the delay from the start of the first pulse to the start of the second pulse.

Parameters:
<Delay> float

Range: 40 ns  to  100 s
Increment: 10 ns
*RST: 1 ns

Example: PULM:DOUB:DEL 22 us
22 us elapse between the beginning of the first pulse and the
beginning of the second pulse in double-pulse mode.

Manual operation: See "Double Pulse Delay" on page 128

[:SOURce<hw>]:PULM:DOUBle:WIDTh <Width>

Sets the width of the second pulse in case of double pulse generation.

Example: PULM:DOUB:WIDT 33 us
sets a width of 33 us for the second pulse.

Manual operation: See "Double Pulse Width" on page 127

[:SOURce<hw>]:PULM:MODE <Mode>

Sets the mode of the pulse generator.

Parameters:
<Mode> SINGle | DOUBle

SINGle
Enables single pulse generation.
DOUBle
Enables double pulse generation. The two pulses are generated
in one pulse period.
*RST: SINGle

Example: PULM:MODE DOUB
enables double pulse generation.

Manual operation: See "Pulse Mode" on page 127

[:SOURce<hw>]:PULM:PERiod <Period>

Sets the period of the generated pulse. The period determines the repetition frequency
of the internal signal.
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Example: PULM:PER 220 us
the pulse period is 220 us.

Manual operation: See "Pulse Period" on page 127

[:SOURce<hw>]:PULM:POLarity <Polarity>

Sets the polarity of the pulse modulator signal. This command is effective only for an
external modulation signal.

Parameters:
<Polarity> NORMal | INVerted

NORMal
The RF signal is suppressed during the pulse pause.
INVerted
The RF signal is suppressed during the pulse.
*RST: NORMal

Example: PULM:SOUR EXT
selects the external modulation source.

Example: PULM:POL INV
selects inverted polarity.

Manual operation: See "Polarity" on page 126

[:SOURce<hw>]:PULM:SOURce <Source>

Selects the source for pulse modulation.

Parameters:
<Source> INTernal | EXTernal

INTernal
The internal pulse generator is used for the pulse modulation.
EXTernal
The signal applied externally via the trigger connector is used for
the pulse modulation.
*RST: INTernal

Manual operation: See "Source" on page 126

[:SOURce<hw>]:PULM:STATe <State>

Activates the pulse modulation.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: 0

Example: PULM:STAT ON
activates pulse modulation.
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Manual operation: See "State" on page 126

[:SOURce<hw>]:PULM:TRIGger:EXTernal:GATE:POLarity <Polarity>

Selects the polarity of the Gate signal.

Parameters:
<Polarity> NORMal | INVerted

*RST: NORMal

Example: PULM:TRIG:EXT:GATE:POL NORM
The pulse signal is generated while the gate signal is high.

Manual operation: See "Gate Input Polarity" on page 129

[:SOURce<hw>]:PULM:TRIGger:EXTernal:IMPedance <Impedance>

Selects the impedance for external pulse trigger.

Parameters:
<Impedance> G50 | G10K

*RST: G50

Example: SOUR:PULM:TRIG:EXT:IMP G50
selects 50 Ohm as the trigger impedance for the external pulse
trigger.

Manual operation: See "External Impedance" on page 126

[:SOURce<hw>]:PULM:TRIGger:EXTernal:SLOPe <Slope>

Sets the polarity of the active slope of an externally applied trigger signal.

Parameters:
<Slope> NEGative | POSitive

*RST: POSitive

Example: PULM:TRIG:EXT:SLOP NEG
The pulse generator is triggered on the negative slope of the
external trigger signal.

Manual operation: See "Ext. Trigger Input Slope" on page 129

[:SOURce<hw>]:PULM:TRIGger:MODE <Mode>

Selects the trigger mode for pulse modulation.

Parameters:
<Mode> AUTO | EXTernal | EGATe

AUTO
The pulse modulation is generated continuously.
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EXTernal
The pulse modulation is triggered by an external trigger event.
The trigger signal is supplied via the trigger connector.
EGATe
The pulse modulation is gated by an external gate signal. The
trigger signal is supplied via the trigger connector.
*RST: AUTO

Example: PULM:TRIG:MODE EXT
selects triggering by an external trigger event.

Manual operation: See "Trigger Mode" on page 129

[:SOURce<hw>]:PULM:WIDTh <Width>

Sets the width of the generated pulse. The width determines the pulse length. The
pulse width must be at least 20ns less than the set pulse period.

Parameters:
<Width> float

Range: 20 ns  to  100 s
Increment: 10 ns
*RST: 2 us

Example: PULM:WIDT 33 us
sets a width of 33 us for the pulse.

Manual operation: See "Pulse Width" on page 127

13.19  SOURce:ROSCillator subsystem

[:SOURce]:ROSCillator:EXTernal:FREQuency.................................................................. 282
[:SOURce]:ROSCillator:OUTPut:FREQuency....................................................................283
[:SOURce]:ROSCillator:SOURce..................................................................................... 283
[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue.............................................................. 283
[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe].............................................................284
[:SOURce]:ROSCillator:EXTernal:SBANdwidth..................................................................284

[:SOURce]:ROSCillator:EXTernal:FREQuency <ExtFreq>

Selects the frequency of the external reference.

Parameters:
<ExtFreq> 10MHZ | 100MHZ | 1000MHZ | 13MHZ

13MHZ requires RF board with part number 1419.5308.02.
To find out the RF board installed in the instrument:
Select "SGMA-GUI > instrument name > Setup > Hardware
Config" > "RF Assembly"
Observe the part number of the assembly "RfBoard".
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Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "Ext. Ref. Input Frequency" on page 96

[:SOURce]:ROSCillator:OUTPut:FREQuency <OutputFreq>

Selects the output for the reference oscillator signal.

Parameters:
<OutputFreq> 10MHZ | 100MHZ | 1000MHZ | 13MHZ

13MHZ requires RF board with part number 1419.5308.02.

Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "Output Frequency" on page 97

[:SOURce]:ROSCillator:SOURce <Source>

Select the reference oscillator signal source.

Parameters:
<Source> INTernal | EXTernal

Example: See Chapter 13.1.2, "Generating an I/Q modulated signal",
on page 215.

Manual operation: See "Ref. Oscillator Source/Ext Ref On/Off" on page 74

[:SOURce]:ROSCillator[:INTernal]:ADJust:VALue <Value>

Allows an application to shift the reference oscillator frequency by a small amount.

The setting range depends on the reference oscillator type and its factory calibration
value. Allowed are the following ranges:

● For TCXO oscillator: Max - Min = 1023
● For OCXO oscillator: Max - Min = 65535 (option R&S SGS-B1 required.)

Parameters:
<Value> integer

Range: Min  to  Max
*RST: 0

Example: See Chapter 13.1.4, "Advanced tasks to optimize performance",
on page 218.

Manual operation: See "DAC Value" on page 98
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[:SOURce]:ROSCillator[:INTernal]:ADJust[:STATe] <State>

Determines whether the calibrated (OFF) or a user-defined (ON) adjustment value is
used for fine adjustment of the frequency.

If user-defined values are used, the instrument is no longer in the calibrated state.
However, the calibration value is not changed and the instrument resumes the calibra-
ted state after sending the com-
mand :SOURce:ROSCillator:INTernal:ADJust:STATe OFF.

Parameters:
<State> 0 | 1 | OFF | ON

*RST: n.a. (factory preset: 0)

Example: ROSC:SOUR INT
Selects the internal source.
ROSC:ADJ ON
Activates use of a user-defined adjustment value.
ROSC:ADJ:VAL 1400
Sets the adjustment value to 1400.

Manual operation: See "Adjustment Active" on page 98

[:SOURce]:ROSCillator:EXTernal:SBANdwidth <SBandwidth>

Sets the synchronization bandwidth for an external reference signal.

Parameters:
<SBandwidth> WIDE | NARRow

NARRow
The synchronization bandwidth is 40 Hz.
WIDE
Synchronization bandwidth is 250 Hz.
*RST: n.a. (factory preset)

Example: ROSC:SOUR EXT
Selects the external source.
ROSC:EXT:FREQ 10 MHz
Informs the instrument that the external reference has a fre-
quency of 10 MHz.
ROSC:EXT:SBAN WID
Selects wideband setting for synchronization bandwidth.

Manual operation: See "Synchronization Bandwidth" on page 97

13.20  STATus subsystem

This system contains the commands for the status reporting system. See also Chap-
ter 12.5, "Status reporting system", on page 193 for detailed information.

STATus subsystem



Remote control commandsR&S®SGS100A

285User Manual 1173.9105.02 ─ 13

*RST on page 223 has no effect on the status registers.

Value ranges

● Queries return the current value of the respective register, which permits a check of
the device status.
Return values: A decimal value in the range 0 to 32767 (=215-1)

● The configuration commands set the respective register thus determining which
status changes of the R&S SGS cause the status registers to be changed.
Setting values: A decimal value in the range 0 to 32767 (=215-1)

:STATus:OPERation:CONDition?.....................................................................................285
:STATus:OPERation:ENABle...........................................................................................285
:STATus:OPERation[:EVENt]...........................................................................................286
:STATus:OPERation:NTRansition.................................................................................... 286
:STATus:OPERation:PTRansition.....................................................................................286
:STATus:PRESet............................................................................................................286
:STATus:QUEStionable:CONDition.................................................................................. 287
:STATus:QUEStionable:ENABle.......................................................................................287
:STATus:QUEStionable[:EVENt]...................................................................................... 287
:STATus:QUEStionable:NTRansition................................................................................ 287
:STATus:QUEStionable:PTRansition................................................................................ 288
:STATus:QUEue[:NEXT]?................................................................................................288

:STATus:OPERation:CONDition?

Quieries the content of the CONDition part of the STATus:OPERation register.

This part contains information on the action currently being performed in the instru-
ment. The content is not deleted after being read out because it indicates the current
hardware status.

Return values: 
<Condition> string

Example: :STATus:OPERation:CONDition?

Usage: Query only

:STATus:OPERation:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:OPERation register. This setting deter-
mines which events of the Status-Event part are forwarded to the sum bit in the status
byte. These events can be used for a service request.

Parameters:
<Enable> string

Example: :STAT:OPER:ENAB 32767
all events are forwarded to the sum bit of the status byte.
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:STATus:OPERation[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:OPERation register. This part
contains information on the actions performed in the instrument since the last readout.
The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: :STAT:OPER:EVEN?
queries the STATus:OPERation:EVENt register.

:STATus:OPERation:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 1 to 0 in the condition part causes an entry to be made in the EVENt
part of the register. The disappearance of an event in the hardware is thus registered,
for example the end of an adjustment.

Parameters:
<Ntransition> string

Example: :STAT:OPER:NTR 0
a transition from 1 to 0 in the condition part of the Status:Opera-
tion register does not cause an entry to be made in the EVENt
part.

:STATus:OPERation:PTRansition <Ptransition>

Sets the bits of the PTRansition part of the STATus:OPERation register. If a bit is set, a
transition from 0 to 1 in the condition part causes an entry to be made in the EVENt
part of the register. A new event in the hardware is thus registered, for example the
start of an adjustment.

Parameters:
<Ptransition> string

Example: :STAT:OPER:PTR 32767
all transitions from 0 to 1 in the condition part of the Status:Oper-
ation register cause an entry to be made in the EVENt part.

:STATus:PRESet <Preset>

Resets the status registers. All PTRansition parts are set to FFFFh (32767), i.e. all
transitions from 0 to 1 are detected. All NTRansition parts are set to 0, i.e. a transition
from 1 to 0 in a CONDition bit is not detected. The ENABle parts of STATus:OPERation
and STATus:QUEStionable are set to 0, i.e. all events in these registers are not passed
on.

Parameters:
<Preset> string
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Example: STAT:PRES
resets the status registers.

:STATus:QUEStionable:CONDition <Condition>

Queries the content of the CONDition part of the STATus:QUEStionable register. This
part contains information on the action currently being performed in the instrument.
The content is not deleted after being read out since it indicates the current hardware
status.

Parameters:
<Condition> string

Example: :STATus:QUEStionable:CONDition?
queries the Status:Questionable:Condition register.

:STATus:QUEStionable:ENABle <Enable>

Sets the bits of the ENABle part of the STATus:QUEStionable register. The enable part
determines which events of the STATus:EVENt part are enabled for the summary bit in
the status byte. These events can be used for a service request.

If a bit in the ENABle part is 1, and the correesponding EVENt bit is true, a positive
transition occurs in the summary bit. This transition is reportet to the next higher level.

Parameters:
<Enable> string

Example: STAT:QUES:ENAB 1
Problems when performing an adjustment cause an entry to be
made in the sum bit.

:STATus:QUEStionable[:EVENt] <Event>

Queries the content of the EVENt part of the STATus:QUEStionable register. This
part contains information on the actions performed in the instrument since the last
readout. The content of the EVENt part is deleted after being read out.

Parameters:
<Event> string

Example: STAT:QUES:EVEN?
queries the Status:Questionable:Event register.

:STATus:QUEStionable:NTRansition <Ntransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<Ntransition> string
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Example: STAT:QUES:NTR 0
a transition from 1 to 0 in the condition part of the STA-
Tus:QUEStionable register does not cause an entry to be made
in the EVENt part

:STATus:QUEStionable:PTRansition <PTransition>

Sets the bits of the NTRansition part of the STATus:QUEStionable register. If a bit is
set, a transition from 1 to 0 in the condition part causes an entry to be made in the
EVENt part of the register.

Parameters:
<PTransition> string

Example: STAT:QUES:PTR 32767
all transitions from 0 to 1 in the condition part of the STA-
Tus:QUEStionable register cause an entry to be made in the
EVENt part

:STATus:QUEue[:NEXT]?

Queries the oldest entry in the error queue and then deletes it. Positive error numbers
denote device-specific errors, and negative error numbers denote error messages
defined by SCPI. If the error queue is empty, 0 ("No error") is returned.

The command is identical to :SYSTem:ERRor[:NEXT]? on page 291.

Return values: 
<Next> string

Example: :STATus:QUEue?
queries the oldest entry in the error queue.
Response: 0, 'no error'
no errors have occurred since the error queue was last read out

Usage: Query only

13.21  SYSTem subsystem

The SYSTem subsystem contains a series of commands for general functions which do
not directly affect signal generation.

:SYSTem:EMODe.......................................................................................................... 289
:SYSTem:ERRor:ALL?....................................................................................................290
:SYSTem:ERRor:CODE:ALL?......................................................................................... 290
:SYSTem:ERRor:CODE[:NEXT]?.....................................................................................291
:SYSTem:ERRor:COUNt?...............................................................................................291
:SYSTem:ERRor[:NEXT]?...............................................................................................291
:SYSTem:SERRor?........................................................................................................ 292
:SYSTem:VERSion?.......................................................................................................292
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:SYSTem:COMMunicate:NETWork:IPADdress.................................................................. 292
:SYSTem:COMMunicate:NETWork:IPADdress:MODE........................................................293
:SYSTem:COMMunicate:NETWork:MACaddress...............................................................293
:SYSTem:COMMunicate:NETWork:STATus?.................................................................... 293
:SYSTem:COMMunicate:NETWork:RESTart..................................................................... 293
:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname................................................293
:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway..................................................294
:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK..........................................294
:SYSTem:COMMunicate:NETWork:RESource?.................................................................294
:SYSTem:COMMunicate:SERial:BAUD............................................................................ 294
:SYSTem:COMMunicate:SERial:PARity............................................................................295
:SYSTem:COMMunicate:SERial:RESource?.....................................................................295
:SYSTem:COMMunicate:SERial:SBITs.............................................................................295
:SYSTem:COMMunicate:HISLip:RESource?..................................................................... 295
:SYSTem:COMMunicate:PCIexpress:RESource?.............................................................. 296
:SYSTem:COMMunicate:SOCKet:PORT...........................................................................296
:SYSTem:COMMunicate:SOCKet:RESource?...................................................................296
:SYSTem:COMMunicate:USB:RESource?........................................................................ 296
:SYSTem:NINFormation?................................................................................................297
:SYSTem:REBoot...........................................................................................................297
:SYSTem:RESTart..........................................................................................................297
:SYSTem:SHUTdown..................................................................................................... 297
:SYSTem:STARtup:COMPlete?....................................................................................... 297
:SYSTem:PROTect<ch>[:STATe]......................................................................................298
:SYSTem:HARDware:ASSembly<dir>:NAME?.................................................................. 298
:SYSTem:HARDware:ASSembly<dir>:PNUMber?............................................................. 298
:SYSTem:HARDware:ASSembly<dir>:REVision?.............................................................. 299
:SYSTem:HARDware:ASSembly<dir>:SNUMber?............................................................. 299
:SYSTem:SOFTware:OPTion<dir>:DESignation?...............................................................299
:SYSTem:SOFTware:OPTion<dir>:EXPiration?................................................................. 300
:SYSTem:SOFTware:OPTion<dir>:LICenses?...................................................................300
:SYSTem:SOFTware:OPTion<dir>:NAME?....................................................................... 300
:SYSTem:MMEMory:PATH:USER?.................................................................................. 301
:SYSTem:OSYStem?......................................................................................................301

:SYSTem:EMODe <Mode>

Enables and selects the Eco Mode. With enabled eco mode EM1 the doubler stage in a
12 GHz instrument is permanently switched off to reduce power consumption and the
maximum frequency is limited to 6 GHz.

Parameters:
<Mode> OFF | EM1

*RST: OFF

Example: see Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213
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:SYSTem:ERRor:ALL?

Queries the error/event queue for all unread items and removes them from the queue.

Return values: 
<All> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
A comma separated list of error number and a short description
of the error in FIFO order.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR:ALL?
Queries all entries in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:CODE:ALL?

Queries the error numbers of all entries in the error queue and then deletes them.

Return values: 
<All> string

Returns the error numbers. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.
0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE:ALL
Queries all entries in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only
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:SYSTem:ERRor:CODE[:NEXT]?

Queries the error number of the oldest entry in the error queue and then deletes it.

Return values: 
<Next> string

Returns the error number. To retrieve the entire error text, send
the command :SYSTem:ERRor:ALL?.
0
"No error", i.e. the error queue is empty
Positive value
Positive error numbers denote device-specific errors
Negative value
Negative error numbers denote error messages defined by
SCPI.

Example: SYST:ERR:CODE
Queries the oldest entry in the error queue.
Response: 0
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor:COUNt?

Queries the number of entries in the error queue.

Return values: 
<Count> integer

0
The error queue is empty.

Example: SYST:ERR:COUN
Queries the number of entries in the error queue.
Response: 1
One error has occurred since the error queue was last read out.

Usage: Query only

:SYSTem:ERRor[:NEXT]?

Queries the error/event queue for the oldest item and removes it from the queue.

Return values: 
<Next> string

Error/event_number,"Error/event_description>[;Device-depend-
ent info]"
Error number and a short description of the error.
If the queue is empty, the response is 0,"No error"
Positive error numbers are instrument-dependent. Negative
error numbers are reserved by the SCPI standard.
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Volatile errors are reported once, at the time they appear. Identi-
cal errors are reported repeatedly only if the original error has
already been retrieved from (and hence not any more present in)
the error queue.

Example: SYST:ERR?
Queries the oldest entry in the error queue.
Response: 0, 'no error'
No errors have occurred since the error queue was last read out.

Usage: Query only

:SYSTem:SERRor?

Returns a list of all errors existing at the time when the query is started. This list corre-
sponds to the display on the info page under manual control.

Return values: 
<Serror> string

Example: SYST:SERR
queries all errors existing in the error queue.

Example: Response: -221, 'Settings conflict', 153,
'Input voltage out of range'
The two returned errors have occurred since the error queue
was last queried.

Usage: Query only

:SYSTem:VERSion?

Queries the SCPI version the instrument's command set complies with.

Return values: 
<Version> string

Example: SYST:VERS
queries the SCPI version.
Response: "1996"
The instrument complies with the SCPI version from 1996.

Usage: Query only

:SYSTem:COMMunicate:NETWork:IPADdress <IpAddress>

Sets the IP address.

Parameters:
<IpAddress> string

Range: 0.0.0.0.  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress "7.8.9.10"
sets the IP address of the instrument.
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Manual operation: See "IP Address" on page 153

:SYSTem:COMMunicate:NETWork:IPADdress:MODE <Mode>

Selects manual or automatic setting of the IP address.

Parameters:
<Mode> AUTO | STATic

*RST: n.a. (factory preset: AUTO)

Example: SYSTem:COMMunicate:NETWork:IPADdress:MODE AUTO
The IP address is assigned automatically (DHCP)

Manual operation: See "Address Mode" on page 153

:SYSTem:COMMunicate:NETWork:MACaddress <MacAddress>

Queries the MAC address of the network adapter.

Parameters:
<MacAddress> string

Example: SYST:COMM:NETW:MAC
queries the MAC address.

:SYSTem:COMMunicate:NETWork:STATus?

Queries the network configuration state.

Return values: 
<State> 0 | 1 | OFF | ON

Usage: Query only

:SYSTem:COMMunicate:NETWork:RESTart

Restarts the network connection to the instrument, terminates the connection and sets
it up again.

Example: SYSTem:COMMunicate:NETWork:RESTart
Usage: Event

:SYSTem:COMMunicate:NETWork[:COMMon]:HOSTname <Hostname>

Sets the individual host name of the R&S SGS.

Note: it is recommended that you do not change the host name in order to avoid prob-
lems with the networdk connection. However, if you change the host name be sure to
use an unique name.

The host name is a protected parameter, To change it, first disable protection level 1
with command :SYSTem:PROTect<ch>[:STATe] on page 298.
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Parameters:
<Hostname> string

Example: SYSTem:PROTect1:STATe OFF,123456
SYSTem:COMMunicate:NETWork:HOSTname 'SIGGEN'
sets the individual computer name of the R&S SGS.

Manual operation: See "Hostname" on page 152

:SYSTem:COMMunicate:NETWork[:IPADdress]:GATeway <Gateway>

Sets the IP address of the default gateway.

Parameters:
<Gateway> string

Range: 0.0.0.0  to  ff.ff.ff.ff

Example: SYSTem:COMMunicate:NETWork:IPADdress:GATeway
'1.2.3.4'
sets the IP address of the default gateway.

Manual operation: See "Default Gateway" on page 154

:SYSTem:COMMunicate:NETWork[:IPADdress]:SUBNet:MASK <Mask>

Sets the subnet mask.

Parameters:
<Mask> string

Example: SYSTem:COMMunicate:NETWork:IPADdress:SUBNet:
MASK '255.255.0.0'
determines the subnet mask.

Manual operation: See "Subnet Mask" on page 153

:SYSTem:COMMunicate:NETWork:RESource?

Queries the VISA resource string, used for remote control of the instrument with VXI-11
protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:NETWork:RESource?
Response: "TCPIP::192.1.2.3::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 154

:SYSTem:COMMunicate:SERial:BAUD <Baud>

Sets the baudrate for the serial remote control interface.
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Parameters:
<Baud> 2400 | 4800 | 9600 | 19200 | 38400 | 57600 | 115200

*RST: n.a. (factory preset: 115200)

Example: SYSTem:COMMunicate:SERial:BAUD 115200
Sets 115200 baudrate.

:SYSTem:COMMunicate:SERial:PARity <Parity>

Sets the parity for the serial remote control interface.

Parameters:
<Parity> NONE | ODD | EVEN

*RST: n.a. (factory preset: NONE)

Example: SYST:COMM:SER:PAR NONE
Selects parity NONE.

:SYSTem:COMMunicate:SERial:RESource?

Queries the VISA resource string for the serial remote control interface. This string is
used for remote control of the instrument.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SERial:RESource?
queries the VISA resource string.
Response: "ASRL1::INSTR"

Usage: Query only

:SYSTem:COMMunicate:SERial:SBITs <SBits>

Sets the number of stop bits for the serial remote control interface.

Parameters:
<SBits> 1 | 2

*RST: n.a. (factory preset: 1)

Example: SYST:COMM:SER:SBIT 2
Selects 2 stop bits.

:SYSTem:COMMunicate:HISLip:RESource?

Queries the VISA resource string, used for remote control of the instrument with
HiSLIP protocol.

Return values: 
<Resource> string
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Example: SYSTem:COMMunicate:HISLip:RESource?
Response: "TCPIP::192.1.2.3::hislip0::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 154

:SYSTem:COMMunicate:PCIexpress:RESource?

Queries the visa resource string for remote control via the PCIe interface.

Return values: 
<Resource> string

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 154

:SYSTem:COMMunicate:SOCKet:PORT <ScpiEthPort>

Sets the port number for remote control via socket communication.

Parameters:
<ScpiEthPort> integer

Range: 1000  to  65535
*RST: n.a. (factory preset: 5025)

Example: SYSTem:COMMunicate:SOCKet:PORT 5030
// specifies the socket port number.

Manual operation: See "SCPI Port" on page 69

:SYSTem:COMMunicate:SOCKet:RESource?

Queries the VISA resource string for remote control via LAN interface, using TCP/IP
socket protocol.

Return values: 
<Resource> string

Example: SYSTem:COMMunicate:SOCKet:RESource?
Response: "TCPIP::10.113.1.150::5025::SOCKET"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 154

:SYSTem:COMMunicate:USB:RESource?

Queries the VISA resource string for remote control via the USB interface.

Return values: 
<Resource> string

SYSTem subsystem



Remote control commandsR&S®SGS100A

297User Manual 1173.9105.02 ─ 13

Example: SYSTem:COMMunicate:USB:RESource?
queries the VISA resource string for remote control via the USB
interface.
Response: "USB::72::000000::INSTR"

Usage: Query only

Manual operation: See "Visa Resource Strings" on page 154

:SYSTem:NINFormation?

Queries the oldest information message ("Error History > Level > Info") in the error/
event queue.

Return values: 
<NextInfo> string

Example: :SYSTem:NINFormation?
Queries the oldest entry in the info message queue.
Response: 90,"Info;=== Instrument startup...
==="
Information message containing error number 90, that states,
that the instrument startup is complete.

Usage: Query only

:SYSTem:REBoot

Restarts the firmware and the operating system.

Usage: Event

:SYSTem:RESTart

Restarts the firmware. The operating system remains active.

Usage: Event

:SYSTem:SHUTdown

Shuts down the instrument.

Usage: Event

:SYSTem:STARtup:COMPlete?

Queries if the startup of the instrument is completed.

Return values: 
<Complete> 0 | 1 | OFF | ON

*RST: 0

SYSTem subsystem



Remote control commandsR&S®SGS100A

298User Manual 1173.9105.02 ─ 13

Example: SYST:STAR:COMP?
// 1
// the startup of the instrument is completed

Usage: Query only

:SYSTem:PROTect<ch>[:STATe] <State>[, <Key>]

Activates and deactivates the specified protection level.

Suffix: 
<ch>

.
Indicates the protection level.

Parameters:
<State> select

*RST: n.a. (factory preset: 1)

Setting parameters: 
<Key> integer

The respective functions are disabled when the protection level
is activated. No password is required for activation of a level. A
password must be entered to deactivate the protection level.
The password for the first level is 123456.

Example: // to activate protection level
SYSTem:PROTect1:STATe 1
// internal adjustments or hostname cannot be changed
// to unlock protection level 1
SYSTem:PROTect1:STATe 0,123456
// internal adjustments are accessible

:SYSTem:HARDware:ASSembly<dir>:NAME?

The query returns a list of hardware assembly names.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<Name> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See " Assembly" on page 144

:SYSTem:HARDware:ASSembly<dir>:PNUMber?

The query returns the list of hardware module part numbers.

SYSTem subsystem



Remote control commandsR&S®SGS100A

299User Manual 1173.9105.02 ─ 13

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<PNumber> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See " Assembly" on page 144

:SYSTem:HARDware:ASSembly<dir>:REVision?

Queries the list of hardware module revisions.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<Revision> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See " Assembly" on page 144

:SYSTem:HARDware:ASSembly<dir>:SNUMber?

Queries the list of hardware module serial numbers.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = common assembly, 2 = RF assembly.

Return values: 
<SNumber> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See " Assembly" on page 144

:SYSTem:SOFTware:OPTion<dir>:DESignation?

Queries the list of option descriptions.
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Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Designation> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 146

:SYSTem:SOFTware:OPTion<dir>:EXPiration?

Queries the list of option expiration informations.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Expiration> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 146

:SYSTem:SOFTware:OPTion<dir>:LICenses?

Queries the list of option license counts.

Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Licenses> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 146

:SYSTem:SOFTware:OPTion<dir>:NAME?

Queries the list of option names.
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Suffix: 
<dir>

.
1..2
Defines the section: 1 = hardware, 2 = software.

Return values: 
<Name> string

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

Manual operation: See "Hardware / Software/WinIQSIM" on page 146

:SYSTem:MMEMory:PATH:USER?

Queries the user directory, that means the directory the instrument stores user files on.

Return values: 
<PathUser> string

Example: SYSTem:MMEMory:PATH:USER?
Response: "/var/sgs/"'

Usage: Query only

:SYSTem:OSYStem?

Queries the operating system of the instrument.

Return values: 
<OperSystem> string

Example: SYSTem:OSYStem?
Response: "Linux"

Usage: Query only

13.22  TEST subsystem

The TEST system contains the commands for performing the routines and for direct
manipulation of the hardware assemblies (:TEST:DIRect).

The self tests return a "0" if the test is performed successfully, otherwise a value other
than "0" is returned. None of the commands of this system have an *RST value.
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Improper use can destroy the assembly
The respective hardware assembly responds directly to the :TEST:DIRect command;
any safety mechanisms are bypassed. The command is intended for servicing purpo-
ses and should be used only by the Rohde & Schwarz service personnel.

:TEST:ALL:STARt...........................................................................................................302
:TEST:ALL:RESult?........................................................................................................302
:TEST:KEYBoard[:STATe]............................................................................................... 302

:TEST:ALL:STARt

Starts the selftest. Use the command :TEST:ALL:RESult? to query the result.

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Event

:TEST:ALL:RESult?

Queries the result of the performed selftest. Start the selftest with :TEST:ALL:STARt.

Return values: 
<Result> 0 | 1 | RUNning | STOPped

*RST: STOPped

Example: See Chapter 13.1.1, "Performing general tasks for instrument
setup", on page 213.

Usage: Query only

:TEST:KEYBoard[:STATe] <State>

Enable/disable keyboard and LED test state.

Parameters:
<State> 1 | ON | 0 | OFF

13.23  UNIT subsystem

The UNIT subsystem contains the commands specifying which units are valid if no unit
is indicated in a command. These settings are valid for the entire instrument.

:UNIT:ANGLe <Angle>

Sets the default angle unit for remote control. Does not influence the manual control
parameter units and the display.
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Parameters:
<Angle> DEGRee | RADian

*RST: RADian

Example: UNIT:ANGL DEG
sets DEG as a default unit for all commands which determine
angle values.

:UNIT:POWer <Power>

Defines the default unit for power parameters. This setting affects the GUI, as well as
all remote control commands that determine power values.

Parameters:
<Power> V | DBUV | DBM

*RST: DBM

Example: UNIT:POW V
sets V as a default unit for all commands which determine power
values.

13.24  List of R&S SGS commands
:CALibration:ALL[:MEASure]?....................................................................................................................... 227
:CALibration:FREQuency:TEMPerature?...................................................................................................... 228
:CALibration:FREQuency[:MEASure]?.......................................................................................................... 227
:CALibration:IQModulator:FULL?...................................................................................................................228
:CALibration:IQModulator:LOCal?................................................................................................................. 228
:CALibration:IQModulator:TEMPerature?......................................................................................................228
:CALibration:LEVel:TEMPerature?................................................................................................................ 228
:CALibration:LEVel[:MEASure]?.................................................................................................................... 228
:CALibration:OEXTension.............................................................................................................................. 229
:CALibration:ROSCillator:DATA:MODE......................................................................................................... 229
:CALibration:ROSCillator[:DATA]................................................................................................................... 229
:CONNector:REFLo:OUTPut......................................................................................................................... 230
:CONNector:TRIGger:OMODe...................................................................................................................... 230
:DIAGnostic:POINt:CATalog?.........................................................................................................................230
:DIAGnostic[:MEASure]:POINt?.....................................................................................................................231
:EXTension:BUSY[:STATe]?...........................................................................................................................233
:EXTension:INSTruments:NAME?................................................................................................................. 232
:EXTension:INSTruments:REMote:CHANnel?...............................................................................................232
:EXTension:INSTruments:REMote:LAN:NAME?........................................................................................... 232
:EXTension:INSTruments:REMote:SERial?...................................................................................................233
:EXTension:INSTruments:SCAN[:STATe]...................................................................................................... 232
:EXTension:REMote:STATe?......................................................................................................................... 231
:EXTension:SELect........................................................................................................................................ 233
:FFASt............................................................................................................................................................243
:INITiate<hw>[:POWer]:CONTinuous............................................................................................................ 250
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:LOCK?.......................................................................................................................................................... 225
:MEMory:HFRee?.......................................................................................................................................... 240
:MMEMory:CATalog:LENGth?....................................................................................................................... 238
:MMEMory:CATalog?..................................................................................................................................... 237
:MMEMory:CDIRectory..................................................................................................................................238
:MMEMory:COPY.......................................................................................................................................... 238
:MMEMory:DATA........................................................................................................................................... 239
:MMEMory:DCATalog:LENGth?.....................................................................................................................240
:MMEMory:DCATalog?...................................................................................................................................240
:MMEMory:DELete.........................................................................................................................................240
:MMEMory:LOAD:STATe............................................................................................................................... 241
:MMEMory:MDIRectory..................................................................................................................................241
:MMEMory:MOVE..........................................................................................................................................241
:MMEMory:MSIS............................................................................................................................................242
:MMEMory:RDIRectory..................................................................................................................................242
:MMEMory:STORe:STATe............................................................................................................................. 242
:OUTPut:AFIXed:RANGe:LOWer?................................................................................................................ 243
:OUTPut:AFIXed:RANGe:UPPer?.................................................................................................................244
:OUTPut:AMODe........................................................................................................................................... 244
:OUTPut[:STATe]............................................................................................................................................245
:OUTPut[:STATe]:PON...................................................................................................................................244
:PFASt............................................................................................................................................................243
:READ<ch>[:POWer]?................................................................................................................................... 251
:SENSe<ch>:UNIT[:POWer]..........................................................................................................................251
:SENSe<ch>[:POWer]:APERture:DEFault:STATe......................................................................................... 252
:SENSe<ch>[:POWer]:APERture:TIMe......................................................................................................... 252
:SENSe<ch>[:POWer]:CORRection:SPDevice:LIST?...................................................................................253
:SENSe<ch>[:POWer]:CORRection:SPDevice:SELect.................................................................................252
:SENSe<ch>[:POWer]:CORRection:SPDevice:STATe.................................................................................. 253
:SENSe<ch>[:POWer]:FILTer:LENGth:AUTO?..............................................................................................253
:SENSe<ch>[:POWer]:FILTer:LENGth[:USER]..............................................................................................254
:SENSe<ch>[:POWer]:FILTer:NSRatio.......................................................................................................... 254
:SENSe<ch>[:POWer]:FILTer:NSRatio:MTIMe..............................................................................................254
:SENSe<ch>[:POWer]:FILTer:SONCe........................................................................................................... 255
:SENSe<ch>[:POWer]:FILTer:TYPE.............................................................................................................. 255
:SENSe<ch>[:POWer]:FREQuency...............................................................................................................256
:SENSe<ch>[:POWer]:LOGGing:STATe........................................................................................................256
:SENSe<ch>[:POWer]:OFFSet......................................................................................................................257
:SENSe<ch>[:POWer]:OFFSet:STATe...........................................................................................................257
:SENSe<ch>[:POWer]:SNUMber?.................................................................................................................257
:SENSe<ch>[:POWer]:SOURce.................................................................................................................... 257
:SENSe<ch>[:POWer]:STATus[:DEVice]?..................................................................................................... 258
:SENSe<ch>[:POWer]:SVERsion?................................................................................................................258
:SENSe<ch>[:POWer]:TYPE?.......................................................................................................................258
:SENSe<ch>[:POWer]:ZERO........................................................................................................................ 259
:SLISt:CLEar:LAN..........................................................................................................................................249
:SLISt:CLEar:USB..........................................................................................................................................249
:SLISt:CLEar[:ALL].........................................................................................................................................250
:SLISt:ELEMent<ch>:MAPPing..................................................................................................................... 250
:SLISt:SCAN:LSENsor...................................................................................................................................248
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:SLISt:SCAN:USENsor.................................................................................................................................. 249
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14  Error messages and troubleshooting
This chapter describes the error messages of the R&S SGS. The error messages are
output in the "Info" line on the screen and entered in the error/event queue of the sta-
tus reporting system.

A great variety of different messages such as status messages, error messages, warn-
ings or information are displayed in the header field of the screen. Some error mes-
sages require that the error must be eliminated before correct instrument operation can
be ensured. The "Info" window with a list of current messages and a detailed descrip-
tion of each message can be opened with the "Info" button (see also Chapter 8.2.1,
"Info dialog", on page 70).

14.1  Status information

The status messages are displayed in the Info line of the R&S SGMA-GUI main panel.
The status information gives the user an overview of the main operating states and set-
tings of the instrument. The states are indicated for information only and do not neces-
sitate any action by the user.

Status Information displayed in the Info line

AttFixed
Attenuator fixed mode is active.
The uninterrupted level settings are made in a fixed range without attenuator switching.
The variation range is set automatically when this mode is activated. The range is dis-
played with the parameter "SGMA-GUI > Instrument Name > Level > Attenuator Fixed
Range".

14.2  Error messages

Messages indicate errors in the instrument. They are displayed in the info line in differ-
ent colors depending on their importance and display duration. Errors (e.g. no calibra-
tion data) are displayed in red, information (e.g. file not found) and warnings in black.
Warnings indicate less significant errors (e.g. the instrument operates outside specified
data).

See also Chapter 8.2.1, "Info dialog", on page 70 and Chapter 8.2.2, "Understanding
the messages in the info bar", on page 71.

14.2.1  Volatile messages

Volatile messages report automatic settings in the instrument (e.g. switching off of
incompatible types of modulation) or on illegal entries that are not accepted by the

Error messages
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instrument (e.g. range violations). They are displayed in the info line on a yellow back-
ground. They are displayed on top of status information or permanent messages.

Volatile messages do not normally demand user actions and disappear automatically
after a brief period of time. They are stored in the history, however.

SCPI command: :SYSTem:ERRor:ALL? and :SYSTem:ERRor[:NEXT]?.

14.2.2  Permanent messages

Permanent messages are displayed if an error occurs that impairs further instrument
operation, e.g. a hardware fault. The error signaled by a permanent message must be
eliminated before correct instrument operation can be ensured.

The message is displayed until the error is eliminated. It covers the status display in
the info line. After error elimination, the message automatically disappears and is also
recorded in the history.

SCPI command: :SYSTem:SERRor?

14.3  SCPI-Error messages

The SCPI error messages are the same in all SCPI instruments. Detailed information
and an overview of all error messages as defined in SCPI standard can be found in the
corresponding documentation.

The errors are assigned negative numbers. The error text being entered into the error/
event queue or being displayed is printed in bold face on the left together with the error
code. Below the error text, there is an explanation as to the respective error.

14.4  Device-Specific error messages

The following table contains all error messages specific for the instrument in alphabeti-
cal order, and an explanation of the error situation. The positive error codes mark the
errors specific of the instrument.

The device-specific error messages set bit 3 in the ESR register.

The index provides a list of the error messages sorted according to their error codes.

Device-Specific error messages
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Error
Code

Error Description Remedy

180 Adjustment failed Adjustment could not be executed The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the device.

182 Adjustment data miss-
ing

Adjustment data are missing. The adjustment data have to be
generated first by an internal or
external adjustment or to be loa-
ded into the instrument.

183 Adjustment data inva-
lid

Adjustment data are invalid and must
be restored.

The adjustment data have to be
generated again by an internal or
external adjustment or to be loa-
ded into the instrument.

200 Cannot access hard-
ware

The data transmission to a module
was unsuccessful.

The module is not installed, not
properly installed or missing.

201 Hardware revision out
of date

A later version of certain parts of the
instrument is necessary to execute
the function selected.

The driver does not support the
installed version of a module.

202 Cannot access the
EEPROM

An error occurs when writing or read-
ing a EEPROM.

The EEPROM can be defective
and requires replacement.

203 Invalid EEPROM data   

204 Driver initialization
failed

Initialization of a driver fails when
booting the instrument firmware.

The driver is not compatible with
the hardware or software config-
uration of the instrument.

241 No current list There is no list selected. To execute the required opera-
tion, a list has to be selected in
the related dialog. If no list is
available, a new list must be cre-
ated.

242 Unknown list type
specified

The list type selected is not valid for
the required operation.

For instance, the file extension for
mapping files is *.map. It is not possi-
ble to enter another file extension
when selecting a list.

Check the selected list type.

460 Cannot open file The selected file cannot be opened. Check the path and file name.

461 Cannot write file The file cannot be written. Check if the file is read-only.

462 Cannot read file The file cannot be read. Check if the file contents are
compatible with the file type.

463 Filename missing The required operation cannot be
executed because the file name is not
specified.

A file name has to be entered
when creating a list.

464 Invalid filename exten-
sion

The file extension is not valid for the
required operation.

Check the file extension.

For instance, the file extension
for the mapping files is *.map. It
is not possible to enter another
file extension when storing a list.

Device-Specific error messages
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Error
Code

Error Description Remedy

465 File contains invalid
data

The selected file contains data that is
not valid for the file type.

Check the file extension.

The file extension determines the
data that is valid for this file type.
If the file extension is changed,
the lists are no longer recognized
and the data are therefore inva-
lid.

468 Cannot find directory Required folder cannot be found. Check drive and path.

469 No files found Folder is empty  

14.5  Contacting customer support

Technical support – where and when you need it

For quick, expert help with any Rohde & Schwarz product, contact our customer sup-
port center. A team of highly qualified engineers provides support and works with you
to find a solution to your query on any aspect of the operation, programming or applica-
tions of Rohde & Schwarz products.

Contact information

Contact our customer support center at www.rohde-schwarz.com/support, or follow this
QR code:

Figure 14-1: QR code to the Rohde & Schwarz support page

Contacting customer support

https://www.rohde-schwarz.com/support
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15  Transporting
Lifting and carrying

See:
● "Lifting and carrying the product" on page 11
● Chapter 3.1, "Lifting and carrying", on page 19.

Packing

Use the original packaging material. It consists of antistatic wrap for electrostatic pro-
tection and packing material designed for the product.

If you do not have the original packaging, use similar materials that provide the same
level of protection.

Securing

When moving the R&S SGS in a vehicle or using transporting equipment, make sure
that the R&S SGS is properly secured. Only use items intended for securing objects.

Transport altitude

Unless otherwise specified in the data sheet, the maximum transport altitude without
pressure compensation is 4500 m above sea level.
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16  Maintenance, storage and disposal
The product does not require regular maintenance. It only requires occasional clean-
ing. It is however advisable to check the nominal data from time to time.

16.1  Cleaning

How to clean the product is described in "Cleaning the product" on page 13.

Do not use any liquids for cleaning. Cleaning agents, solvents, acids and bases can
damage the front panel labeling, plastic parts and display.

16.2  Storage

Protect the product against dust. Ensure that the environmental conditions, e.g. tem-
perature range and climatic load, meet the values specified in the data sheet.

16.3  Disposal

Rohde & Schwarz is committed to making careful, ecologically sound use of natural
resources and minimizing the environmental footprint of our products. Help us by dis-
posing of waste in a way that causes minimum environmental impact.

Disposing electrical and electronic equipment

A product that is labeled as follows cannot be disposed of in normal household waste
after it has come to the end of its service life. Even disposal via the municipal collection
points for waste electrical and electronic equipment is not permitted.

Figure 16-1: Labeling in line with EU directive WEEE

Rohde & Schwarz has developed a disposal concept for the eco-friendly disposal or
recycling of waste material. As a manufacturer, Rohde & Schwarz completely fulfills its
obligation to take back and dispose of electrical and electronic waste. Contact your
local service representative to dispose of the product.

Disposal
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Annex
A  Telnet program examples

The following program example shows a simple TcpClient class that is intended to
explain on how to get started with programming of sockets.

The example sets up a socket communication to R&S SGS and opens a simple user
interface, very similar to the telnet, which allows input of commands. To enable real
automation, further development of the program is required.

TcpClient.h

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
{
  public:
    TcpClient();
    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

TcpClient.cpp

#include <string>
//defines structs for socket handling
#include <netinet/in.h>
using namespace std;
typedef struct sockaddr_in SockAddrStruct;
typedef struct hostent     HostInfoStruct;
class TcpClient
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{
  public:
    TcpClient();
    ~TcpClient();
    void connectToServer( string &hostname, int port );
    void disconnect( );
    void transmit( string &txString );
    void receive( string &rxString );
    string getCurrentHostName( ) const;
    int    getCurrentPort( ) const;
  private:
    string           currentHostName;
    int              currentPort;
    int              currentSocketDescr;
    SockAddrStruct   serverAddress;
    HostInfoStruct * currentHostInfo;
    bool             clientIsConnected;
    int              receiveBufferSize;
};

#include <netdb.h>
#include <netinet/in.h>
#include <unistd.h>
#include "TcpClient.h"
TcpClient::TcpClient()
: currentHostName( "" )
, currentPort( 0 )
, currentSocketDescr( 0 )
, serverAddress ( )
, currentHostInfo( NULL )
, clientIsConnected( false )
, receiveBufferSize( 1024 )
{
}
TcpClient::~TcpClient()
{
  currentHostInfo = NULL;
}

void TcpClient::connectToServer( string &hostname, int port )
{
  currentHostInfo = gethostbyname( hostname.c_str( ) );
  if( currentHostInfo == NULL )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("error connecting host\n" );
  }
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  currentHostName = hostname;
  currentPort     = port;
  currentSocketDescr = socket(AF_INET, SOCK_STREAM, 0);
  if( currentSocketDescr == 0 )
  {
    currentHostName   = "";
    currentPort       = 0;
    currentHostInfo   = NULL;
    clientIsConnected = false;
    printf("can't create socket\n" );
  }
  serverAddress.sin_family = currentHostInfo->h_addrtype;
  serverAddress.sin_port   = htons( currentPort );
  memcpy( (char *) &serverAddress.sin_addr.s_addr, 
  currentHostInfo->h_addr_list[0], currentHostInfo->h_length );
  if( connect( currentSocketDescr, ( struct sockaddr *) &serverAddress, 
  sizeof( serverAddress ) ) < 0 )
  {
   throw string("can't connect server\n" );
  }
  clientIsConnected = true;
}
void TcpClient::disconnect( )
{
  if( clientIsConnected )
  {
    close( currentSocketDescr );
  }
  currentSocketDescr = 0;
  currentHostName    = "";
  currentPort        = 0;
  currentHostInfo    = NULL;
  clientIsConnected  = false;
}
void TcpClient::transmit( string &txString )
{
  if( !clientIsConnected )
  {
  throw string("connection must be established before any data can be sent\n");
  }
  char * transmitBuffer = new char[txString.length() +1];
  memcpy( transmitBuffer, txString.c_str(), txString.length() );
  transmitBuffer[txString.length()] = '\n'; //newline is needed!
  if( send( currentSocketDescr, transmitBuffer, txString.length() + 1, 0 ) < 0 )
  {
    throw string("can't transmit data\n");
  }
  delete [] transmitBuffer;
}
void TcpClient::receive( string &rxString )
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{
  if( !clientIsConnected )
  {
  throw string("connection must be established before any data can be received\n");
  }
  char * receiveBuffer = new char[receiveBufferSize];
  memset( receiveBuffer, 0, receiveBufferSize );
  bool receiving = true;
  while( receiving )
  {
    int receivedByteCount = recv( currentSocketDescr, 
    receiveBuffer, receiveBufferSize, 0 );
    if( receivedByteCount < 0 )
    {
      throw string("error while receiving data\n");
    }
    rxString += string( receiveBuffer );
    receiving = ( receivedByteCount == receiveBufferSize );
  }
  delete [] receiveBuffer;
}
string TcpClient::getCurrentHostName( ) const
{
  return currentHostName;
}
int TcpClient::getCurrentPort( ) const
{
  return currentPort;
}

TelnetClient.cpp

#include <iostream>
#include "TcpClient.h"
void printUsage()
{
  cout<<"usage: EthernetRawCommand <server-ip> [scpi-command]"<<endl;
}
int main( int argc, char *argv[] )
{
  int errorCode         = 0; //no error
  bool useSingleCommand = false;
  string singleCommand  = "";
  string hostname       = "";
  int    port           = 5025;
  string input          = "";
  TcpClient client;
  switch( argc )
  {
    case 3:
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      useSingleCommand = true;
      singleCommand    = argv[2];
    case 2:
      hostname         = argv[1];
      break;
    default:
        printUsage();
        return(-1);
  }
  try
  {
    client.connectToServer( hostname, port );
    bool terminate = false;
    while( !terminate )
    {
      char buffer[1024];
      if( useSingleCommand )
      {
        input =  singleCommand; //send string
      }
      else
      {
        cin.getline( buffer, 1024 );
        input = buffer;
        if( input == "end" )
        {
          terminate = true;
        }
      }
      if( !terminate)
      {
        client.transmit( input ); //send string
        int qPos = input.find( "?", 0 );
        //receive string only when needed
        if( qPos > 0 )
        {
          string rcStr = "";
          client.receive( rcStr );
          cout << rcStr << endl;
        }
      }
      if( useSingleCommand )
      {
        terminate = true;
      }
    }
  }catch( const string errorString )
  {
    cout<<errorString<<endl;
  }
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  client.disconnect( );
  return errorCode;
}
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