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法律事項聲明 
 
本使用手冊內容如有變更，恕不另行通知。 

 
本公司並不對本使用手冊之適售性、適合作某種特殊用途之使用或其他任何事項作

任何明示、暗示或其他形式之保證或擔保。故本公司將不對手冊內容之錯誤，或因

增減、展示或以其他方法使用本手冊所造成之直接、間接、突發性或繼續性之損害

負任何責任。 

 
致茂電子股份有限公司 

桃園市333001龜山區文茂路88號 

 
版權聲明：著作人─致茂電子股份有限公司─西元 2002 年，版權所有，翻印必究。

未經本公司同意或依著作權法之規定准許，不得重製、節錄或翻譯本使用手冊之任

何內容。 
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保  證  書 
 
致茂電子股份有限公司秉持〝品質第一是責任，客戶滿意是榮譽〞之信念，對所製

造及銷售之產品自交貨日起一年內，保證正常使用下產生故障或損壞，負責免費修

復。 

 
保證期間內，對於下列情形之一者，本公司不負免費修復責任，本公司於修復後依

維修情況酌收費用： 

 
1. 非本公司或本公司正式授權代理商直接銷售之產品。 

2. 因不可抗拒之災變，或可歸責於使用者未遵照操作手冊規定使用或使用人之過

失，如操作不當或其他處置造成故障或損壞。 

3. 非經本公司同意，擅自拆卸修理或自行改裝或加裝附屬品，造成故障或損壞。 

 
保證期間內，故障或損壞之維修品，使用者應負責運送到本公司或本公司指定之地

點，其送達之費用由使用者負擔。修復完畢後運交使用者(限台灣地區)或其指定地點

(限台灣地區)之費用由本公司負擔。運送期間之保險由使用者自行向保險公司投保。 

 
 
致茂電子股份有限公司 

桃園市 333001 龜山區文茂路 88 號 

服務專線：(03)327-9999 

傳真電話：(03)327-8898 

電子信箱：info@chromaate.com  

網    址：www.chromaate.com 
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http://www.chromaate.com/
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設備及材料污染控制聲明 
 
請檢視產品上之環保回收標示以對應下列之<有毒有害物質或元素表>。 

 

 ：請對應<表一> 

：請對應<表二> 

 

<表一> 

 

部件名稱 

 有毒有害物質或元素 

鉛 汞 鎘 六价鉻 
多溴聯苯/ 

多溴聯苯醚 
鄰苯二甲酸酯類化合物 

Pb Hg Cd Cr6+ PBB/PBDE DEHP/BBP/DBP/DIBP 

PCBA O O O O O O 

機殼 O O O O O O 

標準配件 O O O O O O 

包裝材料 O O O O O O 

O： 表示該有毒有害物質在該部件所有均質材料中的含量在 SJ/T 11363-2006 與 EU Directive 

2011/65/EU 規定的限量要求以下。 

： 表示該有毒有害物質至少在該部件的某一均質材料中的含量超出 SJ/T 11363-2006 與 EU 

Directive 2011/65/EU 規定的限量要求。 

註: 產品上有 CE 標示亦代表符合 EU Directive 2011/65/EU 規定要求。 

 
 

處置 

切勿將本設備處理為未分類的廢棄物，本設備需做分類回收。有關廢棄物收集系統的訊息，

請聯絡貴公司所在地的相關政府機關。假若將電子電器設備任意丟棄於垃圾掩埋地或垃圾

場，有害的物質會滲漏進地下水並進入食物鏈，將會損害健康。當更換舊裝置時，零售商在

法律上有義務要免費回收且處理舊裝置。 
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<表二> 

 

部件名稱 

 有毒有害物質或元素 

鉛 汞 鎘 六价鉻 多溴聯苯/ 

多溴聯苯醚 
鄰苯二甲酸酯類化合物 

Pb Hg Cd Cr6+ PBB/PBDE DEHP/BBP/DBP/DIBP 

PCBA  O O O O O 

機殻  O O O O O 

標準配件  O O O O O 

包裝材料 O O O O O O 

O： 表示該有毒有害物質在該部件所有均質材料中的含量在 SJ/T 11363-2006 與 EU Directive 

2011/65/EU 規定的限量要求以下。 

： 表示該有毒有害物質至少在該部件的某一均質材料中的含量超出 SJ/T 11363-2006 與 EU 

Directive 2011/65/EU 規定的限量要求。 

 

1. Chroma 尚未全面完成無鉛焊錫與材料轉換，故部品含鉛量未全面符合限量要求。 

2. 產品在使用手冊所定義之使用環境條件下，可確保其環保使用期限。 

 
 

處置 

切勿將本設備處理為未分類的廢棄物，本設備需做分類回收。有關廢棄物收集系統的訊息，

請聯絡貴公司所在地的相關政府機關。假若將電子電器設備任意丟棄於垃圾掩埋地或垃圾

場，有害的物質會滲漏進地下水並進入食物鏈，將會損害健康。當更換舊裝置時，零售商在

法律上有義務要免費回收且處理舊裝置。 
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版本修訂紀錄 
 
下面列示本手冊於每次版本修訂時新增、刪減及更新的章節。 

 
日期 版本 修訂之章節 

2002 年 2 月 1.0 完成本手冊。 

2003 年 11 月 1.1 更新 “系統安裝”一章中的  

▪ 安裝/取消安裝 Chroma 8200 ATS 軟體 

“快速操作說明”一章中的 

▪ 建立新的測試程式 

▪ 列印測試結果報表 

“編輯測試程式”一章中的 

▪ 啟動 

▪ 加入與編輯測試項目 

▪ 設定各測試項目的參數值 

▪ 選單說明 

“驗證測試程式”一章中的  

▪ 執行控制程式主畫面” 

“執行測試程式(GO/NOGO)”一章中的 

▪ 執行控制程式主畫面 

▪ 操作按鈕功能說明 

     “編輯報表格式”一章中的 

▪ 執行程式 

▪ 操作說明 

     “報表產生程式”一章中的 

▪ 設定編輯區的字型及顏色 

▪ 傳送郵件選項 

▪ 關於 Report Generator 

▪ 選單說明 

“系統管理功能”一章中的 

▪ 使用者管理功能 

▪ 儀器及其驅動程式管理功能 

▪ 儀器組態設定檔管理功能 

▪ 測試結果資料管理功能 

▪ 網路相關擴充功能 

刪除 “編輯報表格式”一章中的 

▪ Universal Test Program 檔案格式說明 
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新增 “系統管理功能”一章中的 

▪ 治具型號管理功能 

2004 年 3 月 1.2 更正錯字並刪除重複的內文說明及圖檔。 

2005 年 6 月 1.3 更新致茂電子的地址與電話。 

更新 “系統安裝” 一章以更改 8200 主畫面。 

更新 “設定儀器配置組態” 一章以增加並聯組數由 4 組增加

至 12 組。 

2007 年 3 月 1.4 新增 “設備及材料污染控制聲明”。 

2010 年 10 月 1.5 更新 “報表產生器”一章以新增離線報表過濾待測物功能。 

更新 “系統管理功能”一章以新增語系切換功能。 

更新 “設定儀器配置組態”一章以新增通訊介面設定。 

新增 “統計製程管制(選配)”一章。 

2012 年 10 月 1.6 更新 “執行測試程式（GO/NOGO）”一章以新增 Barcode 預

刷功能及限制手動輸入條碼功能。 

2015 年 4 月 1.7 更新下列章節的內容: 

– “系統安裝” 中的 “在Windows環境上安裝 Chroma 

8200” 一節。 

– “編輯報表格式” 中的 “關於 Report Editor” 一節。 

– “報表產生程式” 中的 “選單說明” 一節。 

2018 年 10 月 1.8 更新下列章節的內容: 

 “系統架構” 一章中的 “簡介”、“系統控制器”與 “軟體系

統需求”。 

 “編輯測試程式”一章中的 “選單說明”。 

新增 Data Type 說明至附錄 “測試結果記錄檔”。 

2020 年 12 月 1.9 更新地址。 
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序言 
 
關於這本使用手冊 

 
這是一本教您如何使用 Chroma 8200 自動測試系統來測試 Switch Power Supply 

的使用手冊，包含自動測試的特性及功能描述。使用時建議您從第一章開始讀起，

然後依序讀第二章、第三章等。為了能有效地使用這本使用手冊，建議您應對

Windows 的基本操作觀念有一些初步的認識。 

 
內容 

 
第1章  系統架構 

說明 Chroma 8200 各儀器設備及組成，以及 Chroma 8200 ATS 軟

體的功能，介紹系統之特性。 

 
第2章  系統安裝 

說明如何安裝 Chroma 8200 自動測試系統。 

 

第3章  快速操作說明 

很快地教導您如何使用 Chroma 8200 ATS 軟體。 

 

第4章  設定儀器配置組態 

教導您如何設定 ATS 中各儀器之組態，以有效運用各儀器來進行測

試工作。 

 

第5章  編輯測試程式 

說明測試程式之組成，及如何編輯您所要的測試程式。 

 

第6章  驗證測試程式 

說明 Chroma 8200 ATS 系統軟體如何驗證測試程式。 

 

第7章  執行測試程式（GO/NOGO） 

說明 Chroma 8200 ATS 如何執行測試程式，及說明如何依您的需要

來設定執行環境。 

 

第8章  編輯報表格式 

說明如何編訂報表之格式。 
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第9章  報表產生器說明 

教導您如何藉由本程式來產生、查看、儲存及列印測試的結果。 

 
第10章  系統管理功能 

說明如何設定使用者及使用者權限，以有效的管制使用人員，並執行

測試程式及儀器設備的匯出、匯入功能。 

 
第11章  統計製程管制（選配） 

   介紹如何利用統計繪圖功能，繪製統計製程管制圖。 

 
附錄  A  測試結果記錄檔說明 

描述測試結果記錄之內容。 

 
使用手冊的描述方式 

 
下面列出在這本使用手冊中所使用的撰寫方法與規範。 
 

粗體 用來標示在視窗上的功能選項、按鈕、和輸出入參數等。 
 

斜體字 用來標記重要的提示及所要參考書籍或文件。 
 

粗體斜體字  使用者可藉由本程式查看、儲存及列印測試的結果。 
 

Courier New 使用者可藉由本程式查看、儲存及列印測試的結果所標示的文字內容

是要由您從鍵盤上輸入資料，其包含磁碟機代號、路徑、目錄、程式

等。 
 

「」 用來表示所開啟的視窗。 
 

        用來表示按鈕。 
 

[ ]->[ ]   選單項目。 
 

【】  資料表。 
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1. 系統架構 

本章主要描述 Chroma 8200 開關電源供應器自動測試系統（Switching Power 

Supply Automatic Test System）之架構及組成，以及說明Chroma 8200 ATS 軟體

的主要功能特性。我們在此先將系統需求列出，以便讓您能很快瀏覽到您的需求環

境。 
 
 

1.1 簡介 

Chroma 8200 自動測試系統係一整合電源供應器測試時所用的各項儀器，建構在開

放式的系統軟體環境下，專為電源供應器設計的自動測試系統。它具有以下特性： 

 
 可整合各種可程式化的儀器設備，提供一個整合的操控環境，達到迅速有效率、

使用簡易的目的。 

 提供完整的測試程式開發環境，以便使用者撰寫、修改測試程式，並輔助測試程

式之偵錯以查核測試程式的正確性。 

 系統架構設計模組化、彈性化，系統更新或擴充容易。 

 採用圖形介面，親和力佳。 

 支援標準硬體介面﹕IEEE-488、RS-232C、I2C、USB。 

 系統提供下列各項測試項目，並允許使用者依實際需要自行編輯測試程式。 

 
1. Input/Output Test ： 用以量測在靜態負載條件下，待測物輸入端及輸出

端的特性。 

2. Combine Regulation 
Test 

： 用以量測在負載大小及輸入電源之電壓同時改變

時，對於待測物輸出電壓或電流所產生的影響。 

3. Turn On & Seq. Test ： 用以量測在開機瞬間待測物的各組輸出電壓的時

序關係。 

4. Hold up & Seq. Test ： 用以量測在關機瞬間待測物的各組輸出電壓的時

序關係。 

5. OLP Test ： 用以量測在過載保護點瞬間待測物的輸出特性。 

6. OPP Test ： 用以量測在過功率保護點瞬間待測物的輸出特

性。 

7. Hold on Adjust ： 用於測試中調整待測物的內部電路以達到正確的

電壓輸出。 

8. Static Test ： 用以量測在靜態負載條件下待測物的輸出特性。 
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9. Short Circuit Test ： 用以量測待測物的一組輸出短路接地的整體輸出

入反應特性。 

10. OVP Test ： 用以量測待測物在過電壓保護瞬間，待測物的輸出

特性。 

11. Line Regulation Test ： 用以量測在輸入電源改變時，對於待測物輸出電壓

所產生的影響。 

12. Load Regulation 
Test 

： 用以量測在負載大小改變時，對於待測物輸出電壓

所產生的影響。 

 
 

1.2 硬體架構說明 

Chroma 8200 自動測試系統須包含以下各項硬體裝置﹕ 

 
 系統控制器（工業電腦及週邊設備）IPC，其功能及規格請參考 1.2.1 節。 

 可程式交流電源供應器（AC Source），其功能及規格請參考 1.2.2 節。 

 直流電子負載（DC Load），其功能及規格請參考 1.2.3 節。 

 短路過電壓控制器，其功能及規格請參考 1.2.4 節。 

 外框﹕用以放置各項硬體裝置的 19 吋標準機箱。 

 測試治具﹕用以連接 Chroma 8200 自動測試系統及待測物。 
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圖 1-1  8200 硬體邏輯方塊圖 

1.2.1 系統控制器（工業電腦及週邊設備） 

■ 控制電腦﹕ 

為本自動測試系統之控制中樞，用以指揮各項儀器執行測試動作、測試結果研

判及資料存檔顯示列印、使用者各項操作之介面等等。其硬體需求如下﹕ 

 
 Intel i3-3220, 3.3GHz 或以上等級之中央處理器。 

 6.4 GB 或以上儲存容量的硬式磁碟機。 

 8GB 或以上的記憶體。 

 40 倍速或以上的光碟機。 

 SVGA 監視器（解析度至少 800x 600）。 

 鍵盤。 

 PS2 或 USB 滑鼠。 

 至少二個以上空槽以供 A/D 卡(PCI)、GPIB 卡( ISA) 使用。 

 並聯式印表機輸出埠。 

 至少一 USB 埠供硬體保護鎖使用 

 
■ 週邊設備﹕ 
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 用以列印測試結果 

 並聯式印表機—詳細資料列印用。 

 
 

1.2.2 可程式交流電源供應器 

可程式交流電源供應器用以提供待測物輸入電源，並模擬輸入電源各種狀況；所以它

必須有足夠的能量及可變化的電壓和頻率，才能滿足各式電源供應器的輸入需求。 

 
有關 Chroma 61 系列、65 系列 AC Source 的詳細規格及操作說明請參考其使用手

冊。 

 
 

1.2.3 直流電子負載 

電子負載係用以執行各項測試時模擬待測物負載變化的各種狀況，使各項測試能逼近

真實情境。 

 
Chroma 8200 自動測試系統預設的電子負載為 Chroma 6310 Electronic Load。有關

Chroma 6310 Electronic Load 的詳細規格及操作說明請參考其使用手冊。 

 
 

1.2.4 短路過電壓控制器 

短路過電壓控制器係執行短路測試與過電壓保護測試，以模擬待測物的輸出端發生短

路或過電壓時，是否有保護的狀況，使測試能逼近於真實情境。 

 
有關 Chroma 8125 Extended Controller 的詳細規格及操作說明請參考其使用手冊。 
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1.3 Chroma 8200 ATS系統概說 

1.3.1 系統特性介紹 

現今的自動測試環境需求，已不再是單純專屬的測試系統所可以滿足。測試工程人員

不再只要求簡單功能有限的測試系統，而是一個可隨硬體需求不同或測試步驟不同而

可彈性變更的測試環境。 

 
Chroma 8200 ATS 採模組化，層次化設計，具有下述之優點： 

 

(1) 架構在Windows環境之下，採標準化的圖形使用者介面，具使用親和性。 

(2) 可編排報表列印格式。 

(3) 可列印測試失敗之讀值，以利維修。 

(4) 測試結果存檔。 

(5) 統計製程管理功能。 

(6) 儀器介面控制程式，均採動態連結程式庫（DLL），可方便抽換或新增儀器。 

 
 

1.3.2 系統模組 

Chroma 8200 ATS 具有以下之功能模組﹕ 

 

(1) 使用者管理﹕ 

可依使用者不同設定使用者之使用權限，如操作員只能進行測試程式之執行，

而工程人員則可使用所有的功能。 

(2) 硬體設備組態設定﹕ 

儀器設備介面（GPIB）之組態位址設定。 

(3) 測試程式編輯驗證功能﹕ 

將系統內建的測試項目編寫成測試程式，同時設定各測試項目之相關參數或測

試規格。測試程式原始檔之副檔名為（.prg）。編輯後之測試程式可使用執行控

制器的功能來執行測試以驗證其結果。 

(4) 報表格式編輯功能﹕ 

您可依實際需要編輯您所需之報表格式，報表格式檔之副檔名為（.rpf）。 

(5) 測試程式執行控制功能﹕ 

經過編輯後之測試程式，即可使用此功能來執行測試。此功能依您編訂之測試

順序逐項呼叫相關之程式進行測試。同時自動記錄測試結果，產生及列印報

表；以及決定各測試項目之結果和各讀值之結果。 
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(6) 報表列印功能﹕ 

報表列印亦可於離線時進行，Chroma 8200 ATS 會將測試所需之測試結果儲存。

因此可利用此一功能，列印某年某月某日所測之某一測試結果。 

(7) 統計製程分析功能： 

透過此功能，您可以就資料庫中之測試結果，進行統計製程分析。 

 
 

1.4 軟體系統需求 

Chroma 8200 ATS 自動測試系統所建議採用的個人電腦軟硬體系統需求如下﹕ 

 
■ Intel i3-3220 3.3GHz 或以上等級之個人電腦。 

■ Microsoft Windows XP、Win 7 或 Win 10(2.10 版(含)以上不支援 XP)。 

■ 建議有 400 MB 以上可用硬碟空間。 

■ 最少要有 8GB 的記憶體。 

■ VGA 或 SVGA 彩色螢幕顯示器。   

■ PS2 或 USB 滑鼠。 

 
 

1.5 共通選單項目說明 

[File][New] 開新檔案 

[File][Open] 開舊檔案 

[File][Print] 列印 

[File][Print Preview] 列印預覽 

[File][Exit] 結束 

  
[Edit][Copy] 複製 

[Edit][Cut] 剪下 

[Edit][Paste] 貼上 

  
[View][Toolbar] 顯示或隱藏工具列 

[View][Status Bar 顯示或隱藏狀態列 

  
[Help][About] 關於該應用程式] 
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1.6 技術名詞中英對照表 

這一節要告訴您在這本使用手冊中所使用到的一些技術性專有名詞之英中對照表，做

為您使用本手冊的參考。各名詞依照英文字母的次序詳列於下﹕ 
 
A 

Automatic Test Equipment （ATE）  自動測試設備 

Automatic Test System （ATS）   自動測試系統 

 
C 

Compile        編譯 

Command       測試指令 

Constraint       限制 

Correction Steps       更正步驟 

Current Limit       電流抑制（限電流） 

Current Measurement Accuracy   電流精確度 

 
D 

Default Data       預設參數值 

Dynamic Transient Response    暫態反應 

 
E 

Error Index        錯誤順序號碼 

Error Message       錯誤訊息 

Export        匯出 

Extension        測試項目名稱註解 

 
I 

Import        匯入 

Inrush Current       湧浪電流 

 
L 

Label        標籤 

Level        使用權限 

Level ID        使用權限識別 

Log         記錄 

 
M 

Module Name       模組名稱 
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O 

Operator        作業員 

Over Load Protection     過載保護 

Over Power Protection     過功率保護 

Over Voltage Protection     過電壓保護 
 
P 

Power Efficiency      效率 

Power Factor       功率因數 

 
R 

Report Output Format     輸出報表格式 

Ripple        漣波 

 
S 

SPC         統計製程控制 

Statistics        統計表 

 
T 

Test Command       測試命令 

Test Item        測試項目 

Test Program       測試程式 

Test Sequence       測試程序 

 
U 

User ID        使用者識別名稱 

User Name       使用者名稱 

 
V 

Voltage Regulation      電壓調整率 

Voltage Stability      電壓穩定度（靜態反應） 

Voltage Measurement Accuracy   電壓精確度 
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2. 系統安裝 

2.1 安裝儀器設備 

Chroma 8200 自動測試系統之各項硬體裝置，係安裝在一個高41英吋寬19英吋的標

準機箱。安裝時依由上往下的順序，逐一安裝各儀器於機箱內（因本系統為開放性

架構，故所列之安裝順序僅供參考，使用者可依實際需要自行安排）。 

 
 

2.1.1 安裝步驟 

(1) 將後背板全部拆卸下來。 

(2) 鎖上系統控制器、可程式交流電源供應器與直流電子負載的兩側固定板。 

(3) 將直流電子負載推入機箱，並鎖上固定螺絲。 

(4) 調整直流電子負載的支撐架使其與短路斷路控制器之間有 1U 的距離。 

(5) 將短路斷路控制器推入機箱內，鎖上固定螺絲。 

(6) 調整短路斷路控制器的支撐架與系統控制器之間有 1U 的距離。 

(7) 將系統控制器推入機箱內，鎖上固定螺絲。 

(8) 調整系統控制器的支撐架與可程式交流電源供應器之間有 1U 的距離。 

(9) 將可程式交流電源供應器推入機箱底座，並鎖上固定螺絲。 

(10) 將直流電子負載與短路斷路控制器的 1U 前端出線面板鎖上 

(11) 將下列的配線組裝上： 

 連接 A/D 卡到待測物治具的量測纜線。 

 連接 AD 卡到短路過電壓控制器的控制排線。 

 連接可程式交流電源供應器到待測物治具的電源線。 

 連接直流電子負載到待測物治具的拉載纜線與量測纜線。 

 連接短路過電壓控制器與直流電子負載的短路纜線。 

 串接各硬體裝置（系統控制器、可程式交流電源供應器、直流電子負載）的

GPIB 電纜。 

(12) 將可程式交流電源供應器、直流電子負載、短路斷路控制器等儀器的電源線插到

機箱內的系統電源插座。 

 



開關電源供應器自動測試系統 8200 使用手冊 

 2-2 

AC
Source

Test Fixture
600011

L

N

VL

VN

Load 1

Load 2

Load 3

Load 4

Load 5

Load 6
sense

Load 1

Load 2

Load 3

Load 4

Load 5

Load 6

LOAD

1

2

2

3

3

4

4

5

5

6

6

8125 Extended
Controller

1

1   2   3   4   5   6

2

3

4

5

6

AD Card
in IPC

 

AC On

PG

TTL 
OUT

EXT 
A,B

1

7

1

2

3

5

4

6

9

8

OUTPUT

TEST 
VOLTAGE 

INPUT

8200 SMPS ATS 配線圖

BNC

BNC

D-TYPE

D-TYPE

紅,黑
配對

RELAY 
Control port

8125 Extended
Controller UNIT

 RELAY 
CONTROL 

PORT 
CABLE

CN2
1 2 3 4 5 6

TTL

註:1.LOAD ,and Sense 線,在裝配時,請注意 裝備輸
       出入的相對應channel 號碼.
     2.8125  extended 6 個輸出,接至DC load輸出端.  
    3.依客戶UUT 規格,使用衰減器.
     4.請注意AD卡內部JP跳法.

JP1 JP2 JP3

JP4 JP5

DIFF INTCLK

-10V

INTREFF

DIFF

AD CARD 
JAMP 
SETUP

sense

sense

sense

sense

sensesense

sense

sense

sense

sense

sense

20pin排線

Input Source

圖 2-1  Chroma 8200 ATS 配線圖 

 
 



系統安裝 

 
 

2-3 

2.1.2 輸入電源需求及應注意事項 

Chroma 8200 自動測試系統各部儀器輸入電壓及需求功率如下表﹕ 

 

儀 器 輸入電壓 頻率範圍 功率需求 廠牌型號 

可程式交流電源供應器 115 / 230 V 47-63HZ 5KV Chroma 61、65 系列 

可程式直流電子負載 115 / 230 V 47-63HZ 180VA max Chroma 6310、

63208 

短路過電壓控制器 115 / 230 V 47-63 HZ 130VA max Chroma 8125 

表 2-1  各儀器輸入電壓及功率需求 

 
在安裝本測試系統之前要先確認可提供足夠容量及穩定電壓和頻率的輸入電源以確

保系統可正常運作，延長使用壽命。 

 
本系統輸入為 230VAC 的儀器，係自後背板最下層的電源插座輸入，並延伸為兩個

AC 230V 的電源插座以供各儀器使用。若要外加儀器，必須考慮電源線及電源插座

容量是否足夠。若外加儀器使用非 230VAC 的輸入電源，必須另外接線；否則不得

使用系統提供的電源插座。 

 

 
非 8200 使用之儀器設備，請勿使用 8200 之電源插座，以免電路無

法負荷，而致 8200 之設備有所損壞。 

 
 

2.2 安裝／取消安裝 Chroma 8200 ATS軟體 

在您使用 Chroma 8200 系統之前，必須先將 Chroma 8200 ATS 軟體安裝到您的硬

式磁碟裡。下面我們要告訴您，如何在您的視窗環境上按步就班地安裝 Chroma 8200 

ATS。 

 
 

2.2.1 在Windows環境上安裝 Chroma 8200 

■ 在您安裝之前，您電腦中的硬碟應預留至少有 400 MB 以上的存放空間。 

■ 將所附的軟體保護器（Software Protection Key）安插到LPT1或USB埠。 

■ 將 Chroma 8200 ATS 系統軟體之光碟片置入光碟機中。 

注意
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■ 若您使用光碟片安裝且您的作業系統有支援 Auto Run 的功能，則安裝程式便

會自動執行，您可立即進行安裝；否則的話，您可以選擇以下兩種方式之一來執

行 SETUP.EXE 安裝程式。 
 

 使用 執行（R）… 命令安裝 

(1) 在您的Windows的桌面上，先將您的滑鼠在左下角的「開始」命令列上

按一下，然後選取 「執行（R）…」 命令並執行，這時會出現「執行」

視窗。 

 

(2) 然後在「執行」視窗中按下 瀏覽（B）… 按鈕來選取安裝程式所在的

磁碟機（A:或 B:）或光碟機（D: 或光碟機代號）中的 SETUP.EXE 。

通常，這個檔案應該會在安裝程式所在磁碟機的根目錄下，或根目錄下

的 Disk1 目錄裡。 
 

 
圖 2-2 「執行」視窗 

 

(3) 按下 確定 按鈕便立即開始安裝。 

 
註 8200 安裝運作需具備 Windows administrator 管理者權限。 

 

 使用 Windows 檔案總管 命令安裝 

(1) 請在視窗的 「開始」 命令列上，先選取 「程式集（P）」，然後再選取 

「Windows 檔案總管」命令並執行。 

(2) 選取安裝程式所在的光碟機（D: 或其他）的根目錄下，以滑鼠在安裝

程式 SETUP.EXE 上連按兩下便可以開始安裝。 

(3) 安裝時首先顯示如圖 2-3之畫面，您可依照您目前電腦上是否已安裝

NI VISA或NI IVI Engine，來決定是否要安裝此二軟體套件。建議您的

安裝順序為，先安裝「NI-VISA」、再安裝「NI-IVI Engine」，最後才安

裝「Chroma 8200 System Software」。 
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圖 2-3  Chroma 8200 系統軟體安裝主功能畫面 

 

(4) 當您要安裝「Chroma 8200 System Software」時，只要按下圖 2-3所示

的Chroma 8200 System Software按鈕，即會顯示如圖 2-4之畫面。 

 

 
圖 2-4  系統軟體資訊畫面 

 

■ 在安裝過程中，只要跟著安裝程式精靈的畫面上的說明來進行即可。 
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圖 2-5  安裝精靈初始化 

 

 
圖 2-6  安裝程式歡迎畫面 
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圖 2-7  Chroma 8200 授權宣告 

 

■ 安裝過程中需輸入使用者姓名及公司名稱。 
 

 
圖 2-8  輸入使用者姓名及公司名稱 
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■ 安裝過程中需輸入您所要安裝的目錄，若您未選擇目錄，安裝程式會自動為您在 

\Program Files 目錄下建立一個 Chroma\Chroma 8200 的預設目錄，然後將所

有相關的程式和資料檔案安裝在此目錄內。建議您直接按下 Next > 鈕即可。下

面列出當您安裝完畢之後，安裝精靈所幫您產生的相關目錄和程式。 

  

 
圖 2-9  選擇安裝目錄 
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圖 2-10  確認安裝路徑 

 

在 C:\Program Files\Chroma\Chroma 8200 目錄內應有下列的子目錄﹕ 

 
\Bin 存放 Chroma 8200 ATS 系統軟體系統程式 

\CVIRTE 存放 CVI runtime engine 

\Data\Db 存放系統資料庫檔案 

\Help 存放使用說明 

\HWCfg 存放硬體組態設定檔（.hwc） 

\Ini 存放測試程式資訊檔 

\Lib 存放儀器驅動程式庫 

\Log 安裝時為空目錄，存放測試結果統計資料記錄檔（以測

試程式名稱為子目錄）。 

\Program 存放測試程式（.prg） 

\Report\Format 存放報表格式檔案（.rpf） 

\Spc 存放「Statistics」專案檔（.spc） 
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圖 2-11  Chroma 8200 安裝中 

 

 
圖 2-12  是否顯示 ReadMe 檔 
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圖 2-13  安裝成功，是否重新開機 

 
 

2.2.2 安裝 GPIB 及 ACL 9112 DIO Card驅動程式 

請依照 GPIB 界面驅動程式安裝手冊之步驟，進行安裝。 

 
 

2.2.2.1 安裝 ACL 9112 DIO Card 驅動程式 

執行包裝盒內之DIO Card 驅動程式光碟，若支援 Auto Run 的功能，則安裝程式

會自動執行，您可立即進行安裝。選Software Package>>NUDAQ PCI Package(介

面卡為PCI介面)>>PCIS DASK>>For WIN98>>命令安裝，如下圖。 
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圖 2-14 

 
將電腦關機後，將ACL 9112 DIO Card 插入電腦中，再重新開機，使WINDOWS作

業系統重新自行偵測新硬體。安裝完成後請確認在進入控制台>>系統>>裝置管理員

之後其內容是否如圖 2-15圈點所示，才為安裝成功。 
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圖 2-15 

 
安裝軟體保護器 

 
當您完成上述的安裝步驟之後，在您啟動 Chroma 8200 ATS 之前，請將 Chroma 

8200 ATS 軟體保護器連接至您 PC 的第一印表輸出埠（LPT1），或USB埠才可正

常執行程式。 
 
 

2.2.3 取消安裝 Chroma 8200 

若您想要移除 Chroma 8200 ATS 軟體時，建議您從 「開始」命令列 上的「設定」

功能群組中的 「控制台」 功能，使用 「新增 / 移除程式」 來刪除Chroma 8200 ATS 

相關項目。 
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圖 2-16  移除 Chroma 8200 ATS 
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3. 快速操作說明 

本章介紹Chroma 8200軟體的快速使用操作，同時說明有關測試程式的基本觀念。

詳細操作方法請參考後面相關章節的說明。  

 
 

3.1 開機前的注意事項 

在開始操作 Chroma 8200 測試系統之前，您必須先確定有足夠和穩定的交流電壓

可供應 Chroma 8200 系統中的每一裝置使用。為減低開機瞬間出現湧浪電流 

(Inrush Current ) 對自動測試系統的衝擊效應，建議您開機的先後順序為交流或直流

輸入電源供應器、OVP / UVP 電源供應器、電子負載及其它儀器設備模組，最後才

是您的個人電腦及其它的週邊硬體設備。 

 
 

3.2 如何啟動 Chroma 8200 

如果您遵照2.2 節中的指示，將 Chroma 8200 軟體安裝到您的硬式磁碟中，在您

的電腦螢幕桌面上會出現一個 Chroma 8200 的捷徑。請以滑鼠雙擊此捷徑，即可

啟動 Chroma 8200。 
 

另外，您也可藉由選取 程式集(P)來執行 Chroma 8200。 [開始] [程式集(P)] 

[Chroma][Chroma 8200]。 

 
執行 Chroma 8200 後，首先會出現登入畫面如下： 

 

 
圖 3-1  登入畫面 

 
請在 User ID 和 Password 輸入欄中鍵入使用者識別名稱(User ID )和正確的密碼

後﹐再按下 Login 按鈕以便開始使用 Chroma 8200。若是第一次使用本軟體﹐請
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在 User ID 欄位鍵入 ”root”﹐Password 欄位留空白即可登入﹐並請在登入後為使用

者 ”root” 加入密碼以確保使用安全。 

 
在您進入主畫面時，Chroma 8200系統會根據您的識別名稱(User ID)取得您的使用

權限，如果您對部份功能沒有使用權限，系統會將您沒有使用權限的功能失效。相

關的權限設定及說明請參考第10章系統管理中有關設定使用者及使用者權限的說

明。 
 

 
圖 3-2  Chroma 8200 主功能畫面 

 

Chroma 8200 的主畫面是由三個功能群組及九個選項所構成。三個功能群組中所提

供的功能選項分別說明如下： 

 
Test Program  用來編輯、驗證測試程式。 
Report Editor  用來編輯報表輸出格式。 
Report Generator 根據Report Editor程式所產生的報表格式及測試過程中所得

之數據來產生報表。 
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GO/NOGO 用來進行待測物測試.。 
Statistics 用來執行統計製程分析 

Management 用來管理使用者的使用權限及測試程式發行、匯出、匯入等

功能的設定。 

 
H/W Configuration 用來設定儀器設備之硬體組態（如GPIB位址設定）及選擇所

需使用的測試設備。 
About 關於Chroma 8200。 
Exit 離開Chroma 8200。 
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3.3 Chroma 8200 操作流程 

Chroma 8200 系統操作統程如下： 

 

 
設定硬體組態 

(H/W Configuration) 

測試程式編輯/驗證 
(Test Program 

Editing/Verification) 

報表編輯 

(Report Editing) 

進行待測物測試 

(GO/NOGO Test) 

報表列印 

(Report Print) 

測試結果符合需求? 

發行測試程式 

(Management/Test Program) 

是 

否 

 
圖 3-3  Chroma 8200 之操作流程 
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3.4 設定儀器配置組態 

當您在Chroma 8200的主畫面中選擇Hardware Configuration選項後，便會顯示出儀

器配置視窗。 

 

 
圖 3-4  儀器配置視窗 

 
 

3.5 建立新的測試程式 

測試程式是由許多的測試項目組合而成。系統中已經內建了一些測試項目，您可以直

接使用它們。要建立新的測試程式，請先將所需的測試項目選出來，然後設定各測試

項目的參數，最後設定所需之報表格式檔（.rpf），作為報表輸出的參考。 
 

當您在主畫面中選擇 Test Program 選項之後，便會顯示出測試程式編輯視窗。此時

會詢問使用者想要新增一個測試程式或開啟已存在的測試程式，若選擇「Create new」

並按下OK按鈕就會顯示出一個新的空白測試程式，如圖 3-5 所示。 
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圖 3-5  測試程式編輯視窗 

 
設定測試程式資訊 
 

按下左窗格上的 Program Info... 按鈕後，會顯示測試程式資訊視窗： 
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圖 3-6  測試程式資訊對話盒 

 
請依需要輸入各項參數。其中 Link 頁面中的 Report Format File 指的是報表列印格

式檔，與測試結果之列印有關，若要指定不同的檔案，請按其右邊的按鈕 … 來選

擇所要的檔案。 

 
加入測試項目至測試程式中﹕ 
 

測試項目的加入是以插入的方式進行。請先在主畫面左邊的測試項目編輯區中以滑鼠

左鍵點選所要插入的位置，假設是 Seq 3，然後在視窗右邊的測試項目列示區中選好

測試項目後按工具列上的 Insert TI ，則此測試項目就會被加到 Seq 3，而原本的 Seq 

3 會被躋到 Seq 4，其後面的測試項目也都會被往後躋。在視窗右邊的測試項目列示

區中，若以滑鼠左鍵雙擊所要的測試項目，則會將此測試項目加到主畫面左邊測試項

目編輯區 Seq3 的下一個項目（Sequence）。 
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設定導引（Vector）值 
 

您可以按主選單中的[View]→[Vector Editor]或工具列上的 Vector 切換到導引編輯

區，如圖 3-7所示，畫面上方的Vector Set Select下拉式選取盒可以讓您選擇所要編

輯Vector的種類，系統出廠時預設了三種Vector：Line In Vector、Load Vector和Spec. 

Vector。 
 

 
圖 3-7  導引編輯視窗 

 

設定測試項目之參數﹕ 
 

請按工具列上的 Parameter 按鈕或是以滑鼠雙擊測試程式項目表格中的 Test Item 

欄位，原先的測試項目列示區就會變成如圖 3-8的測試項目參數編輯區。 
 

請在測試程式項目表格中以滑鼠左鍵點一下所要的測試項目，測試項目參數編輯區就

會顯示所選到的測試項目參數以供編輯。 
 

參數設定完成後，請按工具列上的 Test Item 按鈕，測試項目參數編輯區就會變回

測試項目列示區。 
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圖 3-8  測試項目參數編輯區 

 

儲存測試程式 
 

測試程式寫好後，請記得將其存檔，以確保您所修改的內容可被記錄在儲存裝置中。 
 
 

3.6 驗證測試程式 

當您設定好每一個測試項目的參數值（包括 Vector）後，可按下工具列上的

Execution Control 按鈕，畫面會切換到如圖 3-9 測試程式詳細驗證執行畫面所示的

視窗，Chroma 8200 ATS 系統軟體準備執行您目前正在編輯的測試程式。當然您隨

時可以依照測試的結果，按下工具列上的 TP Editor 按鈕在切回原先的測試程式編

輯視窗。經過反覆測試、驗證您所設定的參數都沒有問題後，確定可以交由生產線

執行前，請務必先執行下一節所要說明的發行程序。 
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圖 3-9  測試程式詳細驗證執行畫面 

 
 

3.7 發行測試程式 

在您透過GO/NOGO模組執行測試程式之前，請先回到Chroma 8200 ATS系統軟體的

主畫面，然後按下 Management 選項按鈕，此時畫面會出現如圖 3-10所示的視窗。

將畫面切換到Test Program標籤頁，在Release欄勾選所要執行的測試程式，經過此

一發行程序後的測試程式，才能夠在GO/NOGO程式被執行。 
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圖 3-10  發行測試程式 

 
 

3.8 執行測試程式 

您在Chroma 8200 ATS系統軟體的主畫面，按下 GO/NOGO 選項按鈕後，會出現如

圖 3-11所示的視窗。 
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圖 3-11  開啟測試程式 

 

待您選擇一個測試程式名稱按下 OK 按鈕後，畫面即會出現如下的視窗。 

 

 
圖 3-12  GO/NOGO 程式畫面 
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等到左下方的窗格出現“Initialize Devices Successfully !”訊息時，您可以按鍵盤上

的功能鍵F10或是以滑鼠左鍵按下工具列上的圖形按鈕  Go (F10) ，Chroma 8200 

ATS系統軟體就依照測試程式中的參數設定，執行測試程式。 
 

 
圖 3-13  GO/NOGO 執行結果畫面 

 
 

3.9 列印測試結果報表 

執行報表產生程式有兩種方法，一是離線（Off-Line）模式，在 Chroma 8200 的主畫

面中按 Report Generator 選項後，便會執行「報表產生程式」，此時會顯示「選擇

欲列印資料視窗」。另一執行方法為線上（On-Line）模式，在測試期間由 GO/NOGO

程式自動呼叫，並將測試結果傳送至本程式。 

 
離線模式執行時，會出現「選擇欲列印資料視窗（Select data of tested UUTs from 

database）」。讓您選擇欲產生報表的資料，您也可以利用選單功能[File]→[Open Log 

Database]來開啟此視窗，如圖 3-14所示。在畫面中有三個選項可以用來過濾待測物，

All代表找出所有待測物，Pass UUT Only代表只找出Pass的待測物，Fail UUT Only

代表只找出Fail的待測物。 
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圖 3-14  離線資料選取視窗 

 
當設定完成時，按 OK 鈕讓程式幫您產生如圖 3-15所示的報表。 
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圖 3-15  顯示報表內容 

 
 

3.10 結束 Chroma 8200 

在Chroma 8200 ATS系統軟體主畫面中，您可用下列三種方式來結束 Chroma 8200

系統軟體程式： 
 

(1) 在主畫面中將滑鼠游標移至Exit上並按滑鼠左鍵，或 

(2) 在主畫面中將滑鼠游標移至視窗右上角的 × 按鈕上並按滑鼠左鍵，或 

(3) 在主畫面中鍵入Alt+F4。 
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4. 設定儀器配置組態 

4.1 執行程式 

當您在 Chroma 8200 系統軟體的主畫面中選擇 H/W Configuration 選項後，便會執

行「儀器配置組態設定程式」。此設定程式會讀出預設的組態設定檔（.hwc）後顯示出

儀器配置視窗，如下圖所示： 

 

 
圖 4-1  儀器配置視窗 

 
「儀器組態配置設定程式」在執行初期會根據 Registry 的內容，讀出預設之組態設定

檔（.hwc），然後根據組態設定檔顯示儀器配置視窗。若預設之.hwc 不存在，則程式

會告知使用者（系統首次安裝後會有一預設的 Config.hwc）。 
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您可利用選單功能表中的 [File]→[Save] 將目前所編輯的組態設定存檔，或是利用

[File]→[Save As…] 將目前所編輯的組態設定存成另一檔名。在本程式中，您可以

開啟不同的 .hwc 檔，但是系統只能有一個預設的 .hwc 檔。您可利用選單功能表中

的 [File]→[Set As System Default] 將目前所編輯的組態設定成系統預設檔，一但

被指定為系統預設檔，則在執行裝置初始化時就以此檔案所設定的內容執行之。 

 
如果您想要重新指定儀器組態，可利用選單功能表中的 [File]→[New] 功能；您也

可利用選單功能表中的 [File]→[Open…] 功能，來開啟系統中既有的組態設定檔，

如下圖所示。 
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4.2 儀器配置視窗說明 

儀器配置視窗中共分為三個小視窗，分別是「左視窗（Instrument Window）」、「上

視窗（Model-Info Window）」及「下視窗（Module-Info Window）」，您可自行依顯

示內容需要而調整三個視窗的大小。視窗內容說明如下： 

 
 

4.2.1 左視窗（Instrument Window） 

「左視窗」用來配合新增、刪除目前配置儀器的組態，並且以樹狀圖顯示目前測試

系統中已經配置了那些儀器的種類、型號與數量。 

 

 
 
樹狀共分為五層：第一層為 Instrument 表示儀器分類的總覽，第二層代表 Device 

Type 儀器分類，第三層 Model 表示儀器型號，第四層 Sub Device Type 表示專屬於

第三層儀器的特殊儀器種類，第五層 Sub Model 則表示專屬於第三層儀器的特殊儀

器設備（型號），如下表所示。 
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視窗中的⊕表示其下層還有其他儀器設備，可在⊕上按滑鼠左鍵展開之。此外，在

儀器設備上按下滑鼠左鍵後，關於儀器設備的相關資訊會顯示在上視窗（Model-Info 

Window）及下視窗（Module-Info Window）。 

 

 Type 意義 舉例 

第一層 Instrument 儀器分類的總覽  

第二層 Device Type 儀器種類 EMU Set 

第三層 Model 儀器設備（型號） Chroma 6011 

第四層 Sub Device Type 專屬於某些儀器的特殊儀器種類 
Short Circuit/OVP 
Tester 

第五層 Sub Model 專屬於某些儀器的特殊設備型號 Chroma 6012 

 
 

4.2.2 上視窗（Model-Info Window） 

以格狀方式（Grid）顯示儀器設備的相關資訊，包含儀器種類（Device Type）、設備

型號（Model Name）、使用介面（Interface）及儀器通訊介面的相關參數（Parameter）

及是否要作用（Active）。 

 

 
 
此視窗所顯示的內容會根據您在左視窗中選擇的項目而不同。選擇第一層項目會顯示

所有Model的資訊，選擇第二、四層項目會顯示與目前相同Device Type的所有Model

資訊，而選擇第三、五層項目則只會顯示目前單一 Model 的資訊，如下表所示。 

 

 選擇項目 上視窗顯示的內容 

第一層 Instrument 顯示所有儀器的資訊 

第二層 Device Type 

顯示與目前具有相同 Device Type 的所有儀器設備

資訊，如上圖即顯示所有目前組態中的所有 AC 

Source 種類的儀器設備資訊。 

第三層 Model 只會顯示目前單一儀器的資訊。 
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第四層 Sub Device Type 同第二層 

第五層 Sub Model 同第三層 

 
 

4.2.3 下視窗（Module-Info Window） 

顯示儀器設備的模組（Module）相關資訊，包含下列三種： 

 
(1) 單一或相同 Device Type 儀器的頻道資訊（Channel Information），包括儀器設

備型號（Model Name）、頻道編號（CH）、模組名稱（Module Name）、指定索

引編號（Spec Index）及 Channel 是否作用（Active）. 

 

 
 
(2) 顯示目前儀器配置的 Load 並聯關係 （Load Connection），其中一列（row）表

示一個並聯關係，如右圖表示 Spec Index 為 1 與 2 的 Channel 並聯，拉載比例

為 40% 與 60%，Spec Index3 的 Channel 為第二個並聯關係，並在 Enable 欄

指定在測試過程中要用到目前所設定的並聯關係。 

 

 
 
(3) 某個儀器之 Sub Model 資訊，包括儀器設備型號（Model Name）、頻道編號（CH）、

模組名稱（Module Name）、指定索引編號（Spec Index）及 Channel 是否作用

（Active）。 
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此視窗所顯示的內容會依不同的操作方式而顯示不同的內容，如下表所示： 

 

操作方式 選擇項目 下視窗顯示的內容 

左視窗 

Instrument 不會顯示任何資訊。 

Device Type 
顯示目前相同 Device Type 的所有 Model 的

Channel Information。 

Model 顯示目前 Model 的 Channel Information 

Sub Device 
Type 

顯示目前相同 Device Type 的所有 SubModel 的

Channel Information。 

Sub Model 
顯示目前單一 Sub Model 的 Channel 

Information。 

上視窗 
Device Type 

顯示目前相同 Device Type 的所有 Model 的

Channel Information。 

Model 顯示目前 Model 的 Channel Information。 

選單(Menu) 

[View / Module 
Information] 

顯示 Module Information Window。 

[View / Load 
Connection] 

顯示 Load Connection Window。 

 
 

4.3 操作說明 

您可以利用儀器配置視窗中的「左視窗」來新增或刪除儀器設備。您亦可以用利

「左視窗」、「上視窗」及「下視窗」來修改測試統中所使用到的儀器的設定，包括
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使用介面、通訊介面參數及頻道資訊等。 

4.3.1 新增儀器設備 

新增 Model 時，在「左視窗」欲新增的 Model 所屬 Device Type 上按下滑鼠右鍵，

出現功能表，然後選擇 [Add…] 即可。功能表可能會因儀器種類不同而出現不同的

文字。例：新增一台 Chroma 6120，在 [Input Source…] 上按下滑鼠右鍵，會出

現「Add Model」視窗，選擇儀器後按 OK 即可。 

 

 
 
 

4.3.2 刪除儀器設備 

1. 要刪除單一 Model 時，在欲刪除的儀器設備上按下滑鼠右鍵，選擇 

[Delete …]功能表即可。例：刪除 Chroma 6120。 
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2. 要刪除相同 Device Type 的所有 Model 時，在欲刪除的 Device Type 上按下滑

鼠右鍵，選擇 [Delete …] 功能表即可。功能表文字可能會因儀器種類不同而

改變。例：刪除所有 Input Source 的 Model。 

 

 
 
3. 欲刪除所有 Model 時，可在「左視窗」Instrument 項目上按下滑鼠右鍵，選擇

[Delete All] 功能表即可。 
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4.3.3 組態之設定及修改 

儀器組態設定與修改包含設備型號、使用介面、通訊介面參數及頻道資訊等，之間

並無一定順序關係。但在某些情況下，當您修改某一欄位時，同一列的其他欄位內

容可能也會被更改。例如：當您將「使用介面」由 GPIB 變更為 RS232 時，其

Parameter 欄位內容也會隨之改變。 

 
 

4.3.3.1 使用介面設定 

 使用介面有 7 種：GPIB、RS485、RS232、IO MAP/PC、I2C、RS232-I2C 及

USB 介面。 

 設定時，在「上視窗」的 Interface 欄位利用[下拉式選單]選取即可。 

 

 
 
 

4.3.3.2 通訊介面參數設定 

 設定時，在「上視窗」Parameter 欄上，欲設定的 Model 通訊介面參數的格子

（Grid）上的雙擊滑鼠左鍵即可。 
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 不同的介面會出現不同的參數設定視窗： 

 
(1) GPIB 介面： 

GPIB 介面使用時，一般來說要只設定其主要位址（GPIB Address）即可。 

 

 
 
(2) RS232 介面 / RS485 介面： 

RS485 參數設定視窗如下圖所示。RS232 介面參數設定視窗與 RS485 一樣，只

是沒有位址（Address）的參數。 

 

 
 
(3) IO MAP/PC 介面： 

此介面指的是插在 PC 上的介面卡，其參數設定視窗如下： 
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(4) I2C 介面／RS232-I2C／USB-I2C 介面： 

此介面可編輯 I2C 裝置的相關參數，如使用卡板須設定板號，若使用 RS232 或

USB-I2C 轉接裝置，須設定 RS232 或 USB-I2C 相關參數。由於 I2C 一般常見

Slave Address 表示法有兩種，請依實際狀況設定。 
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(5) USB 介面： 

此介面須在儀器實際連接時才能設定，如下圖系統會偵測目前線上此類型儀器所

有序號，使用者須指定欲連接的儀器序號。 

 

 
 
 

4.3.3.3 是否作用設定 

在本程式中新增的儀器，您也可以設定它在測試的過程中不被使用。設定時，在

「上視窗」的 Active 欄位利用[下拉式選單]直接設定即可。 
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4.3.3.4 頻道（Channel）資訊設定 

在新增儀器時，程式會顯示頻道資訊內定值。頻道資訊包含儀器設備型號（Model 

Name）、頻道編號（CH）、模組名稱（Module Name）、指定索引編號（Spec Index）

及是否作用（Active）。您必須在「下視窗」中完成設定。其說明如下： 

 
(1) 儀器設備型號（Model Name） 

顯示儀器設備型號。此欄位內容不能更改。 

(2) 頻道編號（CH） 

顯示儀器設備中頻道的編號。此欄位無法更改。 

(3) 模組名稱（Module Name） 

顯示儀器設備中的模組名稱。若此 Model 為不可插換模組，則此欄位無法修改。

反之，若此 Model 是為可插換模組（Module），則您可以在「下視窗」中的 Module 

Name 欄中利用「下拉式選單」來新增或移除某些模組。  

 

 
當使用下拉式選單新增 Model 時，程式會自動尋找且顯示只適合

（Fit）目前狀態的 Module。例如：下圖中不會顯示 Chroma 63107， 

因為 63107 會佔用四個 channel 的位置， 而目前 channel 3 下面

只剩兩個 channel 位置可用（channel 3 & channel 4）。 

 

 
 
(4) 指定索引編號（Spec Index） 

指定索引編號是用來設定儀器的 Channel 在系統測試過程中的邏輯編號。若某頻

道指定索引編號為-１，則表示此頻道不會在測試過程中被用到。需注意的是，對

相同 Device Type 的 Model 來說，可作用的 Channel 其索引編號必須從 1 開始，

且必須連號、不可重覆；否則在存檔時會有錯誤訊息提醒您。欲修改索引編號，

只須在 Spec Index 欄位利用[下拉式選單]設定即可。 

 

注意
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(5) 是否作用（Active） 

用來指定 Channel 在系統測試過程中是否作用。若是，其值為 True；反之，其值

為 False。目前它會隨著指定之 Spec Index 而改變。一般來說，當 Spec Index

為 -1 時，其值為 False，表示無作用；當 Spec Index 不為 -１時，其值為 True，

表示作用。 

 
 

4.3.4 並聯關係（Load Connection）設定 

在系統測試過程中，您可以設定多個 Load 並聯拉載（本系統中最多可設定 12 個）。

設定之前，您可以利用 [View]->[Load Connection] 功能表將「下視窗」切換至

Load Connection 視窗，如下圖所示： 

 

 
圖 4-2  Load Connection 視窗 

 
其中一列（Row）代表一個並聯關係，L1 ~ L12 為 Load 並聯，填上”*”表示為空。

R1 ~ R12 表示各並聯 Load 拉載的比例，而 Acitve 欄則表示此並關係在測試過程中

是否作用。舉例說明，假設您設定了四個並聯關係，第一個並聯關係以 Spec Index

為 1， 4， 6， 8 並聯，拉載比例為 10%， 20%， 30%， 40%；第二個並聯關

係以 Spec Index 為 2 與 3 並聯，拉載比例為 40%與 60%；第三、四個並聯關係的

Spec Index 分別為 5，7，則其結果如下圖所示。 
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圖 4-3  指定 Load 並聯關係 

 
欲變更並聯關係，您可以在非”*”的儲存格上按下滑鼠左鍵，利用拖拉（Drag & 

Drop）的方式來變更。並聯關係改變後，請記得一併修改其拉載比例。您也可以設

定 Active 欄，用來指定是否在測試過程中要用到目前設定的並聯關係。 

 

 
圖 4-4  模組資訊視窗 

 

 
 並聯關係只跟 Device Type 為 Electronic Load 的 Spec Index 

有關。 

 一個並聯關係的拉載總和必須為 100%。 

 在設定並聯關係之前，您必須先設定 Electronic Load 的 Spec 

Index。 

 並聯關係中，只會顯示非 -1 的 Spec Index，也就是說，有作

用的 Channel 才能設定並聯關係。 

 在修改了 Load 的 Spec Index 後，程式會自動根據 Spec 

Index 更改的情形跟著反應。所以建議您，在所有的

Electronic Load 的 Spec Index 都確定之後，再來設定並聯關

係。 

提示
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 若兩個並聯關係（Row）之間有空的 Row，則下次進入時，

程式會自動將並聯關係向前遞補。 

 一旦圖 4-3 中的「Enable」欄位被指定為 Enable 時，圖 4-4

中的「Spec Index」欄位的內容將會以小括弧內的字串來表

示其並聯後的組別（1 ~ 4）。 
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5. 編輯測試程式 

測試程式（.prg）是由許多的測試項目組合而成。系統中已經內建了一些測試項目，

您可以直接使用它們。此外，Chroma 8200 ATS系統軟體又將測試項目分為[Pre Test]、

[UUT Test]與[Post Test]三大群，屬於[Pre Test]的測試項目只有在執行環境第一次執

行此測試程式時才會被執行到，屬於[Post Test]的測試項目則只有在執行環境卸載測

試程式時才會被執行到，至於[UUT Test]中的測試項目在每一次執行測試程式時都會

被執行到。要建立新的測試程式，進行下列三個步驟： 
 

1. 依照執行順序將所需的測試項目選出來。 

2. 編輯所選測試項目之執行流程，包括： 

 Pass Goto 

 Fail Goto 

 Fail Rerty 

 Loop To 

 Loop Cycle 

3. 設定各測試項目的參數值。 

 

以下介紹測試程式編輯視窗之操作。 

 
 

5.1 啟動 

當您在主畫面中選擇 Test Program 選項之後，程式首先會詢問您是要開始編輯一

個新的測試程式或是要開啟先前所儲存的測試程式。 

 

 
圖 5-1  新增或開啟對話盒 
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5.1.1 新增 

若您在新增或開啟對話盒選擇 Create new 選項，或日後按主畫面左邊測試項目編輯

區中的 Program Info… ，會產生如圖 5-2 的對話盒，要求您輸入有關此新測試程

式的資訊。下面僅就較重要的幾項說明之： 

 
[General]  
Date 此選項在 General 頁籤內，指此新測試程式建立日期 

Time 此選項在 General 頁籤內，指此新測試程式建立時間 

Comments 此選項在 General 頁籤內，可輸入對此測試程式的註解 

[Link]  
Report Format File 此選項在 Link 頁籤內，用以指定線上列印報表時所套用的

格式檔（*.rpf），此類型之檔案是由報表編輯程式「Report 

Editor」所產生的。 

Fixture Model 此選項在 Link 頁籤內，可選擇執行測試時治具的 Model 名

稱或留空白，當使用者有輸入時，GO/NOGO 程式在測試每

一顆 UUT 之前都會先比對使用的治具的 Model 是否與測試

程式所記載的一致，以及治具剩餘可插拔的次數。 

[UUT Setup]  
Multi UUT 一次測多顆 

Output Numbers 此選項在 UUT Setup 頁籤內且只有在 Multi UUT 下可以使

用，此選項是用以設定每個 UUT 內含幾個輸出，藉此設定

測試程式是 Multi UUT/Single Output 或是 Multi UUT/Multi 

Output，須注意的是此Output Numbers須是小於Total Load 

Numbers 的因數。 

Identical Test 
Condition 

一次測多顆時，不同顆 UUT 是否要使用相同的測試條件。 

Total Load Numbers 此選項在 UUT Setup 頁籤內，指此新測試程式用到 Load

的 Channel 數，此數字不應該大於在「 Hardware 

Configuration」中所指定 Load 的 Channel 數。 

Load Name 此選項在 UUT Setup 頁籤內，指報表中每個 UUT 的每一

個 Load Channel 的顯示名稱（Show Name） 

Reverse 此選項在 UUT Setup 頁籤內，打勾表示反接，沒打勾表示

不反接。 

Divider 此選項在 UUT Setup 頁籤內，設定輸出電壓的衰減倍率，

以提供 A/D Card 做量測。 
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UUT Type 此選項在 UUT Setup 頁籤內，目前支援 Single UUT / Multi 

Output 及 Multi UUT 兩種型態的測試程式，Multi UUT 時

所有的 Test Result 變數都必須是 Load Array 資料型別，否

則無法使用該 Test Item。且可勾選 Identical Test Condition

選項，此條件表示當 Multi UUT 時，若所有的測試條件都一

樣，輸入一個條件即當成全部的測試條件，若未勾選此項，

則需個別輸入所有的測試條件。 

 

 
圖 5-2  記錄測試程式資訊對話盒 

 
在 Test Program Editor 這支程式中，若表格中某些欄位是可編輯的，則您只要用滑

鼠左鍵在想要編輯的欄位上點兩下，就可以進入編輯模式。當您所有欄位確定輸入完

畢，可按 OK 進入主畫面開始編輯測試程式。 
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5.1.2 開啟 

若您選擇 Open existing TP 選項，或日後按主選單中的 [ File ]→[ Open... ]，將會

產生如圖 5-3 之對話盒，要求您指定所要開啟的測試程式。您可以直接輸入測試程

式名稱（不包含.prg）或在列示盒中點選： 

 

 Release：尚未Release的測試程式您可以修改並用相同檔名儲存。已經 Release

的測試程式則會要求您用另一個檔名儲存之。此欄位的值可在另一支程式

Management 中設定。 

 Date and Time：此測試程式最近一次修改的時間。 

 

當您指定所要開啟的測試程式後，可按 OK 或用滑鼠左鍵在該測試程式名稱上點兩

下進入主畫面開始編輯測試程式。 

 

 
圖 5-3  開啟舊有測試程式對話盒 
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5.1.3 主畫面說明 

主畫面分成左右兩部分，左半部為測試項目編輯區。測試項目編輯區上方顯示目前

所編輯測試程式之名稱。若程式名稱右上角出現星號（*），表示您對該程式已做過

若干修改，但修改結果尚未儲存。按下 Program Info… ，將會產生如圖 5-2 之紀錄

測試程式資訊對話盒。測試程式名稱下方共分成三張表格，分別為 Pre Test、UUT 

Test 以及 Post Test，測試程式執行時也會按照此順序。 

 
主畫面右半部在一開始時顯示的是測試項目列示區。測試項目列示區又分成兩頁：

標示為 System 這一頁中的測試項目為系統出廠時所附，標示為 User 這一頁中的測

試項目則是您自行編輯的。 

 
經由排列組合可知測試項目應分為六大類儲存。這樣做的好處是：當某兩個測試項

目存在有先後順序時，與其讓使用者疑惑誰先誰後，不如經由程式幫使用者做分

類，這樣對使用者在編輯測試項目時應該有相當的幫助。 

 

除了測試項目列示區外，您還可以按工具列上的 Parameter 切換到測試參數編輯

區，按 Vector 切換到導引編輯區，或按 Global Pa. 切換到全域變數編輯區。其

詳細功能會在後面章節中說明。 

 

 
圖 5-4  編輯式開始執行之主畫面 
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5.2 加入與編輯測試項目 

5.2.1 加入測試項目至測試程式中 

測試項目的加入是以插入的方式進行。請先在主畫面左邊的測試項目編輯區中以滑

鼠左鍵點選所要插入的位置，假設是 Seq 3，然後在視窗右邊的測試項目列示區中

選好測試項目後按工具列上的 Insert TI ，則此測試項目就會被加到 Seq 3，而原

本的 Seq 3 會被躋到 Seq 4，其後面的測試項目也都會被往後躋。在視窗右邊的測

試項目列示區中，若以滑鼠左鍵雙擊所要的測試項目，則會將此測試項目加到主畫

面左邊測試項目編輯區 Seq3 的下一個項目（Sequence）。 

 
 

5.2.2 測試項目的剪下、複製、插入與刪除 

為了考慮使用者編輯測試項目的便利性，免除重複輸入的費時，程式在「測試項目編

輯區」中提供了剪貼簿的功能。 

 
Cut (剪下) 將所選取的測試項目記在記憶體中供下一步驟使用並刪除

所選取的測試項目。 

Copy (複製) 將所選取的測試項目記在記憶體中供下一步驟使用並保留

所選取的測試項目。 

Paste (插入) 將所選取的測試項目加到所要插入的位置，原位置的測試項

目被擠到下一個 Seq。 

Delete (刪除) 刪除所選取的測試項目。 

 
想要對某一測試項目進行剪貼簿的功能，必須先做選取的動作。以滑鼠左鍵在所要

選取的測試項目的 Seq 欄位上按一下，整列會變成反白，代表選取的動作完成。若

此時您要刪除所選取的測試項目，只要按工具列上的 Delete ，程式會出現一對話

盒詢問您是否確定要刪除，按 是 完成刪除的動作，按 否 取消刪除。 

 

若此時您要在某一 Seq 插入所選取的測試項目，必須先按工具列上的 Cut 或是

Copy 將所選取的測試項目記在記憶體中。注意記憶體中必須要有一筆測試項目，

工具列上的 Paste 才會被致能（Enable）。然後以滑鼠左鍵在所要貼上或插入的測

試項目的 Seq 欄位上按一下，再按工具列上的 Paste 即可。 
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5.2.3 編輯所選測試項目之執行流程 

主畫面左邊的「測試項目編輯區」乃以表格的方式呈現，除了最左邊的表頭外，共有

九個欄位。其說明如下： 

 
Seq 測試項目的順序號碼，一般情況下測試程式是照此號碼由小到大依序

執行測試的。  

Active 勾選與否決定該測試項目要不要被執行。 

Test Item 測試項目名稱。 

Ext. Name 附加說明。 

Label 標籤，用來標示某一特定的測試項目，配合 Pass Goto、Fail Goto 以

及 Loop To 使用，以控制測試項目之執行流程。 

Pass Goto 此欄位可指定一個已經存在的標籤。執行測試時，若此測試項目通過

測試，則跳到此欄位所指定的標籤所在的測試項目繼續做測試。若未

指定任何標籤，則依照 Seq 順序執行測試。 

Fail Goto 此欄位可指定一個已經存在的標籤。執行測試時，若此測試項目未通

過測試，則跳到此欄位所指定的標籤所在的測試項目繼續做測試。若

未指定任何標籤，則依照 Seq 順序執行測試。 

Fail Retry 此欄位可填入一個整數數字。執行測試時，若測試項目未通過測試，

則對此測試項目再做測試，填入的整數數字即為再測試的最多次數。

此功能的優先順序高於 Fail Goto、Pass Goto 及 Loop To，也就是說

會先執行 Fail Retry 的功能，然後再執行 Fail Goto、Pass Goto 及

Loop To 功能。 

Loop To 執行測試時，若該測試項目此欄位有指定一個已經存在的標籤（必須

指定之前的 Seq 才有作用），則跳回到此欄位所指定的標籤所在的測

試項目，如此形成一個迴圈，至於迴圈的次數則在 Loop Cycle 欄位指

定。若未指定任何標籤，則依照 Seq 順序執行測試。 

Loop Cycle 迴圈的次數(註)。 

Report 將來 Report Generator 產生此測試程式的報表時，可針對每個測試

項目報表決定要不要顯示。 

 
註 例如使用者希望從 Seq 3 測試項目到 Seq 5 測試項目反覆做五次： 
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Seq Test Item Label Loop To Loop Cycle 

：     

：     

3 TestItem A A   

：     

5 TestItem B  A 5 

 

 

5.3 設定各測試項目的參數值 

一測試項目包含哪些參數及其型別是在另一支程式 Test Item Editor 中編輯 

（Chroma 8200 無此功能）。參數的型別除了原有的浮點數、整數、字元、字串、百

分比外，又新增了導引（Vector）與全域變數（Global Parameter），並分別設計了

專有的編輯畫面，建議使用者先進入此兩編輯畫面編輯完後，再開始設定各測試項

目的參數值。 

 
 

5.3.1 編輯導引（Vector）項次資料 

當您在編輯測試項目的參數值時，經常會發現，對於某些參數值，您不斷在重複輸

入某幾組數值。為了節省您重複輸入的工作，Chroma 8200 系統軟體引進了一種新

的變數型別— 導引（Vector）。在您的測試程式中，您只要針對不同類的導引

（Vector）各別編輯其項次（Entry）資料後，那麼測試程式中任何一項測試項目宣

告為導引（Vector）型別的變數都可以在其所屬的導引（Vector）型別選擇一項項次

（Entry）資料來使用。 
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Test Item #1

Test Item #2

Test Item #3

Test Item #n

LineInVector

1.

2.

3.

LoadVector

1.

2.

3.

4.

SpecVector

1.

2.

3.

ExtMeasVector

1.

2.

Test Program

 
圖 5-5  導引（Vector）與測試程式（Test Program）關係圖 

 

您可以按主選單中的 [View][Vector Editor] 或工具列上的 Vector 切換到導引

編輯區。如圖 5-6 所示，畫面上方的 Vector Set Select 下拉式選取盒可以讓您選擇

所要編輯的 Vector 種類，系統出廠時預設了三種 Vector：Line In Vector、Load 

Vector 和 Spec.Vector。以編輯 Line In Vector 為例，表格的第一列為 Vector 

Name，其次為 Line In Vector 所包括的三個元素，Voltage、Frequency 和

Range。 

 
當您想要新增一組 Vector 時，先將滑鼠游標移至表格左方灰色部分 Index 欄位上，

用滑鼠左鍵點一下，此時工作列上的 Append V 被致能，再按一下 Append V ，

則表格中會新增一組 Vector，其預設名稱為 Line In Vector 1。您可以修改它。此名

稱會在編輯測試參數時用到，而兩個元素 Voltage 和 Frequency 的預設值則在系統

出廠時就指定了，您也可以修改它們。 
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再次提醒您，在 Test Program Editor 這支程式中，若表格中某些欄位是可編輯

的，則您只要用滑鼠左鍵在想要編輯的欄位上點兩下，就可以進入編輯模式。 

 
Load Vector 的編輯方法很類似，較大差別在於 Load Vector 元素的個數（各個

Channel 的 Loading）是依照圖 5-2 紀錄測試程式資訊對話盒中的 Total Load 

Numbers 值而定。 

 
想要刪除某一組 Vector，必須先做選取的動作。以滑鼠左鍵在所要選取的 Vector 的

Index 欄位上按一下，整列將會變成反白，代表選取的動作完成。若此時您要刪除所

選取的 Vector，只須按表格上方的點陣圖按鈕（Delete），就可以刪除。 

 
此外，Test Program Editor 這支程式提供使用者一個貼心的小功能。您可以按主選

單中的[ File ][ Import Vector... ]將在別的測試程式中已經編好的 Vector 加進來。 

 

 
圖 5-6  導引編輯區畫面 
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5.3.2 編輯全域變數（Global Parameter） 

不同的兩項測試項目（Test Item）想要互相傳遞參數時，此參數必須宣告為全域變

數（Global Parameter）。這個宣告動作是在「Test Item Editor」程式中完成的，而

「Test Program Editor」所要做的，就是提供這些全域變數（Global Parameter）的

初始值讓測試項目使用。 

 

您可以按主選單中的 [View][Global Pa. Editor] 或工具列上的 Global Pa. 切換

到全域變數編輯區，如圖 5-7 所示。表格中以淺黃色為底色的 Global Parameter’s 

Name 為不可編輯，而列數則是依照圖 5-2 紀錄測試程式資訊對話盒中的 Total 

Load Numbers 值而定。對於屬於 Load 的 Global Parameter，您應該為每一個

Channel 輸入一個值，對於不屬於 Load 的 Global Parameter，您只需輸入一個值，

其餘格子會自動變成灰階。 

 

 
圖 5-7  全域變數編輯區畫面 
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5.3.3 編輯測試參數（Test Condition） 

您可以按主選單中的 [View][Parameter Editor] 或工具列上的 Parameter 切換

到測試參數編輯區，如圖 5-7 所示。此時主畫面左右兩部分必須相互參照。請您用

滑鼠左鍵在主畫面左邊測試項目編輯區中想要編輯測試參數的測試項目該行上點一

下，或用鍵盤上下鍵移動游標至想要編輯測試參數的測試項目該行上。此時主畫面

右邊測試參數編輯區會顯示該測試項目的所有參數。 

 
表格中以淺黃色為底色的 Parameter’s Name 為不可編輯，而 Value 欄位就是您要

輸入參數值的地方。一開始顯示的是預設值，此預設值是在另一支程式 Test Item 

Editor 中指定的（Chroma 8200 無此功能）。至於參數值輸入的方式分為三種： 

 
編輯器 (Edit) 用滑鼠左鍵在想要編輯的欄位上點兩下，就可以進

入編輯模式。 

 
下拉式選取盒

(Combo Box) 

用滑鼠左鍵按下拉式選取盒右邊的向下箭頭按鈕，

會出現選單供您選擇。 

 
屬於矩陣 (Array) 型別 

的變數 

屬於 Load 的參數，若屬於矩陣（Array）的型別，

往往需要為每一個 Channel 輸入一個值，礙於空間

的限制，將欄位延伸到畫面上方，而欄位個數則是

依照圖 5-2 中的 Total Load Numbers 值而定。請您

先在欲編輯參數值的欄位上用滑鼠左鍵點一下，再

移動滑鼠到畫面上方的欄位中開始編輯參數值。 

 

屬於 Vector 型態的參數，也是使用下拉式選取盒（Combo Box）的方式來編輯。當

您用滑鼠左鍵按下拉式選取盒右邊的向下箭頭按鈕，選單中出現的是您先前在導引

編輯區中所編輯導引的 Vector Name 供您挑選。 

 
有些參數會在測試過程中拿來和測試結果（Test Result）做比較。若您在此欄位中

輸入「*」，表示您要求程式略過此一比較動作。 
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圖 5-8  測試參數編輯區畫面 

 
 

5.4 列印測試程式 

Test Program Editor 提供一簡單的列印功能，讓您將所編好的測試程式列印出來，

其內容主要分成四部份： 

 圖 5-2 之紀錄測試程式資訊對話盒的內容。 

 按照 Pre Test、UUT Test、Post Test 的順序列出所有測試項目的名稱。 

 按照 Pre Test、UUT Test、Post Test 的順序列出所有測試項目的參數值。 

 導引(Vector)的內容。 

 

您可以先按主選單中的[ File ][ Print Preview ]預覽要列印的內容，再按預覽視窗左

上方的 列印(P)… 列印或直接按主選單中的[ File ][ Print ]列印。 
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5.5 存檔 

要儲存您編輯好的測試程式，您可以按主選單中的 [File][Save] 或按主選單中的

[File][Save As...]。兩者的差別在於前者除了第一次儲存時會出現如圖 5-9 的對

話盒要求您指定檔名外，在接下來都會以原檔名儲存，不會再出現對話盒。而後者

則假設您想要用不同的檔名儲存，故每次都會出現對話盒要求您指定檔名。 

 

 
圖 5-9  另存新檔對話盒 

 
要注意的是，尚未 Release 的測試程式您可以用相同檔名儲存。已經 Release 的測

試程式則會要求您用另一個檔名儲存之。您可在另一支程式「Management」中指定

某一個測試程式要不要 Release。 
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5.6 選單說明 

[File]→[New] ： 新增一個測試程式。 

[File]→[Open…] ： 開啟一個已存在的測試程式。 

[File]→[Save] ： 儲存您正在編輯的測試程式。如果您編輯的是新

的測試程式（即檔名為 Untitled）時，則會出現

「另存新檔」對話盒讓您指定所欲存入的檔名。 

[File]→[Save As…] ： 將正在編輯的測試程式存成另一檔名。 

[File]→ [Import Vector…] ： 將在別的測試程式中已經編好的 Vector 加進

來。 

[File]→[Export Vector To 

EXCEL…] 

： 將目前編輯的測試程式中的 Vector 匯出至 Excel 

[File]→[Print All Seq.(s)…] ： 選擇開啟測試項目列示區時顯示，將目前編輯的

測試項目全部列印出來。 

[File]→[Print Current 

Selected Seq.…] 

： 選擇開啟測試參數編輯區時顯示，只會列印目前

游標所停留的測試項目其參數內容。 

[File]→[Print Preview…] ： 預覽所編輯的測試程式的列印結果。 

[File]→[Print Setup…] ： 設定印表機。 

[File]→[Print To File(*.txt)…] ： 將目前編輯的測試程式及其變數存至 txt 檔 

[File]→[Exit] ： 結束測試程式編輯，回到自動測試系統的主畫

面。 

   
[Edit]→[Cut] ： 將所選取的測試項目記在記憶體中供下一步驟使

用，刪除所選取的測試項目。 

[Edit]→[Copy] ： 將所選取的測試項目記在記憶體中供下一步驟使

用，保留所選取的測試項目。 

[Edit]→[Paste] ： 將所選取的測試項目加到所要插入的位置，原位

置的測試項目被擠到下一個序列 (Sequence)。 

[Edit]→[Delete] ： 刪除所選取的測試項目。 

[Edit]→[Insert Test Item] ： 從畫面右方測試項目列示區插入一個測試項目到

畫面左方。 
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[Edit]→[Security...] ： 

 
使用者可以為每一個 Test Program 檔設定密

碼，以防止他人修改或觀看。要防止他人修改請

選用 Low:Read Only，要防止他人觀看請選用

High:Deny Open。 

[Edit]→[Format…] ： 出現「預設格式」對話盒，使用者可以選擇浮點

數的預設有效位數。 

[View]→[Edit Tool Bar] ： 設定是否顯示工作列。 

[View]→[Status Bar] ： 設定是否顯示狀態列。 

[View]→[Test Item List] ： 切換到測試項目列示區。 

[View]→[Parameter Editor] ： 切換到測試參數編輯區。 

[View]→[Vector Editor] ： 切換到導引編輯區。 

[View]→[Global Pa. Editor] ： 切換到全域變數編輯區。 

[View]→[Reset Client Size] ： 讓主畫面左右半邊的比例回到出廠時的設定。 

   
[Help]→[About TP Editor…] ： 關於本程式。 
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6. 驗證測試程式 

本章主要描述執行測試程式驗證的環境，說明如何使用執行控制程式（Execution 

Controller）將編輯好的測試程式進行 Detail 測試。Detail 測試是指即時測試 TP 

Editor 編輯好的測試程式，在測試的過程並不會記錄測試程式中的讀值至資料庫

中，但是比 GO/NOGO 程式提供更多的控制功能，讓使用者能較有效率的找出測試

程式設計上的問題點。 

 
 

6.1 執行控制程式主畫面 

當您在 Chroma 8200 系統軟體主畫面中選擇 Test Program 選項，並選擇好所要

編輯的測試程式後，以滑鼠點選工具列上的 Execution Control 按鈕，即會出現如

圖 6-1 的視窗。 

 

 
圖 6-1  測試程式的詳細驗證（DetailTest）執行控制畫面 
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執行控制程式（Execution Contrl）之 Detail Test 畫面的安排和顯示與 GO/NOGO 相

同，請參考第 7 章執行測試程式(GO/NOGO)的說明。在詳細驗證中右方的測試內容

顯示區是展現所有變數的那個頁面。在程式顯示區中和 TP 編輯測試時，則預設值是

只顯示到測試項目。您可以依需要，在某個測試命令上，雙擊滑鼠左鍵，一樣可以達

到展開測試命令的功能。 

 
 程式顯示區： 

Detail Test 在主畫面比 GO/NOGO 程式多三個按鈕，以提供設定/取消斷點 

(Break Point）的功能。 

 

Set Brk 設定在測試命令上的執行斷點。當設定斷點後，該行上

會有一個圖型  （中間為黃色直線） 顯示該測試命

令已被設定為執行段點。 

Clear Brk 清除在測試命令上的執行斷點。 

Clear All Brks 清除在測試項目上的執行斷點。 

 
 您可將滑鼠游標移到所要設定斷點的測試命令（Test Command）上，再按下        

 Set Brk、Clear Brk 或 Clear All Brks 按鈕。您會在所選定的測試命令上看

 到一個小旗子的符號，表示您已經設定一個斷點在這個測試命令上。您也可以

在 該行測試命令上按下滑鼠的右鍵，選擇選單的項目達到設定/取消斷點。出現的

 選單上含有 Set Brk、Clear Brk、Clear All Brks，功能和上述按鍵的功能相

同。 
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圖 6-2  斷點設定 

 
 過程顯示區： 

 和 GO/NOGO 相同。 

 
 測試內容顯示區： 

  Detail Test 在測試內容顯示區上是以展現各個變數的內容為主。 

 
 測試程式各測試項目的變數 

 各變數值的表現和 GO/NOGO 的操作一樣。 

 
 執行測試的設定 

 與 TestProgram Editor 搭配的 Detail Test 內容如下。 
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與 TestItem Editor 搭配的 Detail Test 內容如下。 

 

 
 
 

6.2 設定執行測試功能選項 

本小節說明執行控制工具列的功能。執行控制工具列是整個執行控制的操作重心， 

控制執行或停止測試程式。 

 

在和 TestProgram Editor 搭配的 Detail Test 工具列上共有七個按鍵 Go（F10），

Stop（F2），Single（F9），Step，Report（F3），Pause ，Resume  如下圖： 
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按鈕的功能和 GO/NOGO 的說明相同。Detail Test 多三個按鈕 Step，Pause 和 

Resume。 

 

Step 一步步執行測試命令。 

Pause 暫停測試的執行。 

Resume 繼續剛剛暫停的測試。 

 
底下的圖示，是當執行中斷在斷點上或者被使用者暫停（Pause）執行流程的狀態。 

此時在中斷點上會有一個圖形 （中間為紅色直線），顯示目前的中斷點。 

 

  
 

使用者只可以執行 Stop，Step 和 Reume 的功能。詳細驗證 Detail Test 的其他

功能請參閱第 7 章執行測試程式(GO/NOGO)所述。 
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7. 執行測試程式(GO/NOGO) 

本章主要描述執行測試程式的環境，說明如何使用執行控制程式（Execution 

Controller）將編輯好的測試程式進行 GO/NOGO 測試。在測試過程中會將測試結果

傳送給線上報表程式（On-Line Report Geneartor）以利報表的輸出。執行控制程式

亦會將測試結果記錄至資料庫中，作為未來的統計製程管制分析，以及離線報表列

印工作。 

 
 

7.1 執行控制程式主畫面 

按下 Chroma 8200 的主畫面上的 GO/NOGO ，立即啟動執行控制程式。執行控制

程式會立即啟動「H/W Configuration」程式所設定的設備以進行初始化，並將初始

化的結果顯示在左下方的測試過程顯示區。 

 
下圖為執行控制程式的主畫面。 

 

 
圖 7-1  執行控制程式主畫面 
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在執行控制程式主畫面共可分成三個部份，依逆時鐘方向分別為：程式顯示區、過

程顯示區與測試內容顯示區。 

 

 程式顯示區： 

 
 將開啟的測試程式中的每一個測試項目都顯示在此區表格中。正在執行的該列

將 以較深的顏色表示。 

 

 
 
在表格中共分為六欄，第一欄為測試項目在測試程式中的順序，第二欄為測試

項目的名稱，第三欄為測試項目命令，第四欄為測試命令的參數，第五欄會顯

示測試程式的流程控制設定，第六欄則顯示測試項目執行後的結果。 

 
您會看到某些測試項目的顏色比較淺，這表示該項測試項目在程式編輯時設定

為不需要執行的項目。如上圖中，HoldOnAdjust Test 這個測試項目設定為不

執行。 

 
在 GO/NOGO 測試中，開啟測試程式的預設值為只顯示測試項目，不顯示測

試命令。您可以按 By TestCmd 來展開測試命令，或者按下 By TestItem 以

隱藏測試命令。您也可以在表格中的任一行上快速雙擊滑鼠的左鍵，立刻展開/

隱藏該測試項目的測試命令。 
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 過程顯示區： 

 

在此區內快速雙擊滑鼠的左鍵，可以在顯示執行過程文字和執行結果間相互切

換。您可以藉文字的顯示部份了解執行的過程; 或由圖型的文字顯示立即獲得

執行測試的結果。 

 
 
 
 
 
 

 
 
 測試內容顯示區： 

 

測試內容顯示區共有兩個部份：第一部份為顯示執行測試的一般設定，第二部

份則為顯示執行測試程式後，測試程式中所定義各種變數的值。 

 

 執行測試的設定 

 

 
 

雙擊滑鼠

左鍵 
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Program 區 

 TestProgam：   測試程式的名稱。 

 ModelName：   測試程式的模組名稱。 

 

UUT 區 

 SerialNo：    待測物的序號。 

 Iteration：    執行測試程式的次數。 

          (已執行次數/總需執行次數) 

 Run（%）：    執行的進程百分比。 

 Date/Time：   目前的系統時間。 

 Start Time：   開始測試時間。 

 Elapsed Time：   測試所花費的時間。 

 

FailRate 區 

 UUT Counts：   已測試的待測物個數。 

 Fail Counts：   測試失敗的待測物個數。 

 FailRate：    待測物失敗的比率。 

 

Fixture 區 

 Fixture Model：   治具型號。 

 Available Test Count： 治具剩餘可測次數。 

 
當 FailRate 超過所設定的條件時，FailRate 失敗比率的左方綠燈將轉換成紅燈

閃爍，提醒使用者待測物的失敗比率已經超過設定的上限。 

 

Set TestInfo 提供修改測試時的設定對話盒，此按鍵功能同選單 

[Settings]  [Test Information…]。 

Reset FailRate 重新計算失敗比率，將之前的 UUT Count 清為零，重

新開始計算 FailRate。此按鍵功能同選單 [Settings]  

[Reset FailRate]。 

 
 測試程式各測試項目的變數 

 

各測試後的測試項目，每一個設定值和讀值都可以在測試內容顯示區內的

[Variable Info]中找到。畫面上的安排，在最上方有七個選項，可供您挑選需

要查看的變數分類，以及是否展開陣列變數的每一個元素。 

 
□ Expand Array-type 勾選此項，在顯示陣列變數時，將顯示陣列中每
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variables 一個的值；反之，顯示該變數的名稱。 

□ Pass Readings 勾選此項以顯示符合限制規格的讀值

（TestResult）變數。 

□ Fail Readings 勾選此項以顯示不符合限制規格的讀值

（TestResult）變數。 

□ Temporary 勾選此項以顯示暫時型（Temporary）的變數。 

□ Global 勾選此項以顯示全域型（Global）的變數。 

□ Test Condition 勾選此項以顯示設定型（TestCondition）的變

數。 

□ TP Variables 勾選此項以顯示測試程式上的變數。 

 
在下拉式選單上放置執行過的測試項目，並依測試項目執行的順序排列。您可

選擇一個測試項目，觀察變數的值。 

 

 
 

中間的表格會填上符合下拉式選單所指定之測試項目和各種選項的變數定義和

其值。表格共分成七欄，第一欄為變數的順序編號，第二欄為變數的名稱，第

三欄為變數的值，第四欄為規格判斷，第五欄為變數的型別，第六欄為測試項
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目的測試順序，第七欄則為測試項目在測試程式中的順序。 

 
在變數的名稱上，如果該變數是一個陣列型的變數，且未展開，在變數名稱上

最後會加上 [（L）] 表示這是一個以 Load 為個數的陣列變數。若變數名稱後

加上 [（4）]，則表示此為四個元素的陣列變數。當中的數值表示這個陣列變

數的個數。如果該變數是展開的狀態，每一個陣列變數的元素表示為在變數名

稱後面加上[n]，n 表示是這個陣列變數的第 n 個值。 

 
在第二欄上，表現變數的內容。如果值為 … 而且該變數為一個陣列型的變數

時，您可以快速雙擊該變數，該行會展開/收起陣列變數的內容。 

 
在第三欄表示該 TestResult 變數是否符合規格。 

 
第四欄表現變數的類別。”TR”表示 TestResult 變數，“TC”表示 TestCondition 

變數，”G”表示 Global 變數，“T”表示 Temporary 變數，“TC（V）”表示為

VectorType 的 TestCondition 變數，“T（G）”表示 VectoType 的 Global 變

數，“TP（V）”表示 TestProgram 上的 Vector 變數。 

 
您可以在第一欄按下滑鼠的左鍵，看到一個詳細描述該變數的說明文字，如下

圖。 

 

 
 
 



執行測試程式(GO/NOGO) 

 7-7 

7.2 設定執行測試功能選項 

本小節說明執行控制工具列的功能。執行控制工具列是整個執行控制的操作重心， 

以控制測試程式的執行或停止。 

 
工具列上共有四個可使用的按鍵，如下圖： 

 

 
 
各個按鍵的功能分別說明如下。 

 

按下 Go（F10 或按下快速鍵（F10）， 從測試程式第一個測試項目開始執行， 執

行完畢後將測試結果存入資料庫。如果有 PreTest 型的 TestItem，只會在第一次執

行一次。您也可以按下 Go（F10）右方的 ▼，只執行 [Pre Test] 群組的測試項

目。 

 

 
 

 
 當您選擇序號自動計數（AutoCount）時，序號將自動加一。 

 當您選擇以 Barcode 作計數時，按下此鍵後會跳出一個視窗

（如下圖），接收您使用 Barcode Reader 掃描得到的待測物

的序號。 

 

 

提示



電源供應器自動測試系統 8200 使用手冊 

 7-8 

 
 當您選擇以 Barcode 作計數時，若勾選 Enable prescan 

barcode，按下此鍵後會跳出一個視窗（如下圖），下方

Prescan Barcode 區可讓您在測試當中利用使用 Barcode 

Reader 預先掃描下一組的待測物的序號，而上方的

Processing Barcode 區則用以顯示目前正在處理中的待測物

序號。 

 

 
 
 測試程式執行中無法結束執行控制功能。若要結束執行控制

功能，請先按 Stop (F2) 按鈕停止執行測試程式後，再結束

執行控制功能。 

 當測試程式執行完畢後，所有儀器均會回至初始化狀態，同

時 AC 電源供應器亦會停止供電；故您可進行待測物之更換工

作。 

 

按下 Stop (F2) 或快速鍵（F2），終止執行測試。測試結果不會記錄到資料庫。 
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所有儀器均會回至初始化狀態，同時 AC 電源供應器亦會停止供電；

故您可進行待測物之更換工作。 

 

按下 Single (F9) 或按下快速鍵（F9），開始執行所指定測試項目。 

 
在您按此按鈕前，應先於測試程式顯示區選好您所要執行之測試項目。您可以滑鼠

來選擇您欲執行之測試項目。 

 

 當以 Single (F9) 來執行某測試項目前，應先執行與”Set up” 相關

的測試項目，讓 AC 電源供應器供電。 

 

按下 Report (F3) 或快速鍵（F3）， 切換到報表編輯程式。您可以透過報表編輯程

式立即看到執行後的報表顯示。 

 

有兩個按鈕 Pause 和 Resume 在 GO/NOGO 並沒有作用。Pause 和 Resume 

是提供 Detail 時測試用的兩項功能。 

 
 

7.3 操作按鈕功能說明 

本小節說明執行選單的功能。選單提供您設定各種執行環境。  

 
 

7.3.1 選單 File 

 
 

[File][Open 
TestProgram...] 

快速鍵(Ctrl + O)，由對話盒開啟已編輯好的測試程

式。 

[File][Exit] 結束本程式，回到 Chroma 8200 系統軟體的主畫

面。 

 

 
如果硬體的初始化失敗時，此選單將不能使用。請立刻檢查硬體的

設定，重新開啟執行控制程式即可使用。 

 

注意

注意

注意
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7.3.2 選單 Run  

 
 

[Run]→[Go] 快速鍵（F10），從測試程式第一個測試項目

開始執行，執行完畢後將測試結果存入資料

庫。功能同執行控制工具列的 GO 按鍵。 

[Run]→[Single] 快速鍵（F11），開始執行所指定測試項目。

功能同執行控制工具列的 Single 按鍵。 

[Run]→[Step] Detail 測試用。 

[Run]→[Stop] 快速鍵（F2），終止執行測試，測試結果不會

記錄到資料庫。功能同執行控制工具列的

Stop 按鍵。 

[Run]→[Pause] Detail 測試用。 

[Run]→[Resume] Detail 測試用。 

[Run]→[Go (Pre_TestItems) ] 執行測試程式的 PreTest 的 TestItems。 

[Run]→[Go (Post_TestItems) ] 執行測試程式的 PostTest 的 TestItems。 
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7.3.3 選單 Settings 

 
 

[Settings]→[Reset FailRate] 將 FailRate 的計算值歸零，重新開始計算

FailRate。 

[Setting]→[Test 

Information...] 

有關測試資訊的設定。此選單會出現圖 7-2 的

視窗，提供您輸入測試的相關條件。 

 

 
圖 7-2  測試程式資訊設定視窗 



電源供應器自動測試系統 8200 使用手冊 

 7-12 

 
■ 設定序號（Serial No）︰您可選擇在測試過程中待測物序號是以自動累加序號

的方式（Auto）或是使用條碼掃描機（Barcode Reader）掃描得到的序號。若

使用自動累加序號， 您可以定序號之前導字元與後序字元，以及序號之起始號

碼和長度。若是使用條碼掃描機的方式讀入序號，您可以定義條碼的長度，提

供執行測試時作檢查，防止測試過程中人為輸入錯誤序號的情形。條碼長度的

設定可以按下 Test 鍵幫助您在掃入條碼後自動計算條碼的長度。 如果不需要

在測試過程中檢查條碼的長度，可以將檢查長度設為零。如果輸入的序號包含

了一些您不想要保存的訊息，此時可勾選擷取序號從第幾個字元開始之後幾個

字元，做為實際儲存的序號。 

 
■ 失敗警訊（FailRate）設定 

您必須設定失敗警訊的上限 0~100 %，和在測過幾個待測物後才開始計算失敗

警訊。 

 
■ 測試的相關資訊 

 
Customer Name 客戶名稱 

Order Number 訂貨編號 

LOT Number 批號 

Inspector 檢測人員姓名 

Environment 測試時的環境溫度 

Iterations 待測物所欲重複測試的次數 

 

 
 不同之測試程式，可個別設定測試程式相關資訊，因此更換

不同之測試程式，不需重新設定。 

 測試資訊是以 INI 檔之形式，存於測台之系統軟體安裝目錄 

\INI 子目錄中。 

 
[Setting]→[Option...] 打開選項設定畫面。 

 
如果使用者以“OP”權限或不具有進入“Test Program”權限的使用者登錄時，若使用者

需要修改選項內資料，會呈現輸入帳號、密碼的對話盒，如圖 7-3，如果沒有權限

則無法進入選項中修改內容，如圖 7-4。 

 

提示
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圖 7-3  輸入具有進入“Test Program”權限的使用者帳號和密碼 

 

 
圖 7-4  如果沒有權限則無法進入選項修改設定 

 
選項設定，共有五頁，分別說明如下︰ 

 
第一頁（Execution）： 您可透過這一頁來設定執行控制功能之環境；這一頁中之所

有內容將會記錄至系統中。當您結束執行控制功能後再次啟

動，所有第一頁中之設定，將會自動由系統中載入。 
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Hardware Configuration︰ 

Configuration File：目前測台上所指定的硬體配置組態設定檔案名稱。 

Auto Run：勾選是否要透過 I/O 卡以自動執行的模式執行測試程式。使用目的

測台上之硬體配置組態設定檔。 

Waiting for start bit：讓使用者可以用 DO 控制燈號,但可以不用 DI。 

Enable I/O Card for Multi-UUT Mode：勾選此項功能後，會將每一個單組輸

出的 UUT 測試結果（Pass/Fail），依序輸出到第一片 I/O 卡的輸出 Bit 9 ~ 

16，超過 8 個以上的 UUT 則不支援此功能。 
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Configuration︰ 

Open Last Test Program File：跳過開檔之對話盒，直接開啟上次最後執行

之測試程式。您可透過選取此一設定，節省您每次都必須去開啟同一個測試程

式的時間。 

Show Process Text：勾選是否在執行的過程中顯示較多的訊息在過程顯示區

內。 

Save Global Variables When Exiting：勾選是否在測試程式結束時儲存測試

程式所設定的 Global 變數，以供下次開啟測試程式時能載入上次的設定。 

Stop On Fail： 勾選是否在檢查到某一測試項目不符合規格時，能立刻停止測

試。 

Executing ‘Post Test’ automatically when user press ‘stop’ button or 

error occurred：勾選是否在測試程式結束時或 User 按下 Stop 鍵時執行

Post Test。 

 
Log Data：您可以選擇是否要將測試結果記錄在資料庫，以利報表及統計分析參照

運用。 

 
Fail Rate： 

Merge Retest Data：勾選表示相同序號有重測幾次都要算幾次 fail。 

By Last Times：勾選表示相同序號只看最後一次結果；否則看第一次。 

 
UUT Type︰ 

Single UUT/Multi Output：指示所用的測試程式是單一待測物多個輸出。 

MultiUUT/Single Output：指示所用的測試程式是多顆待測物。 

UUT Number：指示在 MultiUUT/Single Output 模式下，待測物的數量。 

 
第二頁（Report 1）： 您可透過這一頁來設定執行環境所提供的報表功能；這一頁中，

所有內容將會記錄至系統中。當您結束執行控制功能後再次啟

動，所有本頁之設定值，將會自動由系統中載入。 
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Report Generator︰ 

Send data to Report Generator：選取後，當執行環境執行時，自動啟動報表產生

程式。 

 
Prompting when UUT failed：選取後，當待測物測試結果為 Fail 時，系統會顯示

一視窗如下圖，詢問是否要顯示報表。 
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The max. number of the last UUT data in [Report Generator]: 設定「Report 

Generator」所要顯示最近待測物測試資料的最大筆數。 

 
In Test Print：選取後，當測試程式執行完畢，自動啟動列印功能，列印測試結果。

在執行測試程式的測試期間，如果您希望「Report Generator」程式將測試資料送到

印表機列印時，只要將「In Test Print」選項勾選起來，並依照您的需要設定列印的條

件即可，「In Test Print」列印功能說明如下： 

 
All Data:  列印所有的測試資料 

Pass Program:  當整個測試程式執行結果被判定為Pass時，才執行列印的工作。 

Fail Program: 當整個測試程式執行結果被判定為 Fail 時，才執行列印的工作。 

Pass Sequence: 只列印判定為 Pass 的 Sequence。 

Fail Sequence: 只列印判定為 Fail 的 Sequence。 

 
In Test Print to File： 

選取後，當測試程式執行完畢，自動啟動列印至檔案功能，儲存測試結果。 

在執行測試程式的期間，您可以透過「Report Generator」程式將測試資料轉存到檔

案（.txt 或.rtf）。要執行此功能，您只要將「In Test Print to File」選項勾選起來，並

依照您的需要設定存檔的條件即可。「In Test Print to File」存檔功能與「In Test 

Print」列印功能相同，您可參照使用。 

 

 
無論是執行「In Test Print」列印功能或是「In Test Print to File」存

檔功能，您必須先確定 Send data to [Report Generator]選項已經被

勾選。 

 
In One File：所有的測試結果皆儲存到同一個檔案。 

File Name (.txt, .rtf)：執行「In Test Print to File」時，所指定的檔案名稱。 

 
By UUT SN：根據 UUT 序號及日期時間組合成檔案，不同 UUT 儲存到不同的檔

案。 

Saving Path：指定若 by UUT SN 時所產生的檔案放在哪一個目錄。 

 

提示
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第三頁（Report 2）： 當您在第二頁有選取 Send data to [Report Generator]時，

在第三頁您可以進一步設定是否要將 Report Generator 產生

的報表順便儲存成 Excel 檔案。 

 

 
 

Save as Excel file when on-line report is running：選取後，當 Report 

Generator 產生報表時會自動順便儲存成 Excel 檔案。 

 
Station ID：決定檔名的一部分。 

 
File name：提供兩種存檔檔名的設定。 

 
Saving Path：儲存 Excel 檔案的路徑。 
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Excel Separator：一般文件要輸出到 Excel 都會要求訂定分欄符號，這裡提

供三種選擇。 

 

Filter out all the Excel Separators on the hardcopy report：如果要控制

輸出到 Excel 的報表符合期望，則當您在 Report Editor 編輯報表格式檔時

就需要提早考慮到將分欄符號編進報表格式檔，但這樣做可能產生的副作用

就是原先在 Report Generator 看到的報表會多了一大堆的分欄符號，而這

個選項則是會幫您過濾掉分欄符號。 

 
第四頁（Miscellaneous）： 您可透過這一頁來設定執行環境在執行的過程中上所顯

示的數值格式。如設定為整數部份為 7，小數部份為 4，

在執行下一次後，您在系統中所看到的數值顯示將會將小

數第五位以下將自行四捨五入至第四位。請注意：設定格

式只影響顯示的結果，系統內部仍以原來的值作運算。此

外，也可以透過這一頁來設定想要顯示的額外錯誤訊息。 
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第五頁（S/N Check）： 您可透過這一頁來設定序號檢查相關處理。 

 

 
 
Enable check the same serial number: 是否檢查相同序號。 

Stop test the same serial number: 相同序號是否停止測試。 

Stop test when barcode length not match: 是否當序號長度不對時停止測試。 

Enable check for special characters: 是否檢查特殊字元。 

Enable limit manual input: 是否限制手動輸入條碼功能。 
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7.3.4 其它選單 

 
 
[View]→[Show Report Generator] 快速鍵 F3，呼叫報表產生程式。 

[View]→[Expand Test Items] 選取測試程式在測試程式顯示區是否需展開

顯示測試命令 

[View]→[Toolbar] 選取執行功能工具列是否顯示 

[View]→[Status Bar] 選取狀態列是否顯示 

 

 
 
[Help]→[Export Error Report...] 匯出錯誤資訊。 

[Help]→[About ExeCtrl...] 顯示本程式的版本資訊 

 
 

7.4 自動執行功能 

「GO/NOGO」除了可由操作人員以手動測試外，另外也可支援自動測試的控制功能。

其動作方式為透過 I/O 卡的輸入信號啟動測試程式的執行，並將測試結果輸出到 I/O

卡的輸出信號。I/O 卡的使用並不保留為專給「GO/NOGO」使用，使用者可以呼叫我

們提供的 I/O Card 測試命令直接驅動 I/O Card 的所有訊號，因此在設計 Test Program，

須考慮避開這些 I/O 訊號位元。 
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7.4.1 設定 I/O卡 

首先在「H/W Configuration」新增一項 Device Type 為 I/O Card 的裝置，如圖 7-5

所示： 

 

 
圖 7-5  新增 I/O 卡 

 
然後在「GO/NOGO」的[Settings]→[Option..]選項中勾選 AutoRun 功能。

「GO/NOGO」中總是選用第一張卡作為自動控制的對象。如果 I/O 卡並未在「H/W 

Configuration」設定或者初始化未成功，則 AutoRun 選項就會顯示灰階，不讓您勾

選。 
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圖 7-6  自動執行功能選項 

 
在「H/W Configuration」所設定的第一片卡上的輸入埠 Bit 1、2 和輸出埠 Bit 1、

2、3 共五個 Bits 保留給「GO/NOGO」的流程控制用，如下圖定義。 
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12345678910111213141516

12345678910111213141516

INPUT PORT

Run

Trigger

In Test

Bit

Pass

Bit

Fail

Bit
UUT1

P/F
UUT8

P/F

UUT2

P/F

Stop

Trigger
UUT1UUT8 UUT2

 
 
註 若是 Execution 頁面中的 Enable I/O Card for Multi-UUT Mode 有被勾

選，則輸入埠 Bit 9~16 保留給 UUT 1~UUT 8 做為偵測是否有接 UUT 的

訊號，輸出埠 Bit 9~16 保留給 UUT 1 ~ UUT 8 以顯示其測試結果。 

 

在測試中會產生上面圖中的輸出信號，和一個輸入訊號控制測試的進行。 

 
輸出訊號：In Test Bit，Pass Bit，Fail Bit。 

輸入訊號：Run Trigger，Stop Trigger。 

 
測試訊號的動作說明如下： 

(1) 開始測試時，先檢查 Run Trigger 輸入訊號，若是 TTL HIGH Level，則進行測

試，反之不測試，一直到此信號為 HIGH 時才開始測試（一旦測試開始，就不再

管此信號，直到此 UUT 測完，又要開始測下一個 UUT 時，再等此信號為 HIGH

時才又開始測試。）。 

(2) 開始測試後，設定 In Test Bit＝TTL HIGH、Pass Bit＝TTL LOW、Fail Bit＝TTL 

LOW 表示正在測試中。 

(3) 開始測試後，若 Stop Trigger 輸入訊號為 TTL HIGH Level 則測試會停止。 

(4) 測試結束後，設定 In Test Bit＝TTL LOW，表示測試結束。並根據測試結果為

PASS（FAIL）來設定 Pass Bit（Fail Bit）為 TTL HIGH。 

(5) 回(1)重新開始。 

 
您可利用這些信號控制測試的開始，並且結束後利用 PASS／FAIL 做不同的處理。 
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8. 編輯報表格式 

8.1 執行程式 

按下在 Chroma 8200主畫面中選擇 Report Editor 選項後即可開始執行報表編輯程

式。編輯前，程式會要求您選擇所要編輯的報表格式檔，您也可以選擇檔案後按下  

OK 開始編輯，或按下 Cancel 讓程式幫你開啟新的報表格式檔。 

 

 
圖 8-1  開啟報表格式檔視窗 

 
在完成上述選檔步驟後，畫面會顯示出如下圖所示的 Report Editor 視窗。 
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圖 8-2  報表格式編輯畫面 

 
 

8.2 環境說明 

 主視窗的標題列（Caption）中，字串“Report Editor – ”之後的文字即為目前所

編輯的報表格式檔檔名（本例為 “Chroma”）。若您選擇報表格式檔時按下取

消，則檔名會以“Untitled”命名。請在完成編輯報表格式後以選單功能 [Report]

→[Save As...] 將此檔儲存為您所想要的檔名。 

 

 
圖 8-3 
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 主視窗的左上方有兩個下拉式選單，分別為 Test Item Category 與 Test Items。 

上方的 Test Item Category 下拉式選單可讓您選擇測試項目（Teset Item）的種

類。目前分類為 “Header”、“System-defined items” 和 “User-defined items” 三

種。下方的 Test Items 下拉式選單可讓您選擇目前所要編輯報表格式的測試項

目。另外，在兩個下拉式選單下方有一個進度列（Progress Bar），它是用來顯示

目前讀取測試項目的報表格式進度。 

 

 
圖 8-4 

 
 主視窗的右半部為報表格式編輯區。您可在此編輯區中依您所需編輯的報表輸出

格式。編輯區中所顯示的內容即為目前測試項目的報表輸出格式，也就是說，每

一個測試項目的報表輸出格式是分別顯示和編輯的。當您選擇不同的測試項目

（Test Item）時，編輯區的報表格式也會立即更新。在編輯區中除 “#” 外，其餘

字元皆可使用。這是因為我們利用”#”字元形成一個 Pattern 來代表一個變數，

如 “###.##”這個 Pattern 表示此變數有三位整數及兩位小數，長度為六個字元。

在編輯區中每一行的文字長度（含 Pattern）請不要超過 80 個半形字元，以免

在列印時會有資料無法印出。 
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圖 8-5  報表格式編輯區 

 
 主視窗的左下方的「Available Variables 視窗」列出目前 Test Item 的可用變數。

顯示資訊分別為變數的 Type、Call Name 及 Data Type。目前 Type 有 3 種：

*(Header 變數)、TC（Test Condition）及 TR（Test Result），而 Data Type 共

有 10 種：Integer、Float、Percent、Long、String、Char、Integer[L]、Float[L]、

Percent[L] 、Float[ ]、Integer[ ]及 Vector Type。 

 

 
 
 變數的 Data Type 若為 Integer[L]、Float[L]或 Percent[L]，則表示其為與 Load

有關的變數，在報表產生時，程式會根據目前的格式及 Load 的數目自動展開。 

 
 變數的 Data Type 若為 Integer、Integer[L]或 Integer[]時，您可以設定它在報表

產生時的顯示型態，分別可設定為 Integer（十進位數）、Binary（二進位）及
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Hexadecimal（十六進位）三種型態。 

 

 
圖 8-6 

 
 主視窗的下方有三個下拉式選單，Integral、Decimal 與 Number Type 分別表

示變數長度格式中的整數位數與小數位數及變數的數字型態（二進位、十進位或

十六進位）。在加入一個變數到編輯區時會參考到這些資料，形成 Pattern 以代

表變數本身。以下圖為例，此變數形成的 Pattern 為 ######.###，Pattern 長度

為 10。 

 
圖 8-7 

 
 主視窗右下方的「Referenced Variables 視窗」列出目前已選取至報表格式的變

數。顯示之資訊為變數的 Call Name、Data Type 及 Number Type。 
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 若您選擇的變數其 Data Type 為 Vector Type 的話，則程式會再顯示一視窗，讓

您挑選這個 Vector 中的變數，如下圖所示。同樣的，若您選擇的變數 Data Type

為 Integer、Integer[L]或 Integer[]時，您可以設定它在報表產生時的顯示型態。

同時，在右下方的「Referenced Variables 視窗」顯示的變數 Call Name 為

“Vector Name / Variable Name”。 

 

 
圖 8-8  Vector 變數選擇 
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8.3 操作說明 

8.3.1 加入變數至編輯區 

加入變數至編輯區之前，先在「Test Item 視窗」中選取欲編輯的測試項目，接著在

「Available Variables 視窗」中選取一變數，之後設定變數的長度及 Number Type，

然後再按下 Add >> 按鈕，即可將該變數加入 「Referenced Variables 視窗」 和主

視窗上方的編輯區游標處（變數在編輯區中是以 Pattern 呈現）。 

 

 
圖 8-9  加入變數 

 
 

8.3.2 從編輯區中刪除變數 

一次只能刪除一個變數。執行刪除時，請在「Referenced Variables 視窗」中先選擇

欲刪除的變數，然後按下 << Delete 鈕即可。此時會將「Referenced Variables 視窗」

中選擇的變數刪除，同時在編輯區中相對應的 Pattern 也會被移除。 

 
 

8.3.3 檢視編輯區中的變數 

編輯區中的變數是以 Pattern 方式顯示。若您想知道這個變數的資訊，則您可以在編

輯區中的變數 Pattern 上按一下滑鼠，此時「Referenced Variables 視窗」及「Available 

Variables 視窗」會以反白顯示目前 Pattern 的變數資訊，如圖 8-2 所示。 

 
您也可以在「Referenced Variables 視窗」中某個變數上，按下滑鼠左鍵不放開。此

時在編輯區中目前的變數 Pattern 會反白，而「Available Variables 視窗」也會跟著顯

示目前的變數資訊。 
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8.3.4 設定編輯區的字型及顏色 

您可以利用選單 [View][Set Editing Area Color...] 來設定編輯區文字的顏色。

按下選單之後出現如下圖的視窗。您只要在顏色區域按下滑鼠即可出現設定顏色的

視窗讓您挑選顏色。圖中，如果您想將目前設定儲存為預設值，您可以按下 Set 

Default  鈕。您亦可隨時利用 Use Default 取得之前儲存的顏色預設值。 

 

 
圖 8-10  設定編輯區色彩 

 

您可以利用選單 [View][Set Font...] 來設定編輯區文字的字型。如下圖所示的視

窗，您可以選擇字型、字型樣式及字型大小。建議您使用每個字元大小都一樣的字

型，使得報表字元可以對齊顯示，如 Courier New 等。 
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圖 8-11  設定編輯區字型 

 
 

8.3.5 提示視窗（Hint Window） 

在「Available Variables 視窗」中按下滑鼠左鍵不放開，會出現提示視窗（Hint 

Window）。提示視窗比「Available Variables 視窗」有更進一步關於變數的資料。如

下圖黃色區域所示，您可以利用選單功能 [View][Show Hint Window] 來選擇是

否讓程式出現提示視窗。 
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圖 8-12  提示視窗 

 
 

8.3.6 設定字元集 

您可以利用選單功能 [View][Set CharSet...] 設定程式目前使用的字元集。 

 

 
圖 8-13  設定字元集 
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8.3.7 關於 Report Editor 

您可以利用選單功能 [Help][About...] 取得關於本程式的訊息。 

 

 
圖 8-14  關於對話盒 

 
 

8.3.8 選單說明 

[Report]→[New] 新增一個報表輸出格式檔。 

[Report]→[Open...] 開啟一個已存在的報表格式檔（*.Rpf）。 

[Report]→[Save] 儲存您正在編輯的報表輸出格式。如果您編輯的是

新的報表格式（即檔名為 Untitled）時，則會出現

「另存新檔」對話盒以讓您指定所欲存入的檔名。 

[Report]→[Save As...] 將正在編輯的檔案存成另一檔名。 

[Report]→[Exit] 結束本程式，回到 Chroma 8200 ATS 系統軟體的主

畫面。 

  
[View]→[Set Editing Area 

Color...] 

設定編輯區文字顏色。 

[View]→[Set Font...] 設定編輯區文字字型。 

[View]→[Set CharSet...] 設定程式字元集。 

[View]→[Show Hint 

Window] 

設定是否顯示提示視窗。 

  
[Help]→[About...] 顯示本程式的版本資訊。 
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9. 報表產生程式 

9.1 執行程式 

執行報表產生程式有兩種方法。一是離線（Off-Line）模式，在 Chroma 8200 的主畫

面中選擇 Report Generator 選項後，便會執行「報表產生程式」，此時會顯示「選

擇欲列印資料視窗」。另一方法為線上（On-Line）模式，在測試期間由 Exeution 

Controller 程式自動呼叫，並將測試結果傳送至本程式來產生報表，但線上模式不會

產生「選擇欲列印資料視窗」。 

 

 
圖 9-1  選擇欲列印資料視窗 
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離線模式下，在您選擇了欲列印資料後，會顯示報表產生器的主視窗，程式會根據

您選擇的測試程式（Test Program）、測試日期（Date）及待測物序號（UUT 

SerialNo）搭配報表格式檔（Report Format File）中測試項目（Test Item）的報表

格式來產生最後的報表。 

 

 
圖 9-2  報表產生器的主視窗 

 
 

9.2 環境說明 

在本程式的主視窗中有一個編輯視窗（以下稱之為資料顯示區），我們用它來展示最

後的報表產生結果，其屬性為唯讀（Read-Only）。由於資料顯示區一次只能顯示一
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個測待物的報表，所以我們使用頁面（Tab）來區隔開各個測待物（UUT）之間的報

表，如下圖所示。 

 

 
圖 9-3  資料顯示區的頁面 

 
頁面的數量會等於您在「選擇欲列印資料視窗」中所選取得待測物序號數，也就是

說，每一個待測物我們用一個頁面來表示，頁面的標題（Title）就是待測物序號。

當您想觀看某個待測物的報表產生結果時，您只需要在該待測物序號頁面上按下滑

鼠左鍵，程式會自動產生報表，顯示在資料顯示區上。 

 
主視窗下方的狀態列（Status Bar）上之指示器（Indicator）會顯示目前的程式模

式。離線模式時顯示 Off-Line，線上模式時則顯示 On-Line。另外，產生報表需要一

些時間，所以在您切換頁面以產生不同報表時，狀態列上的進度指示器（Progress 

Bar）會啟動。您可以由此知道目前報表產生的進度。 

 

 
圖 9-4  主視窗下方的狀態列 

 
 

9.3 操作說明 

在線上模式的測試過程中，Exeution Control 會自動將待測物的測試結果及數據儲存

在資料庫中，以利您可以隨時利用本程式的離線模式來產生報表。由於離線模式是

藉由測試過程中所得的數據來產生報表，若之前沒有測試資料，本程式將無法產生

任何報表。 
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9.3.1 選擇欲列印資料視窗 

離線模式執行時，會出現「選擇欲列印資料視窗（Select data of tested UUTs from 

database）」讓您選擇欲產生報表的資料。您也可以利用選單功能 [File][Open 

Log Database] 來開啟此視窗。操作步驟如下： 

 

 
圖 9-5  選擇欲列印資料視窗 

 
1. 先利用視窗上方的 Test Program 下拉式選單來選擇欲開啟的測試程式。程式會

根據您選擇的測試程式，更新 Test Date 及 Report Format File 的內容。 

 

2. 之後您可以利用 Test Date 下拉式選單選擇測試日期，再利用 All、Pass UUT 
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Only 及 Fail UUT Only 並按下 Search UUT…來過濾出想要的待測物。此時

Tested UUT SerialNo 視窗的內容會顯示該日期中所測試過的待測物序號（UUT 

Serial No）， 此外您也可以利用 Report Format File 下拉式選單來選擇欲搭配的

報表格式檔。 

 

3. 選擇待測物的序號（Serial No）時，您可以利用 Select All 或 Select None 

按鈕來選擇全部或取消選取。若要一次選擇多個待測物序號，您可以利用滑鼠

左鍵拖拉（Drag & Drop）的方式來連續選取。若您要選擇多個不連續的待測物

序號，您可以按住鍵盤左下方的 Ctrl 鍵不放，再利用滑鼠點選欲選擇的待測

物序號即可。 

 
4. 若您想知道待測物的測試項目（Sequence），您可以單選一個待測物序號，然後

按下選單[Show] →[Sequences…]，即會出現如下視窗，視窗中 Sequences of 

the UUT 列示盒中會顯示待測物的測試項目。 

 
5. 當設定完成時，按 OK 讓程式幫您產生報表。 

 

 
圖 9-6  待測物的測試項目視窗 
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9.3.2 資料顯示區說明 

資料顯示區內容包含二部份：待測物表頭資訊（Header Information）及測試項目

（Sequence）報表內容。每個待測物都有一份 Head Information，而測試項目的多

寡會根據該測試程式的內容而定。 

 

 
圖 9-7  資料顯示區 

 
註 關於測試項目的內容，使用者可自行利用主畫面的 Report Editor 程式

編輯之。其 Reading 的值由 GO/NOGO 測試程式取得，詳細情形請參

考兩者之使用說明。 

 
 

9.3.3 選擇/切換待測物報表 

您只需要在該待測物序號頁面上按下滑鼠左鍵，程式會根據待測物資料自動產生該

待測物報表，顯示在資料顯示區上。 
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9.3.4 檔頭資訊（Header Information） 

待測物的檔頭資訊（Header Information）包含 Serial No、Model Name、Lot 

Number、Order Number、Inspector、Environment、Customer、Elapsed Time 及

System Time。您可以利用選單功能[Show][Header]來設定是否將這些檔頭資訊

顯示在資料顯示區報表當中。檔頭資訊的格式使用者可自行利用主畫面的 Report 

Editor 程式編輯之，而編輯完的結果將儲存在報表格式檔中。 

 

 
圖 9-8  待測物的檔頭資訊 

 
 

9.3.5 設定編輯區的顏色 

您可以利用選單 [View][Set Color..] 來設定編輯區文字的顏色。如下圖視窗，您

只要在顏色區域上按下滑鼠即可出現設定顏色的視窗對話盒讓您挑選顏色。此外，如

果您想將目前的設定儲存為預設值，可以按下  Save As Default。您可隨時利用 

Load Default 取得之前儲存的顏色預設值。 
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圖 9-9  設定編輯區文字的顏色 

說明如下： 

 
Text 一般文字顏色。(固定黑色，不提供設定) 

Background 背景顏色。 

Variable /Spec Setting 值的顏色。 

Variable /Pass Pass Reading 值的顏色。 

Variable /Fail Fail Reading 值的顏色。 

Variable Not Found 找不到變數，變數值以符號 “?” 代替。 

Variable Format Error 變數格式位數不足，無法顯示正確數值，變數值以

符號 “X” 代替。 

Seq. Ext. Name 測試項目副名的顏色。 

 
 

9.3.6 設定編輯區的字型 

您可以利用選單 [View][Set Font...] 來設定資料顯示區的字型。您可以在下面出

現之視窗選擇字型、字型樣式及字型大小。您也可以利用選單功能 [View][Reset 

Font（Report Format File）] 回復到程式預設的字型。 
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圖 9-10  設定資料顯示區的字型 

 
註 程式預設的字型為 Courier New、標準樣式、大小 11。 

 
 

9.4 顯示/列印測試項目 

您可以利用選單功能 [Show][Sequences...] 選擇只顯示部份測試項目

（Sequence）的報表，之後會出現「選擇測試項目視窗」，如下圖所示： 
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圖 9-11  選擇測試項目視窗 

 

選擇測試項目時，您可以利用 Select All 或 Select None 來選擇全部或取消選取。

若要一次選擇多個測試項目，則您可以利用滑鼠左鍵拖拉的方式來連續選取。若要選

擇多個不連續的測試項目，您可以按住鍵盤左下方 Ctrl 鍵不放，再利用滑鼠點選您

欲選擇的待測物序號即可。 

 

如果您要顯示全部的測試項目，您可以利用選單功能 [Show][All Sequences] 達

成。如果您只需要列印部份的測試項目報表，請先依照上面方式選擇部份的測試項

目，然後再利用選單功能的 [File][Print] 來列印即可。 

 
 

9.4.1 預覽列印 

您可以使用選單功能 [File][Print Preview] 進入預覽列印模式。預覽列印將資料

顯示區的內容模擬列印，將實際的報表狀況顯示在螢幕上，您可利用 拉進(I)、拉遠

(O)、上一頁(V) 及 下一頁(N) 操作顯示之內容。若要直接列印則可選擇 列印

(P) ，回到資料顯示區請按 關閉(C)。 
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圖 9-12  預覽列印 

 
註 預覽列印及列印的字型皆使用 Courier New 字型，與資料顯示字型設定

無關。 

 
 

9.4.2 直接列印 

欲對資料顯示區內容直接做列印，不透過列印之前的預覽動作，您可以利用功能選

單 [File][Print(“Courier New” Only)...] 來完成。此時會出現「列印視窗」，讓您

選定印表機、選擇列印頁數及份數的視窗。按下 確定 即可直接列印。 
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圖 9-13  列印視窗 

 
 

9.4.3 儲存/全部儲存 

您可以利用選單功能 [File][Save Current Tab...] 來儲存目前內容顯示區的報表

資料。您可以選擇儲存成一般文字檔（TXT），可由一般文字編輯器開啟，或儲存成

Rich Editor Format Files（RTF）檔，可由 Microsoft Word 開啟；兩者不同的是，

RTF 檔可以一併儲存目前的格式，包含字型、顏色及大小等資訊。 
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圖 9-14  儲存目前頁面報表 

 
若您想要一次將全部待測物的報表儲存，您可以利用選單功能[File]→[Save All...]來

完成。此時程式會出現如下圖所示的檔案儲存選項，詢問您欲儲存的檔案及儲存的

方式。 

 

 
圖 9-15  儲存所有報表 

 
 

9.4.4 列印選項 

您可以利用選單功能[File][Print Option...]來設定列印選項，包括是否跳頁、是否

顯示頁首及其內容與是否顯示頁碼。 

 
當您選擇要跳頁時，程式在列印報表的時候會自動檢查每一頁剩餘的行數是否足夠
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再放進下一個測試項目的報表內容，盡量避免一個測試項目的報表內容被分割成兩

頁。頁首是指列印報表時每一頁最上方要加進去的文字，本程式限制使用者最多能

顯示三行的頁首。 

 
當您選擇要顯示頁碼時，程式在列印報表的時候會在每一頁下方中央位置加入該頁

的頁碼，例如”P 1/20”乃表示此列印報表總共有 20 頁而此頁為第 1 頁。 

 

 
圖 9-16  列印選項 

 
 

9.4.5 傳送郵件選項 

8200 ATS 系統軟體可以將報表產生器產生的報表，透過「MailGen」程式，以附加

檔案的方式傳送到使用者指定的電子郵件信箱，您可以利用選單功能[Options] 

[Auto Mail...] 來設定什麼時候傳送以及收件人的電子郵件住址，其產生的對話盒共

有三頁，此處特別說明第一頁的內容。 
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圖 9-17  MailGen 

 
這一頁的選項包括打開/關閉整個傳送郵件功能，以及各個測試程式所產生的報表是

否要傳送，8200 ATS 系統軟體安裝目錄下必須有某個測試程式的測試資料，該測試

程式才會出現在對話盒中讓使用者設定。「UUT Testing Date / Time」欄位顯示此測

試程式最近一次傳送的 UUT 的測試時間，等到下一次傳送的時間到時，會從此

UUT 的測試時間以後所測的 UUT 開始傳送，使用者可以自行修改「UUT Testing 

Date / Time」欄位以達到控制傳送哪些 UUT 的目的。 

 
 

9.4.6 選單說明 

[File]→[Open Log 

Database...] 

設定欲開啟報表之資訊，並產生報表。 

[File]→[Save Current Tab...] 儲存目前待測物報表。 

[File]→[Save All...] 將所有待測物報表全部存檔。 

[File]→[Print (“Courier New” 

Only)...] 

直接列印。 

[File]→[Print Preview] 預覽列印。 

[File]→[Print Setup...] 設定印表機。 

[File]→[Print Option...] 自定列印選項，包括跳頁、頁首與頁碼。 
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[File]→[Exit] 結束本程式，回到 8200 ATS 系統軟體的主畫

面。 

  
[View]→[Toolbar] 設定是否顯示工作列。 

[View]→[Status Bar] 設定是否顯示狀態列。 

[View]→[Set Font...] 設定資料顯示區字型。 

[View]→[Reset Font (Report 

Format File)] 

使用報表格式檔預設的字型。 

[View]→[Set Color...] 設定資料顯示區顏色。 

[View]→[Ignore Color] 忽略顏色配置。 

  
[Show]→[Header] 設定是否顯示檔頭資訊。 

[Show]→[Pre and Post Test 

Sequences] 

設定是否顯示 Pre and Post 測試項目報表內

容。 

[Show]→[Sequences Name 

and Pass / Fail] 

設定是否顯示測試項目名稱以及該測試項目的測

試結果。 

[Show]→[Step No] 設定是否顯示測試流程號碼 

[Show]→[Sequences No] 設定是否顯示測試項目序號。 

[Show]→[TI Name] 設定是否顯示測試項目的名稱 

[Show]→[Ext. Name] 設定是否顯示測試項目的 Ext 名稱 

[Show]→[Sequences Elapsed 

Time] 

設定是否顯示每個測試項目執行所花的時間。 

[Show]→[Separator] 設定是否顯示兩個測試項目間的分隔線。 

[Show]→[Separator Option...] 設定兩個測試項目間的分隔線的樣式。 

[Show]→[Start Position of 

Sequences Pass / Fail...] 

設定各個測試項目的測試結果在該行的起始位

置。 

[Show]→[Sequences...] 顯示部份測試項目報表。 

[Show]→[All Sequences...] 顯示全部測試項目報表。 

[Show]→[Fail Report] 顯示 Fail 報表，此特殊模式僅會顯示 Fail Seq.

的資料 (註：僅在 Online 報表時才有此選項) 

  
[Options]→[Auto Mail...] 

 

設定何時傳送報表郵件以及收件人的電子郵件住

址等。 

[Options]→[Fail Reading…] 設定是否在 Fail Reading 前加上識別字元 

  
[Help]→[About RptGen...] 顯示本程式的版本資訊。 
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10. 系統管理功能 

當您在 8200 ATS 系統軟體主畫面中選擇 Management 選項後，即可進入

Management 功能，而其中尚可區分為 User (使用者管理功能)、Activity Log (使用

者活動記錄瀏覽功能)、Test Program (測試程式管理功能)、Instrument (儀器及其驅

動程式管理功能)、H/W Configuration File (儀器組態設定檔管理功能)、Log Data 

(測試結果資料管理功能)、Fixture ID (治具型號管理功能)，以及 Net Extension (網

路相關擴充功能)等八項子功能，分別敘述如下。 

 
 

10.1 使用者管理功能 

點選畫面上方的 User 標籤即可顯示使用者管理功能畫面。在本系統中，使用者的權

限是以功能來做區分，而使用層級則是用來定義所可使用的功能有那些。每個使用

者都會被賦與一個使用層級，而使用者所能使用的功能就被其所屬的使用層級所定

義。如果兩個使用者的使用層級名稱（Level Name）相同，則這兩個使用者所能使

用的功能也就相同。 

 
 

10.1.1 使用者資訊 

在「User」頁次中，點選上方的 User ID 可顯示目前已經定義的使用者，以及其相

關資訊。畫面中的 User ID、Level Name、Exp Date、Comment 及 Active 分別表

示使用者的名稱、使用層級、有效期限、備註說明及是否有效。 
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圖 10-1  使用者管理設定視窗 

 

Add： 新增使用者。所須輸入之資訊除了上面所述外，還有使用者密碼

（Password）。 
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圖 10-2  新增使用者對話盒 

 

Edit： 修改目前選擇的使用者資訊。 

Delete： 刪除目前選擇的使用者。 

 
 

10.1.2 使用者層級 

在「User」頁次中，點選上方的 User Level 可顯示目前已經定義的使用層級及其所能

使用的功能。 

 
本系統中有兩個預設的使用層級，其名稱分別為 op 及 supervisor。使用層級為 op 的

使用者在進入系統時，會自動進入 GO/NOGO 功能中；而使用層級為 supervisor 的

使用者則能夠使用所有的功能。這兩個預設的使用層級是無法刪除或修改的。 
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圖 10-3  使用者權限設定視窗  

 

Add： 新增使用層級。按下此按鈕後，原本的 Edit 及 Delete 按鈕會分別變成

 Update 及 Cancel 按鈕。輸入完成後請按 Update，若要取消則請按

Cancel。 

Edit：  修改目前選擇的使用層級。按下此按鈕後，原本的 Edit 及 Delete 按鈕會分

 別變成 Update 及 Cancel 按鈕。輸入完成後請按 Update，若要取消則請按

 Cancel。 

Delete： 刪除目前選擇的使用者。 

 
 

10.1.3 語系設定 

在「User」頁次中，可透過 Language 下拉式選單切換軟體的語系。在退出

Chroma 8200 系統，於下次重新進入系統時會切換成所設定的語系版本。 
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圖 10-4  語系設定 

 
 

10.2 使用者活動記錄瀏覽功能 

點選畫面上方的「Activity Log」標籤即可顯示使用者活動記錄功能畫面。本系統會記

錄使用者進入及離開 Chroma 8200 的時間，以及使用過那些功能。 

 

 
圖 10-5  使用者活動記錄瀏覽視窗  

 

Clear： 清除所有的使用者活動記錄。 
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10.3 測試程式管理功能 

點選畫面上方的「Test Pogram」標籤即可顯示測試程式管理功能畫面。此處可以變

更測試程式的（Release）狀態、匯出/匯入測試程式和刪除測試程式。 

 
測試程式匯出時，會將其資料記錄在一個副檔名為 tpx 的檔案中，而匯入測試程式時

也是讀取此類檔案。藉由測試程式的匯出/匯入功能，可以使不同的 Chroma 8200 系

統使用相同的測試程式而不需要重覆編寫此測試程式。 

 

圖 10-6  測試程式發行視窗  

 

Export： 匯出目前選擇的測試程式，包含其所使用的報表格式檔及硬體組態設定

檔。 

Import： 匯入測試程式，包含其所使用的報表格式檔及硬體組態設定檔。若系統

中已存在同名且相同之測試程式，或測試程式尚未發行，則會詢問是否

要覆蓋；而若系統中已存在同名且不相同之已發行測試程式，則不允許

匯入。 
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Delete： 刪除目前選擇的測試程式 

10.4 儀器及其驅動程式管理功能 

點選畫面上方的「Instrument」標籤即可顯示儀器及其驅動程式管理功能畫面。當需

要使用的儀器未被列在此畫面中時，請先向經銷商或本公司洽詢是否有該儀器之驅動

程式，您所取得的檔案應是一個副檔名為 inx 的檔案，而匯入時也是讀取此類檔案。 

 

 
圖 10-7  儀器及其驅動程式管理視窗 

 

Export：  匯出目前選擇的儀器及其驅動程式。匯出成功後，系統會在指定的目

錄下依指定的檔名產生一個副檔名為 inx 的檔案。 

Import：  匯入儀器及其驅動程式。按下此按鈕後，系統會要求您輸入副檔名為 

inx 的檔名，請輸入或選取正確的檔案，然後選取所需的儀器後即可將

其加入。您也可以輸人副檔名為 hwd 的檔案，這是 1.2 版 (含) 以前

的檔案。 

Delete：  刪除目前選擇的儀器。 
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10.5 儀器組態設定檔管理功能 

點選畫面上方的「H/W Configuration File」標籤即可顯示儀器組態設定檔管理功能畫

面。此處可以匯出、匯入或刪除儀器組態設定檔。 
 

使用匯出功能時，會將所有選到的儀器組態設定檔的資料記錄在一個副檔名為 hwx 

的檔案中，而匯入儀器組態設定檔時也是讀取此類檔案。 
 

 
圖 10-8  儀器組態設定檔管理視窗 

 

Export： 匯出目前選擇的儀器組態設定檔。 

Import： 匯入儀器組態設定檔。當選取一個副檔名為 hwx 的檔案後，程式會將其

中所包含的所有儀器組態設定檔列在一個視窗中以供選擇，若系統中已

存在同名之儀器組態設定檔，則會詢問是否要更改名稱。 

Delete： 刪除目前選擇的儀器組態設定檔。 
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10.6 測試結果資料管理功能 

點選畫面上方的「Log Data」標籤即可顯示測試結果資料管理功能畫面。此處可以匯

出、匯入或刪除測試結果資料，籍由匯出與匯入的功能，可以將測試結果資料拿到不

同的Chroma 8200系統中做報表列印或統計分析等功能。 

 
測試資料匯出時，會將匯出的測試結果資料記錄在一個副檔名為 lgx 的檔案中，而匯

入測試結果資料時也是讀取此類檔案。 

 

 
圖 10-9  測試結果資料匯入匯出視窗 

 

Export： 匯出目前選擇的測試結果資料。 

Import： 匯入測試結果資料。 

Delete： 刪除目前選擇的測試結果資料。 
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10.7 治具型號管理功能 

點選畫面上方的「Fixture ID」標籤即可顯示治具型號管理功能畫面。此處可以匯

出、匯入或刪除治具所適用的型號，只有出現在這個畫面中的型號才以可在測試程

式中被選用，配合Fixture ID Card，可在測試時檢查治具的狀態。請參考Fixture ID 

Card的使用手冊。 
 

使用匯出功能時，會將所有選到的型號記錄在一個副檔名為 fix 的檔案中，而匯入

時也是讀取此類檔案。當使用Fixture ID Editor新建立一個新的治具所適用的型號

後，請先使用Fixture ID Editor中的Utility/Export功能匯出成fix檔，然後就可以在此匯

入到系統中。 
 

 
圖 10-10  治具型號管理視窗 

 

Export： 匯出目前選擇的型號。 

Import： 匯入治具所適用的型號。當選取一個副檔名為 fix 的檔案後，程式會

將其中所包含的所有型號列在一個視窗中以供選擇。 

Delete： 刪除目前選擇的型號。 
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10.8 網路相關擴充功能 

點選畫面上方的「Net Extension」標籤即可顯示網路相關擴充功能畫面。目前只有提

供Remote TP功能，此功能可將測試程式匯出到某一指定的遠端目錄中，而讓許多不

同的Chroma 8200系統在GO/NOGO程式中可直接開啟這些匯出的測試程式來執行

測試，如此可達到測試程式集中管理的功能。 

 

 
圖 10-11  網路相關擴充功能視窗 

 

Setting…： 可啟用/停用 Remote TP 功能, 並設定 Remote TP 所在之目錄。

所有要使用 Remote TP 的 Chroma 8200 系統必需要在此將

Remote TP 啟用並正確地設定目錄。而 Remote TP 啟用後只影

響 GO/NOGO，使其只能開啟 Remote TP 的測試程式，而不會

改變到 Chroma 8200 系統的其他功能。 

Upload： 將所選擇的 Chroma 8200 系統中的測試程式匯出到遠端。 

Download： 將所選擇的遠端的測試程式匯入到 Chroma 8200 系統中。 

Delete： 刪除遠端目前選擇的測試程式。 
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Local H/W Config: 若某一 Chroma 8200 系統所需的硬體組態設定檔與 Remote TP

上的不同，則可以在畫面右邊表格的 Local H/W Config 欄位選用 Local 的硬體組態設

定檔。 
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11. 統計製程管制（選配） 

本統計製程管制功能可將待測物（UUT）測試之後記錄的結果作統計分析。主要功能

有製程能力分析統計圖表（Process Capability Analysis）、平均數與全距管制圖

（Xbar&R Chart）、平均數與標準差管制圖（Xbar&S Chart）、柏拉圖（Pareto Chart）、

不良數管制圖（np Chart）、不良率管制圖（p Chart）、缺點數管制圖（c Chart）及缺

點率管制圖（u Chart）等共8種；本功能還可以將各個統計圖的圖型儲存為圖檔

（Bitmap File）。 
 

在統計製程管制功能外，本功能還提供匯出讀值變數的內容到EXCEL／文字檔中，使

您可以將測試之後記錄的結果送往其它工具程式繼續使用。 

 
 

11.1 開啟統計記錄檔 

當您在Chroma 8200 ATS系統軟體的主畫面上，按下Statistics 選項之後，畫面便會

顯示出如圖 11-1所示的「Statistics」視窗。 
 

「Statistics」視窗中，共分為二頁，第一頁“Data Source Setting”，可讓您欲設定進

行統計的起始及結束日期，詳細說明請參考11.2節之說明。第二頁“Constraint Setting”，

提供您設定篩選條件過濾測試資料，詳細說明請參考11.3節之說明。 
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圖 11-1  「Statistics」視窗 

 

在進行統計分析前，首先必須開啟統計記錄檔（*.spc），按下工具列 Open後，即

可選取系統存在的統計記錄檔，如圖 11-2（預設目錄為“安裝目錄\Spc”）；在您按下

選擇的統計記錄檔時，在圖 11-2上方會顯示統計記錄檔內所指定的測試程式名稱。 

 
當開啟統計記錄檔完成後，便可開始選擇統計的資料來源請參考11.2節之說明。 
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圖 11-2  開啟統計記錄檔 

 
 

11.2 選擇統計的資料來源 

選擇統計的資料來源，首先選擇「Data Source Setting」頁次，統計記錄檔的測試程

式名稱會顯示在 Test Program 欄位中，接著在 Log Data 欄位中設定所欲統計之資料

的起始日與終止日，以選取此段期間中的測試結果資料，如圖 11-3。 
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圖 11-3  設定統計資料的起始日與終止日 

 
接著設定統計的資料來源（Log Data Search Path），一般是使用系統預設測試結果

資料Log目錄（Use Default Log Data Directory），或是使用自定的目錄群（Use 

Path List），提供統計程式到這些目錄尋找測試結果資料，並且可合併兩個以上的

PowerProIII 測台測試結果資料，一起作統計製程管制圖。此外，若有重測資料欲取

代原測試資料時，必須選取核取方塊Merge Retest Data即可。 
 

 Use Default Log Data Directory 使用系統預設測試結果資料Log目錄 

 Use Path List     使用自定的目錄群 
 

Add Directory 增加自定目錄，選擇目錄即可，在視窗下方會顯示出選取的目錄下

所含的測試後結果記錄資料庫檔案，如圖 11-4。 
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圖 11-4  增加自定目錄 

 

Delete 刪除游標所在的自定目錄 

 

 
 合併重測資料功能（Merge Retest Data），若是同樣的序號則

當作是重測的資料。 

 使用合併重測資料功能（Merge Retest Data），務必注意重測

資料檔是否使用同一測試程式，否則會遭遇錯誤。 

 各待測物的測試日期，以所選取出來的測試資料之日期為準。 

 

重測資料取代原測試資料的原則： 

 
當原測試資料中某待測物（UUT）在重測資料中也找到此待測物（UUT）之序號（Serial 

No.）時，則以重測資料取代原測試資料，其餘則仍採用原測試資料。此外，若設有篩

選條件過濾測試資料時，原測試資料及重測資料都必須經篩選條件過濾後，通過者的

測試資料才會被顯示以供統計分析之用。 

 
 設定統計資料的起始日與終止日之日期格式為 YYYY/MM/DD 

YYYY ：表西元年份，例如 2000。 

MM  ：表月份，例如五月份為 05。（範圍：1~12） 

DD  ：表日期，例如 25 日為 25。（範圍：1~31） 

上述日期格式為 2000/05/25。 

使用日期設定右方的上下鍵可以改變日期，請注意，起始日期要比終止日期還

早。 

 

提示
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11.3 設定篩選條件過濾測試資料 

設定篩選條件過濾測試資料，首先選擇 Constraint Setting 頁次，此頁分成 SerialNo 

Constraint 及 Variable Constraint 二部份，除了參數名稱的設定不同外－SerialNo 的

參數固定設為“SerialNo”，Variable 的參數則為一個下拉選單；其餘的皆相同，中間下

拉式選單 OP 提供選擇運算元（=、<>、<、>、>=、<=），右上方提供輸入設定條件

值，當上述三項篩選條件輸入完畢後，按下 Add 按鍵即可將此篩選條件轉換成資料

庫查詢條件並顯示於下方列示表單中，反之按 Delete 按鈕可將列示表單中被選擇的

資料庫查詢條件去除，如圖 11-5。 

 

 
圖 11-5  設定篩選條件過濾測試資料 

 
將統計的資料來源及篩選過濾測試資料條件設定好後，即可以開始取出測試資料，

進行各種統計分析。以下分別介紹各種統計管制圖表的用法。 
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11.4 製程能力分析統計圖表 (Process 

Capability Analysis) 

進行製程能力分析，按下工具列 （Process Capability Analysis）後，即顯示製

程能力分析統計圖表參數設定畫面，如圖 11-6 中，左方顯示此測試程式在 SPC Log 

Setting 功能中篩選出的所有讀值變數。右方顯示左側被選擇讀值變數的所有測試讀

值，當使用者更換選取左側不同讀值變數時，右側會更新為此讀值變數的所有測試讀

值。按下 Select Wizard 會呈現如圖 11-7 的對話盒，透過條件設定，可以快速的依

條件選擇所需的變數，並可將條件儲存成檔案。 

 

 
圖 11-6  製程能力分析統計圖表參數設定－資料 
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圖 11-7  變數選擇精靈 

 

 
圖 11-8  製程能力分析統計圖表參數設定－統計參數 
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圖 11-9  製程能力分析統計圖表參數設定－列印基本資料設定 

 

Logged Variable 表格：（圖 11-6，製程能力分析統計圖表參數設定－資料）顯示

讀值變數的相關資訊，重要欄位說明如下。 

 
No. 讀值變數流水號 

Call Name 讀值變數名稱 CallName 

Load No. 陣列變數的索引值，如果此變數為非陣列變數，索引值為 1。 

Seq. Seq.號碼 

Test Item 測試項目名稱 

Sel 讀值變數核取方塊，被選取後於預覽統計圖表結果或列印，會

有此讀值變數統計圖表結果。 

Remark 讀值變數註解說明 

MaxSpec 讀值變數的參考規格上限變數名稱 

MinSpec 讀值變數的參考規格下限變數名稱 

Variable 讀值變數識別代號名稱 

 

 
Sel 欄位之核取方塊，提供對多讀值變數統計圖表結果連續列印功

能。 
提示
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Select All 選取所有讀值變數，將所有讀值變數核取方塊設定為選取狀

態。 

UnSelect All 取消選取所有讀值變數，將所有讀值變數核取方塊設定為非選

取狀態。 

 
Value 表格：顯示某讀值變數的測試讀值結果，重要欄位說明如下。 

 
No. 測試讀值流水號。 

Serial No 待測物（UUT）序號。 

Value 測試讀值結果值。 

Result 測試讀值成功或失敗（PASS／FAIL）。 

Sel 測試讀值核取方塊，被選取後於預覽統計圖表結果或列印時，

會將此測試讀值列入統計運算。 

Variable ID 讀值變數識別代號。 

 

Select All  選取所有測試讀值，將所有測試讀值核取方塊設定為選取狀

態。 

UnSelect All  取消選取所有測試讀值，將所有測試讀值核取方塊設定為非選

取狀態。 

 
製程能力分析統計圖表的設定參數：共分為兩頁，茲分別說明如下： 

 
「Parameter Setting」頁次（圖 11-8，製程能力分析統計圖表參數設定－統計參

數）： 

 
1) Spec. Max 設定選定變數的規格上限值，用以計算 Cp、Ca、Cpk 等

值。 

2) Spec. Min 設定選定變數的規格下限值，用以計算 Cp、Ca、Cpk 等

值。 

3) Sigma(Cpk) 選擇計算 Sigma 的方式（n：用以計算整個母群體；n-1：

用以估算整個母群體。） 

4) Number of Bins 設定直方圖的區間數。 

 
Use Sturges Rule 由所有讀值資料中取得最大值與最小值作為直方圖分隔區

間的最大值與最小值，並根據所有的樣本數計算區間數，公

式為：1+3.3*log(Sizeof(X))。 

Use Custom Define 
Bins 

由使用者自定分隔區間的最大值與最小值及自定區間數。 
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Number 自定區間數。 

Bin Max 分隔區間的最大值。 

Bin Min 分隔區間的最小值。 

 
Display Histogram  選擇是否顯示直方圖。 

 

 
 Spec. Max 與 Spec. Min 若未指定時，本程式會由此變數的所

有讀值中取出最大與最小值填入此兩欄位中。 

 作單邊管制圖表分析時，若無規格上限值需將 Spec. Max 欄位

輸入-9999，若無規格下限值需將 Spec. Min 欄位輸入-9999，

使系統判定製作單邊管制圖表分析。若所選的資料，其 Sigma

趨近於 0，則無法計算並畫圖！ 

 
「Print Setting」頁次：如圖 11-9，製程能力分析統計圖表參數設定－列印基本資料

設定，其中除 Title、Model Name 及 Condition 可設定外，其餘各欄位均無法設定，

且一定會隨同圖表列印出。 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 

Model Name 待測物型別名稱。 

Test Item Name 測試項目（Test Item）名稱，此欄位僅用以顯示，您無法更

改其內容。 

Variable Name 變數名稱，此欄位僅用以顯示，您無法更改其內容。 

Condition 測試條件設定，您可依實際測試條件，輸入測試條件說當您

按下 Edit Condition 後浮現一個輸入文字對話盒，如圖 

11-10，供您方便地能從測試程式中挑選出合適的

TestCondition 類的變數內容，編輯成此欄的說明文字。 

 

提示
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圖 11-10  編輯測試條件設定 

 
左上方為可挑選的測試項目，在製程能力分析統計圖表中，只需選擇目前讀值變數所

屬的測試項目，左下方的小視窗，顯示的是左上方測試項目所有的測試條件變數；右

上方的視窗為編輯顯示的區域，其中以紅色表示的數字是由左方挑選過來的變數，右

下方顯示的是所有已挑選的變數。 
 

顯示統計圖表 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右方那些測試讀值要被列入統計

運算，最後將「Parameter Setting」與「Print Setting」兩頁之內容都設定好之後，按

下工具列 Print Preview按鈕，即可獲得如圖 11-11製程能力分析統計圖。 
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圖 11-11  製程能力分析統計圖表結果 

 
統計圖表結果是以預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接著顯

示統計圖表，下方列出統計計算數值結果，最後顯示各區間的結果。視窗上方有幾個

按鈕說明如下： 

 

列印(P) 列印此統計圖表結果 

下一頁(N) 預覽下一頁統計圖表結果 

前一頁(v) 預覽上一頁統計圖表結果 

兩頁(T) 以同時顯示兩頁的方式預覽統計圖表 

拉近(I) 將目前預覽統計圖表結果放大呈現 

拉遠(O) 將目前預覽統計圖表結果縮小呈現 

關閉(C)  關閉預覽統計圖表結果 

 
儲存統計圖 
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先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入

統計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 

11-12所示的儲存圖檔對話盒。圖中左方為選取的變數，變數的命名為

VariableName_Sequence_LoadNo，右上方為一個設定特性的區域，可以設定是否

儲存Header、圖表、Data和圖型的大小，可個別設定每個變數圖檔的特性。右下方

為儲存檔案的目錄和自定檔名的部份，檔案的命名方式為使用者自定和自動設定，

自動設定的檔名為_ChartName，其中ChartName會在儲存時自行替換成左方的變數

名稱，檔案類型可由使用者選取為.bmp或.jpg。 

 

 
圖 11-12  儲存圖檔對話盒 
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儲存計算資料 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save Computered Data to Excel File 按鈕，出現轉換設定

對話盒，如圖 11-13 轉換設定資料，以及儲存對話盒，如圖 11-14 儲存計算資料。 

 

 
圖 11-13  轉換設定資料 

 

 
圖 11-14  儲存計算資料 
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11.5 平均數與全距管制圖表（Xbar&R Chart） 

製作平均數與全距管制圖，按下工具列 （Xbar&R）後，即顯示平均數與全距管制

圖表參數設定畫面，如圖 11-15，左方顯示此測試程式在SPC Log Setting功能中篩選

出的所有變數，右方顯示左側被選擇變數的所有測試讀值，當使用者更換選取左側不

同變數時，右側會更新為此變數的所有測試讀值，而另外兩頁是平均數與全距管制圖

表的設定參數，以下分別介紹。 
 

圖 11-15  平均數與全距管制圖表參數設定－資料 
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圖 11-16  平均數與全距管制圖表參數設定－統計參數 

 

 
圖 11-17  平均數與全距管制圖表參數設定－列印基本資料設定 
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Logged Variable 表格：（圖 11-15，平均數與全距管制圖表參數設定－資料）顯示

讀值變數的相關資訊，重要欄位說明如下。 

 
No. 讀值變數流水號 

Call Name 讀值變數名稱 CallName 

Load No. 陣列變數的索引值，如果此變數為非陣列變數，索引值為 1。 

Seq. Seq.號碼 

Test Item 測試項目名稱 

Sel 讀值變數核取方塊，被選取後於預覽統計圖表結果或列印時，

會有此讀值變數統計圖表結果。 

Remark 讀值變數註解說明 

MaxSpec 讀值變數的參考規格上限變數名稱 

MinSpec 讀值變數的參考規格下限變數名稱 

Variable 讀值變數識別代號名稱 

 

 
Sel 欄位之核取方塊，提供對多讀值變數統計圖表結果連續列印功

能。 

 

Select All 選取所有讀值變數，將所有讀值變數核取方塊設定為選取狀

態。 

UnSelect All 取消選取所有讀值變數，將所有讀值變數核取方塊設定為非選

取狀態。 

 
Value 表格：顯示某讀值變數的測試讀值結果，重要欄位說明如下。 

 
No. 測試讀值流水號 

Serial No 待測物（UUT）序號 

Value 測試讀值結果值 

Result 測試讀值成功或失敗（PASS／FAIL） 

Sel 測試讀值核取方塊，被選取後於預覽統計圖表結果或列印時，會

將此測試讀值列入統計運算。 

Variable ID 讀值變數識別代號 

 

Select All 選取所有測試讀值，將所有測試讀值核取方塊設定為選取狀態。 

UnSelect All 取消選取所有測試讀值，將所有測試讀值核取方塊設定為非選取

狀態。 

 

提示
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「Parameter Setting」頁次：（圖 11-16，平均數與全距管制圖表參數設定－統計參

數） 

 
1) Sample Size 設定樣本數大小 

2) Std Err Multiplier 顯示管制上下限為幾倍的標準差 

3) Spec. Max/Min 設定選定變數的規格上下限值，用以計算 Cp、Ca、

Cpk 等值。 

4) Sigma(Cpk) 選擇計算 Sigma 的方式（n：用以計算整個母群體；n-

1：用以估算整個母群體。） 

5) Limit Source 設定管制上下限來源 

 
 From Selected Data 以被選擇的測試讀值計算管制界限 

 Use Std Mean，R0 將下方輸入的 Std Mean與 R0作為基準值（standard 

value）以計算管制界限 

 Use Std Mean，
Sigma 

將下方輸入的 Std Mean與 Sigma作為標準值

（standard value）以計算管制界限 

Std Mean 設定基準平均值（standard mean value） 

Sigma or R0 設定基準標準差值（standard sigma value）或是基準

全距值（standard R0） 

 

 
 平均數與全距管制圖表亦會計算 Cp、Ca 與 Cpk 值，因此必須

輸入規格上下限值（Spec. Max/Spec. Min）。 

 Spec. Max 與 Spec. Min 若未指定時，本程式會由此變數的所

有讀值中取出最大最小值填入欄位中。 

 若為單邊管制時，若無規格上限值需將 Spec. Max 欄位輸入-

9999，若無規格下限值需將 Spec. Min 欄位輸入-9999，使系

統判定作單邊管制分析。 

 若所選的資料，其 Sigma 趨近於 0，則無法計算並畫圖！ 

 
「Print Setting」頁次，如圖 11-17，平均數與全距管制圖表參數設定－列印基本資料

設定： 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱。 
Variable Name 變數名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明。當您

按下  Edit Condition 後浮現一個輸入文字對話盒，如圖 

提示
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11-10，供您方便地能從測試程式中挑選出合適的 Test 

Condition類的變數內容，編輯成此欄的說明文字。 

 
顯示統計表 

 
先選擇好左上方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入

統計運算，最後將Parameter Setting頁次與Print Setting頁次都設定好之後，按下

工具列 Print Preview，即可獲得圖 11-18平均數與全距管制圖表結果。 

 

 
圖 11-18  平均數與全距管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 
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儲存統計圖 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-19。

圖中左方為選取的變數，變數的命名為VariableName_Sequence_LoadNo，右上方為

一個設定特性的區域，可以設定是否儲存Header、圖表、Data和圖型的大小，可個別

設定每個變數圖檔的特性。右下方為儲存檔案的目錄和自定檔名的部份，檔案的命名

方式為使用者自定和自動設定，自動設定的檔名為_ChartName，其中ChartName會

在儲存時自行替換成左方的變數名稱，檔案類型可由使用者選取為.bmp 或.jpg。 

 

 
圖 11-19  儲存圖檔對話盒 

 
儲存計算資料 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save Computered Data to Excel File 按鈕，出現儲存對話

盒，如圖 11-20 儲存計算資料。 
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圖 11-20  儲存計算資料 

 
 

11.6 平均數與標準差管制圖（Xbar&S Chart） 

製作平均數與標準差管制圖，按下工具列 （Xbar&S）後，即顯示平均數與標準差

管制圖表參數設定畫面，如圖 11-21，左方顯示此測試程式在SPC Log Setting功能中

篩選的所有變數，右方顯示左側被選取變數的所有測試讀值，當使用者更換選取左側

不同變數時，右側會更新為此變數的所有測試讀值，而另外兩頁是平均數與標準差管

制圖表的設定參數，以下分別介紹。 
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圖 11-21  平均數與標準差管制圖表參數設定－資料 

 

 
圖 11-22  平均數與標準差管制圖表參數設定－統計參數 
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圖 11-23  平均數與標準差管制圖表參數設定－列印基本資料設定 

 
Logged Variable 表格：（圖 11-21）顯示讀值變數的相關資訊，重要欄位說明如

下。 

 
No. 讀值變數流水號 

Call Name 讀值變數 Call Name 

Load No. 陣列變數的索引值，如果此變數為非陣列變數，索引值為 1。 

Seq. Seq.號碼 

Test Item 測試項目名稱 

Sel 讀值變數核取方塊，被選取後於預覽統計圖表結果或列印時，會有

此讀值變數統計圖表結果。 

Remark 讀值變數註解說明 

MaxSpec 讀值變數的參考規格上限變數名稱 

MinSpec 讀值變數的參考規格下限變數名稱 

Variable 讀值變數識別代號名稱 

 

 
Sel 欄位之核取方塊，提供對多讀值變數統計圖表結果連續列印功

能。 

 

提示
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Select All 選取所有讀值變數，將所有讀值變數核取方塊設定為選取狀態。 

UnSelect All 取消選取所有讀值變數，將所有讀值變數核取方塊設定為選取狀

態。 

 

Value 表格：顯示某讀值變數的測試讀值結果，重要欄位說明如下。 

 
No. 測試讀值流水號 

Serial No 待測物（UUT）序號 

Value 測試讀值結果值 

Result 測試讀值成功或失敗（PASS／FAIL） 

Sel 測試讀值核取方塊，被選取後於預覽統計圖表結果或列印時，會

將此測試讀值列入統計運算。 

Variable ID 讀值變數識別代號 

 

Select All 選取所有測試讀值，將所有測試讀值核取方塊設定為選取狀態。 

UnSelect All 取消選取所有測試讀值，將所有測試讀值核取方塊設定為非選取

狀態。 

 
「Parameter Setting」頁次：（圖 11-22） 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下限為幾倍的標準差 

3)Spec. Max/Min 設定選定變數的規格上限值，用以計算 Cp、Ca、Cpk

等值。 

4)Sigma(Cpk) 選擇計算 Sigma 的方式（n：用以計算整個母群體；

n-1：用以估算整個母群體。） 

5)Limit Source 設定管制上下限來源 

 
 From Selected Data 以被選擇的測試讀值計算管制界限 

 Use Std Mean，s0 將下方輸入的 Std Mean 與 s0 作為基準值（standard 

value）以計算管制界限 

 Use Std Mean，
Sigma 

將下方輸入的 Std Mean 與 Sigma 作為標準值

（standard value）以計算管制界限 

Std Mean 設定基準平均值（standard mean value） 

Sigma or s0 設定基準標準差值（standard sigma value）或是基準

s0 值（standard s0） 

 

 
 平均數與標準差管制圖表亦會計算 Cp、Ca 與 Cpk 值，因此提示
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必須輸入規格上下限值（Spec. Max/Spec. Min）。 

 若未指定時，本程式會由此變數的所有讀值中取出最大最小值

填入欄位中。 

 若為單邊管制時，若無規格上限值需將 Spec. Max 欄位輸入-

9999，若無規格下限值需將 Spec. Min 欄位輸入-9999，使系

統判定作單邊管制分析。 

 若所選的資料，其 Sigma 趨近於 0，則無法計算並畫圖！ 

 
「Print Setting」頁次，如圖 11-23： 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱。 
Variable Name 變數名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明，

當您按下Edit Condition 後浮現一個輸入文字對話盒，如圖 

11-10，供您方便地能從測試程式中挑選出合適的Test 

Condition類的變數內容，編輯成此欄的說明文字。 

 
顯示統計圖表 

 
先選擇好左上方那些讀值變數要製作統計圖表，再選擇右方哪些測試讀值要被列入統

計運算，最後將「Parameter Setting」與「Print Setting」兩頁之內容都設定好之後；

按下工具列 Print Preview按鈕，即可獲得如圖 11-24平均數與標準差管制圖。 
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圖 11-24  平均數與標準差管制圖表結果 

 

統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 
儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-25。

圖中左方為選取的變數，變數的命名為VariableName_Sequence_LoadNo，右上方為

一個設定特性的區域，可以設定是否儲存Header、圖表、Data和圖型的大小，可個別

設定每個變數圖檔的特性。右下方為儲存檔案的目錄和自定檔名的部份，檔案的命名

方式為使用者自定和自動設定，自動設定的檔名為_ChartName，其中ChartName會

在儲存時自行替換成左方變數名稱，檔案類型可由使用者選取為.bmp或.jpg。 
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圖 11-25  儲存圖檔對話盒 

 
儲存計算資料 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save Computered Data to Excel File 按鈕，出現儲存對話

盒，如圖 11-26 儲存計算資料。 

 

 
圖 11-26  儲存計算資料 
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11.7 柏拉圖（Pareto Chart） 

本系統運用柏拉圖的方式，是將每一個待測物的各個測試程序之結果為失敗者視為缺

點，經統計分析運算所得之結果。 
 

製作柏拉圖，按下工具列 （Pareto Chart）後，即顯示柏拉圖表列印基本資料設

定畫面，如圖 11-27，上方顯示每一個待測物（UUT）各個測試程序（Sequence）成

功或失敗的結果（0為失敗，1為成功。）。 

 

 
圖 11-27  柏拉圖表列印基本資料設定畫面－資料 
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圖 11-28  柏拉圖表列印基本資料設定畫面－列印基本資料設定 

 
UUT 表格：（圖 11-27）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 待測物（UUT）編號 

Sel 待測物測試結果核取方塊，被選取後於預覽統計圖表結果或

列印時，會將此測試結果列入統計運算。 

Serial No. 待測物（UUT）之序號 

 
其他欄位顯示各測試程序（Sequence）的測試結果為成功或失敗（1／0）。 

 

Select All 選取所有待測物（UUT）測試結果，將所有待測物測試結果

核取方塊設定為選取狀態。 

UnSelect All 取消選取所有待測物（UUT）測試結果，將所有待測物測試

結果核取方塊設定為非選取狀態。 
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Print Setting 頁次：（圖 11-28） 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明，當

您按下 Edit Condition 後浮現一個輸入文字對話盒（參考圖 

11-29），供您方便地能從測試程式中挑選出合適的

TestCondition類的變數，編輯成此欄的說明文字。 
 

 
圖 11-29  編輯測試各條件設定 

 

左上方為可挑選的測試項目，在製程能力分析統計圖表中，只

需選擇目前讀值變數所屬的測試項目，左下方的小視窗，顯示

的是左上方測試項目所有的測試條件變數；右上方的視窗為編

輯顯示的區域，其中以紅色表示的數字是由左方挑選過來的變

數，右下方顯示的是，所有已挑選的變數。 
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顯示統計圖表 

 

先由上方表格選擇好要被列入統計運算的待測物（UUT）結果，最後將Print Setting

該頁之內容設定好之後，按下工具列 Print Preview按鈕，即可獲得圖 11-30 柏拉

圖表結果。 

 

 
圖 11-30  柏拉圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，最後顯示各測試程序（Sequence）失敗的數量及相對百分比數值結

果，並依照各測試程序失敗的數量由多至少向下排序。 

 
儲存統計圖 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-31。
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圖中左方為圖型的名稱，為Pareto，右上方為一個設定特性的區域，可以設定是否儲

存Header、圖表、Data和圖型的大小。右下方為儲存檔案的目錄和自定檔名的部份，

檔案的命名方式為使用者自定和自動設定，自動設定的檔名為_Pareto，檔案類型可由

使用者選取為.bmp或.jpg。 

 

 
圖 11-31  儲存圖檔對話盒 

 
 

11.8 不良數管制圖（np Chart） 

本系統運用不良數管制圖的方式，是針對每一個待測物的測試結果，若測試結果為失

敗者，將之視為不良，經統計分析運算所得之結果即為不良數管制圖。 

 

製作不良數管制圖，按下工具列 （np Chart）後，即顯示不良數管制圖表參數設定

畫面，如圖 11-32，上方表格中顯示每一個待測物（UUT）的測試結果，而下方是設

定不良數管制圖表參數，以下分別介紹。 
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圖 11-32  不良數管制圖表參數設定－資料 

 

 
圖 11-33  不良數管制圖表參數設定－統計設定 
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圖 11-34  不良數管制圖表參數設定－列印基本設定 

 
UUT 表格：（圖 11-32）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 待測物之流水編號 

Sel 待測物測試結果核取方塊，被選取後於預覽統計圖表結

果或列印時，會將此測試結果列入統計運算。 

Serial No. 待測物之序號 

UUT Pass/Fail (1/0) 顯示待測物之測試結果為成功（1）或失敗（0） 

 

Select All 選取所有待測物測試結果，將所有待測物測試結果核取

方塊設定為選取狀態。 

UnSelect All 取消選取所有被測物測試結果，將所有待測物測試結果

核取方塊設定為非選取狀態。 

 

「Parameter Setting」頁次： 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下限為幾倍的標準差 

3)Limit Source 設定管制上下限來源 
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 From Selected 
Data 

以被選擇的待測物測試結果計算管制界限 

 Use Std p0 將下方輸入的 Std p0 作為基準值（standard p0 

value）以計算管制界限中心線 

Std p0 設定基準 p0 值（standard p0 value），並將 n*p0 作為

管制界限中心線（n 為樣本數大小）。 

 
「Print Setting」頁次，如圖 11-34其中除 Title及 Condition可設定外，其餘欄位均

無法設定且一定隨同圖表列印出。 

 
Title 列印標題設定 
Model Name 待測物型別名稱。 
Condition 列印測試條件設定，您可依實際測試條件，輸入測試條

件說明，當您按下 Edit Condition 後浮現一個輸入文

字對話盒（參考圖 11-29），供您方便地能從測試程式

中挑選出合適的TestCondition類的變數，編輯成此欄的

說明文字。 

 
顯示統計圖 

 
先由上方表格選擇好要列入統計運算的待測物結果，然後將「Parameter Setting」頁

次與「Print Setting」頁次都設定好之後，按下工具列 （Print Preview），即可獲

得如圖 11-35 不良數管制圖。 
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圖 11-35  不良數管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 
儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files 按鈕，出現儲存對話盒，如圖 11-36。

圖中左方為圖型的名稱，為NP Chart，右上方為一個設定特性的區域，可以設定是否

儲存Header、圖表、Data和圖型的大小。右下方為儲存檔案的目錄和自定檔名的部份，

檔案的命名方式為使用者自定和自動設定，自動設定的檔名為_NPChart，檔案類型可

由使用者選取為.bmp或.jpg。 
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圖 11-36  儲存圖檔對話盒 

 
 

11.9 不良率管制圖（p Chart） 

本系統運用不良率管制圖的方式，是將每一天所有待測物的測試結果為失敗之數量多

寡視為不良率，經統計分析運算所得之結果。 

 

製作不良率管制圖，按下工具列 （p Chart）後，即顯示不良率管制圖表參數設定

畫面，如圖 11-37，上方表格顯示每一個待測物（UUT）的測試結果，而下方是設

定不良率管制圖表參數，以下分別介紹。 
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圖 11-37  不良率管制圖表參數設定－資料 

 

 
圖 11-38  不良率管制圖表參數設定－統計設定 

 



電源供應器自動測試系統 8200 使用手冊 

 11-40 

 
圖 11-39  不良率管制圖表參數設定－列印基本設定 

 
Date 表格：（圖 11-37）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 依日期順序編訂之流水號 

Sel 各日期測試結果核取方塊，被選取後於預覽統計圖表結

果或列印時，會將此日期測試結果列入統計運算。 

Date 測試日期 

UUT Pass Counts 某日待測物測試結果為成功之數量 

UUT Fail Counts 某日待測物測試結果為失敗之數量 

UUT Total Counts 某日待測物的測試數量 

 

Select All 選取所有待測物測試結果，將所有待測物測試結果核取

方塊設定為選取狀態。 

UnSelect All 取消選取所有待測物測試結果，將所有待測物測試結果

核取方塊設定為非選取狀態。 

 
「Parameter Setting」頁次：（圖 11-38） 

 
1) Sample Size 設定樣本數大小 

2) Std Err Multiplier 顯示管制上下限為幾倍的標準差 

3) Limit Source 設定管制上下限來源 
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 From Selected Data 以被選擇的待測物測試結果計算管制界限 

 Use Std p0 將下方輸入的 Std p0 作為基準值（standard p0 value）

作為管制界限中心線 

Std p0 設定基準 p0 值（standard p0 value） 

 
「Print Setting」頁次，如圖 11-39： 

 
Title 列印標題設定 
Model Name 待測物型別名稱。 
Condition 列印測試條件設定，您可依實際測試條件，輸入測試

條件說明，當您按下 Edit Condition 後浮現一個輸

入文字對話盒（參考圖 11-29），供您方便地能從測試

程式中挑選出合適的TestCondition類的變數，編輯成

此欄的說明文字。 

 
顯示統計圖 
 

先選擇好上方要列入統計運算的測試日期結果，然後將「Parameter Setting」與「Print 

Setting」兩頁之內容都設定好之後，按下工具列 （Print Preview），即可獲得如圖 

11-40不良率管制圖。 
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圖 11-40  不良率管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示被測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 
儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-41。

圖中左方為圖型的名稱，為P Chart，右上方為一個設定特性的區域，可以設定是否儲

存Header、圖表、Data和圖型的大小。右下方為儲存檔案的目錄和自定檔名的部份，

檔案的命名方式為使用者自定和自動設定，自動設定的檔名為_PChart，檔案類型可

由使用者選取為.bmp或.jpg。 
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圖 11-41  儲存圖檔對話盒 

 
 

11.10 缺點數管制圖（c Chart） 

本系統運用缺點數管制圖的方式，是將每一個待測物之某一測試項目下，所有被記錄

的讀值變數之測試結果為失敗之數量多寡視為缺點數，經統計分析運算所得之結果。 

 

製作缺點數管制圖，按下工具列 （c Chart）後，即顯示缺點數管制圖表參數設定

畫面，如圖 11-42，左方顯示此測試程式的各個測試程序（Sequence），右方則根據

左側選擇的測試程序，將每一個待測物（UUT）於此測試程序之測試讀值成功或失敗

數量顯示出來，而另外幾頁是設定缺點數管制圖表參數，以下分別介紹。 

 



電源供應器自動測試系統 8200 使用手冊 

 11-44 

 
圖 11-42  缺點數管制圖表參數設定－資料 

 

 
圖 11-43  缺點數管制圖表參數設定－統計設定 
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圖 11-44  缺點數管制圖表參數設定－列印基本設定 

 
Sequence 表格：（圖 11-42 的左方）顯示測試程序，欄位說明如下。 

 
Seq. 測試程序序號 

Sel 測試程序核取方塊，被選取後於預覽統計圖表結果或列印

時，會有此讀值變數統計圖表結果。 

Test Item 測試項目名稱 

 

 
Sel 欄位之核取方塊，提供對多測試程序缺點數統計圖表結果連續

列印功能。 

 

Select All 選取所有測試程序，將所有測試程序核取方塊設定為選取

狀態。 

UnSelect All 取消選取所有測試程序，將所有測試程序核取方塊設定為

非選取狀態。 

 
UUT 表格：（圖 11-42 的右方）顯示待測物（UUT）相關資訊，重要欄位說明如

下。 

 
No. 待測物（UUT）測試結果流水號 

Sel 待測物（UUT）測試結果核取方塊，被選取後於預覽統計圖

提示
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表結果或列印時，會將此測試結果列入統計運算。 

Serial No. 待測物（UUT）序號 

Pass Count 待測物（UUT）於此測試程序之所有測試讀值結果為成功

（Pass）的數量 

Fail Count 待測物（UUT）於此測試程序之所有測試讀值結果為失敗

（Fail）的數量 

Total Count 待測物（UUT）於此測試程序之所有測試讀值結果的數量 

 

Select All 選取所有待測物（UUT）測試結果，將所有待測物測試結果

核取方塊設定為選取狀態。 

UnSelect All 取消選取所有待測物（UUT）測試結果，將所有待測物測試

結果核取方塊設定為非選取狀態。 

 

「Parameter Setting」頁次：（圖 11-43） 

 
1) Sample Size 設定樣本數大小 

2) Std Err Multiplier 顯示管制上下限為幾倍的標準差 

3) Limit Source 設定管制上下限來源 

 
 From Selected Data 以被選擇的被測物測試結果計算管制界限 

 Use Std c0 將下方輸入的 Std c0 作為基準值（standard c0 value）以

計算管制界限中心線 

Std c0 設定基準 c0 值（standard c0 value），並將 c0 作為管制

界限中心線。 

 
「Print Setting」頁次，如圖 11-44。 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱。 
Condition 測試條件設定，您可依實際測試條件輸入測試條件說明，

當您按下Edit Condition 後浮現一個輸入文字對話盒

（參考圖 11-29），供您方便地能從測試程式中挑選出合

適的TestCondition類的變數，編輯成此欄的說明文字。 
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顯示統計圖 
 

先選擇好上方要列入統計運算的待測物（UUT）結果，然後將「Parameter Setting」

頁次與「Print Setting」兩頁之內容都設定好之後，按下工具列 （Print Preview），

即可獲得如圖 11-45缺點數管制圖表之結果。 

 

 
圖 11-45  缺點數管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料

接著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 
儲存統計圖 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-46。

圖中左方為選取的變數，變數的命名為TestItemName，右上方為一個設定特性的區域，

可以設定是否儲存Header、圖表、Data和圖型的大小，可個別設定每個變數圖檔的特

性。右下方為儲存檔案的目錄和自定檔名的部份，檔案的命名方式為使用者自定和自
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動設定，自動設定的檔名為_ChartName，檔案類型可由使用者選取為.bmp或.jpg，其

中ChartName會在儲存時自行替換成左方測試項目的名稱。 

 

 
圖 11-46  儲存圖檔對話盒 

 
 

11.11 缺點率管制圖（u Chart） 

本系統運用缺點率管制圖的方式，是將每一天之某一測試項目下，所有被記錄的讀值

變數之測試結果為失敗之數量再除以所有讀值變數數量視為缺點率，經統計分析運算

所得之結果。 

 

製作缺點率管制圖，按下工具列 （u Chart）後，即顯示缺點率管制圖表參數設定

畫面，如圖 11-47，左上方顯示此測試程式的各個測試程序（Sequence），右上方則

根據左側選擇的測試程序，將每一個測試日期於此測試程序之測試讀值成功或失敗數

量顯示出來，而下方是設定缺點率管制圖表參數，以下分別介紹。 
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圖 11-47  缺點率管制圖表參數設定 

 

 
圖 11-48  缺點率管制圖表參數設定－統計參數設定 
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圖 11-49，缺點率管制圖表參數設定－列印基本設定 

 
Sequence 表格：（圖 11-47 左方）顯示測試程序，欄位說明如下。 

 
Seq. 測試程序序號 

Sel 測試程序核取方塊，被選取後於預覽統計圖表結果或列印時，

會有此讀值變數統計圖表結果。 

Test Item 測試項目名稱 

 

 
Sel 欄位之核取方塊，提供對多測試程序缺點率統計圖表結果連續

列印功能。 

 

Select All 選取所有測試程序，將所有測試程序核取方塊設定為選取狀

態。 

UnSelect All 取消選取所有測試程序，將所有測試程序核取方塊設定為非選

取狀態。 

 
Date 表格：（圖 11-47 右方）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 各日期測試結果流水號 

Sel 各日期測試結果核取方塊，被選取後於預覽統計圖表結果或列

印時，會將此日期測試結果列入統計運算。 

提示
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Date 測試日期 

Pass Counts 某測試日期於選定的測試程序下所有測試讀值結果為成功

（Pass）之數量 

Fail Counts 某測試日期於選定的測試程序下所有測試讀值結果為失敗

（Fail）之數量 

Total Counts 某測試日期於選定的測試程序下所有測試讀值之數量 

 

Select All 選取所有測試日期測試結果，將所有測試日期測試結果核取方

塊設定為選取狀態。 

UnSelect All 取消選取所有測試日期測試結果，將所有測試日期測試結果核

取方塊設定為非選取狀態。 

 
「Parameter Setting」頁次：（圖 11-48） 

 
1) Sample Size 設定樣本數大小 

2) Std Err Multiplier 顯示管制上下限為幾倍的標準差 

3) Limit Source 設定管制上下限來源 

 
 From Selected Data 以被選擇的被測物測試結果計算管制界限 

 Use Std u0 將下方輸入的 Std u0 作為基準值（standard u0 value）

作為管制界限中心線 

Std u0 設定基準 u0 值（standard u0 value） 

 
「Print Setting」頁次，如圖 11-49。 

 
Title 列印標題設定，你可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說

明，當您按下 Edit Condition 後浮現一個輸入文字對

話盒（參考圖 11-29），供您方便地能從測試程式中挑選

出合適的Test Condition類的變數，編輯成此欄的說明文

字。 
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顯示統計圖 
 

先由上方表格選擇好要列入統計運算的測試項目測試日期結果，然後將「Parameter 

Setting」頁次與「Print Setting」頁次都設定好之後，按下工具列 （Print Preview），

即可獲得如圖 11-50缺點率管制圖表之結果。 

 

 
圖 11-50  缺點率管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示被測物於此測試項目的基本資料

接著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 
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儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-51所

示。圖中左方為選取的變數，變數的命名為TestItemName，右上方為一個設定特性的

區域，可以設定是否儲存Header、圖表、Data和圖型的大小，可個別設定每個變數圖

檔的特性。右下方為儲存檔案的目錄和自定檔名的部份，檔案的命名方式為使用者自

定和自動設定，自動設定的檔名為_ChartName，檔案類型可由使用者選取為.bmp

或.jpg，其中ChartName會在儲存時自行替換成左方測試項目的名稱。 

 

 
圖 11-51  儲存圖檔對話盒 

 
 

11.12 匯出結果記錄文字檔 

本系統提供匯出測試結果的內容到一個文字檔中，您可以很方便的使用其它應用程式

（如 Microsoft Word）處理這個匯出的文字檔，製作更多樣的報表。 

 

按下工具列 後，即顯示所有的讀值變數設定畫面，如圖 11-52，每一欄的說明如

下： 
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Sel  勾選要匯出的變數 
Seq 變數在測試程式中的順序 
Variable Name 變數的名稱 
Test Item 變數所在測試項目 
Load No 陣列變數的索引值，如果此變數為非陣列變數，索引值為0。 

 

 
圖 11-52  測試程式中所有讀值變數 

 

在圖 11-52中，可由File Format選擇輸出的檔案規格，若選擇“Save as One File 

Name”，則資料會存在設定的檔名；若選擇“Save as MultiFile Name”，則資料會

以每256 Columns存成一檔案，檔名為“所設檔名”+“_?”+“.txt”。由File Header

可選擇要放在標頭的參考資料－Test Item Information、Test Item Name及Max Min 

Specification。 
 

 
?為一數字，由“1”開始。 

 

按下圖 11-52的 Other Option ，即顯示如圖 11-53的選擇畫面： 

 

提示
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圖 11-53  其他相關資訊 

 

在圖 11-52表格中挑選需要匯出的變數在Sel欄上打勾，隨後按下另一頁面（Data 

Table），所勾選的變數會將每個符合選取條件的序號展開成一個表格，如圖 11-54各

個欄位的說明如下： 

 
第一欄 Sel 勾選為是否要輸出的列 

第二欄 S/N 為符合選取的所有 UUT序號 

第三欄 以後為各個變數的名稱，欄位的命名方式如下： 

  VariableName_LoadNo_SeqNo 
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圖 11-54  讀值變數匯出表格 

 
當按下圖 11-54上 Save to Text / Excel File 後，出現一個如圖 11-55所示的對話

盒，讓您選擇要匯出EXCEL/文字檔的目錄和檔名，儲存圖 11-54內的所有選取內容。 

 

 
圖 11-55  匯出文字檔對話盒 
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在此應用程式中，只要有“Sel”欄位的表格，皆可將滑鼠指標移到 

“Sel”標題列，按一下滑鼠左鍵，即可有全選（Select All）或全不

選 (UnSelect All) 的功效。 

 
 

提示
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附錄 A 測試結果記錄檔 

所有的測試結果記錄檔均記錄在 Log 目錄下。每一測試程式均有其個別的記錄檔目

錄和記錄內容。因此所有的記錄均以測試程式來區分。 

 
假設測試程式檔名為 ”MyPrg.prg”，則在 Log 目錄下會建立： 

 
1. 次目錄 MyPrg\：此目錄下才是該測試程式執行後所記錄之測試結果。其中有兩

種不同之資料庫檔案。 

 
 TestInfo.mdb：記錄測試過的待測物序號，內含二個表格 [UUTRetest] 和

[TPInfo]，各欄位說明如後： 

 
 [UUTRetest]  資料表：測試過的待測物序號及重測次數。 

 
SerialNo 文字，待測物之序號。 

RetestTime 日期/時間，測試的日期時間。 

Times 整數，該筆待測物第幾次測試。"0"表示第一次測試，"1"

表示第一次重測。 

Result 待測物測試結果。“0”表示失敗，“1”表示成功。 

 
    [TPInfo]   資料表：測試程式資訊。 

 
Key 文字，名稱。 
Value 文字，內容。 

 
 各個資訊的定義如下: 

 

Key Value 

TPFileName 測試程式名稱。 

TPFilePath 測試程式儲存的目錄。 

Author 測試程式作者。 

Comment 測試程式的備註文字。 

ReportFile 測試程式所對應的報表格式檔案。 

ModelName 測試程式所對應的 Model 名稱。 

LoadNum 測試程式所設定的 Load 個數。 

Load1 第一個 Load 所設定的名稱。 
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Load2 第二個 Load 所設定的名稱。 

…  

MajorVer 測試程式所設定的主版本碼。 

MinorVer 測試程式所設定的次版本碼。 

DateTime 測試程式產生的時間。( 20000304171256 表示 西元

2000 年 3 月 4 日 17:12:56) 

PreSeqNum PreTest 測試項目在測試程式的總數 

PreSeq1 第一個 PreTest 測試項目的名稱 

PreSeqExt 1 第一個 PreTest 測試項目的說明 

… 依 PreSeqNum 個數增加 

PostSeqNum PostTest 測試項目在測試程式的總數 

PostSeq1 第一個 PostTest 測試項目的名稱 

PostSeqExt1 第一個 PostTest 測試項目的說明 

… 依 PostSeqNum 個數增加 

SeqNum UUTTest 測試項目在測試程式的總數 

Seq1 第一個 UUTTest 測試項目的名稱 

SeqExt1 第一個 UUTTest 測試項目的說明 

… 依 SeqNum 個數增加 

Released 測試程式是否發行 

ReleasedDateTime 測試程式發行時間 

 
 MyPrg@19991101.mdb（舉例）：記錄每天測試結果的資料庫，依日期之不

同建立新的記錄檔。其中有五個資料表 [SPCLogData]，[SPCSpec]，

[SPCVar]，[HeaderInfoSet]，[SPCVectorGlobal] 分別說明如後。 

 
[SPCLogData] 資料表：每天測試結果，其各欄位說明如後。 

 
SerialNo 文字，待測物之序號。 
VarID 長整數，變數之流水編號，由「Exection Controller」依

TestProgram決定編訂一唯一之編號。 
Value 雙精準數，讀值之數值。 
Result 位元組（數字），“0”為失敗（Fail），“1”為成功（Pass）。 
RetestTimes 整數，代表重測的次數，應為索引資料庫檔（TestInfo.mdb 

【UUTRetest】）中的索引值。 
RunStep 整數，代表執行時的步驟。 

 

mailto:MyPrg@19980520.mdb
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[SPCLogDataBinary]資料表：每天測試的結果，存放非數值類的值。其各欄

位說明如後。 

 
SerialNo 文字，待測物之序號。 
VarID 長整數，變數之流水編號，由「Exection Controller」依

TestProgram決定編訂一唯一之編號。 
Value 大型二進制值，內容由變數的型別決定。 
Result 位元組（數字），“0”為失敗（Fail），“1”為成功（Pass）。 
RetestTimes 整數，代表重測的次數，應為索引資料庫檔（TestInfo.mdb 

【UUTRetest】）中的索引值。 
RunStep 整數，代表執行時的步驟。 

 
[SPCSpec] 資料表：記錄輸入參數之數值。內容記錄輸入參數 

（主要是規格部份） 之數值。由於輸入參數於執行時

不會變動，因此將輸入參數值記錄在此資料表中。各欄

位說明如後。 

 
SeqNo 數字，該測試項目於測試程式中之順序編號，由“0”起算。 
TestItemName 文字，該測試項目之名稱。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
CallName 文字，輸入參數之Call Name。 
Value 數字，輸入參數之數值。 
DataType 數字，變數的型別。 
DataFlag 數字，變數的狀態。依Bit決定各個狀態。0x01為Fail，0x02

為Invalid，0x04為Less，0x08為Greater，0x10為Don’t care。 
Remark 備忘，未使用。 

 
[SPCSpecBinary] 資料表：記錄輸入參數之非數值類的值。內容記錄輸入

參數（主要是規格部份）之數值，由於輸入參數於執行

時期並不會變動，因此將輸入參數值記錄在此資料表

中。各欄位說明如後。 

 
SeqNo 數字，該測試項目於測試程式中之順序編號，由“0”起算。 
TestItemName 文字，該測試項目之名稱。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
CallName 文字，輸入參數之Call Name。 
Value 大型二進制值，內容由變數的型別決定。 
DataType 數字，變數的型別。 
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DataFlag 數字，變數的狀態。依Bit決定各個狀態。0x01為Fail，0x02

為Invalid，0x04為Less，0x08為Greater，0x10為Don’t care。 
Remark 備忘，未使用。 

 
[SPCVar] 資料表：內容記錄所有的讀值變數之相關資訊，此資料

表實際上是一變數對應表。在查詢測試結果之前，應以

該變數之相關資訊查詢此表，取得該變數之流水編號，

之後在以此編號，至 MyPrg@19991101.mdb   (舉

例）中查詢該變數之數值。各欄位說明如後。 

 
VarID 數字，變數之流水編號，由「Exection Controller」依

TestProgram決定，根據“SeqNo”和變數編訂一唯一之編號。 
SeqNo 數字，該測試項目於測試程式中之順序編號，由“0”起算。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
TestItemName 文字，該測試項目之名稱。 
CallName 文字，輸入參數之Call Name。 
MaxSpec 文字，該讀值容許之最大值（規格）對應之輸入參數之Call 

Name。 
MinSpec 文字，該讀值容許之最小值（規格）對應之輸入參數之Call 

Name。 
DataType 數字，變數的型別。 
Remark 備忘，未使用。 

 
[HeaderInfoSet]  資料表：記錄待測物的資訊。 

 
SerialNo 文字，待測物之序號。 
ModelName 文字，待測物的機型名稱。 
LotNumber 文字，待測物的批號。 
OrderNumber 文字，訂貨編號。 
Environment 文字，測試時的環境溫度。 
Inspector 文字，檢測人員姓名。 
Customer 文字，客戶名稱。 
ElapsedTime 文字，測試所花的時間。 
SystemTime 文字，測試時的系統時間。 
RetestTimes 整數，代表重測的次數，應與TestInfo.mdb中UUTRetest資料

表的Times欄位值一致。 

 
[SPCVectorGlobal] 資料表: 記錄測試程式中 Global 和 Vector 的內容。 

mailto:MyPrg@19980520.mdb(
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Type 數字，該行變數所代表的型別，19為Global，20~29為

Vector，其它值無定義。 
Index 數字，Vector為該Vector的第幾個Element。Global為定義

Global變數的順序（0~5）。(System/User)*(Pre/UUT/Post) 
IndexName 數字，Vector為Vector的名稱。Global為“Global”字串。 
CallName 文字，變數名稱。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
Value 數字，值。 
Remark 備忘，未使用。 

 

Data Type Mean 

0 Float 

1 Integer 

2 Float(%) 

3 Short 

4 String 

5 Byte 

6 Float[L] (大小為 Load 數) 

7 Integer[L] (大小為 Load 數) 

8 Float[L](%) (大小為 Load 數) 

9 HexString 

10 Float[] (大小為使用者設定) 

11 Integer[] (大小為使用者設定) 

14 Date 

20~29 Vector 

100 Chart (波形圖) 

101 Picture (圖片) 
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