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法律事項聲明 
 

本使用手冊內容如有變更，恕不另行通知。 

 
本公司並不對本使用手冊之適售性、適合作某種特殊用途之使用或其他任何事項作任

何明示、暗示或其他形式之保證或擔保。故本公司將不對手冊內容之錯誤，或因增減、

展示或以其他方法使用本手冊所造成之直接、間接、突發性或繼續性之損害負任何責

任。 

 
致茂電子股份有限公司 

桃園市333001龜山區文茂路88號 

 
版權聲明：著作人─致茂電子股份有限公司─西元 2012年，版權所有，翻印必究。 

未經本公司同意或依著作權法之規定准許，不得重製、節錄或翻譯本使用手冊之任何

內容。 
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保  證  書 
 
致茂電子股份有限公司秉持〝品質第一是責任，客戶滿意是榮譽〞之信念，對所製

造及銷售之產品自交貨日起一年內，保證正常使用下產生故障或損壞，負責免費修

復。 

 
保證期間內，對於下列情形之一者，本公司不負免費修復責任，本公司於修復後依

維修情況酌收費用： 

 
1. 非本公司或本公司正式授權代理商直接銷售之產品。 

 
2. 因不可抗拒之災變，或可歸責於使用者未遵照操作手冊規定使用或使用人之過

失，如操作不當或其他處置造成故障或損壞。 

 
3. 非經本公司同意，擅自拆卸修理或自行改裝或加裝附屬品，造成故障或損壞。 

 
保證期間內，故障或損壞之維修品，使用者應負責運送到本公司或本公司指定之地

點，其送達之費用由使用者負擔。修復完畢後運交使用者(限台灣地區)或其指定地

點(限台灣地區)之費用由本公司負擔。運送期間之保險由使用者自行向保險公司投

保。 

 
 
致茂電子股份有限公司 

桃園市 333001龜山區文茂路 88號 

服務專線：(03)327-9999 

傳真電話：(03)327-8898 

電子信箱：info@chromaate.com  

網    址：www.chromaate.com 

 
 

mailto:info@chromaate.com
http://www.chromaate.com/
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設備及材料污染控制聲明 
 
請檢視產品上之環保回收標示以對應下列之<有毒有害物質或元素表>。 

 

 ：請對應<表一> 

：請對應<表二> 

 

<表一> 

部件名稱 

 有毒有害物質或元素 

鉛 汞 鎘 六价鉻 
多溴聯苯/ 

多溴聯苯醚 
鄰苯二甲酸酯類化合物 

Pb Hg Cd Cr6+ PBB/PBDE DEHP/BBP/DBP/DIBP 

PCBA O O O O O O 

機殼 O O O O O O 

標準配件 O O O O O O 

包裝材料 O O O O O O 

O： 表示該有毒有害物質在該部件所有均質材料中的含量在 SJ/T 11363-2006與 EU Directive 

2011/65/EU及 2015/863/EU規定的限量要求以下。 

： 表示該有毒有害物質至少在該部件的某一均質材料中的含量超出 SJ/T 11363-2006與 EU Directive 

2011/65/EU及 2015/863/EU規定的限量要求。 

註: 1. 產品上有 CE標示亦代表符合 EU Directive 2011/65/EU及 2015/863/EU規定要求。 

   2. 本產品符合歐盟 REACH法規對 SVHC物質之管制要求。 

 

處置 

切勿將本設備處理為未分類的廢棄物，本設備需做分類回收。有關廢棄物收集系統的訊息，

請聯絡貴公司所在地的相關政府機關。假若將電子電器設備任意丟棄於垃圾掩埋地或垃圾

場，有害的物質會滲漏進地下水並進入食物鏈，將會損害健康。當更換舊裝置時，零售商在

法律上有義務要免費回收且處理舊裝置。 
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<表二> 

部件名稱 

 有毒有害物質或元素 

鉛 汞 鎘 六价鉻 多溴聯苯/ 

多溴聯苯醚 
鄰苯二甲酸酯類化合物 

Pb Hg Cd Cr6+ PBB/PBDE DEHP/BBP/DBP/DIBP 

PCBA  O O O O O 

機殼  O O O O O 

標準配件  O O O O O 

包裝材料 O O O O O O 

O： 表示該有毒有害物質在該部件所有均質材料中的含量在 SJ/T 11363-2006與 EU Directive 

2011/65/EU及 2015/863/EU規定的限量要求以下。 

： 表示該有毒有害物質至少在該部件的某一均質材料中的含量超出 SJ/T 11363-2006與 EU Directive 

2011/65/EU及 2015/863/EU規定的限量要求。 

 

1. Chroma尚未全面完成無鉛焊錫與材料轉換，故部品含鉛量未全面符合限量要求。 

2. 產品在使用手冊所定義之使用環境條件下，可確保其環保使用期限。 

3. 本產品符合歐盟 REACH法規對 SVHC物質之管制要求。 

 
 

處置 

切勿將本設備處理為未分類的廢棄物，本設備需做分類回收。有關廢棄物收集系統的訊息，

請聯絡貴公司所在地的相關政府機關。假若將電子電器設備任意丟棄於垃圾掩埋地或垃圾

場，有害的物質會滲漏進地下水並進入食物鏈，將會損害健康。當更換舊裝置時，零售商在

法律上有義務要免費回收且處理舊裝置。 
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版本修訂紀錄 
 
下面列示本手冊於每次版本修訂時新增、刪減及更新的章節。 

 
日期 版本 修訂之章節 

2009年 4月 1.0 完成本手冊 

2012年 10月 1.1 新增下列部分: 

 I2C通訊介面設定至 “設定儀器配置組態”一章 

 “驗證測試程式”一章 

 Barcode預刷功能及限制手動輸入條碼功能至 ““執行測
試程式（GO/NOGO）”一章 

2018年 11月 1.2 更新下列節次: 

 “系統架構”一章中的 “簡介”、 “系統控制器” 與 “軟體

系統需求” 

 “編輯測試程式”一章中的 “選單說明” 

移除 “系統安裝”一章中的 “取消安裝 Adapter / Charger ATS

系統軟體說明” 

新增“測試結果記錄檔”一章中的 Data Type說明。 

2020年 12月 1.1 更新地址。 
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前言 
 
關於這本使用手冊 

 
這是一本教您如何使用 Chroma 8020 自動測試系統來測試 Adapter / Charger 的使

用手冊，包含自動測試的特性及功能描述。使用時建議您從第一章開始讀起，然後依

序讀第二章、第三章等。為了能有效地使用這本使用手冊，建議您應對 Windows 的

基本操作觀念有一些初步的認識。 

 

內容 

 
第1章   系統架構 

說明 Chroma 8020各儀器設備及組成，以及 Adapter / Charger 

ATS軟體的功能，介紹系統之特性。 

 

第2章   系統安裝 

說明如何安裝 Chroma 8020自動測試系統 

 
第3章   快速操作說明 

很快地教導您如何使用 Adapter / Charger ATS系統軟體 

 
第4章   設定儀器配置組態 

教導您如何設定 ATS中各儀器之組態，以有效運用各儀器來

進行測試工作。 

 
第5章   編輯測試程式 

說明測試程式之組成，及如何編輯您所要的測試程式。 

 
第6章   驗證測試程式 

說明 Adapter / Charger ATS系統軟體如何驗證測試程式。 

 
第7章   執行測試程式（GO/NOGO） 

說明 Adapter / Charger ATS 系統軟體如何執行測試程式，及

說明如何依您的需要來設定執行環境。 

 
第8章   編輯報表格式 

說明如何編訂報表之格式 
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第9章   報表產生器 

教導您如何藉由本程式來產生、查看、儲存及列印測試的結

果。 

 
第10章   管理系統可運用的資源 

說明如何設定使用者及使用者權限，以有效的管制使用人員，

並執行測試程式、測試項目及儀器設備的匯出、匯入功能。 

 

第11章   統計製程管制 

清楚的介紹如何利用統計繪圖功能，繪製統計製程管制圖。 

 
附錄  A   測試結果記錄檔 

描述測試結果記錄之內容 
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使用手冊的描述方式 
 

下面列出在這本使用手冊中所使用的撰寫方法與規範。 
 

粗體 用來標示在視窗上的功能選項、按鈕（OK）、和輸出入參數等。 
 

斜體字   用來標記重要的提示（僅提供）及所要參考書籍或文件 
 

粗黑斜體字  使用者可藉由本程式查看、儲存及列印測試的結果。 
 

Courier New 使用者可藉由本程式查看、儲存及列印測試的結果所標示的文

字內容是要由您從鍵盤上輸入資料，其包含磁碟機代號、路徑、

目錄、程式等。 
 

「」   用來表示所開啟的程式或視窗 
 

        用來表示按鈕 
 

[ ]→[ ]   選單項目 
 

【】   資料表 
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1. 系統架構 

本章主要描述Chroma 8020 配接器/充電器自動測試系統(Adapter / Charger 

Automatic Test System)之架構及組成，以及說明Adapter / Charger ATS軟體的主要

功能特性。我們在此先將系統需求列出，以便讓您能很快瀏覽到您的需求環境。 

 
 

1.1 簡介 

Chroma 8020自動測試系統係一整合配接器/充電器（Adapter / Charger）測試時所

用的各項儀器，建構在開放式的系統軟體環境下，專為配接器/充電器（Adapter / 

Charger）設計的自動測試系統；它具有以下特性。 

 
 可整合各種可程式化的儀器設備，提供一個整合型的操控環境，達到迅速有效

率、使用簡易的目的。 

 提供完整的測試程式開發環境，可供使用者撰寫、修改測試程式。 

 系統架構設計模組化、彈性化，系統更新或擴充容易。 

 採用圖形介面親和力佳。 

 支援標準硬體介面：IEEE-488、I2C、USB、RS-232C。 
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1.2 硬體架構說明 

Chroma 8020配接器/充電器自動測試系統須包含以下各項硬體裝置： 

 
 系統控制器（工業電腦及週邊設備）IPC，其功能及規格請參考 1.2.1節。 

 可程式交流電源供應器（AC Source），其功能及規格請參考 1.2.2節。 

 可程式直流電源供應器（DC Source），其功能及規格請參考 1.2.3節。 

 數位式功率表（Power Meter），其功能及規格請參考 1.2.4節。 

 直流電子負載（DC Load），其功能及規格請參考 1.2.5節。 

 數位式萬用電表（DMM），其功能及規格請參考 1.2.6節。 

 時序及雜訊分析儀（Timing/Noise Analyzer），其功能及規格請參考 1.2.7節。 

 附加模組，其功能及規格請參考 1.2.8節。 

 外框：用以擺置各項硬體裝置的 19吋標準機箱。 

 測試治具：用以連接 Chroma 8020自動測試系統及待測物，由於各待測物不全

然相同，所以治具須特別製作；一般由使用者提供。 

 測試桌：用以擺置待測物及電腦週邊設備；一般由使用者提供。 

 

EMU Set

IPC

AC

Source

PM

OVP

Source
DMM

DC

Load

UUT

GPIB

Fixture

 
圖 1-1  Chroma 8020硬體邏輯方塊圖 
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圖 1-2  系統外觀圖 

 
 

1.2.1 系統控制器（工業電腦及週邊設備） 

 控制電腦： 

為本自動測試系統之控制中樞，用以控制各項儀器執行測試動作，並可進行測

試結果研判及資料存檔、顯示、列印與分析，提供使用者各項操作之介面等等。

其硬體需求如下： 

 
 Intel i3-3220, 3.3GHz或以上等級之中央處理器 

 8.3 GB或以上儲存容量的硬式磁碟機 

 8GB或以上的記憶體 

 40倍速或以上的光碟機 

 SVGA監視器（解析度至少 800x600） 

 鍵盤 

 PS2或 USB滑鼠 

 至少三個以上空槽以供 DIO卡、GPIB卡使用。 

 並聯式印表機輸出埠 

 至少一 USB埠供硬體保護鎖使用 
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 週邊設備： 

用以列印測試結果 

 並聯式印表機—詳細資料列印用 

 
 

1.2.2 可程式交流電源供應器 

可程式交流電源供應器用以提供待測物輸入電源，並可模擬輸入電源各種狀況，所以

它必須有足夠的能量及可變化的電壓和頻率，才能滿足各式的電源供應器的輸入需求。 

 
Chroma 8020 自動測試系統可支援本公司製造之可程式交流電源供應器（AC 

Source），請參照系統軟體之「H/W Configuration」所明列之型號，至於 AC Source

的詳細規格及操作說明請參考其使用手冊。 

 
 

1.2.3 可程式直流電源供應器 

可程式直流電源供應器係用來提供過電壓保護功能測試時外加的電源﹐它必須能提供

大於待測物發生輸出過電壓保護時的電壓。 

 
Chroma 8020 自動測試系統可支援本公司製造之可程式直流電源供應器（DC 

Source），請參照系統軟體之「H/W Configuration」所明列之型號，至於 DC Source

的詳細規格及操作說明請參考其使用手冊。 

 
 

1.2.4 數位式功率表 

數位式功率表可用以量測待測物輸入端的各項參數，包括電壓、電流、功率、頻

率、功率因素、總諧波失真（Total Harmonic Distortion）等；配合輸出端量測值可

求得待測物整機效率。 

 
Chroma 8020自動測試系統可支援本公司製造之數位式功率表（Power Meter），請

參照系統軟體之「H/W Configuration」所明列之型號，至於 Power Meter 的詳細規

格及操作說明請參考其使用手冊。 
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1.2.5 直流電子負載 

電子負載係用以執行各項測試時模擬待測物的負載變化的各種狀況，使各項測試能逼

近真實情境。 

 
Chroma 8020自動測試系統可支援本公司製造之直流電子負載（DC Load），請參照

系統軟體之「H/W Configuration」所明列之型號，至於 DC Load的詳細規格及操作

說明請參考其使用手冊。 

 
 

1.2.6 數位式萬用電表 

數位式萬用電表可用來量測電壓、電流、電阻，在本自動測試系統中，數位電表是

用來量測待測物反向電流。 

 
Chroma 8020自動測試系統可支援的數位式萬用電表為 Agilent / HP 34401A 

Multimeter。有關 Agilent / HP 34401A Multimeter 的詳細規格及操作說明請參考其

使用手冊。 

 
 

1.2.7 時序及雜訊分析儀（Timing/Noise Analyzer） 

Chroma 8020自動測試系統使用了獨特的「時序及雜訊分析儀」－ Chroma 

80611，它最多可以擴充至 10組輸入量測模組，每一量測模組都可用以量測時序和

雜訊位準。此外，它也提供了 TTL信號和浮接繼電器，以執行外部線路的控制。 

 
有關 Chroma 80611 Timing/Noise Analyzer 的詳細規格及操作說明請參考其使用手

冊。 

 
 

1.2.8 附加模組 

為使本自動測試系統連接上述各硬體裝置達成各項測試功能，尚須有以下附加模組： 

 
(1) 系統控制器之 GPIB卡：提供與各測試儀器間信號連繫的介面裝置。 

(2) 系統控制器之 DIO卡：用以提供自動執行（Auto Run）之介面裝置。 
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(3) 外部控制模板：連接系統控制器之 DIO 卡，有 16 組輸入信號與 16 組開集極

（Open Collector）輸出，用以信號輸入與控制外部線路的之控制裝置。 

 
註 上述儀器為標準配備，實際儀器以出貨內容為準。 

 
 

1.3 Adapter / Charger ATS系統軟體概說 

1.3.1 Adapter / Charger ATS系統軟體特性介紹 

新一代的自動測試環境需求，已不再是單純專屬的測試系統所可以滿足。測試工程人

員不再只要求簡單、功能有限的測試系統，而是一個可隨硬體需求的不同或測試步驟

不同而可彈性變更的測試環境。 

 

Adapter / Charger ATS系統軟體採模組化，層次化設計，具有下述之優點： 

 

(1) 架構在Windows環境之下，採標準化的圖形使用者介面，具使用之親和性。 

(2) 採用隱含式編譯方式，可提昇測試程式執行速率。 

(3) 可自行編排報表列印格式，並支援多國語系。 

(4) 可列印測試失敗之讀值，以利維修。 

(5) 測試結果存檔，以及統計製程管理功能。 

(6) 儀器介面控制程式，均採動態連結程式庫（DLL），可方便抽換或新增儀器。 
 
 

1.3.2 系統模組 

Adapter / Charger ATS系統軟體具有以下之功能模組： 
 

(1) 使用者管理： 

可依使用者之不同，設定使用者之使用權限，如操作員只可進行測試程式之執行，

而工程人員則可使用所有的功能。 

(2) 硬體設備組態設定： 

設定儀器設備之介面組態（GPIB、RS-232C、USB）之位址及定義相關模組、

通道。 
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(3) 測試程式編輯功能： 

將系統內建的測試項目編寫成測試程式，同時設定各測試項目之相關參數或測試

規格。測試程式之副檔名為.prg，此即為一可執行之檔案。 

(4) 報表格式編輯功能： 

您可依實際的需要，就各測試項目編輯您所需之報表格式，報表格式檔之副檔名

為.rpf。 

(5) 測試程式執行控制功能： 

經過編譯後之測試程式，即可使用此功能來執行測試。此功能依您編訂之測試順

序逐項呼叫相關之測試項目進行測試。同時自動記錄測試結果，產生及列印報表；

以及決定各測試項目之結果和各讀值之結果。 

(6) 報表列印功能： 

報表列印亦可於離線時進行，Adapter / Charger ATS系統軟體會將測試所需之

測試結果儲存。因此可利用此一功能，列印某年某月某日所測之某一之測試結果。 

(7) 統計製程分析功能： 

透過此功能，您可以就資料庫中之測試結果，進行統計製程分析。 

 
 

1.4 軟體系統需求 

Chroma 8020配接器/充電器自動測試系統建議採用的個人電腦軟硬體系統需求為： 

 
 Intel i3-3220, 3.3GHz或以上等級之中央處理器 

 Microsoft Windows XP、Win 7或Win 10 (1.10版(含)以上不支援 XP) 

 建議有 400 MB以上可用硬碟空間 

 最少要有 8GB的記憶體大小 

 VGA或 SVGA彩色螢光幕顯示器 

 PS2或 USB滑鼠 
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1.5 技術名詞中英對照表 

這一節要告訴您在這本使用手冊中所使用到的一些技術性專有名詞之英中對照表，方

便您使用本手冊的參考。現依照英文字母的次序詳列於下﹕ 
 
A 

Activity         活動運作 

Automatic Test Equipment（ATE）    自動測試設備 

Automatic Test System（ATS）     自動測試系統 

 
C 

Channel         通道 

Compile         編譯 

Command         測試指令 

Constraint         限制 

Correction Steps        更正步驟 

Current Limit        電流抑制（限電流） 

Current Measurement Accuracy     電流精確度 

Current Harmonics       電流諧波 

 
D 

Default Data        預設參數值 

Dynamic Transient Response     暫態反應 

 
E 

Error Index         錯誤順序號碼 

Error Message         錯誤訊息 

Export         匯出 

Extension         測試項目名稱註解 

External         外部 

 
I 

Import         匯入 

Inrush Current        湧浪電流 

 
L 

Label         標籤 

Level          使用權限 

Level ID         使用權限識別 
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Log          記錄 

 
M 

Main Panel        主功能表 

Member Data        成員資料 

Module Name        模組名稱 

 
O 

Operator         作業員 

Over Load Protection       過負載保護 

Over Voltage Protection      過電壓保護 

 
P 

Power Efficiency       效率 

Power Factor        功率因數 

 
R 

Release         發行 

Report Generator       報表產生器 

Report Output Format      輸出報表格式 

Ripple         漣波 

 
S 

Short Circuit        短路 

SPC          統計製程控制 

Statistics         統計表 

Swing         搖擺 

Sync. Dynamic Loading      同步動態拉載 

 
T 

Test Item         測試項目 

Test Plan         測試計劃 

Test Program        測試程式 

Test Sequence        測試程序 

 
U 

Under Voltage Protection      欠電壓保護 

User ID         使用者識別名稱 

User Name        使用者名稱 
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V 

Vector         導引 

Voltage Regulation       電壓調整率 

Voltage Stability        電壓穩定度（靜態反應） 
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2.   系統安裝 

本章將告訴您如何安裝 Chroma 8020 ATS系統硬體與軟體，同時也提醒您一些應注

意事項，以避免錯誤的作業方式。 

 
 

2.1 安裝 Chroma 8020系統硬體 

Chroma 8020自動測試系統之各項硬體裝置，係安裝在一個高 41吋寬 19吋的標準

機箱。安裝時，請參考下列安裝步驟，由上往下的順序，依各儀器的位置逐一安裝

於機箱內（因本系統為開放性架構，故所列之各項儀器的安裝順序僅供參考，您可

依實際需要自行安排），以下僅提供 Chroma 8020 ATS一般標準配置儀器之安裝程

序。 

 
安裝步驟 

(1) 將空的系統機箱（RACK），平躺於地面，將正面朝上，底部墊住緩衝材，以免

壓損背部機殼及開關。 

(2) 由正上方及由上往下的順序放入儀器設備，如可程式直流電源供應器、直流電

子負載、工業電腦、80611時序及雜訊分析儀、數位式功率表、可程式交流電

源供應器等順序放入，在放入單一儀器同時，調整其支撐鋁架至適當位置，並

將各部位螺絲轉緊固定。 

(3) 將系統從地上撐起，依照系統實際之配線圖，將各部儀器以規定之線材相接。 
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2.2 輸入電源需求及應注意事項 

Chroma 8020自動測試系統各部儀器輸入電壓及需求功率如下： 

 

儀 器 輸入電壓 頻率範圍 功率需求 廠牌型號 

可程式交流電源供應器 190~250 V 47-63 HZ 5000W Chroma 61605 

可程式直流電源供應器 95~250 V 47-63 HZ 1600W Chroma 
62012P 

可程式直流電子負載 115 / 230 V 47-63 HZ 180VA 
max. 

Chroma 6330 

數位式萬用電表 115 / 230 V 50-60 HZ 115W HP 34401 

時序及雜訊分析儀 115 / 230 V 50-60 HZ 173W Chroma 80611 

數位式功率表 130 / 250 V 50-60 HZ 45W Chroma 66202 

表 2-1  各儀器輸入電壓及功率需求表 

 
本系統輸入為 230VAC 的儀器，係自後背板最下層的電源插座輸入，並延伸為兩個

AC 230V 的電源插座以供各儀器使用。若要外加儀器，必須考慮電源線及電源插座

容量是否足夠。若外加儀器使用非 230VAC的輸入電源，必須另外接線；否則不得使

用系統提供的電源插座。在安裝本測試系統之前要先確認可提供足夠容量及穩定電壓

和頻率的輸入電源以確保系統可正常運作，延長使用壽命。 

 

 
非 8020 Adapter / Charger ATS使用之儀器設備，請勿使用，以免

電路無法負荷，而導致設備有所損壞。 

 
 

2.3 安裝/取消安裝 Adapter / Charger ATS系統

軟體 

在您使用 Chroma 8020系統之前，必須先將 Adapter / Charger ATS系統軟體安裝

到您的電腦中的硬式磁碟機裡。在下面的章節中我們要告訴您，如何在您的視窗環境

上按步就班地安裝 Adapter / Charger ATS系統軟體。 

 
 

注意
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2.3.1 安裝 GPIB介面驅動程式 

 請依照GPIB介面驅動程式安裝手冊之步驟，進行安裝。 

 當您完成上述的安裝步驟之後，請重新啟動您的電腦，讓Windows 系統將所有

相關 Adapter/Charger ATS系統軟體的參數產生作用。在您啟動 Adapter/ 

Charger ATS系統軟體之前，請將 Adapter/Charger ATS系統軟體保護器安插至

PC的 USB埠，若要插拔軟體保護器請在電腦關機下進行，以免造成系統當機。 

 
 

2.3.2 在Windows環境上安裝 Adapter / Charger ATS

系統軟體 

 在您安裝之前，您電腦中的硬碟應預留至少有400 MB以上的存放空間。 

 將所附的軟體保護器（Software Protection Key）安插到USB埠。 

 將Adapter / Charger ATS系統軟體之光碟片置入光碟機中。 

 若您使用光碟片安裝且您的作業系統有支援Auto Run 的功能，則安裝程式便會

自動執行，您可立即進行安裝；否則的話，您可以選擇以下兩種方式之一來執行

SETUP.EXE安裝程式。 

 

一、 使用「執行(R)…」命令安裝 

(1) 在您的Windows的桌面上，先將您的滑鼠在左下角的「開始」命令列上按一

下，然後選取「執行(R)…」命令並執行，這時會出現「執行」視窗。 

 

(2) 然後在「執行」視窗中按下 瀏覽(B)… 按鈕來選取光碟機（D：或光碟機

代號）中的SETUP.EXE。通常，這個檔案應該會在安裝程式所在磁碟機

的根目錄下，或根目錄下的Disk1目錄裡。 
 

 
圖 2-1 「執行」視窗 
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(3) 按下 確定 按鈕便立即開始安裝。 

 
二、 使用Windows檔案總管命令安裝 

(1) 請在視窗的「開始」命令列上，先選取「所有程式(P)」，然後再選取

「Windows 檔案總管」命令並執行。 

(2) 選取安裝程式所在的光碟機（D：或其他）的根目錄下，以滑鼠在安裝程式

SETUP.EXE上連按兩下便可以開始安裝。 

(3) 安裝時首先顯示如圖 2-2之畫面，您可依照您目前電腦上是否已安裝NI 

VISA 或 NI IVI Engine，來決定是否要安裝此二套軟體套件。建議您的安

裝順序為先安裝「NI-VISA」，再安裝「NI-IVI Engine」，最後才安裝「Chroma 

8020 System Software」。 

 

 
圖 2-2  Chroma 8020系統軟體安裝主功能畫面 

 

(4) 當您要安裝「Chroma 8020 System Software」時，只要按下圖 2-2所示的

Install Chroma 8020 Software按鈕，即會顯示如圖 2-3之畫面。 
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圖 2-3  系統軟體資訊畫面 

 

 進行安裝過程中，只要跟著安裝程式精靈的畫面上的說明來進行即可。 

 

 
圖 2-4  安裝精靈初始化 
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圖 2-5  安裝 HASP Software Protection Key 

 

 
圖 2-6  安裝程式歡迎畫面 
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圖 2-7  Chroma 8020授權宣告 

 

 安裝過程中需輸入使用者姓名及公司名稱。 
 

 
圖 2-8  輸入使用者姓名及公司名稱 
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 安裝過程中需輸入您所要安裝的目錄，若您未選擇目錄，安裝程式會自動為您在

C:\Program Files目錄下建立一個Chroma\Chroma 8020系統軟體的預設目錄，然

後將所有相關的程式和資料檔案安裝在此目錄內。建議您直接按下Next > 鈕即可。

下面列出當您安裝完畢之後，安裝精靈為您產生的相關目錄和程式。 
 

 
圖 2-9  選擇安裝目錄 

 

 
圖 2-10  確認安裝路徑 
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在 C:\Program Files\Chroma\Chroma 8020系統軟體目錄內應有下列的子目

錄，各子目錄所存放檔案的內容說明如下： 

 
\Bin 存放 Adapter / Charger ATS系統軟體系統程式 

\CVIRTE 存放 CVI runtime engine 

\Data\Db 存放系統資料庫檔案 

\Help 存放使用說明 

\HWCfg 存放硬體組態設定檔（.hwc） 

\Ini 存放測試程式資訊檔 

\Lib 存放儀器驅動程式庫 

\Log 安裝時為空目錄，存放測試結果統計資料記錄檔（以測

試程式名稱為子目錄）。 

\Program 存放測試程式（.prg） 

\Report\Format 存放報表格式檔案（.rpf） 

\Spc 存放「Statistics」專案檔（.spc） 

 

 
圖 2-11  Chroma 8020安裝中 
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圖 2-12  是否顯示 ReadMe檔 

 

 
圖 2-13  安裝成功，是否重新開機 
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2.3.3 取消安裝 Adapter / Charger ATS系統軟體 

若您想要移除Adapter / Charger ATS系統軟體時，建議您從「開始」命令列上的「設

定」功能群組中的「控制台」功能，使用「新增／移除程式」來執行取消安裝（Uninstall）

您的Adapter / Charger ATS系統軟體的相關項目。 
 

 
圖 2-14  修復／移除 Adapter / Charger ATS系統軟體 
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3. 快速操作說明 

這一章要快速地介紹Adapter / Charger ATS系統軟體基本操作方法，同時說明有關測

試程式的一些基本觀念。詳細操作方法請參考後面相關章節的說明。 

 
 

3.1 開機前的注意事項 

在開始操作Adapter / Charger ATS系統軟體自動測試系統之前，您必須先確定有足夠

和穩定的交流電壓可供應Chroma 8020系統中的每一裝置使用。為減低開機的瞬間出

現湧浪電流（Inrush Current）對自動測試系統的衝擊效應，建議您開機的先後順序

為交流電源供應器、電子負載及其它儀器設備模組，最後才是您的個人電腦及其它的

週邊硬體設備。 
 
 

3.2 如何啟動 Adapter / Charger ATS 系統軟體 

如果您遵照在第2章中的指示，已經將Adapter / Charger ATS系統軟體安裝到您的硬

式磁碟中，在您電腦桌面上會出現一個Adapter / Charger ATS系統軟體的捷徑。請以

滑鼠雙擊此捷徑，即可啟動Adapter / Charger ATS系統軟體。另外，您也可藉由選取

程式集 (P) 來執行Adapter / Charger ATS系統軟體。 [開始 ]→ [所有程式 (P)]→

[Chroma 8020]。 

 
執行Adapter / Charger ATS系統軟體後，首先會出現如圖 3-1要求登入的畫面： 

 

 
圖 3-1  登入畫面 

 
請在User ID和Password的輸入欄中鍵入使用者識別名稱（User ID）和正確的密碼

後，再按下 Login 按鈕便可開始使用Adapter / Charger ATS系統軟體。若是第一次
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使用本軟體，請在User ID欄位鍵入“root”，Password欄位留空白即可登入，並請在登

入後為使用者“root”加入密碼以確保使用安全。 
 

當您成功完成登入程序後，畫面即會出現如圖 3-2所示的Adapter / Charger ATS系統

軟體主選單。 
 

 
圖 3-2  Adapter / Charger ATS系統軟體主功能畫面 

 

Adapter / Charger ATS系統軟體的主畫面是由 9 個選項所構成，分別說明如下： 
 

Test Program 用來編輯測試程式 

Report Editor 用來編輯報表輸出格式 

Report Generator 用來列印已存檔的測試結果 

GO/NOGO 用來讓線上作業人員執行測試 

Statistics 用來執行統計製程分析 

H/W Configuration 
用來設定儀器設備之硬體組態（如GPIB位址設定）及選擇

所需使用的測試設備 
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Management 用來管理使用者的使用權限及執行匯出、匯入。 

About 關於Adapter / Charger ATS系統軟體的聲明 

Exit 退出Adapter / Charger ATS系統軟體 
 
 

3.3 Adapter / Charger ATS系統軟體操作流程 

Adapter / Charger ATS系統軟體系統操作流程如下： 

 

設定硬體組態
(

測試程式編輯／驗證
(Test Program 

Editing/Verification)

報表編輯
(Report Editing)

統計製程管制分析
(SPC Analysis)

報表列印
(Report Generator)

測試結果符合需求？

是

否

發行測試程式
(Management/Test Program)

進行待測物測試
(GO/NOGO Test)

 
圖 3-3  Adapter / Charger ATS系統軟體之操作流程 
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3.4 設定儀器配置組態 

當您在Adapter / Charger ATS系統軟體的主畫面中選擇 H/W Configuration 選項

後，便會顯示出如圖 3-4的儀器配置視窗。請您務必依照系統上儀器的配置設定其相

關參數，如GPIB位址、RS-232C參數。 

 

圖 3-4  儀器配置視窗 

 
 

3.5 建立新的測試程式 

測試程式是由許多的測試項目所組合而成的，系統中已經內建了一些測試項目，您可

以直接使用它們。要建立新的測試程式，請先將所需的測試項目選出來，然後設定各

測試項目的參數，最後設定所需之報表格式檔（.rpf），以作為報表輸出的參考。 
 

當您在主畫面中選擇 Test Program 選項之後，便會顯示出測試程式編輯視窗，此

時會詢問使用者想要新增一個測試程式或開啟已存在的測試程式名稱，若選擇

「Create new」並按下 OK 按鈕，就會顯示出一個新的空白測試程式，如下： 
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圖 3-5  測試程式編輯視窗 

 
設定測試程式資訊 
 

按下左窗格上的 Program Info... 按鈕後，會顯示測試程式資訊視窗： 
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圖 3-6  測試程式資訊對話盒 

 

請依需要輸入各項參數。其中Link頁面中的Report Format File指的是報表列印格式

檔，與測試結果之列印有關，若要指定不同的檔案，請按其右邊的按鈕 … 來選擇所

要的檔案。 

 
加入測試項目至測試程式中 
 

請先在左窗格的測試程式項目表格中，以滑鼠左鍵點選所要插入的位置，假設是Seq.3，

然後在右窗格的測試項目列示區中以滑鼠左鍵雙擊所要的測試項目（或是選好測試項

目後按工具列上的 Insert TI 按鈕），則此測試項目就會被加到Seq.3，而原本的

Seq.3會被順延到Seq.4，其後面的測試項目也都會往後順延。 

 
各測試項目之位置及順序可隨意放置，但是，建議您在Pre Test群組第一個測試項目

設為System Setup。 
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設定導引（Vector）值 
 

您可以按主選單中的[View]→[Vector Editor]或工具列上的 Vector 切換到導引編

輯區，如圖 3-7所示，畫面上方的Vector Set Select下拉式選取盒可以讓您選擇所要

編輯Vector的種類，系統出廠時預設了四種Vector：Line In Vector、Load Vector、

Spec. Vector和Ext. Meas. Vector。 

 

 
圖 3-7  導引編輯視窗 

 
設定測試項目之參數 
 

請按工具列上的 Parameter 按鈕或是以滑鼠雙擊測試程式項目表格中的Test Item

欄位，原先的測試項目列示區就會變成如圖 3-8的測試項目參數編輯區。 
 

請在測試程式項目表格中以滑鼠左鍵點一下所要的測試項目，測試項目參數編輯區就

會顯示所選到的測試項目參數以供編輯。 
 

參數設定完成後，請按工具列上的 Test Item 按鈕，測試項目參數編輯區就會變回

測試項目列示區。 
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圖 3-8  測試項目參數編輯視窗 

 
儲存測試程式 
 

測試程式寫好後，請記得將其存檔，以確保您所修改的內容可被記錄在儲存裝置中。 
 
 

3.6 驗證測試程式 

當您設定好每一個測試項目的參數值（包括 Vector）後，可按下工具列上的

Execution Control 按鈕，畫面會切換到如圖 3-9測試程式詳細驗證執行畫面所示

的視窗，Adapter / Charger ATS系統軟體準備執行您目前正在編輯的測試程式。當

然您隨時可以依照測試的結果，按下工具列上的 TP Editor 按鈕在切回原先的測試

程式編輯視窗。經過反覆測試、驗證您所設定的參數都沒有問題後，確定可以交由

生產線執行前，請務必先執行下一節所要說明的發行程序。 
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圖 3-9  測試程式詳細驗證執行畫面 

 
 

3.7 發行測試程式 

在您透過 GO/NOGO 模組執行測試程式之前，請先回到 Adapter / Charger ATS 系

統軟體的主畫面，然後按下 Management 選項按鈕，此時畫面會出現如圖 3-10所

示的視窗。將畫面切換到 Test Program 標籤頁，在 Release欄勾選所要執行的測試

程式，經過此一發行程序後的測試程式，才能夠在 GO/NOGO 程式被執行。 
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圖 3-10  發行測試程式 

 
 

3.8 執行測試程式 

您在Adapter / Charger ATS系統軟體的主畫面，按下 GO/NOGO 選項按鈕後，會

出現如圖 3-11所示的視窗。 
 

 
圖 3-11  測試程式開啟視窗 
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待您選擇一個測試程式名稱按下 OK 按鈕後，畫面即會出現如下的視窗。 

 

 
圖 3-12  GO/NOGO 程式畫面 

 
等到左下方的窗格出現 “Initialize 5 Devices Successfully !” 訊息時，您可以按鍵盤

上的功能鍵F10或是以滑鼠左鍵按下工具列上的圖形按鈕  Go (F10) ，Adapter / 

Charger ATS系統軟體就依照測試程式中的參數設定，執行測試程式。 
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圖 3-13  GO/NOGO 執行結果畫面 

 
 

3.9 列印測試結果報表 

執行報表產生程式有兩方法，一是在離線（Off-line）模式，在Adapter / Charger ATS

系統軟體的主畫面中選擇 Report Generator 選項後，便會執行「報表產生程式」，

此時會顯示「選擇欲列印資料視窗」；另外一執行方法就是在線上（On-line）模式，

在測試期間由GO/NOGO程式自動呼叫，並將測試結果傳送至本程式。 
 

離線模式執行時，會出現「選擇欲列印資料視窗（Select data of tested UUTs from 

database）」讓您選擇欲產生報表的資料，您也可以利用選單功能[File]→[Open Log 

Database]來開啟此視窗，如圖 3-14所示。在畫面中有三個選項可以用來過濾待測

物，All代表找出所有待測物，Pass UUT Only代表只找出Pass的待測物，Fail UUT 

Only代表只找出Fail的待測物。 
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圖 3-14  離線資料選取視窗 

 
當設定完成時，按 OK 鈕讓程式幫您產生如圖 3-15所示的報表。 
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圖 3-15  顯示報表內容 

 
 

3.10 結束 Adapter / Charger ATS系統軟體 

在Adapter / Charger ATS系統軟體主畫面中，您有下列三種方式來結束Adapter / 

Charger ATS系統軟體程式： 
 

(1)  在主畫面中將滑鼠游標移至 Exit 選項上並按滑鼠左鍵，或 

(2)  在主畫面中將滑鼠游標移至視窗右上角的 x 按鈕上並按滑鼠左鍵，或 

(3)  在主畫面中鍵入Alt+F4。 
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4. 設定儀器配置組態 

4.1 執行程式 

當您在 Adapter / Charger ATS系統軟體的主畫面中選擇 H/W Configuration 選項

後，便會執行「儀器配置組態設定程式」，設定程式會讀出預設的組態設定檔（.hwc）

後顯示出儀器配置視窗，如圖 4-1  儀器配置視窗所示： 

 

 
圖 4-1  儀器配置視窗 

 
「儀器組態配置設定程式」在執行初期會根據 Registry的內容，讀出預設之組態設定

檔（.hwc），然後根據組態設定檔顯示儀器配置視窗。若預設之.hwc 不存在，則程式

會告知使用者（系統首次安裝後會有一預設的 Demo.hwc）。 
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您可利用選單功能表中的[File]→[Save]將目前所編輯的組態設定存檔，或是利用

[File]→[Save As…]將目前所編輯的組態設定存成另一檔名。在本程式中，您可以開

啟不同的.hwc檔，但是系統只能有一個預設的.hwc檔，您可利用選單功能表中的[File]

→[Set As System Default]將目前所編輯的組態設定系統預設檔，一旦被指定為系

統預設檔，則在執行裝置初始化時就以此檔案所設定的內容執行之。 

 
如果您想要重新指定儀器組態，可利用選單功能表中的[File]→[New]功能；您也可利

用選單功能表中的[File]→[Open…]功能，來開啟系統中既有的組態設定檔，如下圖

所示。 

 
 
 

4.2 儀器配置視窗說明 

儀器配置視窗（圖 4-1）中共分為三個小視窗，分別是「左視窗（Instrument 

Window）」、「上視窗（Model-Info Window）」及「下視窗（Module-Info 

Window）」，您可自行依顯示內容需要而調整三個視窗的大小，視窗內容其說明如

下。 
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4.2.1 左視窗（Instrument Window） 

 
 
「左視窗」用來配合新增、刪除目前配置儀器的組態，並且以樹狀圖顯示目前測試系

統中已經配置了那些儀器的種類、型號與數量。 

 
樹狀共分為五層：第一層為 Instrument表示儀器分類的總覽，第二層代表Device Type

儀器分類，第三層 Model 表示儀器型號，第四層 Sub Device Type 表示專屬於第三

層儀器的特殊儀器種類，第五層 Sub Model 則表示專屬於第三層儀器的特殊儀器設

備（型號），如下表所示。 

 
視窗中的⊕表示其下層還有其他儀器設備，可在⊕上按滑鼠左鍵展開之。此外，在儀

器設備上按下滑鼠左鍵後，關於儀器設備的相關資訊會顯示在上視窗（Model-Info 

Window）及下視窗（Module-Info Window）。 

 

 種類 意義 範例 

第一層 Instrument 儀器分類的總覽  

第二層 Device Type 儀器種類 EMU Set 

第三層 Model 儀器設備（型號） Chroma 6011 

第四層 Sub Device Type 專屬於某些儀器的特殊儀器種類 
Short Circuit/OVP 
Tester 

第五層 Sub Model 
專屬於某些儀器的特殊儀器設備

（型號） 
Chroma 6012 
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4.2.2 上視窗（Model-Info Window） 

 
以格狀方式（Grid）顯示儀器設備的相關資訊，包含儀器種類（Device Type）、設

備型號（Model Name）、使用介面（Interface）及儀器通訊介面的相關參數

（Parameter）及是否要作用（Active）。此視窗所顯示的內容會根據您在左視窗中

選擇的項目而顯示不同資訊：選擇第一層項目會顯示所有 Model的資訊，選擇第

二、四層項目會顯示與目前相同 Device Type的所有 Model資訊，而選擇第三、五

層項目則只會顯示目前單一 Model的資訊，如下表所示。 

 

 選擇項目 上視窗顯示的內容 

第一層 Instrument 顯示所有儀器的資訊 

第二層 Device Type 

顯示與目前具有相同 Device Type的所有儀器設備

資訊，如上圖即顯示所有目前組態中的所有 AC 

Source種類的儀器設備資訊。 

第三層 Model 只會顯示目前單一儀器的資訊 

第四層 Sub Device Type 同第二層 

第五層 Sub Model 同第三層 

 
 

4.2.3 下視窗（Module-Info Window） 

 
顯示儀器設備的模組（Module）相關資訊，其可顯示的資訊包含三種： 
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(1) 單一或相同 Device Type儀器的頻道資訊（Channel Information），其包含儀器

設備型號（Model Name）、頻道編號（CH）、模組名稱（Module Name）、指定

索引編號（Specified Index）及 Channel是否作用（Active）。 

 

 
(2) 顯示目前儀器配置的 Load 的並聯關係（Load Connection），其中一列（row）

表示一個並聯關係，如下圖表示 Spec Index 為 1與 2的 Channel並聯，拉載比

例為 40%與 60%，Spec Index3的 Channel為第二個並聯關係，並在 Enable欄

指定在測試過程中要用到目前所設定的並聯關係。 

 

 
 
(3) 某個儀器之 Sub Model資訊，其包含儀器設備型號（Model Name）、頻道編號

（CH）、模組名稱（Module Name）、指定索引編號（Spec Index）及 Channel

是否作用（Active）。此視窗所顯示的內容會根據您不同的操作方式而顯示不同的

內容，如下表所示： 

 

操作方式 選擇項目 下視窗顯示的內容 

左視窗 

Instrument 不會顯示任何資訊 

Device Type 
顯示目前相同 Device Type的所有 Model的

Channel Information 

Model 顯示目前 Model的 Channel Information 

Sub Device Type 
顯示目前相同 Device Type的所有 SubModel的

Channel Information 

Sub Model 顯示目前單一 Sub Model 的 Channel Information 



配接器/充電器自動測試系統 8020使用手冊 

 4-6 

上視窗 
Device Type 

顯示目前相同 Device Type的所有 Model的

Channel Information 

Model 顯示目前 Model的 Channel Information 

選單

（Menu） 

[View / Module 
Information] 

顯示 Module Information Window 

[View / Load 
Connection] 

顯示 Load Connection Window 

 
 

4.3 操作說明 

您可以利用儀器配置視窗中的「左視窗」來新增或刪除儀器設備，您可以利用「左

視窗」、「上視窗」及「下視窗」來修改測試統中所使用到的儀器的設定，包含使用

介面、通訊介面參數及頻道資訊等。 

 
 

4.3.1 新增儀器設備 

新增 Model 時，在「左視窗」欲新增的 Model 所屬 Device Type 上按下滑鼠右鍵，

出現功能表，然後選擇[Add…]即可，功能表可能會因儀器種類不同而出現不同的文

字。例：新增一台 Chroma 61500 Series，在[Add Input Source…]上按下滑鼠右鍵。

會出現「Add Model」視窗，選擇儀器後按 OK 鈕即可。 

 

 

4.3.2 刪除儀器設備 

1. 欲刪除單一 Model時，在欲刪除的儀器設備上按下滑鼠右鍵，選擇[Delete …]
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功能表即可，例：刪除 Chroma 6630。 

 

 
 
2. 欲刪除相同 Device Type的所有 Model時，在欲刪除的 Device Type上按下滑

鼠右鍵，選擇[Delete …]功能表即可，功能表文字可能會因儀器種類不同而改

變。例：刪除所有 Power Analyzer 的 Model。 

 

 
 
3. 欲刪除所有 Model時，可在「左視窗」Instrument項目上按下滑鼠右鍵，選擇

[Delete All]功能表即可。 
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4.3.3 組態之設定及修改 

儀器組態設定與修改包含設備型號、使用介面、通訊介面參數及頻道資訊等，之間並

無一定順序關係，但在某些情況下，當您修改某一欄位時，同一列的其他欄位內容也

可能會被更改。例如：當您將「使用介面」由 GPIB變更為 RS232時，其 Parameter

欄位內容也會隨之改變。 

 
 

4.3.3.1 使用介面設定 

 使用介面分為 7種：GPIB、RS485、RS232、IO MAP/PC、I2C、RS232-

I2C及 USB介面。 

 設定時，在「上視窗」的 Interface欄位利用[下拉式選單]直接選取即可。 
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4.3.3.2 通訊介面參數設定 

 設定時，在「上視窗」Parameter欄上，欲設定的 Model通訊介面參數的格

子（Grid）上的雙擊滑鼠左鍵即可。 

 

 
 
 不同的介面會出現不同的參數設定視窗： 

 
(1) GPIB介面： 

GPIB介面使用時，一般來說只要設定其主要位址（GPIB Address）即可。 

 

 
 
(2) RS232介面／RS485介面： 

RS485 參數設定視窗如下圖所示。RS232 介面參數設定視窗與 RS485 一樣，

只是沒有位址（Address）的參數。 
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(3) IO MAP/PC介面： 

此介面指的是插在 PC上的介面卡，其參數設定視窗如下： 

 

 
 
(4) I2C介面／RS232-I2C介面： 

此介面可編輯 I2C 裝置的相關參數，如使用卡板須設定板號，若使用 RS232 轉

接裝置，須設定 RS232 相關參數。由於 I2C一般常見 Slave Address 表示法有

兩種，請依實際狀況設定。 
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(5) USB介面： 

此介面須在儀器實際連接時才能設定，如下圖系統會偵測目前線上此類型儀器所

有序號，使用者須指定欲連接的儀器序號。 
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4.3.3.3 是否作用設定 

在本程式中新增的儀器，您也可以設定它在測試的過程中不被使用。設定時，在

「上視窗」的 Active欄位利用下拉式選單直接設定即可。 

 

 
 
 

4.3.3.4 頻道（Channel）資訊設定 

在新增儀器時，我們會附與頻道資訊內定值。頻道資訊包含儀器設備型號（Model 

Name）、頻道編號（CH）、模組名稱（Module Name）、指定索引編號（Spec Index）

及是否作用（Active）。您必須在「下視窗」中完成設定，說明如下： 

 
(1) 儀器設備型號（Model Name） 

顯示儀器設備型號，此欄位內容不能更改。 
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(2) 頻道編號（CH） 

顯示儀器設備中頻道的編號。此欄位無法更改。 

(3) 模組名稱（Module Name） 

顯示儀器設備中的模組名稱。若此 Model 為不可插換模組，則此欄位為無法修

改；反之，若此 Model是為可插換模組（Module），則您可以在「下視窗」中的

Module Name欄中利用「下拉式選單」來新增或移除某些 Module。 

 

 
當您使用下拉式選單新增 Model時，程式會自動尋找且顯示只適

合（Fit）目前狀態的 Module，例如：下圖中不會顯示 Chroma 

63108，因為 C63108佔用四個 Channel的位置，而目前 Channel 

3之下只剩兩個 Channel位置可用（Channel 3 & Channel 4）。 

 

 
 
(4) 指定索引編號（Spec Index） 

指定索引編號是用來設定儀器的 Channel 在系統測試的過程中的邏輯編號。若

某頻道指定索引編號為-1，則表示此頻道不會在測試過程中被用到。需注意的是，

對相同 Device Type的 Model來說，可作用的 Channel其索引編號必須從 1開

始，且必須連號、不可重覆，否則在存檔時會有錯誤訊息提醒您。欲修改索引編

號，只要在 Spec Index欄位利用[下拉式選單]直接設定即可。 

 

 
 
(5) 是否作用（Active） 

用來指定 Channel 在系統測試過程中是否可作用，若可，其值為 True；反之，

提示
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其值為 False。目前它會隨著指定 Spec Index 而改變，一般來說，當 Spec Index

為-1時，其值為 False，表示不可作用；當 Spec Index 不為-1時，其值為 True，

表示可作用。 

 
 

4.3.4 並聯關係（Load Connection）設定 

在系統測試過程中，您可以設定多個電子負載（Electronic Load）並聯拉載（本系統

中最多可設定 12個）。設定之前，您可以利用[View]→[Load Connection]功能選項，

或是將滑鼠移到「下視窗」中並按下滑鼠右鍵，則「下視窗」會切換至如圖 4-2所示

的「Load Connection視窗」。 

 

 
圖 4-2  Load Connection 視窗 

 
其中一列（Row）代表一個並聯關係，L1~L12 為 Load 並聯，填上“*”表示為空，

R1~R12 表示各並聯 Load 拉載的比例，而 Enable 欄則表示此並聯關係在測試過程

中是否可作用。舉例來說，假設您設定了四個並聯關係，第一個並聯關係以 Spec Index

為 1、4、6及 8並聯，拉載比例各為 10%、20%、30%及 40%，第二個並聯關係以

Spec Index 為 2與 3並聯，拉載比例各為 40%與 60%，第三、四個並聯關係的 Spec 

Index分別為 5和 7，則其結果如圖 4-3所示。 

 

 
圖 4-3  指定 Load並聯關係 
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欲變更並聯關係，您可以在非“*”的儲存格上按下滑鼠左鍵，利用拖拉（Drag & Drop）

的方式來變更，並聯關係改變後，請記得一併修改其拉載比例。您也可以設定 Active

欄，用來指定是否在測試過程當中要用到目前設定的並聯關係。 

 

 
圖 4-4  模組資訊視窗 

 

 
 並聯關係只跟 Device Type 為 Electronic Load 的 Spec Index

有關。 

 一個並聯關係的拉載總和必須為 100%。 

 在設定並聯關係之前，您必須先設定 Electronic Load 的

Spec Index。 

 並聯關係中，只會顯示非-1的 Spec Index，也就是說，可作

用的 Channel才能設定並聯關係。 

 若您不設定並聯關係（使用預設值），則程式會視為每個

Spec Index 為非-1的 Channel各自為一個並聯關係，且該

Channel的拉載比例為 100%。 

 當您修改了 Load的 Spec Index後，程式會自動根據 Spec 

Index更改的情形跟著反應，故建議您，在所有的 Electronic 

Load的 Spec Index都確定之後，再來設定並聯關係。 

 若兩個並聯關係之間有空的 Row，則下次進入時，程式自動

將並聯關係向前遞補。 

 如圖 4-5所示，Spec. Index 欄位中左右括號（）表示的是邏

輯 Channel與並聯後之次邏輯 Channel的關係。以 2（1）為

例，括號內的數值代表的是並聯後的邏輯 Channel

（Connection欄位值），因此 1（1）與 2（1）代表的是邏輯

Channel 1與邏輯 Channel 2兩組並聯，而且視為並聯邏輯

提示
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Channel 1。 

 

 
圖 4-5  Load模組指定視窗 
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圖 4-6  Load並聯指定關係視窗 
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5. 編輯測試程式 

測試程式（.prg）是由許多的測試項目依序所組合而成的，這些測試項目在 Adapter 

/ Charger ATS系統內均為內建，此外，Adapter / Charger ATS系統軟體又將測試項

目分為[Pre Test]、[UUT Test]與[Post Test]三大群，屬於[Pre Test]的測試項目只有在

執行環境第一次執行此測試程式時才會被執行到，屬於[Post Test]的測試項目則只有

在執行環境卸載測試程式時才會被執行到，至於[UUT Test]中的測試項目在每一次執

行測試程式時都會被執行到。要建立新的測試程式，主要包含三個步驟： 

 

1. 依照執行順序將所需的測試項目選出來。 

2. 編輯所選測試項目之執行流程，包括： 

 Pass Goto 

 Fail Goto 

 Fail Rerty 

 Loop To 

 Loop Cycle 

3. 設定各測試項目的參數值。 

 

以下介紹測試程式編輯視窗之操作。 

 
 

5.1 啟動 

當您在主畫面中選擇 Test Program 選項之後，程式首先會詢問您是要開始編輯一

個新的測試程式或是要開啟先前所儲存的測試程式。 

 

 
圖 5-1  新增或開啟對話盒 
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5.1.1 新增 

若您在新增或開啟對話盒選擇「Create new」選項，或日後按主畫面左邊的測試項目

編輯區中的 Program Info… ，將會產生如圖 5-2之對話盒，要求您輸入有關此新

測試程式的資訊，僅就較重要的幾項說明： 

 
[General]  
Date 此新測試程式建立日期。 

Time 此新測試程式建立時間。 

Comments 可輸入對此測試程式的註解。 

[Link]  
Report Format 
File 

線上列印報表時所套用的格式檔（*.rpf），此類型之檔案是由報

表編輯程式「Report Editor」所產生的。 

Fixture Model 可選擇執行測試時治具的 Model名稱或留空白，當使用者有輸

入時，GO/NOGO 程式在測試每一顆 UUT 之前都會先比對使

用的治具的 Model是否與測試程式所記載的一致，以及治具剩

餘可插拔的次數。 

[UUT Setup]  
Multi UUT 一次測多顆 

Output Numbers 此選項只有在 Multi UUT 下可以使用，此選項是用以設定每個

UUT 內含幾個輸出，藉此設定測試程式是 Multi UUT/Single 

Output 或是 Multi UUT/Multi Output，須注意的是此 Output 

Numbers須是小於 Total Load Numbers 的因數。 

Identical Test 
Condition 

一次測多顆時，不同顆 UUT是否要使用相同的測試條件。 

Total Load 
Numbers 

此新測試程式用到 Load 的 Channel 數，此數字不應該大於在

「Hardware Configuration」中所指定 Load的 Channel數。 

Load Name 報表中 Load每一個 Channel的顯示名稱（Show Name）。 

Reverse 打勾表示反接，沒打勾表示不反接。 

UUT Type 此選項目前支援 Single UUT / Multi Output 及 Multi UUT 兩種

型態的測試程式，Multi UUT 時所有的 Test Result 變數都必須

是 Load Array資料型別，否則無法使用該 Test Item。且可勾選

Identical Test Condition選項，此條件表示當 Multi UUT時，若

所有的測試條件都一樣，輸入一個條件即當成全部的測試條件，

若未勾選此項，則需個別輸入所有的測試條件。 
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圖 5-2  記錄測試程式資訊對話盒 

 
在 Test Program Editor 這支程式中，若表格中某些欄位是可編輯的，則您只要用滑

鼠左鍵在想要編輯的欄位上點兩下，就可以進入編輯模式。當您所有欄位確定輸入完

畢，可按 OK 進入主畫面開始編輯測試程式。 

 

 

5.1.2 開啟 

若您選擇「Open existing TP」選項，或日後按主選單中的[File]→[Open]，將會產生

如圖 5-3之對話盒，要求您指定所要開啟的測試程式，您可以直接輸入測試程式名稱

（不包含.prg）或在列示盒中點選。 

 
 Release：尚未 Release的測試程式您可以修改並用相同檔名儲存，已經

Release的測試程式則會要求您用另一個檔名儲存之。此欄位的值可在另一支

程式 Management 中設定。 
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 Date and Time：此測試程式最近一次修改的時間。 

當您指定所要開啟的測試程式後，可按 OK 或用滑鼠左鍵在該測試程式名稱上

點兩下進入主畫面開始編輯測試程式。 

 

 
圖 5-3  開啟舊有測試程式對話盒 

 
 

5.1.3 主畫面說明 

主畫面圖 5-4大略分成左右兩部分，左半部為測試項目編輯區，測試項目編輯區上方

顯示目前所編輯測試程式之名稱，若程式名稱右上角出現星號（*），表示您對該程式

已做過若干修改，但修改結果尚未儲存。按下 Program Info… ，將會產生如圖 5-2

之測試程式資訊對話盒。測試程式名稱下方共分成三張表格，分別是[Pre Test]、[UUT 

Test]以及[Post Test]，測試程式執行時也將按照此順序。 

 
主畫面右半部在一開始顯示的是測試項目列示區：標示為 System這一頁中的測試項

目為系統出廠時所附。 

 

除了測試項目列示區外，您還可以按工具列上的 Parameter 切換到測試參數編輯區，

按 Vector 切換到導引編輯區，其詳細功能將在後面章節中說明之。 
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圖 5-4  測試程式編輯環境畫面 

 
 

5.2 加入與編輯測試項目 

5.2.1 加入測試項目至測試程式中 

測試項目的加入是以插入的方式進行的。請先在主畫面左邊的測試項目編輯區中以滑

鼠左鍵點選所要插入的位置，假設是 Seq 3，然後在視窗右邊的測試項目列示區中選

好測試項目後按工具列上的 Insert TI ，則此測試項目就會被加到 Seq 3，而原本的

Seq 3會被順延到 Seq 4，其後面的測試項目也都會被往後順延。在視窗右邊的測試

項目列示區中，若以滑鼠左鍵雙擊所要的測試項目，則會將此測試項目加到主畫面左

邊測試項目編輯區 Seq 3的後一個項目（Sequence）。 

 

 



配接器/充電器自動測試系統 8020使用手冊 

 5-6 

5.2.2 測試項目的剪下、複製、插入與刪除 

為了考慮使用者編輯測試項目的便利性，免除重複輸入的費時，程式在「測試項目編

輯區」中提供了剪貼簿的功能： 

 
Cut（剪下） 將所選取的測試項目記在記憶體中供下一步驟使用，刪除所

選取的測試項目。 

Copy（複製） 將所選取的測試項目記在記憶體中供下一步驟使用，保留所

選取的測試項目。 

Paste（貼上） 將所選取的測試項目加到所要插入的位置，原位置的測試項

目被順延到下一個 Seq。 

Delete（刪除） 刪除所選取的測試項目 

 

想要對某一測試項目進行剪貼簿的功能，必須先做選取的動作。以滑鼠左鍵在要選取

的測試項目的 Active欄位上按一下，整列將會變成反白，代表選取的動作完成。您也

可以按一下滑鼠左鍵並拖曳或配合 Ctrl 或 Shift 作複選。若此時您要刪除選取的

測試項目，只要按工具列上的 Delete ，程式會出現一對話盒詢問您是否確定要刪除，

按 是 完成刪除的動作，按 否 取消刪除。 

 
若此時您要在某一 Seq插入選取的測試項目，必須先按工具列上的 Cut 或是按工具

列上的 Copy 將所選取的測試項目記在記憶體中，注意記憶體中必須要有一筆測試

項目，工具列上的 Paste 才會被致能（Enable）。然後以滑鼠左鍵在要貼上或插入的

測試項目的 Seq欄位上按一下，再按工具列上的 Paste 即可。 

 

 

5.2.3 編輯所選測試項目之執行流程 

主畫面左邊的「測試項目編輯區」乃以表格的方式呈現，包括最左邊的表頭，共有

十一個欄位，其說明如下： 

 
Seq 測試項目的順序號碼，一般情況下測試程式是照此號碼由小到大依

序執行測試的。  

Active 勾選與否決定該測試項目要不要被執行 

Test Item 測試項目名稱 

Ext. Name 附加說明 

Label 標籤，用來標示某一特定的測試項目，配合 Pass Goto、Fail 

Goto 以及 Loop To使用，以控制測試項目之執行流程。 
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Pass Goto 此欄位可指定一個已經存在的標籤。執行測試時，若此測試項目通

過測試，則跳到此欄位所指定的標籤所在的測試項目繼續做測試；

若未指定任何標籤，則依照 Seq順序執行測試。 

Fail Goto 此欄位可指定一個已經存在的標籤。執行測試時，若此測試項目未

通過測試，則跳到此欄位所指定的標籤所在的測試項目繼續做測

試；若未指定任何標籤，則依照 Seq順序執行測試。 

Fail Retry 此欄位可填入一個整數數字。執行測試時，若測試項目未通過測試，

則對此測試項目再做測試，填入的整數數字即為再測試的最多次

數。此功能的優先順序高於 Fail Goto、Pass Goto及 Loop To，也

就是說會先執行Fail Retry的功能然後再執行Fail Goto、Pass Goto

及 Loop To的功能。 

Loop To 執行測試時，若該測試項目此欄位有指定一個已經存在的標籤（必

須指定之前 Seq才有作用），則跳回到此欄位所指定的標籤所在的

測試項目，如此形成一個迴圈，至於迴圈的次數則在 Loop Cycle欄

位指定；若未指定任何標籤，則依照 Seq順序執行測試。 

Loop Cycle 迴圈的次數（註） 

Report 測試資料在 Report Generator程式要產生報表時，該測試項目要

不要出現在報表上。 

 

註：例如使用者希望從 Seq 3測試項目到 Seq 5測試項目反覆做五次。 

 

Seq Test Item Label Loop To Loop Cycle 

：     

：     

3 TestItem A A   

：     

5 TestItem B  A 5 

 
 

5.3 設定各測試項目的參數值 

測試項目包含哪些參數及其型別是在測試項目編輯器程式「Test Item Editor」中宣告

的，參數的型別除了原有的浮點數、整數、字元、字串、百分比外，又新增了導引

（Vector），並分別設計了專有的編輯畫面，建議使用者先進入此兩編輯畫面編輯完

後，再開始設定各測試項目的參數值。 

 



配接器/充電器自動測試系統 8020使用手冊 

 5-8 

5.3.1 編輯導引（Vector）項次資料 

當您在編輯測試項目的參數值時，經常會發現，對於某些參數值，您不斷在重複輸入

某幾組數值，為了節省您重複輸入的工作，Adapter / Charger ATS系統軟體引進了

一種新的變數型別—導引（Vector）。在您的測試程式中，您只要針對不同類的導引

（Vector）各別編輯其項次（Entry）資料後，那麼測試程式中任何一項測試項目，有

宣告為導引（Vector）型別的變數都可以在其所屬的導引（Vector）型別選擇一個項

次（Entry）資料來使用。 

 

Test Item #1

Test Item #2

Test Item #3

Test Item #n

LineInVector

1.

2.

3.

LoadVector

1.

2.

3.

4.

SpecVector

1.

2.

3.

ExtMeasVector

1.

2.

Test Program

 
圖 5-5  導引（Vector）與測試程式（Test Program）關係圖 

 

您可以按主選單中的[View]→[Vector Editor]或工具列上的 Vector 切換到導引編輯

區，如圖 5-6所示，畫面上方的 Vector Set Select 下拉式選取盒可以讓您選擇所要

編輯Vector的種類，系統出廠時預設了四種Vector：「Line In Vector」、「Load Vector」、

「Spec. Vector」和「Ext. Meas. Vector」，以編輯「Line In Vector」為例，表格的第
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一列為 Vector Name，其次為「Line In Vector」所包括的兩個元素，Voltage、Frequency。 

 
當您想要新增一組導引（Vector）項次資料時，只要用滑鼠左鍵按下表格上方的點陣

圖按鈕（Append），則表格中將新增一組導引（Vector）項次資料，其預設名稱為“Line 

In Vector 1”，您可以修改它，此名稱會在編輯測試參數時用到，而兩個元素 Voltage

和 Frequency的預設值則在系統出廠時就指定了，您也可以修改它們。 

 
再次提醒您，在「Test Program Editor」這支程式中，若表格中某些欄位是可編輯的，

則您只要用滑鼠左鍵在想要編輯的欄位上點兩下，就可以進入編輯模式。 

 
「Load Vector」的編輯方法很類似，較大差別在於「Load Vector」元素的個數（各

個 Channel 的 Loading）是依照圖 5-2  記錄測試程式資訊對話盒中的 Total Load 

Numbers值而定。 

 
想要刪除某一組導引項次資料只要先用滑鼠左鍵點選想要刪除的項次資料再按下表

格上方的點陣圖按鈕（Delete）即可。 

 

 
圖 5-6  導引編輯區畫面 
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5.3.2 編輯測試條件（Test Condition）的參數 

您可以按主選單中的[View]→[Parameter Editor]或工具列上的 Parameter 或是直

接在「測試項目編輯區」以滑鼠雙擊 Test Item 欄後，此時右窗格會切換到「測試參

數編輯區」，如圖 5-7所示，畫面左右兩窗格必須交互參照，請您用滑鼠左鍵在畫面

左窗格「測試項目編輯區」中，欲編輯測試參數的測試項目該行上點一下，或用鍵盤

上下鍵移動游標至想要編輯測試參數的測試項目該行上，此時畫面右窗格「測試參數

編輯區」就會顯示該測試項目的所有參數。 

 
表格中以淺黃色為底色的 Show Name為不可編輯，而 Value欄位就是您要輸入參數

值的地方，一開始顯示的是預設值，此預設值是在測試項目編輯器「Test Item Editor」

中指定的，至於參數值輸入的方式大抵分為三種： 

 
編輯器（Edit） 用滑鼠左鍵在想要編輯的欄位上點兩下，就可以進入編輯

模式。 

下拉式選取盒

（Combo Box） 

用滑鼠左鍵按下拉式選取盒右邊的向下箭頭按鈕，會出現

選單供您選擇。 

屬於矩陣（Array） 

型別的變數 

屬於 Load的參數，若屬於矩陣（Array）的型別，往往需

要為每一個 Channel輸入一個值，礙於空間的限制，將欄

位延伸到畫面上方，而欄位個數則是依照圖 5-2測試程式

資訊對話盒中的 Total Load Numbers 值而定。請您先在

欲編輯參數值的欄位上用滑鼠左鍵點一下，再移動滑鼠到

畫面上方的欄位中開始編輯參數值。 

 
屬於導引（Vector）型別的參數，也是使用下拉式選取盒（Combo Box）的方式來編

輯，當您用滑鼠左鍵按下拉式選取盒右邊的向下箭頭按鈕，選單中出現的是您先前在

導引（Vector）編輯區中所編輯導引（Vector）的 Vector Name供您挑選。 

 
有些參數會在測試過程中拿來和測試結果（Test Result）做比較，這一類參數的編輯

型別都為編輯器（Edit），若您以滑鼠左鍵在此參數的編輯欄位上雙擊，進入編輯模式

後，輸入米字「*」，就表示您要求執行環境忽略此一比較的動作。 
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圖 5-7  測試參數編輯區畫面 

 
 

5.4 列印測試程式 

測試程式編輯環境提供一簡單的列印功能，讓您將所編好的測試程式列印出來，其列

印內容包括四部份： 

 
1. 圖 5-2之記錄測試程式資訊對話盒的內容。 

2. 按照[Pre Test]、[UUT Test]、[Post Test]的順序列出所有測試項目的名稱。 

3. 按照[Pre Test]、[UUT Test]、[Post Test]的順序列出所有測試項目的參數

值。 

4. 導引（Vector）的內容。 

 
您可以先按主選單中的[File]→[Print Preview]預覽要列印的內容，再按預覽視窗左

上方的 列印(P)… 列印或直接按主選單中的[File]→[Print]列印。 
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5.5 存檔 

要儲存您編輯好的測試程式，您可以按主選單中的[File]→[Save]或按主選單中的

[File]→[Save As]，兩者的差別在於前者除了第一次儲存時會出現如圖 5-8 的對話

盒要求您指定檔名外，在接下來都會以原檔名儲存，不會再出現對話盒。而後者則假

設您想要用不同的檔名儲存，故每次都會出現對話盒要求您指定檔名。 

 

 
圖 5-8  另存新檔對話盒 

 
有一點要特別注意的是，尚未發行（Release）過的測試程式您可以用相同檔名儲存，

已經發行（Release）的測試程式則會要求您用另一個檔名儲存之。您可在系統管理

程式「Management」中指定某一個測試程式要不要發行（Release）。 
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5.6 選單說明 

[File]→[New] ： 新增一個測試程式 

[File]→[Open…] ： 開啟一個已存在的測試程式 

[File]→[Save] ： 儲存您正在編輯的測試程式。如果您編輯的是新的

測試程式（即檔名為 Untitled）時，則會出現「另存

新檔」對話盒讓您指定所欲存入的檔名。 

[File]→[Save As…] ： 將正在編輯的測試程式存成另一檔名 

[File]→[Import Vector…] ：  將在別的測試程式中已經編好的 Vector 加進來 

[File]→[Export Vector To 

EXCEL…] 

： 將目前編輯的測試程式中的 Vector 匯出至 Excel 

[File]→[Print All Seq.(s)…] ： 選擇開啟測試項目列示區時顯示，將目前編輯的測

試項目全部列印出來。 

[File]→[Print Current 

Selected Seq.…]  

： 選擇開啟測試參數編輯區時顯示，只會列印目前游

標所停留的測試項目其參數內容。 

[File]→[Print Preview…] ： 預覽所編輯的測試程式的列印結果 

[File]→[Print Setup…] ： 設定印表機 

[File]→[Print To 

File(*.txt)…] 

： 將目前編輯的測試程式及其變數存至 txt檔 

[File]→[Exit] ： 結束測試程式編輯，回到自動測試系統的主畫面。 

   
[Edit]→[Cut] ： 將所選取的測試項目記在記憶體中供下一步驟使

用，刪除所選取的測試項目。 

[Edit]→[Copy] ： 將所選取的測試項目記在記憶體中供下一步驟使

用，保留所選取的測試項目。 

[Edit]→[Paste] ： 將所選取的測試項目加到所要插入的位置，原位置

的測試項目被順延到下一個序列（Sequence）。 

[Edit]→[Delete] ： 刪除所選取的測試項目 

[Edit]→[Insert Test Item] ： 從畫面右方測試項目列示區插入一個測試項目到畫

面左方 
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[Edit]→[Security...] ： 

 
使用者可以為每一個 Test Program 檔設定密碼，

以防止他人修改或觀看。要防止他人修改請選用

Low:Read Only，要防止他人觀看請選用

High:Deny Open。 

[Edit]→[Format…] ： 出現「預設格式」對話盒，使用者可以選擇浮點數

的預設有效位數。 

[Edit]→[Option...] ： 出現「選項」對話盒，使用者可以選擇要不要開啟

「當新建測試程式時每種 Vector自動加上一筆初

始值」的功能。 

   
[View]→[Edit Toolbar] ： 設定是否顯示工作列 

[View]→[Status Bar] ： 設定是否顯示狀態列 

[View]→[Test Item List] ： 切換到測試項目列示區 

[View]→[Parameter Editor] ： 切換到測試參數編輯區 

[View]→[Vector Editor] ： 切換到導引編輯區 

[View]→[Reset Client Size] ： 讓主畫面左右半邊的比例回到出廠時的設定 

   
[Help]→[About TP 

Editor…] 

： 關於本程式 
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6. 驗證測試程式 

本章主要描述執行測試程式驗證的環境，說明如何使用執行控制程式（Execution 

Controller）將編輯好的測試程式進行 Detail測試。Detail測試是指即時測試 TP 

Editor編輯好的測試程式，在測試的過程並不會記錄測試程式中的讀值至資料庫

中，但是比 GO/NOGO程式提供更多的控制功能，讓使用者能較有效率的找出測試

程式設計上的問題點。 

 
 

6.1 執行控制程式主畫面 

當您在 Adapter / Charger ATS 系統軟體主畫面中選擇 Test Program 選項，並選

擇好所要編輯的測試程式後，以滑鼠點選工具列上的 Execution Control 按鈕，

即會出現如圖 6-1的視窗。 

 

 
圖 6-1  測試程式的詳細驗證（Detail Test）執行控制畫面 
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執行控制程式（Execution Control）之 Detail Test 畫面的安排和顯示和 GO/NOGO

相同，請參考第 7章執行測試程式（GO/NOGO）的說明。在程式顯示區中預設值是

只顯示到測試項目。 

 
● 程式顯示區： 

Detail Test在主畫面比 GO/NOGO 程式多三個按鈕，供您設定／取消斷點

 （Break Point）的功能。 

 

Set Brk 設定在測試命令上的執行斷點。當設定斷點後，該行上會有

一個圖型 （中間為黃色直線）顯示該測試命令已被設定

為執行斷點。 

Clear Brk 清除在測試命令上的執行斷點 

Clear all brks 清除在測試項目上的執行斷點 

 

您可將滑鼠游標移到所要設定斷點的測試項目（Test Item）上，再按下 Set Brk 、 

Clear Brk 或 Clear all brks 按鈕，您會在所選定的測試項目上看到一個小旗子的

符號，表示您已經設定一個斷點在這個測試項目上。您也可以在該行測試項目上按下

滑鼠的右鍵，選擇選單的項目達到設定／取消斷點，會出現一個選單，上含有Set Brk、

Clear Brk、Clear All Brks，功能和上述按鍵的功能相同。 

 

 
圖 6-2  斷點設定 
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● 過程顯示區： 

和 GO/NOGO 相同。 

 
● 測試內容顯示區： 

Detail Test在測試內容顯示區上是以展現各個變數的內容為主。 

 
測試程式各測試項目的變數 

各變數值的表現和 GO/NOGO 的操作一樣。 

 
執行測試的設定 

與 Test Program Editor 搭配的 Detail Test會是如下的內容： 

 

 
 
 

6.2 設定執行測試功能選項 

本小節說明執行控制工具列的功能。執行控制工具列是整個執行控制的操作重心，

控制執行或停止測試程式。 

 
在和 Test Program Editor 搭配的 Execution Control 工具列上共有八個按鍵

Go(F10)、Stop(F2)、Single(F9)、Step、Report(F3)、Pause、Resume、

Save Data 如下圖： 
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按鈕的功能和 GO/NOGO的說明相同，底下的圖示，是當執行中斷在斷點上或者被

使用者中斷（Pause）執行流程的狀態，此時在中斷點上會有一個圖型 （中間

為紅色直線），顯示目前的中斷點。 

 

使用者只可以執行 Stop 以及 Resume 的功能。 

 

 
 
有關 Detail Test的其餘功能請參照第 7章執行測試程式（GO/NOGO）所述。 
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7. 執行測試程式（GO/NOGO） 

本章主要描述執行測試程式的環境，說明如何使用執行控制程式（Execution 

Controller）將編輯好的測試程式進行 GO/NOGO測試，在測試過程中會將測試結

果傳送給線上報表程式（On-line Report Generator）以利報表的輸出。執行控制程

式亦會將測試結果記錄至資料庫中，作為未來的統計製程管制分析，以及離線報表

列印工作。 

 
 

7.1 執行控制程式主畫面 

按下 Adapter / Charger ATS的主畫面上的 GO/NOGO ，立即啟動執行控制程式，

執行控制程式會立即啟動「H/W Configuration」程式所有設定的設備的初始化，並將

初始化的結果顯示在左下方的測試過程顯示區。圖 7-1為執行控制程式的主畫面。 

 

 
圖 7-1  執行控制程式主畫面 
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在執行控制程式主畫面共可分成三個部份，依逆時鐘方向分別為：程式顯示區、過

程顯示區與測試內容顯示區。 

 

 程式顯示區： 

 

 
 
將開啟的測試程式中的每一個測試項目都顯示在此區表格之中；若在執行的過

程，正在執行的該列將以較深的顏色表示。 

 
在表格中共分為六欄，第一欄為測試項目在測試程式中的順序，第二欄為測試項

目的名稱，第三欄為測試項目命令，第四欄為測試命令的參數，第五欄會顯示測

試程式的流程控制設定。第六欄會顯示測試項目執行後的結果。 

 
在 GO/NOGO 測試中為只顯示測試項目，不顯示測試命令。 
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 過程顯示區： 

 

在此區範圍內，快速雙擊滑鼠的左鍵，可以在顯示執行過程文字和顯示執行結

果顯示之間相互切換。您可以藉文字的顯示部份了解執行的過程；或由圖型的

文字顯示立即獲得執行測試的結果。 

 

 測試內容顯示區： 

 

測試內容顯示區共有兩個部份：第一部份為顯示執行測試的一般設定，第二部

份則為顯示執行測試程式後，測試程式中所定義各種變數的值。 

 
執行測試的設定 

 

 
 

雙擊滑鼠

左鍵 
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Program區 

 Test Program  ：測試程式的名稱 

 Model Name  ：測試程式的模組名稱 

 
UUT區 

 Serial No   ：待測物的序號 

 Iteration   ：執行測試程式的次數 

（已執行次數／總執行次數） 

 Run（%）   ：執行的進程百分比 

 Date/Time   ：目前的系統時間 

 Start Time   ：開始測試時間 

 Elapsed Time  ：測試所花費的時間 

 
Fail Rate區 

 UUT Counts  ：已測試的待測物個數 

 Fail Counts  ：測試失敗的待測物個數 

 Fail Rate   ：待測物失敗的比率 

 
當 Fail Rate超過所設定的條件時，Fail Rate失敗比率的左方綠燈將轉換成紅

燈閃爍，提醒使用者待測物的失敗比率已經超過設定的上限。 

 

Set Test Info 提供修改測試時的設定對話盒，此按鍵功能同選單 

[Settings]→[Test Information…]。 

Reset Fail Rate 重新計算失敗比率，將之前的 UUT Count 清為零，重新

開始計算 Fail Rate。此按鍵功能同選單 [Settings]→

[Reset Fail Rate] 
 
治具顯示區 

 Fixture Model  ：在 TP Editor中選用的治具機型名稱 

 Available Test Count ：顯示現行治具可用的測試次數 

 
測試程式各測試項目的變數 

 

各測試後的測試項目，每一個設定值和讀值都可以在測試內容顯示區內的

[Variable Info]中找到。畫面上的安排，在最上方有五個選項，可供您挑選需要查

看的變數分類，以及是否展開陣列變數的每一個元素。 

 
□Expand Array-type 

variables 

若勾選此項，在顯示陣列變數時，將顯示陣列中每一

個的值；反之，顯示該變數的名稱。 
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□Pass Readings 若勾選此項，顯示符合限制規格的讀值（Test Result）

變數。 

□Fail Readings 若勾選此項，顯示不符合限制規格的讀值（Test 

Result）變數。 

□Test Condition 若勾選此項，顯示設定型（Test Condition）的變數。 

□TP Variables 若勾選此項，顯示測試程式上的變數。 

 
在下拉式選單上放置執行過的測試項目，並依測試項目執行的順序排列。您可

選擇一個測試項目，觀察變數的值。 

 

 
 
中間的表格會填上符合下拉式選單所指定測試項目和各種選項的變數定義和其

值。表格共分成六欄，第一欄為變數的順序編號，第二欄為變數的名稱，第三

欄為變數的值，第四欄為規格判斷，第五欄為變數的型別，第六欄為測試項目

的測試順序，第七欄為測試項目在測試程式中的順序。 
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在變數的名稱上，如果該變數是一個陣列型的變數，如果該變數並未展開，在

變數名稱上最後會加上[(L)]表示這是一個以 Load為個數的陣列變數，若變數名

稱後加上[(4)]，則表示這為四個元素的陣列變數，當中的數值表示這個陣列變數

的個數；如果該變數是展開的狀態，每一個陣列變數的元素表示為變數名稱的

後面加上[n]，n表示是這個陣列變數的第 n個值。 

 
在第二欄上，表現變數的內容，如果值為『…』而且該變數為一個陣列型的變數

時，您可以快速雙擊該變數，該行會展開／收起陣列變數的內容。 

 
在第三欄表示該 Test Result變數是否符合規格。 

 
第四欄在表現變數的類別，“TR”表示 Test Result變數，“TC”表示 Test Condition

變數，“TC(V)”表示為 Vector Type 的 Test Condition 變數，“TP(V)”表示 Test 

Program 上的 Vector變數。 

 
您可以在第一欄按下滑鼠的左鍵，可以看到一個詳細描述該變數的說明文字，

如下圖。 
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7.2 設定執行測試功能選項 

本小節說明執行控制工具列的功能。執行控制工具列是整個執行控制的操作重心，

控制測試程式的執行或停止。 

 
工具列上共有四個可使用的按鍵，如下圖： 

 

 
 
各個按鍵的功能分別說明如下。 

 
按下 Go(F10) 或按下快速鍵（F10），從測試程式第一個測試項目開始執行，執行完

畢後將測試結果存入資料庫。如果有 Pretest 型的 Test Item，只會在第一次執行一

次。您也可以按下 Go(F10)右方的▼，只執行[Pre Test]群組的測試項目。 

 

 

 

 
 當您選擇序號自動計數（Auto Count）時，序號將自動加

一。 

 當您選擇以 Barcode作計數時，若未勾選 Enable prescan 

multi barcode，按下此鍵後會跳出一個視窗（如下圖），接收

您使用 Barcode Reader 掃描得到的待測物的序號。 

 

 
 

提示
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 當您選擇以 Barcode 作計數時，若勾選 Enable prescan 

barcode，按下此鍵後會跳出一個視窗（如下圖），下方 Prescan 

Barcode區可讓您在測試當中利用使用 Barcode Reader預先

掃描下一組的待測物的序號，而上方的 Processing Barcode

區則用以顯示目前正在處理中的待測物序號。 

 

 
 
 測試程式執行中無法結束執行控制功能；若要結束執行控制

功能，請先按 

 Stop(F2) 按鈕停止執行測試程式後，再結束執行控制功

能。 

 當測試程式執行完畢後，所有儀器均會回至初始化狀態，同

時 AC電源供應器亦會停止供電；故您可進行待測物之更換

工作。 
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按下 Stop(F2) 或按下快速鍵（F2），終止執行測試，測試結果不會記錄到資料

庫。 

 

 按下 Single(F9) 或按下快速鍵（F9），開始執行所指定測試項

目。 

在您按此按鈕前，應先於測試程式顯示區選好您所要執行之測試項目。您可以滑鼠

來選擇您欲執行之測試項目。 

 

 當以 Single(F9) 來執行某測試項目前，應先執行與“Setup”相

關的測試項目，讓 AC電源供應器供電。 

 

按下 Report(F3) 或按下快速鍵（F3），切換到報表編輯程式。您可以透過報表編

輯程式立即看到執行後的報表顯示。 

 

有兩個按鈕 Pause 和 Resume 在「GO/NOGO」並沒有作用，Pause 和

Resume 是提供 Detail測試用的兩項功能。 

 
 

7.3 操作按鈕功能說明 

本小節說明執行選單的功能。選單提供您設定各種執行環境。 

 
 

7.3.1 選單 File 

 
 

[File]→[Open 

TestProgram...] 

快速鍵（Ctrl+O），由對話盒開啟已編輯好的測試

程式。 

[File]→[Exit] 結束本程式，回到 Adapter / Charger ATS系統軟

體的主畫面。 

 

 
如果硬體的初始化失敗時，此選單將不能使用，請立刻檢查硬體

的設定，重新開啟執行控制程式即可使用。 

提示

提示

提示
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7.3.2 選單 Run 

 
 

[Run]→[Go] 快速鍵（F10），從測試程式第一個測試項目開

始執行，執行完畢後將測試結果存入資料庫。

功能同執行控制工具列的 GO 按鍵。 

[Run]→[Single] 快速鍵（F11），開始執行所指定測試項目。功

能同執行控制工具列的 Single 按鍵。 

[Run]→[Step] Detail測試用。 

[Run]→[Stop] 快速鍵（F2），終止執行測試，測試結果不會

記錄到資料庫。功能同執行控制工具列的

Stop 按鍵。 

[Run]→[Pause] Detail測試用 

[Run]→[Resume] Detail測試用 

[Run]→[Go (Pre_TestItems)] 執行測試程式的「PreTest」的測試項目 

[Run]→[Go (Post_TestItems)] 執行測試程式的「PostTest」的測試項目 
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7.3.3 選單 Settings 

 
 

[Settings]→[Reset FailRate] 將 Fail Rate的計算值歸零，重新開始計算 Fail 

Rate。 

[Settings]→[Test 

Information...] 

有關測試資訊的設定。此選單會出現圖 7-2的

視窗，提供您輸入測試的相關條件。 

 

 
圖 7-2  測試程式資訊設定視窗 
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圖 7-3  在 MultiUUT 模式沒接 I/O 卡時確認 UUT序號狀態的視窗 

 
 設定序號（Serial No.）︰您可選擇在測試過程中待測物的序號是以自動累加序

號的方式（Auto）或是使用條碼掃描機（Barcode Reader）所掃描得到的序號。

若您是使用自動累加序號，您還可以指定序號之前導字元及後序字元，以及序號

之起始號碼和長度。若您在 MultiUUT 模式但並無使用 I/O 卡來判斷是否有接

UUT，可勾選選項即會呈現對話盒讓您確認連接狀況及序號，如圖 7-3，即勾選

第一、第三組沒接 UUT，系統會自動跳過不產生序號。若是您是使用條碼掃描

機的方式讀入序號，您可以定義條碼的長度，提供執行測試時作檢查，防止測試

過程中人為輸入錯誤序號的情形，條碼長度的設定可以按下 Test 按鍵幫助您掃

入條碼後自動為您計算條碼的長度；如果您不需要在測試過程中檢查條碼的長度，

可以將檢查長度設定為零。如果輸入的序號包含了一些您不想要保存的訊息，此

時可勾選擷取序號從第幾個字元開始之後幾個字元，做為實際儲存的序號。 

 
 失敗警訊（Fail Rate）設定 

您必須設定失敗警訊的上限 0~100 %，及測過多少待測物後才開始計算失敗警

訊的次數。 

 測試的相關資訊 

 
Customer Name 客戶名稱 

Order Number 訂貨編號 

LOT Number 批號 

Inspector 檢測人員姓名 

Environment 測試時的環境溫度 

Iterations 待測物所欲重複測試的次數 
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 不同之測試程式，可個別設定測試程式相關資訊，因此更換

不同之測試程式，不需重新設定。 

 測試資訊是以 INI檔之形式，存於測台之系統軟體工作目錄

\INI之子目錄中。 

 
[Settings]→[Option...] 打開選項設定畫面 

 
如果使用者以“OP”權限或不具有進入“Test Program”權限的使用者登錄時，若使用

者需要修改選項內資料，會呈現輸入帳號、密碼的對話盒，如圖 7-4，如果沒有權

限則無法進入選項中修改內容，如圖 7-5。 

 

 
圖 7-4  輸入具有進入“Test Program”權限的使用者帳號和密碼 

 

 
圖 7-5  如果沒有權限則無法進入選項修改設定 

 

提示
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選項設定共有 5頁，分別說明如下︰ 

 
第一頁（Execution）： 您可透過這一頁來設定執行控制功能之環境；這一頁中之所

有內容將會記錄至系統中。當您結束執行控制功能後再次啟

動，所有第一頁中之設定，將會自動由系統中載入。 

 

 
 

H/W Configuration︰ 

Configuration File：目前測台上所指定的硬體配置組態設定檔案名稱。 

Auto Run：勾選是否要透過 I/O 卡或 Chroma A-B Fixture 以自動執行的模

式執行測試程式。使用目前測台上之硬體配置組態設定檔。 

Waiting for start bit：讓使用者可以用 DO 控制燈號,但可以不用 DI。 
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Enable I/O Card：勾選此項功能後，會將每一個單組輸出的 UUT測試結果

（Pass／Fail），依序輸出到第一片 I/O 卡的輸出 Bit 9~16，超過 8個以上的

UUT則不支援此功能。 

 
Configuration︰ 

Open Last Test Program File：跳過開檔之對話盒，直接開啟上次最後執行

之測試程式。您可透過選取此一設定，節省您每次都必須去開啟同一個測試

程式的時間。 

 
Show Process Text：勾選是否在執行的過程中顯示較多的訊息在過程顯示

區內。 

Save Global Variables When Exiting：勾選是否在測試程式結束時儲存測

試程式所設定的 Global 變數，以供下次開啟測試程式時能載入上次的設定。 

Stop On Failure：勾選是否在檢查到某一測試項目不符合規格時，能立刻停

止測試。 

Executing ‘Post Test’ automatically when user press ‘stop’ button or 

error occurred：勾選是否在測試程式結束時或 User 按下 Stop 鍵時執行

Post Test。 

 
Log Data： 

您可以選擇是否要將測試結果記錄在資料庫，以利報表及統計分析參照運用。 

 
Fail Rate： 

Merge Retest Data：勾選表示相同序號有重測幾次都要算幾次 fail。 

By Last Times：勾選表示相同序號只看最後一次結果；否則看第一次。 

 
UUT Type︰ 

Single UUT/Multi Output：指示所用的測試程式是單一待測物多個輸出。 

MultiUUT/Single Output：指示所用的測試程式是多顆待測物。 

UUT Number：指示在 MultiUUT/Single Output模式下，待測物的數量。 
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第二頁（Report 1）： 您可透過這一頁來設定執行環境所提供的報表功能；這一頁中，

所有內容將會記錄至系統中。當您結束執行控制功能後再次啟

動，所有本頁之設定值，將會自動由系統中載入。 

 

 
 

Report Generator︰ 

Send data to [Report Generator]：選取後，當執行環境執行時，自動啟動

報表產生程式。 

 
Prompting when UUT failed：選取後，當待測物測試結果為 Fail時，系統

會顯示一視窗如下圖，詢問是否要顯示報表。 
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The max. number of the last UUT data in [Report Generator]:設定

「Report Generator」所要顯示最近待測物測試資料的最大筆數。 

 
In Test Print：選取後，當測試程式執行完畢，自動啟動列印功能，列印測試

結果。在執行測試程式的測試期間，如果您希望「Report Generator」程式將

測試資料送到印表機列印時，只要將「In Test Print」選項勾選起來，並依照

您的需要設定列印的條件即可，「In Test Print」列印功能說明如下： 

 
All Data：列印所有的測試資料 

Pass Program：當整個測試程式執行結果被判定為 Pass 時，才執行列印

的工作。 

Fail Program：當整個測試程式執行結果被判定為 Fail 時，才執行列印的

工作。 

Pass Sequence：只列印判定為 Pass的 Sequence。 

Fail Sequence：只列印判定為 Fail的 Sequence。 

 
In Test Print to File：選取後，當測試程式執行完畢，自動啟動列印至檔案

功能，儲存測試結果。在執行測試程式的測試期間，您可以透過「Report 

Generator」程式將測試資料轉存到檔案（.txt或.rtf），要執行此功能，您只要

將「In Test Print to File」選項勾選起來，並依照您的需要設定存檔的條件即

可，「In Test Print to File」存檔功能與「In Test Print」列印功能相同，您可

參照使用。 

 
注意，無論是執行「In Test Print」列印功能或是「In Test Print to File」存檔

功能，您必須先確定 Send data to [Report Generator]選項已經被勾選。 

 
In One File：所有的測試結果皆儲存到同一個檔案。 

 
File Name (.txt)：執行「In Test Print to File」時，所指定的檔案名稱。 

 
By UUT SN：根據 UUT序號及日期時間組合成檔案，不同 UUT儲存到不



配接器/充電器自動測試系統 8020使用手冊 

 7-18 

同的檔案。 

 
Saving Path：指定若 by UUT SN 時所產生的檔案放在哪一個目錄。 

 
第三頁（Report 2）： 當您在第二頁有選取 Send data to [Report Generator]時，在

第三頁您可以進一步設定是否要將 Report Generator 產生的

報表順便儲存成 Excel檔案。 

 

 
 

Save as Excel file when on-line report is running：選取後，當 Report 

Generator產生報表時會自動順便儲存成 Excel檔案。 

 
Station ID：決定檔名的一部分。 



執行測試程式（GO/NOGO） 

7-19 

 
File name：提供兩種存檔檔名的設定。 

 
Saving Path：儲存 Excel檔案的路徑。 

 
Excel Separator：一般文件要輸出到 Excel都會要求訂定分欄符號，這裡提

供三種選擇。 

 

Filter out all the Excel Separators on the hardcopy report：如果要控制

輸出到 Excel 的報表符合期望，則當您在 Report Editor 編輯報表格式檔時

就需要提早考慮到將分欄符號編進報表格式檔，但這樣做可能產生的副作用

就是原先在 Report Generator 看到的報表會多了一大堆的分欄符號，而這

個選項則是會幫您過濾掉分欄符號。 
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第四頁（Miscellaneous）： 您可透過這一頁來設定執行環境在執行的過程中上所顯

示的數值格式。如設定為整數部份為 7，小數部份為 4，

在執行下一次後，您在系統中所看到的數值顯示將會將小

數第五位以下將自行四捨五入至第四位。請注意：設定格

式只影響顯示的結果，系統內部仍以原來的值作運算。此

外，也可以透過這一頁來設定想要顯示的額外錯誤訊息。 
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第五頁（S/N Check）： 您可透過這一頁來設定序號檢查相關處理。 

 

 
 
Enable check the same serial number: 是否檢查相同序號。 

 
Stop test the same serial number: 相同序號是否停止測試。 

 
Stop test when barcode length not match: 是否當序號長度不對時停止測試。 

 
Enable check for special characters: 是否檢查特殊字元。 

 
Enable limit manual input: 是否限制手動輸入條碼功能。 
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7.3.4 其它選單 

 
 

[View]→[Show Report 

Generator] 

快速鍵 F3，呼叫報表產生程式。 

[View]→[Expand Test Items] 選取測試程式在測試程式顯示區是否需展開

顯示測試命令 

[View]→[Toolbar] 選取執行功能工具列是否顯示 

[View]→[Status Bar] 選取狀態列是否顯示 

 

 
 

[Help]→[Export Error Report...] 匯出錯誤資訊。 

[Help]→[About ExeCtrl...] 顯示本程式的版本資訊 

 
 

7.4 自動執行功能 

「GO/NOGO」除了可由操作人員以手動測試外，另外也可支援自動測試的控制功能。

其動作方式為透過 I/O 卡的輸入信號啟動測試程式的執行，並將測試結果輸出到 I/O

卡的輸出信號。I/O 卡的使用並不保留為專給「GO/NOGO」使用，使用者可以呼叫

我們提供的 I/O Card 測試命令直接驅動 I/O Card 的所有訊號，因此在設計 Test 

Program，須考慮避開這些 I/O 訊號位元。 
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7.4.1 設定 I/O卡 

首先在「H/W Configuration」新增一項 Device Type為 I/O Card的 ADLink PCI-

7230裝置，如圖 7-6所示，並新增一項 Device Type 為 EMU Set的 Chroma 

80611。 

 

 
圖 7-6  新增 I/O 卡 

 
然後在「GO/NOGO」的[Settings]→[Option..]選項中勾選 AutoRun功能。在 8020

中「GO/NOGO」預設會以 HWCfg中 IO 分類的第一張卡(ADLink PCI-7230)與 EMU 

SET 分類的第一張卡(Chroma 80611)作為自動控制的對象。如果 I/O卡並未在「H/W 

Configuration」設定或者初始化未成功，則 AutoRun 選項就會顯示灰階，不讓您勾

選。 
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圖 7-7  自動執行功能選項 

 
在「H/W Configuration」所設定的第一片 ADLink PCI-7230卡上的輸入埠 Bit 1到

6共 6個 Bits 保留給「GO/NOGO」的流程控制用，如下圖定義。 
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12345678910111213141516

12345678910111213141516

INPUT PORT

Start1

Trigger

Stop

Trigger

UUT1UUT10 UUT2

OUTPUT PORT

Start2

Trigger

R/L-M

Trigger

R/L-A1

Trigger

R/L-A2

Trigger

 
註 若是 Execution頁面中的 Enable I/O Card 有被勾選，則輸入埠 Bit 

7~16保留給 UUT 1~UUT 10做為偵測是否有接 UUT的訊號。 

 
在「H/W Configuration」所設定的第一片 Chroma 80611卡上的輸出埠 Bit 31到

40共 10個 Bits 保留給「GO/NOGO」的顯示 Pass燈號，輸出埠 Bit 41到 50共

10個 Bits 保留給「GO/NOGO」的顯示 Fail燈號。 
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8. 編輯報表格式 

8.1 執行程式 

在 Adapter / Charger ATS 系統軟體主畫面中按下 Report Editor 選項後即可開始

執行報表編輯程式。編輯前，程式會要求您選擇所要編輯的報表格式檔，您也可以選

擇檔案後按下 OK 開始編輯，或按下 Cancel 讓程式幫你開啟一個新的報表格式檔。 

 

 
圖 8-1  開啟報表格式檔視窗 

 
在完成上述選檔的步驟後，顯示出 Report Editor 主畫面視窗如圖 8-2所示。 
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圖 8-2  報表格式編輯畫面 

 
 

8.2 環境說明 

 主視窗的標題列（Caption）中，字串“Report Editor – ”之後的文字即為目前

所編輯的報表格式檔的檔名（本例為“Chroma”）﹔若您選擇報表格式檔時按

下 取消，則檔名將被命名為“Untitled”，請在完成編輯報表格式後以選單功能

[Report]→[Save As]將此檔儲存為您所想要的檔名。 
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 主視窗的左上方有兩個下拉式選單，分別為 Test Item Category與 Test Items。

上方的 Test Item Category 下拉式選單可讓您選擇系統定義的測試項目

（System-defined items）或檔頭（Header）；下方的 Test Items下拉式選單可

讓您選擇目前所要編輯報表格式的測試項目。另外，在兩個下拉式選單下方有一

個進度列（Progress Bar），它是用來顯示目前讀取測試項目的報表格式的進度。 

 

 
 
 主視窗的右半部為報表格式的編輯區，您可在此編輯區中依所需編輯報表輸出格

式。編輯區中所顯示的內容即為目前測試項目的報表輸出格式，也就是說，每一

個測試項目的報表輸出格式是分別顯示和編輯的，當您選擇不同的測試項目時，

編輯區的報表格式也會立即更新。在編輯區中除“#”外其餘字元皆可使用，這

是因為我們利用“#”字元形成一個 Pattern 來代表一個變數，如“###.##”這

個 Pattern表示此變數有三位整數及兩位小數，長度為六個字元。在編輯區中每

一行的文字長度（含 Pattern）請不要超過 80個半形字元，以免在列印時會有資

料無法印出。 
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 主視窗的左下方的「Available Variables 視窗」列出目前 Test Item 的可用變數，

顯示資訊分別為變數的 Type、Call Name、Show Name 及 Data Type。目前

Type有三種：* (Header變數)、TC（Test Condition）及 TR（Test Result），而

Data Type共有十數種，包含 Integer、Float、Percent、Long、String、Char、

Integer[L]、Float[L]、Percent[L]、Float[]、Integer[]及 Vector Type。 

 

 
 
 變數的 Data Type 若為 Integer[L]、Float[L]或 Percent[L]，則表示其為與 Load

有關的變數，在報表產生時，程式會根據目前的格式及 Load 的數目自動展開。 

 
 變數的 Data Type若為 Integer、Integer[L]或 Integer[]時，您可以設定它在報表

產生時的顯示型態，分別可設定為 Integer（十進位數）、Binary（二進位）及

Hexadecimal（十六進位）三種型態。 
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 主視窗的下方有三個下拉式選單，Integral 與 Decimal 分別表示變數的長度格

式中的整數位數及小數位數。在您加入一個變數到編輯區時將會參考到這些資料，

形成 Pattern 以代表變數本身，以下圖為例，格式 6.3 的變數形成的 Pattern 為

######.###，Pattern長度為 10。 

 

 
 
 主視窗的右下方的「Referenced Variables 視窗」列出目前您已選取至報表格式

的變數，顯示的資訊為變數的 Call Name、Data Type 及 Number Type。 
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 若您選擇的變數其 Data Type為 Vector Type的話，則程式會再顯示一視窗，讓

您挑選這個 Vector 中的變數，如下圖所示。同樣的，若您選擇的變數 Data Type

為 Integer、Integer[L]或 Integer[]時，您可以設定它在報表產生時的顯示型態。

同時，在右下方的「Referenced Variables 視窗」顯示的變數 Call Name 為

“Vector Name / Variable Name”。 

 

 
 
 

8.3 操作說明 

8.3.1 加入變數至編輯區 

加入變數至編輯區之前，先在左上方「Test Item 視窗」中選取欲編輯的測試項目，接

著在左下方「Available Variables 視窗」中利用滑鼠點選一變數，之後設定變數的長

度，若 Number Type為可設定，您還可以設定它的顯示型態，然後再按下 Add>> 按

鈕，即可將該變數加入「Referenced Variables 視窗」和主視窗上方的編輯區之游標

處（變數在編輯區中是以 Pattern呈現）。 
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8.3.2 從編輯區中刪除變數 

若您要刪除一個變數，建議您在「Referenced Variables 視窗」中先用滑鼠點選欲刪

除的變數，然後按下<<Delete 鈕即可，此時「Referenced Variables 視窗」中被選

擇的變數會被刪除，同時在編輯區中相對應的 Pattern也會同時被移除。 

 
 

8.3.3 檢視編輯區中的變數 

編輯區中的變數是以 Pattern方式顯示，若您想知道這個變數的資訊，則您可以在

編輯區中的變數 Pattern上按一下滑鼠，此時「Referenced Variables 視窗」及

「Available Variables 視窗」會以反白顯示目前 Pattern的變數資訊，如圖 8-2所

示。 

 
您也可以在「Referenced Variables」視窗中某個變數上，按下滑鼠左鍵不放開，則

此時在編輯區會反白目前變數的 Pattern，而「Available Variables 視窗」也會跟著

顯示目前的變數資訊。 

 
 

8.3.4 設定編輯區的字型及顏色 

您可以利用選單[View]→[Set Editing Area Color...]來設定編輯區文字的顏色，按下

選單之後出現如下圖的視窗，您只要在顏色區域上按下滑鼠即可出現設定顏色的視窗

對話盒讓您挑選顏色。圖中，如果您想將目前設定儲存為預設值，您可以按下  Set 

Default 鈕，您隨時可利用 Use Default 取得之前儲存的顏色預設值。 
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圖 8-3  設定編輯區文字的顏色 

 
您可以利用選單[View]→[Set Font...]來設定編輯區文字的字型，之前會出現如下圖

所示的視窗，您可以選擇字型、字型樣式及字型大小。建議您使用每個字元大小都一

樣的字型，使得報表字元可以對齊顯示，如 Courier New等。 

 

 
圖 8-4  設定編輯區文字的字型 

 
 

8.3.5 提示視窗（Hint Window） 

在「Available Variables 視窗」中按下滑鼠左鍵不放開時，會出現提示視窗（Hint 

Window），提示視窗比「Available Variables 視窗」有更進一步相關於變數的資料，
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如下圖黃色區域所示。您可以利用選單功能[View]→[Show Hint Window]來選擇是

否讓程式出現提示視窗。 

 

 
圖 8-5  提示視窗 

 
 

8.3.6 設定字元集 

您可以利用選單功能[View]→[Set Char Set...]設定程式目前使用的字元集。 

 

 
圖 8-6  設定字元集 
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8.3.7 關於 Report Editor 

您可以利用選單功能[Help]→[About...]取得關於本程式的相關訊息。 

 

 
 
 

8.3.8 選單說明 

[Report]→[New] 新增一個報表輸出格式檔 

[Report]→[Open...] 開啟一個已存在的報表格式檔（*.Rpf） 

[Report]→[Save] 儲存您正在編輯的報表輸出格式。如果您編輯的

是新的報表格式（即檔名為 Untitled）時，則會出

現「另存新檔」對話盒以讓您指定所欲存入的檔

名。 

[Report]→[Save As...] 將正在編輯的檔案存成另一檔名 

[Report]→[Exit] 結束本程式，回到 Adapter / Charger ATS系統

軟體的主畫面。 

  
[View]→[Set Editing Area 

Color...] 

設定編輯區文字顏色 

[View]→[Set Font...] 設定編輯區文字字型 

[View]→[Set Char Set...] 設定程式字元集 

[View]→[Show Hint Window] 設定是否顯示提示視窗 

  
[Help]→[About...] 顯示本程式的版本資訊 
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9. 報表產生器 

9.1 執行程式 

執行報表產生程式可由兩方法，一是在離線（Off-line）模式，在 Adapter / Charger 

ATS系統軟體的主畫面中選擇 Report Generator 選項後，便會執行「報表產生程

式」，此時會顯示「選擇欲列印資料視窗」；另外一執行方法就是在線上（On-line）模

式，在測試期間由「Execution Control」程式自動呼叫，並將測試結果傳送至本程式，

但線上模式不會產生「選擇欲列印資料視窗」。 

 

 
圖 9-1  選擇欲列印資料視窗 
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離線模式下，在您選擇了欲列印資料後，會顯示報表產生器的主視窗，程式會根據您

選擇的測試程式（Test Program）、測試日期（Date）及待測物序號（UUT Serial No.）

搭配報表格式檔（Report Format File）中測試項目（Test Item）的報表格式來產生

最後的報表。 

 

 
圖 9-2  報表產生器的主視窗 

 
 

9.2 環境說明 

在本程式的主視窗中有一個編輯視窗（以下稱之為資料顯示區），我們用它來展示最

後的報表產生結果，其屬性為唯讀（read-only）。由於資料顯示區一次只能顯示一個

待測物的報表，所以我們使用頁面（Tab）來區隔開各個待測物（UUT）之間的報表，

如圖 9-3所示。 
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圖 9-3  資料顯示區的其中一個頁面 

 
頁面的數量會等於您在「選擇欲列印資料視窗」中所選取得待測物序號數，也就是說，

每一個待測物我們用一個頁面來表示，頁面的標題（Title）就是待測物序號。當您想

觀看某個待測物的報表產生結果時，您只需要在該待測物序號頁面上按下滑鼠左鍵，

程式會自動幫您產生報表，顯示在資料顯示區上。 

 
主視窗下方的狀態列（Status Bar）上的指示器（Indicator）會顯示目前的程式模式，

離線模式時顯示 Off-line，線上模式時則顯示 On-line。另外，產生報表需要部份時間，

所以在您切換頁面以產生不同報表時，狀態列上的進度指示器（Progress Bar）會啟

動，您可以由此知道目前報表產生的進度。 

 

 
圖 9-4  主視窗下方的狀態列 

 
 

9.3 操作說明 

在線上模式的測試過程中，「Execution Control」會自動將待測物的測試結果及數據

儲存在資料庫中，以利您可以隨時利用本程式的離線模式來產生報表。故離線模式就

是藉由測試過程中所得的數據來產生報表，若之前沒有測試資料，本程式將無法產生

任何報表。 
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9.3.1 選擇欲列印資料視窗 

離線模式執行時，會出現「選擇欲列印資料視窗（Select data of tested UUTs from 

database）」讓您選擇欲產生報表的資料，您也可以利用選單功能[File]→[Open Log 

Database]來開啟此視窗。操作步驟如下： 

 

 
圖 9-5  選擇欲列印資料視窗 

 
1. 先利用視窗上方的 Test Programs 下拉式選單來選擇欲開啟的測試程式，程式會

根據您選擇的測試程式，更新 Report Format File 及 Test Date的內容。 

 

2. 之後您可以利用 Test Date下拉式選單選擇測試日期，再利用 All、 Pass 

UUT Only 及 Fail UUT Only 並按下 Search UUT… 來過濾出想要的待測
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物。此時 Tested UUT SerialNo視窗的內容會顯示該日期中所測試過的待測物

序號（UUT Serial No）， 此外您也可以利用 Report Format File 下拉式選單來

選擇欲搭配的報表格式檔。 

 

3. 選擇待測物的序號（Serial No.）時，您可以利用 Select All 或 Select None 

按鈕來選擇全部或取消選取，若您欲一次選擇多個待測物序號，則您可以利用滑

鼠左鍵拖拉（Drag & Drop）的方式來連續選取，若您要選擇多個不連續的待測

物序號，您可以按住鍵盤左下方 Ctrl 鍵不放，再利用滑鼠點選您欲選擇的待測

物序號即可。 

 
4. 若您想知道待測物的測試項目（Sequence），您可以單選一個待測物序號，然後

按下選單 [Show]→ [Sequences…]，即會出現一視窗如圖  9-6，視窗中

Sequences of the UUT 列示盒中會顯示待測物的測試項目。 

 

5. 當設定完成時，按 OK 鈕讓程式幫您產生報表。 

 

 
圖 9-6  待測物的測試項目視窗 

 
 

9.3.2 資料顯示區說明 

資料顯示區內容包含二部份：待測物檔頭資訊（Header Information）及測試項目

（Sequence）報表內容，每個待測物都有一份 Head Information，而測試項目的多

寡會根據該測試程式的內容而定。 
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圖 9-7  資料顯示區 

 

 關於測試項目的內容，使用者可利用主畫面的 Report Editor 程

式來編輯，其 Reading值由 GO/NOGO 測試程式取得，詳細情

形請參考兩者之使用說明手冊。 

 
 

9.3.3 選擇／切換待測物報表 

您只需要在該待測物序號頁面上按下滑鼠左鍵，程式會根據待測物資料自動幫您產

生該待測物報表，顯示在資料顯示區上。 

 
 

提示
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9.3.4 檔頭資訊（Head Information） 

待測物的檔頭資訊（Header Information）包含 Test Program Name、Serial No、

Model Name、Lot Number、Order Number、Inspector、Environment、Customer、

Elapsed Time、Test Result 及 System Time。您可以利用選單功能[Show]→[Header]

來設定是否將這些檔頭資訊顯示在資料顯示區報表當中。檔頭資訊的格式使用者可自

行利用主畫面的 Report Editor 程式編輯之，而編輯完的結果將儲存在報表格式檔

中。 

 

 
圖 9-8  待測物的檔頭資訊 

 
 

9.3.5 設定編輯區的顏色 

您可以利用選單[View]→[Set Color...]來設定編輯區文字的顏色，之後出現如圖 9-9

的視窗，您只要在顏色區域上按下滑鼠即可出現設定顏色的視窗對話盒讓您挑選顏色。

圖 9-9中，如果您想將目前設定儲存為預設值，您可以按下 Save As Default 鈕；

您隨時可利用 Load Default 取得之前儲存的顏色預設值。 
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圖 9-9  設定編輯區文字的顏色 

 
說明如下： 

 
Text 一般文字顏色(固定黑色，不提供設定) 

Background 背景顏色 

Variable / Spec Setting值的顏色 

Variable / Pass Pass Reading值的顏色 

Variable / Fail Fail Reading值的顏色 

Variable Not Found 找不到變數，變數值以符號“?”代替。 

Variable Format Error 變數格式位數不足，無法顯示正確數值，變數值以

符號“X”代替。 

Seq. Ext. Name 在每一塊測項的報表的第一行中，內容包括 Seq. 

No、Seq. Name、Seq. Ext. Name、Elapsed Time

等，而其中的 Seq. Ext. Name可以特別指定不同的

顏色。 
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9.3.6 設定編輯區的字型 

您可以利用選單[View]→[Set Font...]來設定資料顯示區的字型，之後會出現如圖 

9-10 所示的視窗，您可以選擇字型、字型樣式及字型大小。您也可以利用選單功能

[View]→[Reset Font (Report Format File)]回復到程式預設的字型。 

 

 
圖 9-10  設定資料顯示區的字型 

 

 
程式預設的字型為 Courier New、標準樣式、大小 11。 

 
 

9.3.7 顯示／列印測試項目 

您可以利用選單功能[Show]→[Sequences...]選擇只顯示部份測試項目

（Sequence）的報表，之後會出現「選擇測試項目視窗」，如圖 9-11所示： 

 

提示



配接器/充電器自動測試系統 8020使用手冊 

 9-10 

 
圖 9-11  選擇測試項目視窗 

 

選擇測試項目時，您可以利用 Select All 或 Select None 按鈕來選擇全部或取消

選取，若您欲一次選擇多個測試項目，則您可以利用滑鼠左鍵拖拉的方式來連續選取；

若您要選擇多個不連續的測試項目，您可以按住鍵盤左下方 Ctrl 鍵不放，再利用滑

鼠點選您欲選擇的測試項目即可。 

 
如果您要顯示全部的測試項目，您可以利用選單功能[Show]→[All Sequences]達成。

如果您只需要列印部份的測試項目報表的話，請先依照上面方式選擇部份的測試項目，

然後再利用選單功能的[File]→[Print]來列印即可。 

 
 

9.3.8 預覽列印 

您可以使用選單功能[File]→[Print Preview]進入預覽列印模式。預覽列印為將資料

顯示區的內容模擬列印動作完成後之實際報表的狀況所見即所得的顯示在螢幕上，您

可利用 拉進(I) 、 拉遠(O)、上一頁(V)及下一頁(N)操作顯示之內容。若欲直接列印

則可選擇 列印(P) ，回到資料顯示區請按 關閉(C) 。 
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圖 9-12  預覽列印 

 

 
預覽列印及列印的字型皆使用 Courier New字型，與資料顯示字

型設定無關。 

 
 

9.3.9 直接列印 

欲對資料顯示區內容做直接列印，不透過列印之前的預覽動作，您可以利用功能選單

[File]→[Print(“Courier New” Only)...]來完成，此時會出現「列印視窗」，讓您選定

印表機、選擇列印頁數及份數的視窗。按下確定 即可直接列印。 

 

提示
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圖 9-13  列印視窗 

 
 

9.3.10 儲存／全部儲存 

您可以利用選單功能[File]→[Save Current Tab...]來儲存目前內容顯示區的報表資

料。您可以選擇儲存成一般文字檔（TXT），可由一般文字編輯器開啟，或儲存成 Rich 

Editor Format Files（RTF）檔，可由 Microsoft Word及WordPad程式開啟；兩者不

同的是，RTF檔可以一併儲存目前的格式，包含字型、顏色及大小等資訊。 

 

 
圖 9-14  儲存 
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若您想要一次將全部待測物的報表儲存，您可以利用選單功能[File]→[Save All...]來

完成。此時程式會一個一個詢問您欲儲存檔案的名稱，您可以給予新的名稱或用程式

給予的預設值（通常是待測物的序號）。 

 
 

9.3.11 列印選項 

您可以利用選單功能[File]→[Print Option...]來設定列印選項，包括是否跳頁、是否

顯示頁首及其內容與是否顯示頁碼。 

 
當您選擇要跳頁時，程式在列印報表的時候會自動檢查每一頁剩餘的行數是否足夠再

放進下一個測試項目的報表內容，盡量避免一個測試項目的報表內容被分割成兩頁。

頁首是指列印報表時每一頁最上方要加進去的文字，本程式限制使用者最多能顯示三

行的頁首。 

 
當您選擇要顯示頁碼時，程式在列印報表的時候會在每一頁下方中央位置加入該頁的

頁碼，例如“P 1/20”乃表示此列印報表總共有 20頁而此頁為第 1頁。 

 

 
圖 9-15  列印選項 

 
 

9.3.12 傳送郵件選項 

Adapter / Charger ATS系統軟體可以將報表產生器產生的報表，透過「MailGen」程

式，以附加檔案的方式傳送到使用者指定的電子郵件信箱，您可以利用選單功能
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[Options]→[Auto Mail...]來設定什麼時候傳送以及收件人的電子郵件住址，其產生

的對話盒共有三頁，此處特別說明第一頁的內容。 

 

 
圖 9-16  MailGen 

 
這一頁的選項包括打開／關閉整個傳送郵件功能，以及各個測試程式所產生的報表是

否要傳送，Adapter / Charger ATS系統軟體安裝目錄下必須有某個測試程式的測試

資料，該測試程式才會出現在對話盒中讓使用者設定。「UUT Testing Date / Time」

欄位顯示此測試程式最近一次傳送的UUT的測試時間，等到下一次傳送的時間到時，

會從此 UUT 的測試時間以後所測的 UUT 開始傳送，使用者可以自行修改「UUT 

Testing Date / Time」欄位以達到控制傳送哪些 UUT的目的。 

 
 

9.3.13 選單說明 

[File]→[Open Log Database…] 設定欲開啟報表之資訊，並產生報表。 

[File]→[Save Current Tab…] 儲存目前待測物報表 

[File]→[Save All…] 將所有待測物報表全部存檔 

[File]→[Print (“Courier New” 

Only)…] 

直接列印 

[File]→[Print Preview] 預覽列印 
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[File]→[Print Setup…] 設定印表機 

[File]→[Print Option…] 自定列印選項，包括跳頁、頁首與頁碼。 

[File]→[Exit] 結束本程式，回到 Adapter / Charger ATS系

統軟體的主畫面。 

  
[View]→[Toolbar] 設定是否顯示工作列 

[View]→[Status Bar] 設定是否顯示狀態列 

[View]→[Set Font…] 設定資料顯示區字型 

[View]→[Reset Font (Report 

Format File)] 

使用報表格式檔預設的字型 

[View]→[Set Color…] 設定資料顯示區顏色 

  
[Show]→[Header] 設定是否顯示檔頭資訊 

[Show]→[Pre and Post Test 

Sequences] 

設定是否顯示 Pre and Post測試項目報表內

容 

[Show]→[Sequences Name 

and Pass / Fail] 

設定是否顯示測試項目名稱以及該測試項目

的測試結果 

[Show]→[Step No] 設定是否顯示測試流程號碼 

[Show]→[Sequences No] 設定是否顯示測試項目序號 

[Show]→[TI Name] 設定是否顯示測試項目的名稱 

[Show]→[Ext. Name] 設定是否顯示測試項目的 Ext名稱 

[Show]→[Sequences Elapsed 

Time] 

設定是否顯示每個測試項目執行所花的時間 

[Show]→[Separator] 設定是否顯示兩兩測試項目間的分隔線 

[Show]→[Separator Option…] 設定兩測試項目間的分隔線的樣式 

[Show]→[Start Position of 

Sequences Pass / Fail…] 

設定 Pass及 Fail在報表上顯示的位置 

[Show]→[Sequences…] 顯示部份測試項目報表 

[Show]→[All Sequences] 顯示全部測試項目報表 

[Show]→[Fail Report] 顯示 Fail 報表，此特殊模式僅會顯示 Fail 

Seq.的資料 (註：僅在 Online 報表時才有此

選項) 

  
[Options]→[Auto Mail…] 設定什麼時候傳送報表郵件以及收件人的電

子郵件住址等 

[Options]→[Fail Reading…] 設定是否在 Fail Reading前加上識別字元 

  
[Help]→[About RptGen...] 顯示本程式的版本資訊 
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10. 管理系統可運用的資源 

當您在Adapter / Charger ATS系統軟體主畫面中選擇 Management 選項後，即可

進入Management功能，而其中尚可區分為User（使用者管理功能）、Activity Log（使

用者活動記錄瀏覽功能）、Test Program（測試程式管理功能）、H/W Configuration 

File（儀器組態設定檔管理功能）、Log Data（測試結果資料管理功能）、Fixture ID（治

具型號管理功能），以及Net Extension（網路相關擴充功能）等七項子功能，分別敘

述如下： 

 
 

10.1 使用者管理功能 

點選畫面上方的「User」標籤即可顯示使用者管理功能畫面。在本系統中，使用者的

權限是以功能來做區分的，而使用層級是用來定義所能使用的功能有那些。每個使用

者都會被賦與一個使用層級，而使用者所能使用的功能就被其所屬的使用層級所定義；

如果兩個使用者的使用層級名稱（Level Name）相同，則這兩個使用者所能使用的功

能也就相同。 
 
 

10.1.1 使用者資訊 

在「User」頁次中，點選上方的User ID可顯示目前已經定義的使用者，以及其相關

的資訊。畫面中的User Name、Level Name、Expired Date、Comment及Active分別

表示使用者的名稱、使用層級、有效期限、備註說明及是否有效。 
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圖 10-1  使用者管理設定視窗 

 

 
圖 10-2  新增使用者對話盒 

 

Add 新增使用者。所需輸入之資訊除了上面所述之外，還有使用者密碼

（Password）。 

Edit 修改目前選擇的使用者的資訊 

Delete 刪除目前選擇的使用者 
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10.1.2 使用者層級 

在「User」頁次中，點選上方的User Level可顯示目前已經定義的使用層級及其所能

使用的功能。 

 
本系統中有兩個預設的使用層級，其名稱分別為op及supervisor。使用層級為op的使

用者在一進入系統時，會自動進入GO/NOGO功能中；而使用層級為supervisor的使

用者則能夠使用所有的功能。這兩個預設的使用層級是無法被刪除或修改的。 
 

 
圖 10-3  使用者權限設定視窗 

 

Add 新增使用層級。按下此按鈕後，原本的 Edit 及 Delete 按鈕會分別

變成 Update及 Cancel按鈕，當輸入完成後請按下 Update按鈕，

若要取消則請按下 Cancel按鈕。 

Edit 修改目前選擇的使用層級。按下此按鈕後，原本的 Edit 及 Delete

按鈕會分別變成 Update 及 Cancel 按鈕，當輸入完成後請按下

Update按鈕，若要取消則請按下 Cancel按鈕。 

Delete 刪除目前選擇的使用者 
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10.2 使用者活動記錄瀏覽功能 

點選畫面上方的「Activity Log」標籤即可顯示使用者活動記錄功能畫面。本系統會記

錄使用者進入及離開Adapter / Charger ATS系統軟體的時間，以及使用者使用過那些

功能。 
 

 
圖 10-4  使用者活動記錄瀏覽視窗 

 

Clear 清除所有的使用者活動記錄 

 
 

10.3 測試程式管理功能 

點選畫面上方的「Test Program」標籤即可顯示測試程式管理功能畫面。此處可以變

更測試程式的發行（Release）狀態、匯出／匯入測試程式、刪除測試程式。 

 
測試程式匯出時，會將匯出的測試程式及其所使用的報表格式資料記錄在一個副檔

名為.tpx的檔案中，而匯入測試程式時也是讀取此類檔案。藉由測試程式的匯出/匯

入功能，可以使不同的 Chroma 8020系統使用相同的測試程式，而不需要重覆的編

寫此測試程式。 
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圖 10-5  測試程式發行視窗 

 

Export 匯出目前選擇的測試程式，包含其所使用的報表格式檔及硬體組

態設定檔。 

Import 匯入測試程式，包含其所使用的報表格式檔及硬體組態設定檔。

若系統中已存在同名且相同之測試程式，或測試程式尚未發行，

則會詢問是否要覆蓋；而若系統中已存在同名且不相同之已發行

測試程式，則不允許匯入。 

Delete 刪除目前選擇的測試程式 

 
 

10.4 儀器組態設定檔管理功能 

點選畫面上方的「H/W Configuration File」標籤即可顯示儀器組態設定檔管理功能畫

面。此處可以匯出、匯入或刪除儀器組態設定檔。 
 

使用匯出功能時，會將所有選到的儀器組態設定檔的資料記錄在一個副檔名為.hwx的

檔案中，而匯入儀器組態設定檔時也是讀取此類檔案。 
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圖 10-6  儀器組態設定檔管理視窗 

 

Export 匯出目前選擇的儀器組態設定檔 

Import 匯入儀器組態設定檔。當選取一個副檔名為.hwx 的檔案後，程式會

將其中所包含的所有儀器組態設定檔列在一個視窗中以供選擇，若

系統中已存在同名之儀器組態設定檔，則會詢問是否要更改名稱。 

Delete 刪除目前選擇的儀器組態設定檔 

 
 

10.5 測試結果資料管理功能 

點選畫面上方的「Log Data」標籤即可顯示測試結果資料管理功能畫面。此處可以匯

出、匯入或刪除測試結果資料，藉由匯出與匯入的功能，可以將測試結果資料拿到不

同的Chroma 8020系統中做報表列印或統計分析等功能。 

 
測試資料匯出時，會將匯出的測試結果資料記錄在一個副檔名為.lgx的檔案中，而匯

入測試結果資料時也是讀取此類檔案。 
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圖 10-7  測試結果資料匯入匯出視窗 

 

Export 匯出目前選擇的測試結果資料 

Import 匯入測試結果資料 

Delete 刪除目前選擇的測試結果資料 

 
 

10.6 治具型號管理功能 

點選畫面上方的「Fixture ID」標籤即可顯示治具型號管理功能畫面。此處可以匯出、

匯入或刪除治具所適用的型號，只有出現在這個畫面中的型號才以可在測試程式中被

選用，配合Fixture ID Card，可在測試時檢查治具的狀態。請參考Fixture ID Card的

使用手冊。 
 

使用匯出功能時，會將所有選到的型號記錄在一個副檔名為.fix 的檔案中，而匯入時

也是讀取此類檔案。當使用 Fixture ID Editor 新建立一個新的治具所適用的型號後，

請先使用 Fixture ID Editor 中的 Utility/Export 功能匯出成.fix檔，然後就可以在此匯

入到系統中。 
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圖 10-8  治具型號管理功能視窗 

 

Export 匯出目前選擇的型號 

Import 匯入治具所適用的型號。當選取一個副檔名為.fix 的檔案後，程式

會將其中所包含的所有型號列在一個視窗中以供選擇。 

Delete 刪除目前選擇的型號 

 
 

10.7 網路相關擴充功能 

點選畫面上方的「Net Extension」標籤即可顯示網路相關擴充功能畫面。目前只有提

供Remote TP功能，此功能可將測試程式匯出到某一指定的遠端目錄中，而讓許多不

同的Chroma 8020系統在GO/NOGO程式中可直接開啟這些匯出的測試程式來執行

測試，如此可達到測試程式集中管理的功能。 
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圖 10-9  網路相關擴充功能視窗 

 

Setting… 可啟用／停用 Remote TP功能, 並設定 Remote TP所在之目

錄。所有要使用 Remote TP的 Chroma 8020系統必需要在此將

Remote TP啟用並正確地設定目錄。而 Remote TP啟用後只影

響 GO/NOGO，使其只能開啟 Remote TP的測試程式，而不會

改變到 Chroma 8020系統的其他功能。 

Upload 將所選擇的 Chroma 8020系統中的測試程式匯出到遠端 

Download 將所選擇的遠端的測試程式匯入到 Chroma 8020系統中 

Delete 刪除遠端目前選擇的測試程式 

 
Local H/W Config：若某一 Chroma 8020系統所需的硬體組態設定檔與 Remote TP

上的不同，則可以在畫面右邊表格的 Local H/W Config 欄位選用 Local 的硬體組態

設定檔。 
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11. 統計製程管制 

本統計製程管制功能可將待測物（UUT）測試之後記錄的結果作統計分析。主要功能

有製程能力分析統計圖表（Process Capability Analysis）、平均數與全距管制圖

（Xbar&R Chart）、平均數與標準差管制圖（Xbar&S Chart）、柏拉圖（Pareto Chart）、

不良數管制圖（np Chart）、不良率管制圖（p Chart）、缺點數管制圖（c Chart）及缺

點率管制圖（u Chart）等共8種；本功能還可以將各個統計圖的圖型儲存為圖檔

（Bitmap File）。 
 

在統計製程管制功能外，本功能還提供匯出讀值變數的內容到EXCEL／文字檔中，使

您可以將測試之後記錄的結果送往其它工具程式繼續使用。 

 
 

11.1 開啟統計記錄檔 

當您在Adapter / Charger ATS系統軟體的主畫面上，按下 Statistics 選項之後，畫

面便會顯示出如圖 11-1所示的「Statistics」視窗。 
 

「Statistics」視窗中，共分為二頁，第一頁“Data Source Setting”，可讓您欲設定進

行統計的起始及結束日期，詳細說明請參考11.2節之說明。第二頁“Constraint Setting”，

提供您設定篩選條件過濾測試資料，詳細說明請參考11.3節之說明。 
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圖 11-1 「Statistics」視窗 

 

在進行統計分析前，首先必須開啟統計記錄檔（*.spc），按下工具列 Open後，即

可選取系統存在的統計記錄檔，如圖 11-2（預設目錄為“安裝目錄\Spc”）；在您按下

選擇的統計記錄檔時，在圖 11-2上方會顯示統計記錄檔內所指定的測試程式名稱。 

 
當開啟統計記錄檔完成後，便可開始選擇統計的資料來源請參考11.2節之說明。 
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圖 11-2  開啟統計記錄檔 

 
 

11.2 選擇統計的資料來源 

選擇統計的資料來源，首先選擇「Data Source Setting」頁次，統計記錄檔的測試程

式名稱會顯示在 Test Program 欄位中，接著在 Log Data欄位中設定所欲統計之資料

的起始日與終止日，以選取此段期間中的測試結果資料，如圖 11-3。 
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圖 11-3  設定統計資料的起始日與終止日 

 
接著設定統計的資料來源（Log Data Search Path），一般是使用系統預設測試結果

資料Log目錄（Use Default Log Data Directory），或是使用自定的目錄群（Use Path 

List），提供統計程式到這些目錄尋找測試結果資料，並且可合併兩個以上的

PowerProIII測台測試結果資料，一起作統計製程管制圖。此外，若有重測資料欲取代

原測試資料時，必須選取核取方塊 Merge Retest Data 即可。 
 

 Use Default Log Data Directory  使用系統預設測試結果資料Log目錄 

 Use Path List     使用自定的目錄群 
 

Add Directory 增加自定目錄，選擇目錄即可，在視窗下方會顯示出選取的目錄下

所含的測試後結果記錄資料庫檔案，如圖 11-4。 
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圖 11-4  增加自定目錄 

 
Delete 刪除游標所在的自定目錄 

 

 
 合併重測資料功能（Merge Retest Data），若是同樣的序號則

當作是重測的資料。 

 使用合併重測資料功能（Merge Retest Data），務必注意重測

資料檔是否使用同一測試程式，否則會遭遇錯誤。 

 各待測物的測試日期，以所選取出來的測試資料之日期為準。 

 
重測資料取代原測試資料的原則： 

 
當原測試資料中某待測物（UUT）在重測資料中也找到此待測物（UUT）之序號（Serial 

No.）時，則以重測資料取代原測試資料，其餘則仍採用原測試資料。此外，若設有

篩選條件過濾測試資料時，原測試資料及重測資料都必須經篩選條件過濾後，通過者

的測試資料才會被顯示以供統計分析之用。 

 
 設定統計資料的起始日與終止日之日期格式為 YYYY/MM/DD 

YYYY  ：表西元年份，例如 2000。 

MM  ：表月份，例如五月份為 05。（範圍：1~12） 

DD  ：表日期，例如 25日為 25。（範圍：1~31） 

上述日期格式為 2000/05/25。 

使用日期設定右方的上下鍵可以改變日期，請注意，起始日期要比終止日期還

早。 

 
 

提示
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11.3 設定篩選條件過濾測試資料 

設定篩選條件過濾測試資料，首先選擇 Constraint Setting 頁次，此頁分成 SerialNo 

Constraint、Generial Constraint 及 Variable Constraint 三部份，除了參數名稱

(Variable)的設定不同外－SerialNo 的參數固定設為“SerialNo”，General Constraint

與 VariableConstraint 的參數則為一個下拉選單；其餘的皆相同，中間下拉式選單 OP

提供選擇運算元（=、<>、<、>、>=、<=），Value 的編輯框提供輸入設定條件值，

當上述三項篩選條件輸入完畢後，按下 Add 按鍵即可將此篩選條件轉換成資料庫查

詢條件並顯示於下方列示表單中，反之按 Delete 按鈕可將列示表單中被選擇的資料

庫查詢條件去除，如圖 11-5。 

 

 
圖 11-5  設定篩選條件過濾測試資料 

 
將統計的資料來源及篩選過濾測試資料條件設定好後，即可以開始取出測試資料，

進行各種統計分析。以下分別介紹各種統計管制圖表的用法。 
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11.4 製程能力分析統計圖表（Process 

Capability Analysis） 

進行製程能力分析，按下工具列 （Process Capability Analysis）後，即顯示製

程能力分析統計圖表參數設定畫面，如圖 11-6中，左方顯示此測試程式在 SPC Log 

Setting 功能中篩選出的所有讀值變數。右方顯示左側被選擇讀值變數的所有測試讀

值，當使用者更換選取左側不同讀值變數時，右側會更新為此讀值變數的所有測試讀

值。按下[Select Wizard]會呈現如圖 11-7 的對話盒，透過條件設定，可以快速的依

條件選擇所需的變數，並可將條件儲存成檔案。 

 

 
圖 11-6  製程能力分析統計圖表參數設定－資料 
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圖 11-7  變數選擇精靈 

 

 
圖 11-8  製程能力分析統計圖表參數設定－統計參數 
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圖 11-9  製程能力分析統計圖表參數設定－列印基本資料設定 

 

Logged Variable 表格：（圖 11-6，製程能力分析統計圖表參數設定－資料）顯示

讀值變數的相關資訊，重要欄位說明如下。 

 
No. 讀值變數流水號 

Call Name 讀值變數 Call Name 

Load No. 陣列變數的索引值，如果此變數為非陣列變數，索引值為 1。 

Seq. Seq.號碼 

Test Item 測試項目名稱 

Sel 讀值變數核取方塊，被選取後於預覽統計圖表結果或列印，會有

此讀值變數統計圖表結果。 

Remark 讀值變數註解說明 

MaxSpec 讀值變數的參考規格上限變數名稱 

MinSpec 讀值變數的參考規格下限變數名稱 

Variable 讀值變數名稱 

 

 
Sel欄位之核取方塊，提供對多讀值變數統計圖表結果連續列印功

能。 
提示
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Select All  選取所有讀值變數，將所有讀值變數核取方塊設定為選取狀

態。 

UnSelect All  取消選取所有讀值變數，將所有讀值變數核取方塊設定為非選

取狀態。 

 
Value表格：顯示某讀值變數的測試讀值結果，重要欄位說明如下。 

 
No. 測試讀值流水號 

Serial No. 待測物（UUT）序號 

Value 測試讀值結果值 

Result 測試讀值成功或失敗（PASS／FAIL） 

Sel 測試讀值核取方塊，被選取後於預覽統計圖表結果或列印時，

會將此測試讀值列入統計運算。 

Variable ID 讀值變數識別代號 

 

Select All  選取所有測試讀值，將所有測試讀值核取方塊設定為選取狀

態。 

UnSelect All  取消選取所有測試讀值，將所有測試讀值核取方塊設定為非選

取狀態。 

 
製程能力分析統計圖表的設定參數：共分為兩頁，茲分別說明如下： 

 
「Parameter Setting」頁次（圖 11-8，製程能力分析統計圖表參數設定－統計參

數）： 

 
1)Spec. Max 設定選定變數的規格上限值，用以計算 Cp、Ca、Cpk 等

值。 

2)Spec. Min 設定選定變數的規格下限值，用以計算 Cp、Ca、Cpk 等

值。 

3)Sigma(Cpk) 選擇計算 Sigma的方式（n：用以計算整個母群體；n-

1：用以估算整個母群體。） 

4)Number of Bins 設定直方圖的區間數 
   
Use Sturges Rule 由所有讀值資料中取得最大值與最小值作為直方圖分隔區

間的最大值與最小值，並根據所有的樣本數計算區間數，

公式為：1+3.3*log（Sizeof(X)）。 

Use Custom Define 
Bins 

由使用者自定分隔區間的最大值與最小值及自定區間數 



統計製程管制 

 11-11 

Number 自定區間數 

Bin Max 分隔區間的最大值 

Bin Min 分隔區間的最小值 

 
Display Histogram 選擇是否顯示直方圖 

 

 
 Spec. Max 與 Spec. Min若未指定時，本程式會由此變數的所

有讀值中取出最大與最小值填入此兩欄位中。 

 作單邊管制圖表分析時，若無規格上限值需將 Spec. Max 欄

位輸入-9999，若無規格下限值需將 Spec. Min欄位輸入-

9999，使系統判定製作單邊管制圖表分析。若所選的資料，

其 Sigma趨近於 0，則無法計算並畫圖！ 

 
「Print Setting」頁次：如圖 11-9，製程能力分析統計圖表參數設定－列印基本資料

設定，其中除 Title、Model Name及 Condition可設定外，其餘各欄位均無法設定，

且一定會隨同圖表列印出。 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 

Model Name 待測物型別名稱。 

Test Item Name 測試項目（Test Item）名稱，此欄位僅用以顯示，您無法

更改其內容。 

Variable Name 變數名稱，此欄位僅用以顯示，您無法更改其內容。 

Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明，

當您按下 Edit Condition 後浮現一個輸入文字對話盒，

如圖 11-10，供您方便地能從測試程式中挑選出合適的

TestCondition類的變數內容，編輯成此欄的說明文字。 

 

提示
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圖 11-10  編輯測試條件設定 

 
左上方為可挑選的測試項目，在製程能力分析統計圖表中，只需選擇目前讀值變數所

屬的測試項目，左下方的小視窗，顯示的是左上方測試項目所有的測試條件變數；右

上方的視窗為編輯顯示的區域，其中以紅色表示的數字是由左方挑選過來的變數，右

下方顯示的是所有已挑選的變數。 
 

顯示統計圖表 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右方那些測試讀值要被列入統計

運算，最後將「Parameter Setting」與「Print Setting」兩頁之內容都設定好之後，

按下工具列 Print Preview按鈕，即可獲得如圖 11-11製程能力分析統計圖。 
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圖 11-11  製程能力分析統計圖表結果 

 
統計圖表結果是以預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接著顯

示統計圖表，下方列出統計計算數值結果，最後顯示各區間的結果。視窗上方有幾個

按鈕說明如下： 
 

列印(P) 列印此統計圖表結果 

下一頁(N) 預覽下一頁統計圖表結果 

前一頁(v) 預覽上一頁統計圖表結果 

兩頁(T) 以同時顯示兩頁的方式預覽統計圖表 

拉近(I) 將目前預覽統計圖表結果放大呈現 

拉遠(O) 將目前預覽統計圖表結果縮小呈現 

關閉(C) 關閉預覽統計圖表結果 
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儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入

統計運算，按下工具列 Save to Image Files 按鈕，出現儲存對話盒，如圖 

11-12所示的儲存圖檔對話盒。圖中左方為選取的變數，變數的命名為

VariableName_Sequence_LoadNo，右上方為一個設定特性的區域，可以設定是否

儲存Header、圖表、Data和圖型的大小，可個別設定每個變數圖檔的特性。右下方

為儲存檔案的目錄和自定檔名的部份，檔案的命名方式為使用者自定和自動設定，

自動設定的檔名為_ChartName，其中ChartName會在儲存時自行替換成左方的變

數名稱，檔案類型可由使用者選取為.bmp或.jpg。 

 

 
圖 11-12  儲存圖檔對話盒 

 

儲存計算資料 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save Computered Data to Excel File 按鈕，出現轉換設

定對話盒，如圖 11-13轉換設定資料，以及儲存對話盒，如圖 11-14儲存計算資料。 
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圖 11-13  轉換設定資料 

 

 
圖 11-14  儲存計算資料 

 
 

11.5 平均數與全距管制圖表（Xbar&R Chart） 

製作平均數與全距管制圖，按下工具列 （Xbar&R）後，即顯示平均數與全距管制

圖表參數設定畫面，如圖 11-15，左方顯示此測試程式在SPC Log Setting功能中篩

選出的所有變數，右方顯示左側被選擇變數的所有測試讀值，當使用者更換選取左側

不同變數時，右側會更新為此變數的所有測試讀值，而另外兩頁是平均數與全距管制

圖表的設定參數，以下分別介紹。 
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圖 11-15  平均數與全距管制圖表參數設定－資料 

 

 
圖 11-16  平均數與全距管制圖表參數設定－統計參數 
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圖 11-17  平均數與全距管制圖表參數設定－列印基本資料設定 

 
Logged Variable 表格：（圖 11-15，平均數與全距管制圖表參數設定－資料）顯示

讀值變數的相關資訊，重要欄位說明如下。 

 
No. 讀值變數流水號 

Call Name 讀值變數 CallName 

Load No. 陣列變數的索引值，如果此變數為非陣列變數，索引值為 1。 

Seq. Seq.號碼 

Test Item 測試項目名稱 

Sel 讀值變數核取方塊，被選取後於預覽統計圖表結果或列印時，

會有此讀值變數統計圖表結果。 

Remark 讀值變數註解說明 

MaxSpec 讀值變數的參考規格上限變數名稱 

MinSpec 讀值變數的參考規格下限變數名稱 

Variable 讀值變數名稱 

 

 
Sel欄位之核取方塊，提供對多讀值變數統計圖表結果連續列印功

能。 

 

Select All 選取所有讀值變數，將所有讀值變數核取方塊設定為選取狀

提示
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態。 

UnSelect All 取消選取所有讀值變數，將所有讀值變數核取方塊設定為非選

取狀態。 

 
Value表格：顯示某讀值變數的測試讀值結果，重要欄位說明如下。 

 
No. 測試讀值流水號 

Serial No 待測物（UUT）序號 

Value 測試讀值結果值 

Result 測試讀值成功或失敗（PASS／FAIL） 

Sel 測試讀值核取方塊，被選取後於預覽統計圖表結果或列印時，

會將此測試讀值列入統計運算。 

Variable ID 讀值變數識別代號 

 

Select All 選取所有測試讀值，將所有測試讀值核取方塊設定為選取狀

態。 

UnSelect All 取消選取所有測試讀值，將所有測試讀值核取方塊設定為非選

取狀態。 

 
「Parameter Setting」頁次：（圖 11-16，平均數與全距管制圖表參數設定－統計參

數） 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下線為幾倍的標準差 

3)Spec. Max/Min 設定選定變數的規格上下限值，用以計算 Cp、Ca、

Cpk 等值。 

4)Sigma(Cpk) 選擇計算 Sigma的方式（n：用以計算整個母群體；n-

1：用以估算整個母群體。） 

5)Limit Source 設定管制上下限來源 

 
 From Selected Data 以被選擇的測試讀值計算管制界線 

 Use Std Mean，R0 將下方輸入的 Std Mean與 R0作為基準值（standard 

value）以計算管制界線 

 Use Std Mean，
Sigma 

將下方輸入的 Std Mean與 Sigma作為標準值

（standard value）以計算管制界線 

Std Mean 設定基準平均值（standard mean value） 

Sigma or R0 設定基準標準差值（standard sigma value）或是基準

全距值（standard R0） 



統計製程管制 

 11-19 

 

 
 平均數與全距管制圖表亦會計算 Cp、Ca與 Cpk 值，因此必須

輸入規格上下限值（Spec. Max/Spec. Min）。 

 Spec. Max 與 Spec. Min若未指定時，本程式會由此變數的所

有讀值中取出最大最小值填入欄位中。 

 若為單邊管制時，若無規格上限值需將 Spec. Max 欄位輸入-

9999，若無規格下限值需將 Spec. Min欄位輸入-9999，使系

統判定作單邊管制分析。 

 若所選的資料，其 Sigma趨近於 0，則無法計算並畫圖！ 

 
「Print Setting」頁次，如圖 11-17，平均數與全距管制圖表參數設定－列印基本資

料設定： 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱，此欄位僅用以顯示，您無法更改

其內容。 
Variable Name 變數名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明。

當您按下Edit Condition 後浮現一個輸入文字對話盒，如圖 

11-10供您方便地能從測試程式中挑選出合適的Test 

Condition類的變數內容，編輯成此欄的說明文字。 

 

顯示統計表 

 
先選擇好左上方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入

統計運算，最後將Parameter Setting頁次與Print Setting頁次都設定好之後，按下

工具列 Print Preview，即可獲得圖 11-18平均數與全距管制圖表結果。 

 

提示
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圖 11-18  平均數與全距管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 
儲存統計圖 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入

統計運算，按下工具列 Save to Image Files 按鈕，出現儲存對話盒，如圖 

11-19。圖中左方為選取的變數，變數的命名為

VariableName_Sequence_LoadNo，右上方為一個設定特性的區域，可以設定是否

儲存Header、圖表、Data和圖型的大小，可個別設定每個變數圖檔的特性。右下方

為儲存檔案的目錄和自定檔名的部份，檔案的命名方式為使用者自定和自動設定，

自動設定的檔名為_ChartName，其中ChartName會在儲存時自行替換成左方的變

數名稱，檔案類型可由使用者選取為.bmp或.jpg。 
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圖 11-19  儲存圖檔對話盒 

 

儲存計算資料 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save Computered Data to Excel File 按鈕，出現儲存對

話盒，如圖 11-20儲存計算資料。 

 

 
圖 11-20  儲存計算資料 
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11.6 平均數與標準差管制圖（Xbar&S Chart） 

製作平均數與標準差管制圖，按下工具列 （Xbar&S）後，即顯示平均數與標準差

管制圖表參數設定畫面，如圖 11-21，左方顯示此測試程式在SPC Log Setting功能

中篩選的所有變數，右方顯示左側被選取變數的所有測試讀值，當使用者更換選取左

側不同變數時，右側會更新為此變數的所有測試讀值，而另外兩頁是平均數與標準差

管制圖表的設定參數，以下分別介紹。 

 

 
圖 11-21  平均數與標準差管制圖表參數設定－資料 
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圖 11-22  平均數與標準差管制圖表參數設定－統計參數 

 

 
圖 11-23  平均數與標準差管制圖表參數設定－列印基本資料設定 
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Logged Variable 表格：（圖 11-21）顯示讀值變數的相關資訊，重要欄位說明如

下。 

 
No. 讀值變數流水號 

Call Name 讀值變數 CallName 

Load No. 陣列變數的索引值，如果此變數為非陣列變數，索引值為 1。 

Seq. Seq.號碼 

Test Item 測試項目名稱 

Sel 讀值變數核取方塊，被選取後於預覽統計圖表結果或列印時，

會有此讀值變數統計圖表結果。 

Remark 讀值變數註解說明 

MaxSpec 讀值變數的參考規格上限變數名稱 

MinSpec 讀值變數的參考規格下限變數名稱 

Variable 讀值變數名稱 

 

 
Sel欄位之核取方塊，提供對多讀值變數統計圖表結果連續列印功

能。 

 
Select All 選取所有讀值變數，將所有讀值變數核取方塊設定為選取狀

態。 

UnSelect All 取消選取所有讀值變數，將所有讀值變數核取方塊設定為選取

狀態。 

 

Value表格：顯示某讀值變數的測試讀值結果，重要欄位說明如下。 

 
No. 測試讀值流水號 

Serial No 待測物（UUT）序號 

Value 測試讀值結果值 

Result 測試讀值成功或失敗（PASS／FAIL） 

Sel 測試讀值核取方塊，被選取後於預覽統計圖表結果或列印時，

會將此測試讀值列入統計運算。 

Variable ID 讀值變數識別代號 

 
Select All 選取所有測試讀值，將所有測試讀值核取方塊設定為選取狀

態。 

UnSelect All 取消選取所有測試讀值，將所有測試讀值核取方塊設定為非選

取狀態。 

 

提示
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「Parameter Setting」頁次：（圖 11-22） 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下線為幾倍的標準差 

3)Spec. Max/Min 設定選定變數的規格上限值，用以計算 Cp、Ca、Cpk

等值。 

4)Sigma(Cpk) 選擇計算 Sigma的方式（n：用以計算整個母群體；n-

1：用以估算整個母群體。） 

5)Limit Source 設定管制上下限來源 

 
 From Selected Data 以被選擇的測試讀值計算管制界線 

 Use Std Mean, s0 將下方輸入的 Std Mean與 s0作為基準值（standard 

value）以計算管制界線 

 Use Std Mean, 
Sigma 

將下方輸入的 Std Mean與 Sigma作為標準值

（standard value）以計算管制界線 

Std Mean 設定基準平均值（standard mean value） 

Sigma or s0 設定基準標準差值（standard sigma value）或是基準

s0值（standard s0） 

 

 
 平均數與標準差管制圖表亦會計算 Cp、Ca與 Cpk 值，因此

必須輸入規格上下限值（Spec. Max/Spec. Min）。 

 若未指定時，本程式會由此變數的所有讀值中取出最大最小

值填入欄位中。 

 若為單邊管制時，若無規格上限值需將 Spec. Max 欄位輸入-

9999，若無規格下限值需將 Spec. Min欄位輸入-9999，使系

統判定作單邊管制分析。 

 若所選的資料，其 Sigma趨近於 0，則無法計算並畫圖！ 

 
「Print Setting」頁次，如圖 11-23： 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱，此欄位僅用以顯示，您無法更改

其內容。 
Variable Name 變數名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明，

當您按下 Edit Condition 後浮現一個輸入文字對話盒，如圖 

提示
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11-10，供您方便地能從測試程式中挑選出合適的Test 

Condition類的變數內容，編輯成此欄的說明文字。 
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顯示統計圖表 

 
先選擇好左上方那些讀值變數要製作統計圖表，再選擇右方哪些測試讀值要被列入統

計運算，最後將「Parameter Setting」與「Print Setting」兩頁之內容都設定好之

後；按下工具列 Print Preview按鈕，即可獲得如圖 11-24平均數與標準差管制圖。 

 

 
圖 11-24  平均數與標準差管制圖表結果 

 

統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 
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儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-25。

圖中左方為選取的變數，變數的命名為VariableName_Sequence_LoadNo，右上方

為一個設定特性的區域，可以設定是否儲存Header、圖表、Data和圖型的大小，可個

別設定每個變數圖檔的特性。右下方為儲存檔案的目錄和自定檔名的部份，檔案的命

名方式為使用者自定和自動設定，自動設定的檔名為_ChartName，其中ChartName

會在儲存時自行替換成左方變數名稱，檔案類型可由使用者選取為.bmp或.jpg。 
 

 
圖 11-25  儲存圖檔對話盒 

 

儲存計算資料 

 
先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save Computered Data to Excel File 按鈕，出現儲存對

話盒，如圖 11-26儲存計算資料。 
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圖 11-26  儲存計算資料 

 
 

11.7 柏拉圖（Pareto Chart） 

本系統運用柏拉圖的方式，是將每一個待測物的各個測試程序之結果為失敗者視為缺

點，經統計分析運算所得之結果。 
 

製作柏拉圖，按下工具列 （Pareto Chart）後，即顯示柏拉圖表列印基本資料設

定畫面，如圖 11-27，上方顯示每一個待測物（UUT）各個測試程序（Sequence）

成功或失敗的結果（0為失敗，1為成功。） 
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圖 11-27  柏拉圖表列印基本資料設定畫面－資料 
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圖 11-28  柏拉圖表列印基本資料設定畫面－列印基本資料設定 

 
UUT表格：（圖 11-27）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 待測物（UUT）編號 

Sel 待測物測試結果核取方塊，被選取後於預覽統計圖表結果或列印

時，會將此測試結果列入統計運算。 

Serial No. 待測物（UUT）之序號 

 
其他欄位顯示各測試程序（Sequence）的測試結果為成功或失敗（1／0）。 

 

Select All 選取所有待測物（UUT）測試結果，將所有待測物測試結果核

取方塊設定為選取狀態。 

UnSelect All 取消選取所有待測物（UUT）測試結果，將所有待測物測試結

果核取方塊設定為非選取狀態。 

 

Print Setting 頁次：（圖 11-28） 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
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Model Name 待測物型別名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明，當

您按下 Edit Condition 後浮現一個輸入文字對話盒（參考圖 

11-29），供您方便地能從測試程式中挑選出合適的Test 

Condition 類的變數，編輯成此欄的說明文字。 
 

 
圖 11-29  編輯測試各條件設定 

 

左上方為可挑選的測試項目，在製程能力分析統計圖表中，只需

選擇目前讀值變數所屬的測試項目，左下方的小視窗，顯示的是

左上方測試項目所有的測試條件變數；右上方的視窗為編輯顯示

的區域，其中以紅色表示的數字是由左方挑選過來的變數，右下

方顯示的是，所有已挑選的變數。 

 

顯示統計圖表 
 

先由上方表格選擇好要被列入統計運算的待測物（UUT）結果，最後將Print Setting

該頁之內容設定好之後，按下工具列 Print Preview按鈕，即可獲得圖 11-30柏拉

圖表結果。 
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圖 11-30  柏拉圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，最後顯示各測試程序（Sequence）失敗的數量及相對百分比數值

結果，並依照各測試程序失敗的數量由多至少向下排序。 

 
儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-31。

圖中左方為圖型的名稱，為Pareto，右上方為一個設定特性的區域，可以設定是否儲

存Header、圖表、Data和圖型的大小。右下方為儲存檔案的目錄和自定檔名的部份，

檔案的命名方式為使用者自定和自動設定，自動設定的檔名為_Pareto，檔案類型可

由使用者選取為.bmp或.jpg。 
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圖 11-31  儲存圖檔對話盒 

 
 

11.8 不良數管制圖（np Chart） 

本系統運用不良數管制圖的方式，是針對每一個待測物的測試結果，若測試結果為失

敗者，將之視為不良，經統計分析運算所得之結果即為不良數管制圖。 

 

製作不良數管制圖，按下工具列 （np Chart）後，即顯示不良數管制圖表參數設

定畫面，如圖 11-32，上方表格中顯示每一個待測物（UUT）的測試結果，而下方是

設定不良數管制圖表參數，以下分別介紹。 
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圖 11-32  不良數管制圖表參數設定－資料 

 

 
圖 11-33  不良數管制圖表參數設定－統計設定 
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圖 11-34  不良數管制圖表參數設定－列印基本設定 

 
UUT表格：（圖 11-32）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 待測物之流水編號 

Sel 待測物測試結果核取方塊，被選取後於預覽統計圖表結

果或列印時，會將此測試結果列入統計運算。 

Serial No. 待測物之序號 

UUT Pass/Fail (1/0) 顯示待測物之測試結果為成功（1）或失敗（0） 

 
Select All 選取所有待測物測試結果，將所有待測物測試結果核取

方塊設定為選取狀態。 

UnSelect All 取消選取所有被測物測試結果，將所有待測物測試結果

核取方塊設定為非選取狀態。 

 

「Parameter Setting」頁次： 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下線為幾倍的標準差 

3)Limit Source 設定管制上下限來源 
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 From Selected 
Data 

以被選擇的待測物測試結果計算管制界線 

 Use Std p0 將下方輸入的 Std p0作為基準值（standard p0 

value）以計算管制界線中心線 

Std p0 設定基準 p0值（standard p0 value），並將 n*p0作為

管制界線中心線（n為樣本數大小）。 

 
「Print Setting」頁次，如圖 11-34其中除 Title及 Condition可設定外，其餘欄位

均無法設定且一定隨同圖表列印出。 

 
Title 列印標題設定 
Model Name 待測物型別名稱。 
Condition 列印測試條件設定，您可依實際測試條件，輸入測試條

件說明，當您按下 Edit Condition 後浮現一個輸入

文字對話盒（參考圖 11-29），供您方便地能從測試程

式中挑選出合適的TestCondition類的變數，編輯成此欄

的說明文字。 

 

顯示統計圖 
 

先由上方表格選擇好要列入統計運算的待測物結果，然後將「Parameter Setting」頁

次與「Print Setting」頁次都設定好之後，按下工具列 （Print Preview），即可獲

得如圖 11-35不良數管制圖。 
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圖 11-35  不良數管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 
儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入

統計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 

11-36。圖中左方為圖型的名稱，為NP Chart，右上方為一個設定特性的區域，可以

設定是否儲存Header、圖表、Data和圖型的大小。右下方為儲存檔案的目錄和自定
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檔名的部份，檔案的命名方式為使用者自定和自動設定，自動設定的檔名為

_NPChart，檔案類型可由使用者選取為.bmp或.jpg。 
 

 
圖 11-36  儲存圖檔對話盒 

 
 

11.9 不良率管制圖（p Chart） 

本系統運用不良率管制圖的方式，是將每一天所有待測物的測試結果為失敗之數量多

寡視為不良率，經統計分析運算所得之結果。 

 

製作不良率管制圖，按下工具列 （p Chart）後，即顯示不良率管制圖表參數設

定畫面，如圖 11-37，上方表格顯示每一個待測物（UUT）的測試結果，而下方是

設定不良率管制圖表參數，以下分別介紹。 
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圖 11-37  不良率管制圖表參數設定－資料 

 

 
圖 11-38  不良率管制圖表參數設定－統計設定 
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圖 11-39  不良率管制圖表參數設定－列印基本設定 

 
Date表格：（圖 11-37）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 依日期順序編訂之流水號 

Sel 各日期測試結果核取方塊，被選取後於預覽統計圖表結果

或列印時，會將此日期測試結果列入統計運算。 

Date 測試日期 

UUT Pass Counts 某日待測物測試結果為成功之數量 

UUT Fail Counts 某日待測物測試結果為失敗之數量 

UUT Total Counts 某日待測物的測試數量 

 

Select All 選取所有待測物測試結果，將所有待測物測試結果核取方

塊設定為選取狀態。 

UnSelect All 取消選取所有待測物測試結果，將所有待測物測試結果核

取方塊設定為非選取狀態。 

 
「Parameter Setting」頁次：（圖 11-38） 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下線為幾倍的標準差 

3)Limit Source 設定管制上下限來源 
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 From Selected Data 以被選擇的待測物測試結果計算管制界線 

 Use Std p0 將下方輸入的 Std p0作為基準值（standard p0 value）

作為管制界線中心線 

Std p0 設定基準 p0值（standard p0 value） 

 
「Print Setting」頁次，如圖 11-39： 

 
Title 列印標題設定 
Model Name 待測物型別名稱，僅用以顯示您無法更改其內容。 
Condition 列印測試條件設定，您可依實際測試條件，輸入測試條

件說明，當您按下 Edit Condition 後浮現一個輸入文

字對話盒（參考圖 11-29），供您方便地能從測試程式

中挑選出合適的TestCondition類的變數，編輯成此欄的

說明文字。 
 

顯示統計圖 
 

先選擇好上方要列入統計運算的測試日期結果，然後將「Parameter Setting」與「Print 

Setting」兩頁之內容都設定好之後，按下工具列 （Print Preview），即可獲得如圖 

11-40不良率管制圖。 
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圖 11-40  不良率管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示被測物於此測試項目的基本資料接

著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 
儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入

統計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 

11-41。圖中左方為圖型的名稱，為P Chart，右上方為一個設定特性的區域，可以

設定是否儲存Header、圖表、Data和圖型的大小。右下方為儲存檔案的目錄和自定

檔名的部份，檔案的命名方式為使用者自定和自動設定，自動設定的檔名為

_PChart，檔案類型可由使用者選取為.bmp或.jpg。 
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圖 11-41  儲存圖檔對話盒 

 
 

11.10 缺點數管制圖（c Chart） 

本系統運用缺點數管制圖的方式，是將每一個待測物之某一測試項目下，所有被記錄

的讀值變數之測試結果為失敗之數量多寡視為缺點數，經統計分析運算所得之結果。 

 

製作缺點數管制圖，按下工具列 （c Chart）後，即顯示缺點數管制圖表參數設定

畫面，如圖 11-42，左方顯示此測試程式的各個測試程序（Sequence），右方則根據

左側選擇的測試程序，將每一個待測物（UUT）於此測試程序之測試讀值成功或失敗

數量顯示出來，而另外幾頁是設定缺點數管制圖表參數，以下分別介紹。 
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圖 11-42  缺點數管制圖表參數設定－資料 

 

 
圖 11-43  缺點數管制圖表參數設定－統計設定 
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圖 11-44  缺點數管制圖表參數設定－列印基本設定 

 
Sequence表格：（圖 11-42的左方）顯示測試程序，欄位說明如下。 

 
Seq. 測試程序序號 

Sel 測試程序核取方塊，被選取後於預覽統計圖表結果或列印時，

會有此讀值變數統計圖表結果。 

Test Item 測試項目名稱 

 

 
Sel欄位之核取方塊，提供對多測試程序缺點數統計圖表結果連續

列印功能。 

 

Select All 選取所有測試程序，將所有測試程序核取方塊設定為選取狀

態。 

UnSelect All 取消選取所有測試程序，將所有測試程序核取方塊設定為非選

取狀態。 

 
UUT表格：（圖 11-42的右方）顯示待測物（UUT）相關資訊，重要欄位說明如

下。 

 
No. 待測物（UUT）測試結果流水號 

Sel 待測物（UUT）測試結果核取方塊，被選取後於預覽統計圖表

提示
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結果或列印時，會將此測試結果列入統計運算。 

Serial No. 待測物（UUT）序號 

Pass Count 待測物（UUT）於此測試程序之所有測試讀值結果為成功

（Pass）的數量 

Fail Count 待測物（UUT）於此測試程序之所有測試讀值結果為失敗（Fail）

的數量 

Total Count 待測物（UUT）於此測試程序之所有測試讀值結果的數量 

 

Select All 選取所有待測物（UUT）測試結果，將所有待測物測試結果核

取方塊設定為選取狀態。 

UnSelect All 取消選取所有待測物（UUT）測試結果，將所有待測物測試結

果核取方塊設定為非選取狀態。 

 

「Parameter Setting」頁次：（圖 11-43） 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下線為幾倍的標準差 

3)Limit Source 設定管制上下限來源 

 
 
 From Selected 
Data 

以被選擇的被測物測試結果計算管制界線 

 Use Std c0 將下方輸入的 Std c0作為基準值（standard c0 value）以

計算管制界線中心線 

Std c0 設定基準 c0值（standard c0 value），並將 c0作為管制界

線中心線。 

 
「Print Setting」頁次，如圖 11-44。 

 
Title 列印標題設定，您可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱。 
Condition 測試條件設定，您可依實際測試條件輸入測試條件說明，當

您按下Edit Condition後浮現一個輸入文字對話盒（參考

圖  11-29），供您方便地能從測試程式中挑選出合適的

TestCondition類的變數，編輯成此欄的說明文字。 
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顯示統計圖 
 

先選擇好上方要列入統計運算的待測物（UUT）結果，然後將「Parameter Setting」

頁次與「Print Setting」兩頁之內容都設定好之後，按下工具列 （Print Preview），

即可獲得如圖 11-45缺點數管制圖表之結果。 

 

 
圖 11-45  缺點數管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示待測物於此測試項目的基本資料

接著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 

 

儲存統計圖 

 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-46。

圖中左方為選取的變數，變數的命名為TestItemName，右上方為一個設定特性的區

域，可以設定是否儲存Header、圖表、Data和圖型的大小，可個別設定每個變數圖檔

的特性。右下方為儲存檔案的目錄和自定檔名的部份，檔案的命名方式為使用者自定
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和自動設定，自動設定的檔名為_ChartName，檔案類型可由使用者選取為.bmp或.jpg，

其中ChartName會在儲存時自行替換成左方測試項目的名稱。 

 

 

圖 11-46  儲存圖檔對話盒 

 
 

11.11 缺點率管制圖（u Chart） 

本系統運用缺點率管制圖的方式，是將每一天之某一測試項目下，所有被記錄的讀值

變數之測試結果為失敗之數量再除以所有讀值變數數量視為缺點率，經統計分析運算

所得之結果。 

 

製作缺點率管制圖，按下工具列 （u Chart）後，即顯示缺點率管制圖表參數設定

畫面，如圖 11-47，左上方顯示此測試程式的各個測試程序（Sequence），右上方則

根據左側選擇的測試程序，將每一個測試日期於此測試程序之測試讀值成功或失敗數

量顯示出來，而下方是設定缺點率管制圖表參數，以下分別介紹。 
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圖 11-47  缺點率管制圖表參數設定 

 

 
圖 11-48  缺點率管制圖表參數設定－統計參數設定 
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圖 11-49  缺點率管制圖表參數設定－列印基本設定 

 
Sequence表格：（圖 11-47左方）顯示測試程序，欄位說明如下。 

 
Seq. 測試程序序號 

Sel 測試程序核取方塊，被選取後於預覽統計圖表結果或列印時，會

有此讀值變數統計圖表結果。 

Test Item 測試項目名稱 

 

 
Sel欄位之核取方塊，提供對多測試程序缺點率統計圖表結果連續

列印功能。 

 

Select All 選取所有測試程序，將所有測試程序核取方塊設定為選取狀態。 

UnSelect All 取消選取所有測試程序，將所有測試程序核取方塊設定為非選取

狀態。 

 
Date表格：（圖 11-47右方）顯示待測物（UUT）相關資訊，重要欄位說明如下。 

 
No. 各日期測試結果流水號 

Sel 各日期測試結果核取方塊，被選取後於預覽統計圖表結果或列印

時，會將此日期測試結果列入統計運算。 

Date 測試日期 

提示
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Pass Counts 某測試日期於選定的測試程序下所有測試讀值結果為成功

（Pass）之數量 

Fail Counts 某測試日期於選定的測試程序下所有測試讀值結果為失敗

（Fail）之數量 

Total Counts 某測試日期於選定的測試程序下所有測試讀值之數量 

 

Select All 選取所有測試日期測試結果，將所有測試日期測試結果核取方

塊設定為選取狀態。 

UnSelect All 取消選取所有測試日期測試結果，將所有測試日期測試結果核

取方塊設定為非選取狀態。 

 
「Parameter Setting」頁次：（圖 11-48） 

 
1)Sample Size 設定樣本數大小 

2)Std Err Multiplier 顯示管制上下線為幾倍的標準差 

3)Limit Source 設定管制上下限來源 

 
 From Selected Data 以被選擇的被測物測試結果計算管制界線 

 Use Std u0 將下方輸入的 Std u0作為基準值（standard u0 value）

作為管制界線中心線 

Std u0 設定基準 u0值（standard u0 value） 

 
「Print Setting」頁次，如圖 11-49。 

 
Title 列印標題設定，你可隨意的輸入標題名稱。 
Model Name 待測物型別名稱。 
Test Item Name 測試項目（Test Item）名稱。 
Condition 測試條件設定，您可依實際測試條件，輸入測試條件說明，

當您按下 Edit Condition 後浮現一個輸入文字對話盒

（參考圖 11-29），供您方便地能從測試程式中挑選出合

適的Test Condition類的變數，編輯成此欄的說明文字。 
 

顯示統計圖 
 

先由上方表格選擇好要列入統計運算的測試項目測試日期結果，然後將「Parameter 

Setting」頁次與「Print Setting」頁次都設定好之後，按下工具列 （Print Preview），

即可獲得如圖 11-50 缺點率管制圖表之結果。 
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圖 11-50  缺點率管制圖表結果 

 
統計圖表結果是以視窗預覽的形式呈現，上方顯示被測物於此測試項目的基本資料

接著顯示統計圖表，右側列出統計計算數值結果，最後顯示各點數值結果。 
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儲存統計圖 
 

先選擇好左方那些讀值變數要製作統計圖表，再選擇右上方那些測試讀值要被列入統

計運算，按下工具列 Save to Image Files按鈕，出現儲存對話盒，如圖 11-51所

示。圖中左方為選取的變數，變數的命名為TestItemName，右上方為一個設定特性

的區域，可以設定是否儲存Header、圖表、Data和圖型的大小，可個別設定每個變數

圖檔的特性。右下方為儲存檔案的目錄和自定檔名的部份，檔案的命名方式為使用者

自定和自動設定，自動設定的檔名為_ChartName，檔案類型可由使用者選取為.bmp

或.jpg，其中ChartName會在儲存時自行替換成左方測試項目的名稱。 

 

 
圖 11-51  儲存圖檔對話盒 

 
 

11.12 匯出結果記錄文字檔 

本系統提供匯出測試結果的內容到一個文字檔中，您可以很方便的使用其它應用程式

（如 Microsoft Word）處理這個匯出的文字檔，製作更多樣的報表。 

 

按下工具列 後，即顯示所有的讀值變數設定畫面，如圖 11-52，每一欄的說明如

下： 
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Sel  勾選要匯出的變數 
Seq 變數在測試程式中的順序 
Test Item 變數所在測試項目 
Variable Name 變數的名稱 
Load No 陣列變數的索引值，如果此變數為非陣列變數，索引值為0。 

 

 
圖 11-52  測試程式中所有讀值變數 

 

在圖 11-52中，可由File Format選擇輸出的檔案規格，若選擇“Save as One File 

Name”，則資料會存在設定的檔名；若選擇“Save as MultiFile Name”，則資料會以

每256 Columns存成一檔案，檔名為“所設檔名”+“_?”+“.txt”。由File Header可選擇

要放在標頭的參考資料－Test Item Information、Test Item Name及Max Min 

Specification。 
 
註 ?為一數字，由“1”開始。 
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按下圖 11-52的 Other Option ，即顯示如圖 11-53的選擇畫面： 
 

 
圖 11-53  其他相關資訊 

 

在圖 11-52表格中挑選需要匯出的變數在Sel欄上打勾，隨後按下另一頁面（Data 

Table），所勾選的變數會將每個符合選取條件的序號展開成一個表格，如圖 11-54各

個欄位的說明如下： 

 
第一欄 Sel 勾選為是否要輸出的列 

第二欄 S/N 為符合選取的所有 UUT序號 

第三欄 以後為各個變數的名稱，欄位的命名方式如下： 

  VariableName_ LoadNo _SeqNo 
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圖 11-54  讀值變數匯出表格 

 
當按下圖 11-54上 Save to Text / Excel File 後，出現一個如圖 11-55所示的對話

盒，讓您選擇要匯出EXCEL/文字檔的目錄和檔名，儲存圖 11-54內的所有選取內容。 

 

 
圖 11-55  匯出文字檔對話盒 

 
在此應用程式中，只要有“Sel”欄位的表格，皆可將滑鼠指標移到提示
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“Sel”標題列，按一下滑鼠左鍵，即可有全選（Select All）或全不

選（UnSelect All）的功效。 
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附錄 A 測試結果記錄檔 

 
所有的測試結果記錄檔均記錄在 Adapter / Charger ATS系統軟體工作目錄之子目錄

Log下，每一測試程式均有其個別的記錄檔目錄及記錄內容。因此所有的記錄均以測

試程式來區分。 

 
假設測試程式檔名為“MyPrg.prg”，則在 Log目錄下會建立以測試程式主檔名命

名之子目錄 MyPrg，此目錄下才是該測試程式執行後所記錄之測試結果，這裡定義

了兩種不同之 Microsoft Access 資料庫檔案（.mdb）：TestInfo.mdb與

MyPrg@yyyymmdd.mdb，其中 yyyy表示西元年，mm表月份，dd表日期，茲將

其內含表格說明如下： 

 
(1). TestInfo.mdb：記錄測試過的待測物序號，內含兩個表格【UUTRetest】及

【TPInfo】各欄位說明如後。 

 
【UUTRetest】資料表：測試過的待測物序號及重測的次數 

 
SerialNo 文字，待測物之序號。 
RetestTime 日期／時間，測試的日期時間。 
Times 整數，該筆待測物第幾次的測試，“0”表示第一次測試，“1”表

示第一次重測。 
Result 待測物測試結果。“0”表示失敗，“1”表示成功。 

 
【TPInfo】資料表：測試程式的資訊 

 
Key 文字，名稱。 
Value 文字，內容。 

 
各筆記錄的定義如下： 

 

Key Value 

TPFileName 測試程式的名稱 

TPFilePath 測試程式儲存的目錄 

Author 測試程式的作者 

Comment 測試程式的備註文字 

ReportFile 測試程式所對應的報表格式檔案 

mailto:MyPrg@19980520.mdb
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ModelName 測試程式所對應的 Model名稱 

LoadNum 測試程式所設定的 Load個數 

Load1 第一個 Load所設定的名稱 

Load2 第二個 Load所設定的名稱 

…  

MajorVer 測試程式所設定的主版本碼 

MinorVer 測試程式所設定的次版本碼 

DateTime 測試程式產生的時間（20000304171256 表示西元

2000年 3月 4日 17:12:56） 

PreSeqNum PreTest測試項目在測試程式的總數 

PreSeq1 第一個 PreTest測試項目的名稱 

PreSeqExt 1 第一個 PreTest測試項目的說明 

… 依 PreSeqNum 個數增加 

PostSeqNum PostTest 測試項目在測試程式的總數 

PostSeq1 第一個 PostTest測試項目的名稱 

PostSeqExt1 第一個 PostTest測試項目的說明 

… 依 PostSeqNum 個數增加 

SeqNum UUTTest 測試項目在測試程式的總數 

Seq1 第一個 UUTTest測試項目的名稱 

SeqExt1 第一個 UUTTest測試項目的說名 

… 依 SeqNum 個數增加 

Released 測試程式是否發行 

ReleasedDateTime 測試程式發行時間 

 
(2). MyPrg@20000531.mdb（舉例）：記錄每天測試結果之資料庫，依日期之不同建

立新的記錄檔。其中有七個資料表【SPCLogData】、【SPCLogDataBinary】、

【 SPCSpec 】、【 SPCSpecBinary】、【 SPCVar 】、【 HeaderInfoSet 】與

【SPCVectorGlobal】分別說明如後。 

 
【SPCLogData】資料表：每天測試的結果，存放數值類的值。其各欄位說明

如後。 

 
SerialNo 文字，待測物之序號。 
VarID 長整數，變數之流水編號，由「Exection Controller」依

TestProgram決定編訂一唯一之編號。 
Value 雙精準數，讀值之數值。 
Result 位元組（數字），“0”為失敗（Fail），“1”為成功（Pass）。 

mailto:MyPrg@19980520.mdb
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RetestTimes 整數，代表重測的次數，應為索引資料庫檔（TestInfo.mdb 

【UUTRetest】）中的索引值。 
RunStep 整數，代表執行時的步驟。 

 
【SPCLogDataBinary】資料表：每天測試的結果，存放非數值類的值。其各欄

位說明如後。 

 
SerialNo 文字，待測物之序號。 
VarID 長整數，變數之流水編號，由「Exection Controller」依

TestProgram決定編訂一唯一之編號。 
Value 大型二進制值，內容由變數的型別決定。 
Result 位元組（數字），“0”為失敗（Fail），“1”為成功（Pass）。 
RetestTimes 整數，代表重測的次數，應為索引資料庫檔（TestInfo.mdb 

【UUTRetest】）中的索引值。 
RunStep 整數，代表執行時的步驟。 

 
【SPCSpec】資料表：記錄輸入參數之數值。內容記錄輸入參數（主要是規格部

份）之數值，由於輸入參數於執行時期並不會變動，因此將輸入參數值記錄在此

資料表中。各欄位說明如後。 

 
SeqNo 數字，該測試項目於測試程式中之順序編號，由“0”起算。 
TestItemName 文字，該測試項目之名稱。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
CallName 文字，輸入參數之Call Name。 
Value 數字，輸入參數之數值。 
DataType 數字，變數的型別。 
DataFlag 數字，變數的狀態。依Bit決定各個狀態。0x01為Fail，0x02

為Invalid，0x04為Less，0x08為Greater，0x10為Don’t care。 
Remark 備忘，未使用。 

 
【SPCSpecBinary】資料表：記錄輸入參數之非數值類的值。內容記錄輸入參數

（主要是規格部份）之數值，由於輸入參數於執行時期並不會變動，因此將輸入

參數值記錄在此資料表中。各欄位說明如後。 

 
SeqNo 數字，該測試項目於測試程式中之順序編號，由“0”起算。 
TestItemName 文字，該測試項目之名稱。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
CallName 文字，輸入參數之Call Name。 



配接器/充電器自動測試系統 8020使用手冊 

 A-4 

Value 大型二進制值，內容由變數的型別決定。 
DataType 數字，變數的型別。 
DataFlag 數字，變數的狀態。依Bit決定各個狀態。0x01為Fail，0x02

為Invalid，0x04為Less，0x08為Greater，0x10為Don’t care。 
Remark 備忘，未使用。 

 
【SPCVar】資料表：內容記錄所有的讀值變數之相關資訊，此資料表實際上是一

變數對應表。在查詢測試結果之前，應以該變數之相關資訊查詢此表，取得該變

數之流水編號，之後在以此編號，至 MyPrg@19991101.mdb（舉例）中查詢該

變數之數值。各欄位說明如後。 

 
VarID 數字，變數之流水編號，由「Exection Controller」依

TestProgram決定，根據“SeqNo”和變數編訂一唯一之編

號。 
SeqNo 數字，該測試項目於測試程式中之順序編號，由“0”起算。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
TestItemName 文字，該測試項目之名稱。 
CallName 文字，輸入參數之Call Name。 
MaxSpec 文字，該讀值容許之最大值（規格）對應之輸入參數之Call 

Name。 
MinSpec 文字，該讀值容許之最小值（規格）對應之輸入參數之Call 

Name。 
DataType 數字，變數的型別。 
Remark 備忘，未使用。 

 
【HeaderInfoSet】資料表：記錄待測物的資訊 

 
SerialNo 文字，待測物之序號。 
ModelName 文字，待測物的機型名稱。 
LotNumber 文字，待測物的批號。 
OrderNumber 文字，訂貨編號。 
Environment 文字，測試時的環境溫度。 
Inspector 文字，檢測人員姓名。 
Customer 文字，客戶名稱。 
ElapsedTime 文字，測試所花的時間。 
SystemTime 文字，測試時的系統時間。 
RetestTimes 整數，代表重測的次數，應與TestInfo.mdb中UUTRetest資料

表的Times欄位值一致。 
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【SPCVectorGlobal】資料表：記錄測試程式中 Global和 Vector 的內容。 

 
Type 數字，該行變數所代表的型別，19為Global，20~29為Vector，

其它值無定義。 
Index 數字，Vector為該Vector的第幾個Element。Global為定義

Global變數的順序（0~5）。(System/User)*(Pre/UUT/Post) 
IndexName 數字，Vector為Vector的名稱。Global為“Global”字串。 
CallName 文字，變數名稱。 
LoadNo 數字，表示Element Index，如果和Array無關的變數為0。 
Value 數字，值。 
Remark 備忘，未使用。 

 

Data Type Mean 

0 Float 

1 Integer 

2 Float(%) 

3 Short 

4 String 

5 Byte 

6 Float[L] (大小為 Load數) 

7 Integer[L] (大小為 Load數) 

8 Float[L](%) (大小為 Load數) 

9 HexString 

10 Float[](大小為使用者設定) 

11 Integer[](大小為使用者設定) 

14 Date 

20~29 Vector 

100 Chart(波形圖) 

101 Picture(圖片) 
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